Digitale signatur mit IMAP Konto

  • Ich verwende nun seit einer Woche digitale Signaturen und Verschlüsselung mit meinem POP Konto bei inode.at.
    Funktioniert tadellos.
    Mein Kollege, mit dem ich viele Mails austausche, hat ein IMAP Konto bei A1. Es gelingt uns nicht bei ihm seine eigene Signatur einzurichten, entweder bekommen wir die Fehlermeldung dass die gesendete Mail nicht in Ordner Gesendet (A1) abgespeichert werden kann, oder es gibt keinen Mail Abruf am Server, wenn wir versuchen in den Einstellungen die gesendeten Mails auf einen lokalen Ordner zu legen.
    Ohne digitale Signatur und Zertifikate gelöscht funktioniert alles tadellos.


    Gibt es Einstellungen, die man anders setzen muss wenn es sich um ein IMAP Konto handelt, von dem man senden möchte?


    Danke für Hinweise


    Thunderbird-Version 17.0.8:
    Windows 7 SP 1 32 bit:
    IMAP Konto:
    A1:
    SMIME:

  • Guten Abend Reinhard! (<= Ja, so viel Zeit nehmen wir uns hier ... .)


    So richtig kann ich dein Problem nicht nachvollziehen. Ich habe viele Mailkonten bei verschiedenen Providern, grundsätzlich und aus Überzeugung alles IMAP, und bei mir werden seit vielen Jahren fast alle Mails verschlüsselt. Aber dieses Problem habe ich noch nie gehabt.
    Also müssen wir nach den Ursachen suchen, denn eine besondere Einstellung für IMAP-Konten und S/MIME gibt es eigentlich nicht.


    Als erstes möchte ich dich bzw. deinen TB als Ursache ausschließen:
    Du kannst problemlos verschlüsselte und signierte Mails an dich selbst verschicken und diese wieder empfangen, dabei wird eine erfolgreiche Signaturprüfung angezeigt, und du kannst diese Mails auch lesen? Richtig?


    Zu deinem Kollegen:
    Er besitzt eine Schlüsseldatei, welche exakt zu seiner Mailadresse passt?
    Das (richtige!) Herausgeberzertifikat des ausstellenden TrustCenters ist installiert, und die Schlüsseldatei ist richtig importiert?
    Der eigene Schlüssel ist in den Konteneinstellungen zum Signieren und zum Verschlüsseln seinem Konto zugeordnert?
    Der AV-Scanner darf das TB-Userprofil nicht überwachen, und die Überwachung des ein- und ausgehenden Mailtraffics wurde testweise deaktiviert?
    Was passiert, wenn nur eine signierte und nur eine verschlüsselte Mail von ihm selbst an sich selbst geschickt wird?
    Kann er verschlüsselte und / oder signierte Mails von dir lesen?
    Kommen bei irgendwelchen Aktionen irgendwelche Fehlermeldungen? Wenn ja, welche?


    Dass die gesendete Mail (kommt diese denn an?) nicht in den Gesendet-Ordner auf dem Server kopiert werden kann, passiert bei IMAP sehr oft. Deshalb das testweise Deaktivieren des AV-Scanners. Verschlüsselte Mails, verschlüsselte Verbindungen und AV-Scanner vertragen sich in der Regel nicht, denn weil sie den Inhalt nicht scannen können, blockieren sie lieber die Verbindung. Ist ja auch richtig so!


    Ja, mehr fällt mir erst mal nicht ein.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Danke vorerst, bin auf Urlaub und melde mich wieder wenn wir Deine Ratschläge umgesetzt haben. Habe auch Meldung eines zweiten Kollegen, auch Thunderbird, auch A1.net, gleiches Problem wie oben geschildert.

  • Guten Morgen Peter, ich bin einer der Kollegen von Reinhard. Ich habe auch dieses Problem.
    Ich habe heute wieder eine Anlauf genommen, um diesen Problem auf den Grund zu gehen. Leider ohne Erfolg.


    Er besitzt eine Schlüsseldatei, welche exakt zu seiner Mailadresse passt? - ja


    Das (richtige!) Herausgeberzertifikat des ausstellenden TrustCenters ist installiert, und die Schlüsseldatei ist richtig importiert? - ja


    Der eigene Schlüssel ist in den Konteneinstellungen zum Signieren und zum Verschlüsseln seinem Konto zugeordnert? - ja


    Der AV-Scanner darf das TB-Userprofil nicht überwachen, und die Überwachung des ein- und ausgehenden Mailtraffics wurde testweise deaktiviert?


    Ich habe MS Security Essential installiert. Nun Ihrer Anweisung nach habe ich den Echtzeit-Schutz von MS Security Essential de-aktiviert.
    Ergebnis: wie gehabt.

    Was passiert, wenn nur eine signierte und nur eine verschlüsselte Mail von ihm selbst an sich selbst geschickt wird?


    nur eine verschlüsselte Mail an mich selber - Ergebnis: wie gehabt.
    nur eine signierte Mail an mich selber - Ergebnis wie gehabt.

    Kann er verschlüsselte und / oder signierte Mails von dir lesen? - nein,
    Die "abgeschickte" Mail kann vom TB nicht im "Gesendet" gespeichert werden.
    Aber nun kann TB auch nichts mehr einlesen. TB gibt vor dass es läuft. Läuft . .

    Wenn ich nun die Eintragungen für Schlüsseldatei, Herausgeberzertifikat, etc. in Kontoeinstellungen entferne bzw. de-aktiviere, dann
    kommen diese "an mich selbst geschickten" E-Mails in den "Posteingang". Aber:


    ** die nur unterschriebene e-Mail: ist okey, mit dem Brief-Umschlag-Symbol
    ** die nur verschlüsselten e-Mail: mit dem Text: Thunderbird kann die Nachricht nicht entschlüsseln. Der Absender hat diese Nachricht mit einem Ihrer digitalen Zertifikate verschl. . . .
    ** die verschlüsselte und unterschriebene e-Mail: mit dem Text. Thunderbird kann die Nachricht nicht entschlüsseln Der Absender hat diese Nachricht mit einem Ihrer digitalen Zertifikate verschl


    Kommen bei irgendwelchen Aktionen irgendwelche Fehlermeldungen? Wenn ja, welche? - TB gibt vor beschäftigt zu sein, und läuft.



    Hat diese etwa mit der Konteneinstellung (bei de-aktivierten Digitaler Signatur, Verschlüsselung) zu tun? Meine einstellung ist nun:
    Server-Einstellung:
    Server-Typ = IMAP
    server = imap.a1.net
    Port = 993 (= Standard)
    Verbindungsicherheit = SSL/TLS
    ..
    Postausgang-Server (SMTP):
    Server = smtp.a1.net
    Port = 25
    ..
    Authentifizierungsmethode: Password. ungesichert übertragen
    Verbindungsicherheit = keine
    ..

    * Thunderbird-Version: 45.8.0
    * Betriebssystem + Version: Windows 10 Home - version 1607 - 64-Bit-Betr.Syst.

    * Kontenart (POP / IMAP): IMAP

    * Postfachanbieter: A1 (Telekom Austria)

    * Eingesetzte Antiviren-Software: Windows Defender, Malwarebytes Anti-Malware, -



    Beste Grüsse + danke für die Hilfe.
    Bumblebee

  • ich habe das Zertifikat aktiviert, und sende nun eine Nachricht an mich selbst, aber nur mit "Nachricht unterschrieben" und nicht "Nachricht verschlüsselt".
    Hier das ergebnis:




    TB will die abgeschickte Nachricht speichern, aber es kann nicht. TB läuft . .
    Hier das nächste Bild:




    Erst wenn ich die Eintragungen für Schlüsseldatei, Herausgeberzertifikat, etc. in Kontoeinstellungen entferne bzw. de-aktiviere, dann kommen diese "an mich selbst geschickten" E-Mails in den "Posteingang"

  • Hi,


    ganz kurz (habe Urlaub, und wir wollen raus):
    Handelt es sich um ganz normale private Internetanschlüsse, oder um Geräte, welche sich in einem (irmen-)Intranet befinden?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi,
    Enjoy your vacation. There is no hurry to find a solution for my digital signatur.


    Ich habe einen ganz normale private Internetanschluss,
    verbunden über Festnetz-Telefon (von A1) und WLAN (Telefon - PC)
    Modem = Pirelli PRG AV4202N
    Netzwerk-Sicehrheitstype = Type = WPA+WPA2
    Netzwerk-Verschlüsselungtype = TKIP

    Bilder

    * Thunderbird-Version: 45.8.0
    * Betriebssystem + Version: Windows 10 Home - version 1607 - 64-Bit-Betr.Syst.

    * Kontenart (POP / IMAP): IMAP

    * Postfachanbieter: A1 (Telekom Austria)

    * Eingesetzte Antiviren-Software: Windows Defender, Malwarebytes Anti-Malware, -



    Beste Grüsse + danke für die Hilfe.
    Bumblebee

  • So, jetzt habe ich etwas mehr Zeit ... .


    Die Frage nach dem Internetanschluss hat einen ganz einfachen Hintergrund: In Firmen werden oft Gateways eingesetzt, welche (um zum Bsp. zu verhindern, dass unbemerkt Informationen per Mail abfließen) einen verschlüsselten Mailinhalt blockieren. Und manche User "vergessen", uns derartige Informationen mitzuteilen ... .


    Aus deinem vorletzten Beitrag entnehme ich, dass du erfolgreich eine signierte Mail an dich selbst senden kannst.
    Zuerst einmal musst du sauber trennen zwischen dem Senden einer E-Mail (erfolgt über das SimpleMailTransportProtocol, also über den SMTP-Server deines Providers) und allen Aktionen, welche per IMAP-erfolgen. Die Anzeige des Mailbestandes auf dem Server (Auflistung der vorhandenen Mails), die Anzeige des Inhaltes der Mails (Lesen) das Löschen, aber auch sämtliche Kopier-und Verschiebeaktionen sind Aktionen, welche mit IMAP ablaufen. Auch das Kopieren der gesendeten Mails in den Gesendet-Ordner auf dem IMAP-Server!
    => Es handelt sich also keinesfalls um ein Sendeproblem!
    Bei vielen Providern gibt es Probleme beim nachträglichen (also nach dem erfolgreichen Senden) Kopieren der Mails in den Gesendet-Ordner. Warum das ist, haben wir noch nicht herausgefunden. Ist eben so.
    Ich helfe mir damit, indem ich (und dafür gibt es sogar eine Einstellung im Programm!) sämtliche Mails per Blindcopy (BCC) zusätzlich an mich selbst versende. Der Empfänger merkt davon nichts, und wenn die Mail nach ein paar Sekunden bei mir ankommt, dann habe ich die ultimative Bestätigung, dass diese Mail auch tatsächlich gesendet wurde! Die ankommende Mail von der eigenen Absenderadresse lasse ich automatisch per Filter in einen von mir gewünschten Ordner verschieben (ich habe sehr viele Ordner angelegt, und ich packe eine gesendete Mail auch wieder in den betreffenden Vorgangs- oder Personen-Ordner, so dass meine Kommunikation komplett an einem Ort vorliegt.)


    Wenn ich das also richtig verstanden habe, funktioniert bei dir das Senden von signierten Mails.
    Was ist nun mit den verschlüsselten Mails?
    Gehen sie raus? (Und kommen sie bei dir wieder an?)
    Was wird bei dir bei Klick auf den S/MIME-Butten angezeigt?
    Sind unten rechts in der Statuszeile die Icons für Signatur und Verschlüsselung zu sehen?


    Es gibt auch bei IMAP keinerlei besondere Einstellungen für das Versenden von verschlüsselten und unverschlüsselten Mails. Außer natürlich dem, was du mit dem S/MIME-Button anstellen kannst. Aber in den eigentlichen Konteneinstellungen ist nichts, was du da zu beachten hast. Dabei gehe ich davon aus, dass du die Herausgeberzertifikate und die Zertifikate deiner Mailpartner sowie deine eigene Schlüsseldatei korrekt installiert und deinem Konto zugeordnet hast. Den Automatismus für Verschlüsseln und Signieren solltest du besser deaktivieren. (Wenn du erfolgreich signieren konntest, ist das wohl auch bis auf die Zertifikate der Mailpartner gegeben.)


    Also, was ist mit verschlüsselt senden?



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Ich habe mein Zertifkat nochmals installiert.


    Ich kann nun "unterschreibene & nicht verschlüsselte" Mails an mich senden. Das Brief-Umschlag-Sysmbol wird auch angezeichnet. Diese Mails werden abgeschickt, aber NICHT abgespeichert, TB wehrt sich dagegen. Aber . . .


    Ich kann keine Mails einlesen. Auch bei einem neuen Start von TB, steht unten:
    Verbunden mit imap.a1.net . . .


    Ich muss erst alle Einträge für das Zertifikat unter Extras + Einstellungen + Kontoeinstellung entfernen, dann erst lässt mich TB die Mail einlesen.

    * Thunderbird-Version: 45.8.0
    * Betriebssystem + Version: Windows 10 Home - version 1607 - 64-Bit-Betr.Syst.

    * Kontenart (POP / IMAP): IMAP

    * Postfachanbieter: A1 (Telekom Austria)

    * Eingesetzte Antiviren-Software: Windows Defender, Malwarebytes Anti-Malware, -



    Beste Grüsse + danke für die Hilfe.
    Bumblebee

  • Das passt eigentlich zu dem, was ich geschrieben habe.
    Die Sende- (also SMTP-)Funktion funktioniert, und alles was mit IMAP zu tun hat, funktioniert eben nicht.


    Heißt das, dass du auch (mit importiertem Zertifikat) keine unverschlüsselten Mails von anderen Usern (Absendern) empfangen kannst? Was passiert, in diesem Fall?

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Bei importierten Zertifikat: Ja, das stimmt. TB ist erstarrt im Status: Verbunden mit imap.a1.net . . . (das steht links unten) und ich kann keine einzige Mail von irgend jemanden einlesen.

    * Thunderbird-Version: 45.8.0
    * Betriebssystem + Version: Windows 10 Home - version 1607 - 64-Bit-Betr.Syst.

    * Kontenart (POP / IMAP): IMAP

    * Postfachanbieter: A1 (Telekom Austria)

    * Eingesetzte Antiviren-Software: Windows Defender, Malwarebytes Anti-Malware, -



    Beste Grüsse + danke für die Hilfe.
    Bumblebee

  • Das heißt also:


    - sämtliche Konteneinstellungen stimmen (Server, Benutzername, Port, Art der Authentisierung, usw.)
    - AV-Scanner und sonstige "Sicherheits-"Software sind deaktiviert (natürlich nur zur Eingrenzung des Problems!)
    - die Verbindung zum IMAP-Server erfolgt unverschlüsselt (auch hier Eingrenzung ...)
    - und allein die Tatsache, dass du die Zertifikate (oder konkreter deine eigene Schlüsseldatei) installiert und in den Konteneinstellungen dem Konto zugeordnet hast, entscheidet, ob du per IMAP zum Server kommst oder eben nicht?

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Die Tatsache, dass ich die Zertifikate (oder konkreter deine eigene Schlüsseldatei) installiert und in den Konteneinstellungen dem Konto zugeordnet habe, entscheidet, ob ich mit Thunderbird per IMAP zum Server komme oder eben nicht?


    Stimmt.


    Ich werde nochmals mit dem Server-Support-Team (A1) Kontakt aufnehmen. Danke für den Support.

    * Thunderbird-Version: 45.8.0
    * Betriebssystem + Version: Windows 10 Home - version 1607 - 64-Bit-Betr.Syst.

    * Kontenart (POP / IMAP): IMAP

    * Postfachanbieter: A1 (Telekom Austria)

    * Eingesetzte Antiviren-Software: Windows Defender, Malwarebytes Anti-Malware, -



    Beste Grüsse + danke für die Hilfe.
    Bumblebee

  • Du hast eine PN.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo allerseits,


    mir ist etwas aufgefallen:

    "Bumblebee" schrieb:

    server = imap.a1.net
    Port = 993 (= Standard)


    Und hier (Link auf Hilfeseite von A1.net) wird folgende Einstellung empfohlen:

    "A1 website" schrieb:

    Posteingangsserver: imap.a1.net (Port 143)


    oder

    "A1 website" schrieb:

    Posteingangsserver: securemail.a1.net (Post 993 - Verbindungstyp SSL)
    Postausgangsserver: securemail.a1.net (Port 25 - Verbindungstyp STARTTLS)


    Ich will mich hier ja nicht großartig einmischen, dennoch scheint es mir einen Versuch wert, einmal die beiden Server-Einstellungen zu versuchen:

    • server: securemail.a1.net
      Port : 993
      Verbindungstyp : SSL/TLS


    • server: imap.a1.net
      Port: 143
      Verbindungstyp: STARTTLS


    Auf der von mir verlinkten Hilfeseite ist auch eine *.pdf Datei, die die Einrichtung des IMAP-Kontos für Thunderbird bebildert (IMAP ist ganz am Ende der Datei zu finden).


    Grüße, Ulrich

  • Danke für den Hinweis. Leider hat dies auch nicht die Lösung des Problems gebracht.
    Ich habe auch das Support-Team vom Provider kontaktiert, aber keine Lösung gefunden.

    * Thunderbird-Version: 45.8.0
    * Betriebssystem + Version: Windows 10 Home - version 1607 - 64-Bit-Betr.Syst.

    * Kontenart (POP / IMAP): IMAP

    * Postfachanbieter: A1 (Telekom Austria)

    * Eingesetzte Antiviren-Software: Windows Defender, Malwarebytes Anti-Malware, -



    Beste Grüsse + danke für die Hilfe.
    Bumblebee