Bug: Status-Kennzeichnung verschwindet nach Reparieren

  • Thunderbird-Version: 24.1.1 und 26.b01
    Betriebssystem + Version: Mac OS X 10.6
    Kontenart (POP / IMAP): beide
    Postfachanbieter (z.B. GMX): Free


    Hallo,


    ich wurde leider gerade mit einem mir unbekannten Bug konfrontiert.
    Mir fiel auf, dass die Status-Kennzeichnungen "Beantwortet" und "Weitergeleitet" nicht mehr angezeigt werden werden bei Nachrichten, die ich nachweislich beantwortet oder weitergeleitet habe.


    Bei einer Suche bin ich auf den Bug 840418 "replied/forwarded icons disappear after folder repair" gestoßen.
    Ich hatte in der Tat den Ordner vor kurzer Zeit repariert.
    Einige Tests mit an mich weitergeleiteten Mails und anschließendem Reparieren bestätigen das Verschwinden der Symbole.
    Der in Comment 11 angegebene Workaround funktioniert: nach dem Beantworten oder Weiterleiten der Nachricht den "Stern" in der Kennzeichnung-Spalte mit zwei Klicks anzeigen und wieder "entfernen" schützt gegen den Verlust des Symbols bei späterem Reparieren.


    Davon sind nur Nachrichten aus dem Jahr 2013 betroffen, aber nicht ältere Nachrichten, wie ich beim Reparieren von Archiv-Ordnern aus den Vorjahren festgestellt habe.


    Hat jemand unter euch das gleiche Missgeschick erlebt?
    Laut Comment 8 kann der Status über ein Python-Script wieder hergestellt werden.
    Hat jemand Erfahrung damit?


    Gruß


    Mapenzi

  • Hallo Mapenzi ,


    der Bug tritt in der aktuellen Version bei mir nicht auf.
    Das heißt, im Ordner, aus dem geantwortet bzw. weitergeleitet wird, bleibt der jeweilige Status erhalten.
    Auch nach TB-Neustart.
    Könnte das Problem Provider abhängig sein?
    Z.B. bei Schlagwörtern hatte ich bei einigen IMAP-Konten dieses Problem, aber niemals bei "starred" Mails.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Der Bug ist sicher unabhängig vom Provider, er wurde in mehreren Ländern beobachtet, erstmals in der v17 in Russland vom Autor des bug report: http://forums.mozillazine.org/viewtopic.php?f=39&t=2658059
    Ich werde das mal mit einer älteren Version testen....


    Nachtrag: inzwischen habe ich das mit einigen älteren Versionen getestet.
    Die Regression hat beim Übergang von TB 11 auf TB 12 stattgefunden und ist eine "Nebenwirkung" des Bug 402392 "Support other message storage formats. (prelude to pluggable mail stores)", der mit der v12 gelöst wurde.

  • Hast du auch in Windows getestet?
    Wäre merkwürdig, wenn das ein panmondialer Bug wäre, ich davon aber nichts mitbekommen habe, weil ich ihn nicht habe.
    Na gut, hatten wir ja schon öfter.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:

    Hast du auch in Windows getestet?


    Kann ich hier nicht.
    Aber alle, die den Bug bisher bestätigt haben, sind Windows-Nutzer.

    Zitat

    Wäre merkwürdig, wenn das ein panmondialer Bug wäre, ich davon aber nichts mitbekommen habe, weil ich ihn nicht habe.


    So oft werden Ordner ja nicht repariert, und wenn, dann merken es auch nicht alle, dass die Symbole weg sind ;)


    Gruß

  • Hatte das mit "repaired folders" überlesen bzw. vergessen.


    Ein neuer Test ergab:
    In IMAP-Konten (und nur die hatte ich vorher getestet) passiert nach dem Reparieren nichts. Allerdings habe ich bei allen Konten das Bereithalten von Nachrichten deaktiviert.
    Anders sieht es bei POP-Konten oder im lokalen Ornder aus:
    Hier verschwindet ein Teil der Symbole für Beantwortet. Neue immer, ältere scheinen immun zu sein.
    Also aussagekräfig ist das nicht.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:

    Hatte das mit "repaired folders" überlesen bzw. vergessen.


    Das ist aber entscheidend! Steht auch in meinem Titel "..... verschwinden nach Reparieren." ;)
    Ein neuer Test ergab:


    Zitat

    Anders sieht es bei POP-Konten oder im lokalen Ornder aus:
    Hier verschwindet ein Teil der Symbole für Beantwortet. Neue immer, ältere scheinen immun zu sein.


    Genau wie bei mir.
    Bei älteren Nachrichten aus 2012 und früher bleiben die Symbole erhalten.
    Wahrscheinlich Nachrichten, die noch unter der v11 beantwortet oder weitergeleitet wurden.

    Zitat

    Also aussagekräfig ist das nicht.


    Hhhmmm, ....ich kann es wegen der möglichen Folgen natürlich niemand zumuten, probeweise seine Ordner zu reparieren, es sei denn, man macht vorher ein Backup der entsprechenden Mbox-Datei.
    Aber ich bin sicher, dass auch noch andere Nutzer den Bug feststellen würden, wenn sie den Test machen.


    Gruß

  • Ja, das Problem kann man ohne Ersatzprofil auch nicht rückgängig machen - wie ich fälschlich dachte.
    Ich war sicher, es würde genügen, die alte *.msf überzukopieren.
    Pustekurchen, die wurde bei Neustart gleich auf 0 KB gesetzt einschließlich der dort von mir gesicherten *.msf.alt (eigenltich kaum zu glauben).


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw