Nach Profil Wiederherstell., Betreff u. Abs. unsichtbar[erl]

  • TB-Version 17.0.11
    System Windows 7 Prof. 64
    Konten: Google.com und Yahoo.com Konten, beide POP.


    Hallo,
    Ich wäre sehr dankbar, wenn jemand mir helfen könnte.


    Nach formatieren des Computers, habe ich versucht, mein altes TB-Profil wiederherzustellen. Zwar sind alle E-Mails da, leider ist der „Betreff“ und die „Absender“ Infos im Header unsichtbar. Nur das Datum ist sichtbar. Außerdem ist die Unterordner-Struktur der Inbox unabhängig geworden d. h. TB erstellte 2 neue (.sbd) Unterordner mit den selben Namen der Ordner.


    Zu Widerestellungm habe ich mein altes Profil einfach gespeichert. Manche Ordner waren komprimiert, andere nicht. Leider habe ich ImportExportTool oder MozBackup nicht benutzt, da die Profilspeicher-Methode früher mal erfolgreich war. Alle meine Emails sind da. Die Email-Inhalte erscheinen als Quelltext mit allen Infos über Absender; Betreff …, etc. Aber leider bleibt der Header leer!

    Mehr Info zu TB

    Benutze BiDi Extention für Arabische Sprache.
    Inbox mit mehreren Unterordnern; auch mehrere (.sbd) Level.
    Archiv Dateien unter beiden Konten.
    Der Inbox des Yaoo-Kontos ist 534 MB groß (hier hat TB sbd Ordner selbständig erstellt).
    Alle anderen Ordner sind weniger als 500 MB groß.


    Folgende Versuche wurden unternommen um die Fehler zu korrigieren, aber leider ohne Erfolg:


    - Neues Profil erstellt; alle Ordner des neuen Profils gelöscht; Ordner vom alten Profil in das neue einkopiert; alle msf Dateien gelöscht. (Neu abgerufene Mails erscheinen normal mit allen Infos im Header).
    - Default Profil unberührt belassen, per Programmanger neues Profil erstellt; das alte Profil per Ordner-Wählen als Benutzer-Profil genannt. (Beide Profile rufen neue Emails mit Header Infos. Nur die alten Emails sind -nach wie vor- ohne Betreff und Absender).
    - Falsch erstellte Unterordner manuell korrigiert. Kein Resultat.
    - Nach erstellen ein neues Profil mit dem selben Email-Konten und die selbe Unterordner-Struktur, Dateien per ImpportExport importiert. Keine Besserung.
    - Einzelne Ordner bzw. Emails per ImportExportTool exportiert und wieder importiert. Erfolglos.
    - Verschiedene Zeichenkodierung (Arabisch, Unicode, ...) probiert.
    - Mit aktivierten, deaktivierten, und deinstallierten Antivirus probiert (Avast).
    - Verschiedene TB Versionen installiert und probiert (24.2.0; 24.0.; 17.0.11) Beste Performance hat 17.0.11 erzielt. Die Mail-Inhalte (Quelltext ähnlich) sind mit dieser Version besser zu lesen.
    - TB in Safemode probiert.

  • Hallo DeMailer und willkommen im Thunderbird-Forum,


    eigentlich hast Du alles richtig gemacht - insbesondere das Kopieren des Profils statt MozBackup zu benutzen. Und eigentlich (jaja, ich weiß, eigentlich sollte ich Millionär sein, ich bin's aber nicht) sollte beim Neueinbinden des Profils alles so sein wie vorher. Auch Deine Lösungsansätze sind tauglich, dass da nichts passiert ist echt verwunderlich.


    Was mir aber auffällt, sind die unterschiedlichen TB-Versionen. Hast Du das ursprüngliche Profil in einer anderen TB-Version betrieben als diejeneige, in die Du es dann wieder eingebunden hast. Ich kann mir nur vorstellen, dass hierbei etwas falsch gelaufen ist.


    Wenn ich Dich richtig verstehe, hast Du auch kein backup mehr von dem Original-Profil, sondern hast Die Kopie benutzt, oder? Sonst würde ich vorschlagen, dieses Original-Backup nochmals zu kopieren und in die TB-Version einzubinden, in der Du es vorher auch betrieben hast.


    Bist Du Dir denn sicher, dass die Daten vorher vollständig vorhanden waren? Sonst könnte der Fehler schon viel früher aufgetreten sein.


    Du kannst noch mal versuchen, die Ordner zu reparieren (Rechtsklick->Eigenschaften->Reparieren). Eigentlich ist das nichts anderes, als das was passiert, wenn die msf-Dateien gelöscht werden (was Du aj schon getan hast), aber versuch's ruhig noch mal.


    Ansonsten bin ich ratlos. :nixweiss:


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hallo slengfe
    danke für die Antwort.


    Leider ist mir die ursprüngliche TB Version nicht mehr bekannt. TB hat sich aber regelmäßig updatet bis 13 Dezember 2013.


    Ein Backup vom Orignal-Profil habe ich noch und habe per Profilmanager damit ein neuem Profil erstellt. Leider kein Erfolg. Auch die Aktion „Reparieren“ blieb Erfolgslos.


    Trotzdem danke für Ihre Muhe und die Besten Wünsche für die Feirtage.


  • Hallo,


    zunächst mal: TB erstellt keine .sbd-Ordner "selbständig" im Profil.
    Diese .sbd-Ordner werden erzeugt, wenn der Nutzer Unterordner anlegt in einem Ordner wie z.B. im "Posteingang", in "Gesendet" oder "Archiv" ... usw.


    Ich habe keine Patentlösung zu dem Problem der fehlenden "Betreff" oder "Absender", aber an deiner Stelle würde ich mal Folgendes testen:
    beende TB, gehe zu deinem alten Profil-Backup und kopiere irgendeine (oder auch gleich zwei oder drei) "endungslose" (Mbox) - Datei (aber nicht die zugehörige .msf-Datei), die sich beispielsweise im Ordner "Inbox.sbd" befindet.
    Füge die kopierte(n) Datei(en) in den Ordner \Mail\Local Folders\ deines augenblicklichen Profils ein und starte TB.
    Wenn Betreff und Absender in den so importierten Ordner(n) immer noch nicht angezeigt werden, solltest du noch das "Reparieren" versuchen.


    Gruß

  • Hallo Mapenzi
    danke für Ihren Beitrag.


    Ich habe Ihrne Rat befolgt und habe einen 99MB Unterordner ausgesucht. Bitte sehen Sie sich dafür Bild1 an



    Das TB selbständig keine Unterordner erstellt, wage ich zu bezweifeln. Bitte sehen sie sich die 2 Grafiken unten an.

  • Hallo DeMailer,
    Ich würde jetzt erst mal ganz schnell die Email-Adresse in Bild 2 unkenntlich machen, bevor sie von Spam-Robotern kopiert wird!

    "DeMailer" schrieb:


    Ich habe Ihrne Rat befolgt und habe einen 99MB Unterordner ausgesucht. Bitte sehen Sie sich dafür Bild1 an


    Wenn es sich bei dem getesteten Unterordner um "AACC" handelt, dann würde wohl eher das Bild 3 (ganz unten) dazu passen.
    Eine Anzeige des Nachrichten-Quelltextes im Vorschau-Fenster statt des Nachrichtentextes habe ich allerdings noch nie gesehen und dazu nur einen Bug Bericht gefunden, allerdings in einem "Nightly build" https://bugzilla.mozilla.org/show_bug.cgi?id=713611:
    "messed-up some messages (showing their source in the preview pane due to offset shift by 2 bytes".
    Hast du auch versucht, den Ordner AACC zu komprimieren?


    Zitat

    Das TB selbständig keine Unterordner erstellt, wage ich zu bezweifeln. Bitte sehen sie sich die 2 Grafiken unten an.


    Ich bleibe dabei: außer den Standard-Nachrichtenordnern erstellt TB keine anderen Nachrichtenordner oder Unterordner selber, das kann nur durch den Nutzer geschehen.
    Ein Ordner im Profil wie z.B. "Inbox.sbd" wird natürlich von TB erstellt, aber auch nur, wenn du selbst einen (oder mehrere) Unterordner im Posteingang erstellt hast.
    Auch dass in den screen shots gleichnamige Ordner oder Unterordner mehrfach angezeigt werden, beweist nichts, da du schon mehrere Importmethoden versucht hast.
    Wir hatten allerdings kürzlich hier einen Fall, in dem sich ein vom Nutzer erstellter Ordner mitsamt Unterordnern multipliziert hatte, aber auch da bezweifle ich, dass es ohne Eingriff des Nutzers geschehen konnte.


    Die screen shots sind im übrigen etwas verwirrend und stammen offenbar von drei verschiedenen Profilen.
    Mir fällt z. B. auf, dass in dem oberen Bild der Ordner "AACC" ein reiner Unterordner des Posteingangs ist und im darunter befindlichen Bild ein Unterordner mit einem weiteren Unterordner.
    Sah denn der Ordnerbaum schon genau so aus in deiner alten TB-Installation?


    Ich kann mir nicht vorstellen, dass bei der Profilsicherung vor dem Formatieren der Festplatte alle Mbox-Dateien im Profil beschädigt wurden.


    Daher die Frage: wie wurde die Profilsicherung durchgeführt?
    Was heißt "Zu Widerestellungm habe ich mein altes Profil einfach gespeichert"?
    Bedeutet das, dass du manuell eine Kopie des kompletten Profilordners gemacht hast?
    In diesem Fall wäre es interessant, die Struktur des Kontenordners "pop.yahoo.com" (oder so ähnlich) zu sehen, der sich im Ordner "Mail" der Profilsicherung befindet.

  • Hallo Mapenzi,
    Danke für Ihre Engagement.


    Zitat

    Wenn es sich bei dem getesteten Unterordner um "AACC" handelt, dann würde wohl eher das Bild 3 (ganz unten) dazu passen.


    Die Bilder Oben habe ich in die richtige Reihenfolge gebracht.


    Zitat

    Eine Anzeige des Nachrichten-Quelltextes im Vorschau-Fenster statt des Nachrichtentextes habe ich allerdings noch nie gesehen und dazu nur einen Bug Bericht gefunden, allerdings in einem "Nightly build" https://bugzilla.mozilla.org/show_bug.cgi?id=713611:


    Das ist sehr Lehrreich. Danke. Den englischen Beitrag habe ich gelesen, allerdings weiß ich nicht, wie ich diese Information nutzen kann, um mein Problem zu lösen.


    Zitat

    Die screen shots sind im übrigen etwas verwirrend und stammen offenbar von drei verschiedenen Profilen.
    Mir fällt z. B. auf, dass in dem oberen Bild der Ordner "AACC" ein reiner Unterordner des Posteingangs ist und im darunter befindlichen Bild ein Unterordner mit einem weiteren Unterordner.
    Sah denn der Ordnerbaum schon genau so aus in deiner alten TB-Installation?


    Ja. Das sind 3 Profile. Wie in Ihren Vorschlag, habe ich ein Ordner in ein neues/funktionierendes Profil integriert (Bild 1). Bild 2 ist das gespeicherte Profil. Der Ordner „pop.yahoo.com“ sieht natürlich genau wie im Bild 2 aus. Allerdings habe ich die mit Rot markierten (duplizierten) Ordner nicht erstellt. Daher die Vermutung, dass TB diese selbständig angelegt hat. Das Original-Profil sieht wie in Bild 3 aus. Wie in meinem Beitrag beschrieben, habe ich das Profil manuell korrigiert. Ich arbeite mit diesem Profil seit langem (2008) und erinnere mich genau an seine Struktur. Ob TB selbständig Unterordner angelegt hat, ist für mich kein Thema. Mein Ziel ist meine alten E-mails wiederherstellen zu können.


    Zitat

    Daher die Frage: wie wurde die Profilsicherung durchgeführt?
    Was heißt "Zu Widerestellungm habe ich mein altes Profil einfach gespeichert"?
    Bedeutet das, dass du manuell eine Kopie des kompletten Profilordners gemacht hast?


    Das Profil wurde in eine externe Festplatte (Cloud) kopiert, gespeichert und später runtergeladen.


    Die besten Wünsche für die Feiertage,
    Gruß

  • "DeMailer" schrieb:


    Das ist sehr Lehrreich. Danke. Den englischen Beitrag habe ich gelesen, allerdings weiß ich nicht, wie ich diese Information nutzen kann, um mein Problem zu lösen.


    Ich weiß es leider auch nicht ;)


    Zitat

    (Bild 1). Bild 2 ist das gespeicherte Profil. Der Ordner „pop.yahoo.com“ sieht natürlich genau wie im Bild 2 aus.


    Das glaube ich, trotzdem würde mich ein screen shot des Ordners "pop.yahoo.com" aus dem gespeicherten Profilordner interessieren.

    Zitat

    Mein Ziel ist meine alten E-mails wiederherstellen zu können.


    Ist mir klar, das will ich auch.
    Leider hat der erste Versuch keinen Erfolg gebracht, offenbar auch nicht nach einem Komprimieren dieses Ordners AACC.


    Zitat

    Das Profil wurde in eine externe Festplatte (Cloud) kopiert, gespeichert und später runtergeladen.


    Wurde der Profilordner so wie er war gespeichert oder in eine zip-Datei komprimiert?
    Kann man den Profilordner noch einmal herunter laden aus der Cloud?


    Die Chancen, die Nachrichten wieder korrekt anzeigen zu können, sind offenbar äußerst gering.
    Möglicherweise wurden zu irgend einem Zeitpunkt alle Mbox-Dateien beschädigt.
    Bei einer Suche in mehreren Sprachen habe ich jedoch außer dem oben erwähnten Bug absolut nichts gefunden.


    Trotzdem würde ich noch nicht aufgeben.
    Ich schlage vor, noch folgende Versuche zu unternehmen:
    ◾ wenn möglich nochmals das Profil aus der Cloud herunter laden, ansonsten die Originalsicherung verwenden
    ◾ eine (nicht zu große) Mbox-Datei dieses Mal mit der zugehörigen .msf-Datei in den Ordner "Local Folders" des neuen Profils (Bild 3) kopieren
    ◾ wenn die Mails nicht normal angezeigt werden, die .msf-Datei löschen, den importierten Ordner komprimieren
    ◾ wenn das nicht hilft, mit ImportExportTools alle Nachrichten des Ordners im .eml-Format exportieren
    ◾ man erhält einen neuen Ordner, darin eine Datei "index.html" und einem Unterordner mit .eml-Dateien, eine pro Mail
    ◾ beim öffnen der index.html-Datei sollte man schon die Kolonnen Betreff, Von, An, .. usw sehen
    ◾ jetzt eine oder mehrere der .eml-Dateien per drag & drop bei geöffntem TB in die Themen/Nachrichtenliste eines (möglichst) leeren Ordners ziehen und überprüfen, ob die Mails korrekt angezeigt werden mit Betreff, Von, ...


    Wenn dieser Versuch erfolglos war
    ◾ das Tool "mbox2eml" hier herunter laden http://sourceforge.net/projects/mbox2eml/files/
    ◾ eine Mbox-Datei aus der Originalsicherung auswählen und mit "mbox2eml" in xx .eml-Dateien splitten
    ◾ eine oder mehrere dieser .eml-Dateien wie oben beschrieben manuell in einen Ordner im geöffneten TB importieren


    Vor diesen Versuchen würde ich aber eine (nicht zu große) Mbox-Datei der Originalprofil-Sicherung mit einem Text-Editor öffnen.
    Der Anfang einer Nachricht sollte etwa so aussehen, mit den Angaben für Subject, Date, From, To:


    [IMG:http://i1274.photobucket.com/a…zi5/Inbox_zps66f4cba8.png]


    Wenn sich diese Angaben in der geöffneten Mbox-Datei nicht finden lassen, lässt sich wohl nichts mehr machen, es sei denn es findet sich noch eine andere Backup-Kopie des alten Profils.


    Zitat

    Die besten Wünsche für die Feiertage


    Danke gleichfalls ;)

  • Hallo Mapenzi,


    Das Sie weiter versuchen mir trotz der geringen Chance zu helfen, weiß ich sehr zu schätzen.


    Das Exportieren und wieder Importieren von Ordner per ImportExportTool in (eml) Format hat leider nicht funktioniert, weil die E-mails ohne Betreff und Absender exportiert werden. Wie im folgenden Bild.




    Leider konnte ich mbox2eml nicht installieren, trotz mehrerer Versuche; (Java update, Java einstellen, etc.)


    Die einzig gute Nachricht ist, dass alle Angeben (Subject, date, from, etc) im E-mailtext enthalten sind. Die E-mails sind in diesem Sinne noch Intakt. Ich bin auch überzeugt, dass alle Mboxen an einem Punkt beschädigt worden sind.


    Gruß

  • "DeMailer" schrieb:

    Das Exportieren und wieder Importieren von Ordner per ImportExportTool in (eml) Format hat leider nicht funktioniert, weil die E-mails ohne Betreff und Absender exportiert werden.


    Das ist kein gutes Zeichen!
    Wurde auch ein Versuch gemacht, in dem eine Mbox-Datei mit der zugehörigen .msf-Datei aus der Profilsicherung in den Ordner "Local Folders" im augenblicklichen (funktionierenden) Profil kopiert wurde?
    Ich weiß, meine Antworten sind lang und wahrscheinlich unübersichtlich, aber mir wäre es auch wichtig, wenn Sie diese Fragen beantworten könnten:
    ▪ Wurde der Profilordner so wie er war gespeichert oder erst in eine zip-Datei komprimiert und dann in die Cloud geladen?
    ▪ Kann man den Profilordner noch einmal herunter laden aus der Cloud?


    Zitat

    Die einzig gute Nachricht ist, dass alle Angeben (Subject, date, from, etc) im E-mailtext enthalten sind. Die E-mails sind in diesem Sinne noch Intakt.


    Um das zu überprüfen, würde ich eine Mbox-Datei im Text-Editor öffnen, den gesamten Text der ersten Nachricht kopieren und als Textdatei unter einem beliebigen Namen mit der Endung .eml sichern.
    (kopieren von der mit "From - ....." beginnenden ersten Zeile bis zurr nächsten Nachricht, die mit "From - ..." beginnt:


    [IMG:http://i1274.photobucket.com/albums/y440/mapenzi5/From2_zpsff2c707b.png]


    Dann diese .eml-Maildatei manuell in einen Ordner im geöffneten TB verschieben, beispielsweise in den Ordner "Entwürfe, damit man sie nicht erst inmitten anderer Nachrichten suchen muss.
    Wenn auch jetzt kein Betreff, Absender usw. angezeigt werden, dann besteht kaum noch Hoffnung auf eine Lösung.

  • Hallo,
    Inzwischen hat sich der Schleier über dem Geheimnis der nicht darstellbaren Nachrichten etwas gelüftet!
    Ich hatte gestern DeMailer per PN vorgeschlagen, mir eine kleine unbedeutende Mbox-Datei zu übermitteln, um mit ihr zu experimentieren.
    Beim Öffnen der zugesandten Mbox-Datei, die drei Mails enthält, fiel mir sofort der ungewöhnlich große Zeilenabstand in der gesamten Text-Datei auf.
    Zwischen den Zeilen der Header-Einträge wie auch denen des Nachrichten-Textes selber liegt jeweils eine Leerzeile.
    Der Anfang einer Mail seht in etwa so aus:



    Die Datei enthält also alle Informationen wie Datum, Betreff, Von, An, ...usw, infolge des Zeilenfehlers wird eine Nachricht im Vorschaufenster von TB aber als Quelltext dargestellt, mit einem lesbaren Header und darunter dem nicht lesbaren Zeichensalat des Nachrichtentextes.


    Ich habe zum Testen eine Nachricht aus der Mbox-Datei kopiert und im Text-Editor manuell alle überflüssigen Leerzeilen entfernt, die modifizierte Datei als "Test.eml" gesichert und manuell in einen Ordner im geöffneten TB verschoben.
    Die Nachricht wurde jetzt tatsächlich ganz normal dargestellt, mit Betreff, Von, ...usw und lesbarem Nachrichtentext.
    In einem zweiten Test wurden im Text-Editor die Leerzeilen nur im Header entfernt, nicht aber im Nachrichtentext. Auch jetzt konnte die Nachricht korrekt geöffnet werden, die einzigen Unterschiede waren ein anderer Schrifttyp und eine kleinere Schriftgröße.


    Es ist also geklärt, wo der Fehler liegt.
    Vermutlich entstand er beim Hoch- oder Herunterladen des Profils in die / von der Cloud.
    DeMailer wird jetzt nochmals die Dateien herunter laden, diesmal direkt von der Cloud ohne Benutzung von "BitKinex".
    Im besten Fall sind die Mbox-Dateien dann normal, und das Problem ist gelöst.


    Heureka! ;) Soeben erhalte ich eine neue Nachricht von DeMailer:


    Der TE wird sich hier nochmals (in Deutsch) zu Wort melden ;)

  • Inzwischen, hat sich das Problem ganz gelöst, dank Ihrer Beiträge im Forum, ins besondere die von Mapenzi, seine seriösen Lösungsansätze, seine beständige Arbeit und sorgfältige Analyse.


    Ich habe den Ordner „Mail“ direkt von der Cloud runtergeladen, ohne den Webdav-Client (BitKinex) zu benutzen. Alle Ordner habe ich in ein TB-Porfil importiert. Alle Ordner sind intakt, und die Informationen in Header sind vollständig.Es liegt die Vermutung nah, dass BitKinex Lehrzeilen in Email-Inhalt addiert hat bzw. im Email-Header und damit verhindert hat, das der „Betreff“ und die „Absender“ erscheinen können.


    Ich danke dem Forum-Team vielmals und wünsche noch viel Erfolg.
    DeMailer

  • Hallo DeMailer,


    vielen Dank für die Rückmeldung!
    Es hat mich gefreut, dass wir zur Lösung deines Problems beitragen konnten.
    Viel Spaß weiterhin mit Thunderbird! ;)