CalDAV Kalender v. ownCloud werden nicht synchronisiert[erl]

  • Thunderbird-Version: 24.4.0
    Lightning-Version: 2.6.4
    Betriebssystem + Version: Microsoft Windows 7


    Hallo,
    ich habe ownCloud auf meiner Synology DiskStation installiert und einen Kalender mit einigen Terminen angelegt.
    Wenn ich in Lightning einen neuen Kalender anlege und den CalDAV-Link mit http am Anfang eingebe, werden alle Termine synchronisiert.
    Wenn ich allerdings den selben Kalender SSL-Verschlüsselt synchronisieren möchte, funktioniert es nicht mehr. Der Link ist der selbe, außer dass https am Anfang steht.
    Grundsätzlich funktioniert der Zugang über https aber, denn mein iPhone und auch ein Android Smartphone können verschlüsselt synchronisieren.
    Hat jemand einen Tipp für mich?


    Gruß Björn

  • Hallo Björn,


    der einzige Tipp, der mir einfällt, wäre, noch einmal einen Blick in die Fehlerkonsole zu werfen, um zu schauen, ob dort etwas Hilfreiches beim Versuch über SSL auftaucht.
    Legst du den Kalender in Lightning mit oder ohne Offline-Unterstützung an?


    Rätselnde Grüße
    Robert

  • Danke erstmal für deine Antwort!
    Ich habe schon mit und ohne Offline-Funktion getestet.


    In der Fehlerkonsole bezieht sich eine Warnung auf den Kalender:
    getAttributeNodeNS() sollte nicht mehr verwendet werden. Verwenden Sie stattdessen getAttributeNS().
    resource://calendar/modules/calXMLUtils.jsm

    Kann man damit etwas anfangen?


    Wenn ich bei meinem Kalender auf synchronisieren klicke erscheint unten rechts eine Fortschrittsleiste, die jedoch grau bleibt.

  • Die Meldung sollte meines Wissens nicht zum Scheitern der Kalendersynchronisation führen.


    Der Fortschrittsbalken sollte natürllich nicht länger da bleiben, sondern flugs verschwinden und stattdessen Termine erscheinen lassen. Komisch, dass der Kalenderzugriff mit anderen Devices läuft und Lightning ohne Meldung streikt - ob du die Logging-Einstellungen probehalber mal hochsetzen könntest, falls noch nicht geschehen? Bei mir stehen dafür in Thunderbirds erweiterter Konfiguration die Schlüssel calendar.debug.log und calendar.debug.log.verbose auf "true". Ich erwarte mir nicht viel, aber vielleicht gelingt ja ein Glückstreffer...


    Robert

  • Jetzt habe ich folgende Fehlermeldungen:


    Vielleicht wirst du ja daraus schlau.


    Gruß Björn

    Einmal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Ah, ok, einen Fehler haben wir jetzt:

    Zitat

    CalDAV: Unexpected status 405 while querying options Standardkalender


    Diese Meldung (method not allowed) darf nicht auftauchen. Ich bin kein Protokoll-Experte bzw. habe lange nicht mehr in dieser Ecke basteln müssen, aber das hört sich nach einem Fehler auf Serverseite an. Möglicherweise gibt es doch einen Einrichtungsfehler beim Umbiegen von ownCloud auf SSL? Das wäre jedenfalls die Recherche-Richtung, zu der ich dir da nun raten würde. Selbst habe ich da leider nichts Substanzielles mehr auf Lager, sorry.


    Schöne Grüße
    Robert

  • Vielen Dank auf jeden Fall für deine Hilfe.
    Kennst sich evtl. noch jemand mit ownCloud aus und weiß, warum die verschlüsselte Synchronisation mit Lightning nicht klappt?
    Auf iPhone und Android funktioniert es hingegen problemlos, sodass ownCloud ja nicht völlig falsch konfiguriert sein kann.


    Gruß Björn

  • Hallo computerfan3,
    soviel ich weiß kennt rb sich am besten mit diesem Thema aus, darum habe ich ihn auch per PN angeschrieben.
    Leider hat rb nicht immer Zeit hier rein zuschauen.
    Wenn Du aber zur einer Lösung kommen solltest wäre es sehr nett sie uns hier mit zuteilen.


    MfG
    EDV Oldi

  • Hallo,
    ich habe bis jetzt leider noch keine Nachricht von rb erhalten.
    Nachdem ich Thunderbird nochmal ganz neu installiert habe, ist eine weitere Fehlermeldung hinzugekommen:

    Zitat

    [JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=https://***.no-ip.org/owncloud/remote.php/caldav/calendars/cordes.bjoern/standardkalender, result=2147500037, op=[xpconnect wrapped calIOperation]"]


    Vielleicht kann damit ja jemand etwas anfangen?


    Gruß Björn

  • Zitat von "computerfan3"

    Die Lösung: SPDY in den Webdiensten deaktivieren.


    Gruß Björn


    Super - das war auch bei mir die Lösung!

  • Hallo zusammen,


    2 Jahre später: ich hab anscheinend genau das Problem. Ich habe Ich habe den ganzen Vormittag gesucht um herauszufinden, wieso mein


    Thunderbird 38.5.0 mit
    Lightning 4.0.4.1 und der
    owncloud 8.2.1 auf
    Win10


    seit einigen Wochen nicht mehr funktioniert. Hingegen zwischen Android und Owncloud passt es prima und funktioniert seit eh und je gut.


    Wo in welchen Webdiensten muss ich denn das SPDY deaktivieren ? Wie mache ich das ? Gibts ein HowTo?


    LG Chris

  • Hallo Chris,


    hast Du eine Synology? Dann siehe hier, ebenfalls in diesem Forum.


    Falls das nicht hilft, eröffne besser Deinen eigenen Faden und beschreibe das Problem möglichst genau (Was sind die Rahmenbedingungen? Was genau geht nicht? Seit wann? Was wurde verändert?, usw.). Dazu gehören auch das Nennen möglicher Fehlermeldungen und eine Auflistung dessen, was Du bereist unternommen hast.
    Gerade in dem anderen Faden, in dem Du auch ebenfalls pauschal geschrieben hast, Du hättest das gleiche Problem, gibt es Reihe an Hinweise, denen Du zunächst einmal nachgehen solltest.


    Gruß


    Susanne

  • Hallo zusammen,


    da der andere Thread mit dem Hinweis auf diesen hier geschlossen wurde poste ich mal hier weiter.


    Ich habe dasselbe Problem wie hellweg116. Die Synchronisation von Lightning mit Owncloud funktioniert nur in eine Richtung nämlich aus Lightning in die Cloud d. h. wenn ich in Lightning einen Eintrag mache wird er in die Cloud übernommen umgekehrt allerdings nicht. Die Synchronisation zwischen meinem Blackberry und der Cloud funktioniert einwandfrei. Alte Zertifikate habe ich gelöscht.


    Außerdem kann ich in Lightning keine alten Einträge mehr löschen, neu erstellte jedoch schon. Ob das zusammenhängt weiß ich nicht aber es trat zur gleichen Zeit auf. Dazu mache ich aber einen neuen Thread auf.