Timeout des SMTP Servers verändert

  • Hallo!


    Thunderbird 24.4.0
    Windows 7 Pro x64


    Ich habe IMAP Konten angelegt. Verändere das Timeout des SMTP Servers über about:config und/oder prefs.js den Wert mail.server.server1.timeout (usw) von 29 auf egal was. Das Problem ist, das der Wert immer wieder überschrieben wird, wenn das Konto abgerufen wird, das kann ich wirklich nachvollziehen, indem ich während die Konten aktualisert werden, im about:config sich der Wert wieder auf 29 ändert (automatisch).


    Muss man den Wert an einer anderen Stelle einstellen?


    Vielen Dank

  • Hallo


    und willkommen im Thunderbird-Forum!


    Lass uns doch erst einmal klären, wofür du diese Änderung überhaupt vornehmen willst?


    Btw: das

    "Dev Kbits" schrieb:

    mail.server.server1.timeout

    ist afair nicht für den

    "Dev Kbits" schrieb:

    SMTP Server

    zuständig, sondern da wirkt mailnews.tcptimeout.
    Und worin siehst du hier

    "Dev Kbits" schrieb:

    über about:config und/oder prefs.js

    den Unterschied?

  • Hallo


    danke fürs Willkommen.


    Beim versenden von E-Mails mit größeren Anhang (über 2 MByte) kommt die Fehlermeldung, das die Kopie nicht in den gesendeten Ordner abgelegt werden kann (gesendet wurde es trotzdem!) und bei Anhängen über 5 MByte konnte es gar nicht gesendet werden.


    Ich hab das ganze mit einem anderen E-Mail Client Programm ausprobiert (gleiches Konto, IMAP, ...), und mit dem hat es dann funktioniert. Deshalb habe ich angenommen, das es nicht am SMTP Server liegt.


    mail.server.server1.timeout deshalb, weil ich den Hinweis auf anderen Foreneinträge gefunden habe.


    about:config und/oder prefs.js sehe ich jetzt als Laie keinen Unterschied. Denk about:config ist eine GUI von prefs.js. Oder sowas ähnliches. Aber irgendwo wird der Wert mail.server.server1.timeout überschrieben. Und mich würde es interessieren, von was und warum.


    mailnews.tcptimeout. d.h. erhöht mir das Timeout fürs versenden von E-Mails. Ich werds mal ausprobieren und sag Bescheid


    Danke

  • Hallo,


    hast du einen Virenscanner am Laufen? Der sollte weder das Profil, noch ausgehende Mails scannen!

    "Dev Kbits" schrieb:

    mailnews.tcptimeout. d.h. erhöht mir das Timeout fürs versenden von E-Mails.

    ja, aber darum geht es doch auch. Bei IMAP Konten werden die gesendeten Mails ja auch auf den Server geschoben. Wähle mal in Extras>Konten-Einstellungen>%Accountname%>Kopien & Ordner den Gesendet Ordner unter "Anderer Ordner.." und davor auch zum Test mal einen lokalen Ordner.
    Bei der about:config und/oder prefs.js liegst du richtig, deshalb wunderte ich mich über

    "Dev Kbits" schrieb:

    Verändere das Timeout des SMTP Servers über about:config und/oder prefs.js



    Antivirus-Software - Datenverlust droht!
    Und: ein- ausgehende Mails scannen? Hier ein interessanter Beitrag von Peter_Lehmann dazu

  • Hallo


    Virenscanner ist im Einsatz, habe ich für einen Test auch schon mal deaktiviert, war aber das gleich Ergebnis.


    Ich habe eine Testreihe gestartet. Es ist immer ein E-Mail mit 3,5MByte Anhang.


    1.Änderung: mailnews.tcptimeout erhöht.
    Ergebnis: E-Mail wurde gesendet ABER Fehler: Die Nachricht konnte nicht in den Ordner "Gesendet" gespeichert werden.
    NACHTRAG: wird aber dann doch manchmal im gesendeten Ordner angezeigt


    2. Änderung: Einstellung -> Kopien & Ordner: Eine Kopie speichern unter -> Ordner "Gesendet" in : Lokaler Ordner eingestellt
    Ergebnis: hat funktioniert.


    3. Verwende OperaMail als Client mit gleichen IMAP Account (Authentifizierung hier "nur Text, in TB: Keine, Passwort, ungesichert übertragen. Ich weiß nicht, ob das einen Unterschied ist)
    Ergebnis: hat funktioniert.


    4. Änderung: schicke gleiches Mail in Thunderbird über einen anderen IMAP Account (Unterschied ist Eingangsserver, Ausgangsserver, Authentifizierung)
    Ergebnis: hat funktioniert


    Weiß nicht an was es liegt. Auf der einen Seite schaut es aus, wie wenn es an den Mailserver liegt (siehe 4.) auf der anderen Seite, wie wenn es am Client liegt (siehe 3). Und wieso funktioniert es mit der lokalen Einstellung?


    Vielleicht kann mir wer sagen, wie das Kopieren in den Gesendeten Ordner abläuft? Was macht der Client, was macht der Server? Keine Ahnung.


    Vielleicht kann sich wer anderer aus meiner Testeihe ein Reim draus machen.


    Danke

  • Hallo,


    Virenscanner/Firewall deaktivieren alleine genügt nicht, die Regeln greifen zu tief ins System ein. Wäre ja auch für Malware dann möglich...
    Also: den Start mit dem OS deaktivieren und den PC neu starten, per Taskmanager kontrollieren, dass wirklich nichts mehr davon mitläuft und dann testen.


    2) wenn ein lokaler Ordner gewählt wird, brauchen wir ja den Server nicht mehr.
    TB sendet eine Mail raus und sobald die Nachricht des Servers zur Verbindung kommt, wird der Mailentwurf in den gewählten Gesendet Ordner gelegt. Ist dieser lokal, gibt es da keine Probleme. Manche Provider lassen aber auf den systemeigenen Ordner von außen keinen schreibenden Zugriff zu. Hast du den Ordner abonniert?
    Hast du es für den Server mal mit der Auswahl des gleichen Ordners unter "Anderer Ordner.." versucht, oft hilft das.

  • Hallo Dev Kbits,


    rum fragte dich ja schon, wofür du diese Änderung überhaupt vornehmen willst. Das Herumschrauben an diesem Parameter ist nämlich absolut unnützt! Du solltest diese Einstellung so lassen, wie sie ist. Was du tun sollst ist, nach den Ursachen der Verzögerung zu suchen, und nicht etwa an den Sympthomen herumzudoktern.


    Was bedeutet denn "timeout"?
    Es ist die Zeit, in welcher keine (oder extrem wenige) Daten fließen, bis dich dann eben jenes timeout von weiterem sinnlosen Warten befreit. Selbstverständlich kannst du hier einen Extremwert einstellen. Es ist ja deine Wartezeit ... . Stell dir vor, du rufst 10 Mailkonten ab, und hast ein timeout von 10 Minuten eingestellt (und deine Internetverbindung steht nicht). Ja dann wartest du eben im Extremfall deine 100 Minuten. Viel Spaß! (In der Praxis kommt das timeout schneller, da der TB mehrere Mailkonten parallel bedienen kann.)
    Ich leide zum Beispiel gerade jetzt im Urlaub unter einer extrem langsamen Mobilfunkverbindung (EDGE, manchmal am Abend nur wenige 100 bit/s!). Trotzdem kommt es nicht zum Timeout, es fließen ja Daten, und ich kann meine Mails abholen und auch welche senden. Meine Frau nennt es "Geduldstraining".


    Dann solltest du wissen, dass das Versenden von Mails ein völlig anderer Vorgang ist, als das plumpe Kopieren der gesendeten Mail in den Gesendet-Ordner. Das erste erfolgt mittels "SimpleMailTransportProtocol" (SMTP) an den Postausgangsserver deines Providers und das zweite ist ein reiner interner Kopiervorgang. Und dieser erfolgt eben über IMAP, dem gleichen Protokoll, mit welchem du deine Mails abholst. Dieses Protokoll funktioniert nämlich in beiden Richtungen - und hat absolut nix mit dem Senden zu tun.
    Es ist ein bekanntes Problem, welches bei diesem "Hochkopieren" auf den IMAP-Server bei manchen Providern auftritt. Warum, hat noch keiner so richtig ermittelt. Ich auch nicht, denn ich habe dieses Problem eben nicht. Auf jeden Fall macht der AV-Scanner es uns (den Windows-Nutzern unter uns) eben nicht leichter. Meistens ist das Problem vorbei, wenn der AV-Scanner von den Verbindungen zu den Mailservern ferngehalten wird.
    Mein Tipp: wähle einen lokalen Gesendet-Ordner aus. Das funktioniert immer. Und wenn du es brauchst, dann schubse die gesendeten E-Mails ab und an mit der Maus im Block auf den Server. Kurioserweise funktioniert auch dieses immer. Perfektionisten machen das sogar mit einem Filter.
    Mein 2. Tipp: Vergiss dieses IMHO sinnlose Kopieren der gesendeten Mails in den Gesendet-Ordner. Als Beweis für einen erfolgreichen Sendevorgang ist es eh nicht zu gebrauchen. Es ist, wie schon gesagt, ein reines lokales Kopieren. Viel besser ist es, die interne Option des TB zu nutzen, und jede gesendete Mail auch noch als BCC (von den Empfängern somit nicht bemerkt) an eine eigene Adresse zu senden. Du hast dann einen einzigen Sendevorgang, und wenn diese Mail dann nach ein paar Sekungen bei dir wieder ankommt, hast du den echten Beweis, dass der SMTP-Server deines Providers diese Mail zum Versenden angenommen hat. Mehr ist ja eh nicht zu beweisen. Die angekommene Mail mit dem eigenen Absender kannst du dann per Filter vollautomatisch in deinen Gesendet-Ordner verschieben. Auch das klappt immer!



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter_Lehmann,


    danke für deine Ausführungen. Das mit der Kopie in den gesendeten Ordner hab ich mir eh so gedacht, wollte nur sicher gehen, da wissen du ich es nicht.


    Das mit BBC hab ich bereits ausprobiert plus Filter. Funktioniert auch gut ABER ich habe es nicht geschafft, das es als gelesen verschoben wurde. Das verwirrt - nicht mich persönlich, aber in unsern Betrieb bin ich nicht alleine :), Das zweite Probem war, das es manchmal, und das konnte ich auch nicht nachvollziehen, beriets verschobene E-Mail wieder im Posteingang auftauchten. D.h. ich sehe sie dann doppelt - im Posteingang und im gesendeten Ordern (den Filter kann ich dann auch nur mehr manuell drüber laufen lassen). Dann schicken sich manche als Memo sich selbst E-Mails, die dann im gesendeten Ordner landen. Also kurz gesagt, auch keine gute Lösung.


    Was mich aber jetzt wirklich wundert, und da hat mir jetzt noch keiner wirklich eine Antwort liefern können, ist, dass es mit einem andern E-Mail Client wunderbar funktioniert. Dh. am Provider kann es nicht liegen und am AV kann es nicht liegen! Bleibt TB, oder!?


    lg

  • "rum" schrieb:

    Hallo,


    Virenscanner/Firewall deaktivieren alleine genügt nicht, die Regeln greifen zu tief ins System ein. Wäre ja auch für Malware dann möglich...
    Also: den Start mit dem OS deaktivieren und den PC neu starten, per Taskmanager kontrollieren, dass wirklich nichts mehr davon mitläuft und dann testen.


    2) wenn ein lokaler Ordner gewählt wird, brauchen wir ja den Server nicht mehr.
    TB sendet eine Mail raus und sobald die Nachricht des Servers zur Verbindung kommt, wird der Mailentwurf in den gewählten Gesendet Ordner gelegt. Ist dieser lokal, gibt es da keine Probleme. Manche Provider lassen aber auf den systemeigenen Ordner von außen keinen schreibenden Zugriff zu. Hast du den Ordner abonniert?
    Hast du es für den Server mal mit der Auswahl des gleichen Ordners unter "Anderer Ordner.." versucht, oft hilft das.


    Hallo rum,
    zu 1. Virenscanner ist es definitiv nicht. Ich habe meinen komplett deinstalliert, gleiches Problem. Ist kein gutes Gefühl "ungeschützt" im Internet zu hängen, auch wenn es nur für 5min sind


    zu 2. Ordner sind abonniert. Hab auch andere Ordner versucht. Gleiches Problem. Schreibrechte ist sicher auch kein Problem, da es mit Mails ohne oder kleinen Anhängen funktioniert. Es funktioniert ja nur nicht mit größeren Anhängen in TB.


    lg

  • Hallo Leute.


    Das hier ist ein relativ altes Thema. Da ich momentan aber an der Dokumentation arbeite, bin ich hier gelandet und habe ein Wenig Recherche betrieben.


    Fakt ist, dass man in Thunderbird schon seit längerem nicht mehr im Einstellungen-Dialog den Timeout einfach und für alle (?) Verbindungsarten festlegen kann.


    Ich habe IMAP Konten angelegt. Verändere das Timeout des SMTP Servers über about:config und/oder prefs.js den Wert mail.server.server1.timeout (usw) von 29 auf egal was. Das Problem ist, das der Wert immer wieder überschrieben wird, wenn das Konto abgerufen wird, das kann ich wirklich nachvollziehen, indem ich während die Konten aktualisert werden, im about:config sich der Wert wieder auf 29 ändert (automatisch).

    Zu diesem von Kbits angesprochenen Problem habe ich einen BugZilla-Eintrag (Bug 323193) gefunden. Dort wird beschrieben, warum man bei IMAP-Konten den Timeout auf 29 Sekunden festlegt (und somit zwangsweise immer wieder zurückstellt). Der Grund ist, dass bei IMAP per IDLE-Befehl sowieso alle 30 Sekunden quasi erneut eine Verbindung aufgebaut wird. Leider wird in dem BugZilla-Eintrag nicht darauf eingegangen, wie man eventuell separat für SMTP ein längeres Timeout festlegen könnte.

    Gruß
    Thunder


    Keine Forenhilfe per Konversation! - Danke für Euer Engagement und Eure Geduld!