Wiederhestellung [erl.]

  • Thunderbird-Version: 24.4.0
    Betriebssystem + Ve.rsion: Windows 7 64bit und 8.1 64 bit
    Kontenart (POP / IMAP): egeal
    Postfachanbieter (z.B. GMX):mehrere
    Hallo
    habe meine Betriebsysteme neu aufgesetzt und kann jetzt trotz Rückspielens des Thunderbirdordners nicht auf meine Mails zugreifen. Diese Problem habe ich aber nur bei Windows 7 - bei Windows 8 hat es ohne Probleme geklappt. Kann mir keinen Reim darauf machen. Habe den Ordner mal vor der Instalation und mal nach der instalation kopiert. Immer das Selbe wie bei einer Neuinstalation.
    Jemand eine Idee ?
    Gruß Ulrich

  • Hallo Ulrich,


    hast du auf dem Win 7-Rechner den kompletten "Thunderbird" Datenordner oder nur den Profilordner "xxxxxxxx.default" zurückgespielt?
    Und wenn es der Thunderbird-Ordner war, hast du ihn an dieser Stelle eingesetzt:
    Users\username\AppData\Roaming\Thunderbird\ ?

  • Kompletten Thunderbirdordner. Hat bei Windows 8 auch einwandfrei geklapt und bei Windows 7 früher auch nur jetzt halt nicht !!!!!!!!!!!!!!!!

  • Wenn es der komplette Thunderbird-Ordner ist, sollte eigentlich nichts schief laufen!
    Bleibt meine zweite Frage: wurde er an der richtigen Stelle eingesetzt?


    Öffne doch mal den Ordner \Roaming\Thunderbird\Profiles\ :
    wahrscheinlich befinden sich darin jetzt zwei oder mehr Profilordner.
    Überprüfe, ob sich dein altes Profil darunter befindet.
    Wenn ja, öffne die Datei "profiles.ini", suche den Pfad zu deinem alten Profil und überprüfe, ob er korrekt ist.
    Stelle ebenfalls fest, unter welchem Profilpfad sich die Zeile "Default=1" befindet.
    Wenn du irgendwelche Zweifel hast, gib uns den Inhalt dieser Datei an und die Namen der in "Profiles" gelegenen Profilordner.

  • Verzeichnis stimmt. Habe den Ordner mal nach windows 8 verschoben und dort probiert funktioniert auch nicht. Wenn ich nur den Ordner Mail ersetze werden wenigstens die Mails angezeigt die ich in eigenen unterkategorien gesichert hatte, aber leider nicht die E-Mailkonten. Versuche gerade das System wieder auf den alten stand zubringen über ein Backup was aber bei einem neuen Mainboard nicht ganz so einfach ist. Hoffe das ich dann alle Einstelungen wieder habe.

  • "Ulrich035" schrieb:

    Verzeichnis stimmt.


    Das kann man so glauben, hilft aber nicht weiter!
    Wenn man dann entsprechende screenshots sieht, erlebt man manche Überraschung.
    Da wir nicht in deinen Ordner "Thunderbird" oder die Datei profiles.ini hinein schauen können, hatte ich sehr detaillierte Angaben gemacht, was du überprüfen solltest, was du mit einem lapidaren "Verzeichnis stimmt" beantwortest.


    Da TB sich bei dir augenblicklich wie beim Erststart öffnet, heißt das, dass er ein neues Profil angelegt hat, in dem er sich auch bei jedem weiteren Start öffnen wird.
    Man kann aber meistens heraus finden, warum er sich nicht im alten Profil öffnet.
    Dazu wären die Ergebnisse der von mir vorgeschlagenen Überprüfungen hilfreich gewesen, aber da du nicht zweifelst....


    Bevor du wieder alles umkrempelst, kann ich dir abschließend nur noch den Vorschlag machen, den Profile Manager zu starten und zu versuchen, das alte Profil zu öffnen.


    Du kannst auch in diesem Artikel http://www.thunderbird-mail.de/wiki/Profile_verwalten alles Wissenswerte über Profile erfahren.

  • [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/nxida5yh.default


    [Profile1]
    Name=Ulrich
    IsRelative=1
    Path=Profiles/nxida5yh.default


    [Profile2]
    Name=Test
    IsRelative=1
    Path=Profiles/nxida5yh.default


    [Profile3]
    Name=Standard-Benutzer
    IsRelative=1
    Path=Profiles/0ka5ocks.default
    Default=1


    Das neu erstellte 0ka5... ist das einzige was er anzeigt. Das was ich dringend brauche ist das nixda.... ist ca. 3GB groß

  • Habe jetzt das Backup eingespielt und macht den gleichen mist. Muß sich beider Sicherung vor dem Mainboardwechsel zerschossen haben. Bei Windows 8.1 ist es noch Inordnung da es dort aber nur die imap Konten sind hilft mir das nicht weiter.

  • So imap Konto erstellt. Dann den alten in den neuen xxxx.deault Ordner integriert - wieder bei 0

  • "Ulrich035" schrieb:


    Das neu erstellte 0ka5... ist das einzige was er anzeigt. Das was ich dringend brauche ist das nixda.... ist ca. 3GB groß


    Da haben wir's ja!
    Vier Profile (oder zumindest vier Profilpfade), davon das unterste (sicherlich jungfräulich), in dem sich TB gegenwärtig öffnet, da es den Zusatz Default=1 hat.


    Drei weitere Profile nxida5yh.default, offenbar alle die gleichen, nur das erste heißt "default", darunter "Ulrich" und schließlich auch noch "Test".
    Aber wir wissen immer noch nicht, wie viele Profilordner sich im Ordner "Profiles" befinden.
    Ich vermute mal, dort gibt es nur die Profile nxida5yh.default und 0ka5ocks.default.
    Ersteres dürfte dein altes Profil sein.
    Wie die 3 Pfade zu dem Profil nxida5yh.default zustande kamen, darüber kann ich mangels Infos nur spekulieren.
    So was passiert z.B., wenn man im Profile Manager nacheinander zwei Mal ein neues Profil mit jeweils einem anderen Namen erstellt und dann den schon im Ordner "Profiles" vorhandenen Ordner nxida5yh.default "anwählt".
    Dem widerspricht allerdings deine Beschreibung, dass du den kompletten Ordner "Thunderbird" in den Ordner "Roaming" eingefügt hast.


    Die Situation mit den 4 Profilpfaden, wie ich sie oben beschrieben habe, hätte theoretisch aber auch schon bestehen können, als du den Ordner "Thunderbird" eingesetzt hast.
    Ich kann mir bislang keinen Reim darauf machen, aber ich schlage nochmals vor, den Profile Manager zu starten und eines der Profile "default", "Ulrich" oder "Test" zu markieren und TB zu starten, notfalls nacheinander mit allen Profilen probieren.


    Inzwischen habe ich zwei Benachrichtigungen über deine neuen Beiträge erhalten und muss feststellen, dass ich mit dem rasanten Tempo deiner neuen Versuche nicht Schritt halten kann. ;)
    Ich bin jetzt zu einer mehrstündigen Pause gezwungen und schaue mir deine nächsten Schritte am späten Abend an.

  • @ Ulrich035


    Es ist sinnvoll, Ergänzungen im schon vorhandenen Beitrag zu schreiben, solange noch niemand darauf geantwortet hat. So wird u. a. vermieden, dass die Helfer, die den Thread abonniert haben, laufend benachrichtigt werden.

  • Die Profile 1 und 2 sind zustande gekommen weil ich die versucht habe über den Profilmanager einzubinden. Handelt sich aber immer um das was ich benötige. Meine Vermutung geht dahin das im Profilordner eine Datei defeckt ist die Thunderbird sagt wo die verschiedenen Konten im Profil gespeichert sind. Nur welche ist das und kann man die manuel bearbeiten und wieder herstellen?

  • Hallo,

    Zitat

    sagt wo die verschiedenen Konten im Profil gespeichert sind. Nur welche ist das und kann man die manuel bearbeiten und wieder herstellen?


    Das ist die Datei profiles.ini. Defekt ist die aber nicht, sie kann aber falsche oder auch fehlende Einträge enthalten, die aber nicht von alleine dort hinkommen. Die Ursache können der falsche Umgang mit dem Profilmanager oder auch Abstürze sein.
    Man kann die Datei leicht editieren, wenn man die Regeln dazu kennt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "Ulrich035" schrieb:

    Die Profile 1 und 2 sind zustande gekommen weil ich die versucht habe über den Profilmanager einzubinden.


    OK, so hatte ich das auch interpretiert, aber bislang hattest du noch nichts von diesen Versuchen erzählt.
    Auch nicht, warum du diese Versuche gemacht hast.
    Du hattest den kompletten Thunderbird-Ordner (mit dem selben Profil, das auf Windows 8 einwandfrei funktioniert) kopiert vom Windows 8-Rechner auf den Windows 7-Rechner kopiert und (hoffentlich bei beendetem TB) im Ordner "Roaming" eingesetzt, dann TB gestartet. Das sollte 100%ig funktionieren, ohne irgendwelche zusätzliche Manipulationen, und nach dem Start von TB hättest alles so sehen müssen wie in auf Windows 8.


    Ich hatte schon zwei mal gefragt, was passiert, wenn du jetzt den Profile Manager startest, eines der drei Profile "default", "Ulrich" oder "Test" markierst und TB startest.
    Inzwischen bin ich des Fragen müde und gebe mir selber die Antwort: Fenster wie beim Erststart mit Aufforderung zur Erstellung eines Kontos. Richtig Ja/Nein?

    Zitat

    Meine Vermutung geht dahin das im Profilordner eine Datei defeckt ist die Thunderbird sagt wo die verschiedenen Konten im Profil gespeichert sind. Nur welche ist das und kann man die manuel bearbeiten und wieder herstellen?


    Die Konteneinstellungen und Ordnerpfade sind in der prefs.js-Datei gespeichert.
    Eine prefs.js-Datei kann gelegentlich beschädigt werden, aber es ist in den meisten Fällen äußerst schwierig oder zu zeitraubend, sie zu reparieren.
    Da es sich auf beiden Rechnern um die gleiche prefs.js-Datei handelt und sie auf Win8 funktioniert, kann ich mir nur schwer vorstellen, dass sie beim Kopieren des Thunderbird-Ordners von einem zum anderen Rechner beschädigt wurde.


    Ich schlage einen der folgenden Versuche vor:
    den Thunderbird-Ordner nochmals aus User\user\AppData\Roaming\ von Win8 auf Win 7 kopieren,
    auf Win7 bei beendetem TB den Thunderbird-Ordner in \Roaming\ löschen und durch die Kopie ersetzen.
    TB starten.


    Oder ersatzweise nur die Datei prefs.js aus dem Profilordner nxida5yh.default auf Win8 kopieren und auf Win7 bei beendetem TB die prefs.js-Datei im Profilordner nxida5yh.default durch die Kopie ersetzen.
    Dann den Profile Manager aufrufen und TB in einem der Profile "default", "Ulrich" oder "Test" öffnen.

  • Sorry wohl nicht richtig ausgedrückt. Ein Rechner zwei Betriebssysteme. Unter 7 als pop Konten und unter 8 als imap. Wichtig ist aber 7 da dort die alten Mails ja gespeichert sind. Aus dem Profilmanger läst sich kein Profil von Windows 7 Starten - fängt bei 0 an auser das neu angelegte.

  • Mapenzi Danke für deine Mühe. Manchmal hat man halt Bretter vor dem Kopf. Mir sind zwei wirklich dumme Fehler passiert die drei Tage arbeit (neuinstalationen Rechnerumbau und sonstiges ) nach sich gezogen haben. Die Profildatei ist aber defekt und der Fehler würde mich trotz allem interessieren. Mach immer zwei Sicherungen - einmal nur die Daten immer einmal die Woche und einmal im Monat das ganze System. Vor dem Umbau bei Sicherungen ausgeführt aber bei der Programierung der Datensicherung habe ich bei Acronis den Verkehrten Ordner erwischt(Lokal statt Roaming). Bei der gesamt Sicherung viel mir dann heute ein das ich einen Tag zuvor auch eine Sicherung gemacht habe und die ist zum Glück intakt - alles wieder da. :):):):):):):):):):):) :lol: :lol: :lol: :lol:

  • "Ulrich035" schrieb:

    aber bei der Programierung der Datensicherung habe ich bei Acronis den Verkehrten Ordner erwischt(Lokal statt Roaming).


    Schön, dass du schließlich selbst darauf gekommen bist!
    Du kannst dich aber trösten, du bist in diesem Forum nicht der Erste, dem das passiert. ;)


    Zitat

    Die Profildatei ist aber defekt und der Fehler würde mich trotz allem interessieren.


    Ich würde dir das gerne erläutern, aber du musst mir erst erklären, was du mit "die Profildatei" meinst.
    Meinst du eine bestimmte Datei im Profil, und wenn ja, welche?
    Den Profilordner "xxxxxxxx.default"?
    Die Datei "profiles.ini"?
    Und welche Konsequenzen zieht diese nicht benannte defekte Datei bei dir augenblicklich nach sich?

    Einmal editiert, zuletzt von Mapenzi ()

  • Die Datensicherung wo ich mich bei dem Ordner verhauen hatte habe ich nicht benutzt sondern den von der Komplettsicherung da der es wegen der größe schon nicht sein konnte - 34 MB zu 3GB. Was mich nur so stutzig macht ist warum in der Komplettsicherung vom 25.3. der Profilordner xxxx.default defekt ist und vom 24.3. zum Glück Inordnug. :confused: Aber alle Mails wieder da und nur das Zählt. Hatte zwischen den beiden Sicherungen zum Glück keine über Pop3 abgerufen. Womit kann ich denn die Perfs.js anschauen um zu sehen wo den wohl der Fehler liegt?

  • Die prefs.js-Datei kannst du mit einem Text-Editor öffnen, aber zur Sicherheit würde ich das mit einer Kopie der Datei machen. Den Fehler zu finden wird u. U. sehr schwierig sein.
    Aber da du im jetzt aus der anderen Sicherung übernommenen Profil eine "gesunde" prefs.js-Datei hast, kannst du auch diese kopieren und zum Vergleich heranziehen.