Server-Einstellungen --> Lokaler Ordner [erl.]

  • Thunderbird-Version: 24,4,0
    Betriebssystem + Version: Win 7
    Kontenart (POP / IMAP): pop
    Postfachanbieter (z.B. GMX): gmx


    Hallo,


    ich hab ein Frage zu Server-Einstellungen und dort ganz unten der Eintrag Lokaler Ordner ...


    mit dem vorgegebenen Eintrag C:\user\[username]\AppData\Roaming\Thunderbird\Profiles\.nnnn.default\Mail\pop3.xxxx.gmx


    muckt Tb immer rum und meldet


    'Der angegebene Ordner "C:\Users\[username]\AppData\Roaming\Thunderbird\Profiles\ficqgoys.default\Mail\pop3.xxx.de" ist zum Abspeichern von Nachrichten nicht geeignet. Bitte wählen Sie einen anderen Ordner.'


    würde ich gerne machen ... habe auch einen anderen Ordner angelegt, aber da muckt Tb ebenso ...


    welchen Ordner muß ich wählen (mein Kollege hat denselben Eintrag mit anderem 'default') und bei ihm muckt nix ...


    Vielen Dank


    Michael

    Michael
    _________________________
    nette Menschen gibt es überall

  • Hallo Michael,


    der Account Manager von TB verhindert seit der Version 24, dass Nutzer den lokalen Ordner des Nachrichtenspeichers eines Kontos innerhalb des Profilordners willkürlich wechseln können.
    Auch die "Lokalen Ordner" werden von TB als Konto betrachtet, auch wenn keine Identität mit ihm verknüpft ist.


    Offenbar versuchst du, den Kontenordner "pop3.xxx.de" als lokalen Ordner des Nachrichtenspeichers für die "Lokalen Ordner" zu bestimmen.
    Das verhindert der Account Manager, da dieser Ordner schon als Nachrichtenspeicher für dein POP-Konto gmx benutzt wird.
    Der "richtige" Nachrichtenspeicher für die "Lokalen Ordner" heißt "Local Folders" und befindet sich im Profil im Ordner "Mail", ebenso wie die POP-Kontenordner.


    Oder vielleicht hast du diese Änderung schon in einer älteren TB-Version gemacht und bekommst jetzt diese Fehlermeldung, wenn du die Konten-Einstellungen für die Lokalen Ordner" anzeigen willst?
    Wenn dies der Fall ist, können wir dir helfen, diesen Fehler zu beheben.


    Gruß

  • vielen Dank für die Antwort ...


    eigentlich habe ich nichts gemacht ... ich habe von XP auf Win 7 umgestellt, zuvor mit MozBackup alles gespeichert und dann zurückgespielt ... und seither muckt TB, aber ohne große Folgen ... an den Kontoeinstellungen habe ich nix geändert ...


    ich werde ein neues Konto einrichten, dann müßte sich ja auch dieser ORdner selbst und richtig einrichten, oder?


    Gruß


    Michael

    Michael
    _________________________
    nette Menschen gibt es überall

  • "Michael12353" schrieb:

    eigentlich habe ich nichts gemacht ... ich habe von XP auf Win 7 umgestellt,


    Diese Angabe fehlte bisher, dabei hast du vermutlich einige Altlasten des vorigen Profils übernommen.
    Ich muss meine erste Antwort korrigieren, ich hatte leider deinen Ausdruck "Lokaler Ordner" falsch interpretiert, da ich an die "Lokalen Ordner" gedacht hatte.
    Es handelt es aber um den lokalen Ordner des Nachrichtenspeichers für dein Pop-Konto.
    Ich vermute, dass unter XP irgendwann der Profilname geändert wurde.


    Leider hast du die Pfade ungenau angegeben, sodass man sie nicht vergleichen kann.
    Zunächst gibst du den Pfad wie folgt an: Thunderbird\Profiles\.nnnn.default\Mail\pop3.xxxx.gmx
    In der Fehlermeldung steht aber: Thunderbird\Profiles\ficqgoys.default\Mail\pop3.xxx.de"
    Wir können also nicht erkennen, ob es sich um den selben Profilnamen handelt.

    Zitat

    ich werde ein neues Konto einrichten, dann müßte sich ja auch dieser ORdner selbst und richtig einrichten, oder?


    Damit würde ich noch warten, außerdem bin ich mir nicht sicher, ob das Neu-Einrichten des Kontos das Problem behebt.


    Zeige den Profilordner an über Menü "Hilfe" -> Informationen zur Fehlerbehebung, suche die Datei "prefs.js" und öffne sie in einem Text-Editor.
    Suche die Zeilen, die mit "user_pref("mail.root..." beginnen und kopiere sie in deine Antwort.


    Zu diesem Problem siehe auch Der angegebene Ordner ist zum Abspeichern von Nachrichten #26

  • die Fehlermeldung ist vom Inhalt richtig ... da habe ich nur den Anwendername rausgenommen ...


    in der pref.js habe ich keinen Eintrag gefunden mit mail.root ... usw.

    Michael
    _________________________
    nette Menschen gibt es überall

  • "Michael12353" schrieb:

    die Fehlermeldung ist vom Inhalt richtig ... da habe ich nur den Anwendername rausgenommen ...


    Es geht nicht um den Anwendernamen in der Fehlermeldung, sondern um die 8 Ziffern/Buchstaben, die vor .default stehen und die ich farbig gekennzeichnet habe!
    Du hast sie durch "nnn" ersetzt, aber wie heißen diese 8 Ziffern/Buchstaben im Pfad zum lokalen Ordner des Nachrichtenspeichers deines POP-Kontos, also in der Zeile, die du unter "Lokaler Ordner" siehst?


    Zitat

    in der pref.js habe ich keinen Eintrag gefunden mit mail.root ... usw.


    Das kann ich nicht glauben.
    Du müsstest solche Zeilen wie diese sehen:


    Code
    1. user_pref("mail.root.imap", "/Users/xxxxxx/Library/Thunderbird/Profiles/onotis81.Dominsp/ImapMail");
    2. user_pref("mail.root.imap-rel", "[ProfD]ImapMail");
    3. user_pref("mail.root.none-rel", "[ProfD]Mail");
    4. user_pref("mail.root.pop3-rel", "[ProfD]Mail");


    Suche nochmals in deiner prefs.js-Datei.

  • hier die fehlenden Zeichen und den Rest dazu ficqgoys.default\Mail\pop.gmx-1.net


    die Datei nennt sich prefs.zal und hat u.A. diesen Inhalt


    user_pref("mail.root.imap", "C:\\Dokumente und Einstellungen\\nnnn\\Anwendungsdaten\\Thunderbird\\Profiles\\lu4sa0xf.default\\ImapMail");
    user_pref("mail.root.none", "C:\\Dokumente und Einstellungen\\nnnn\\Anwendungsdaten\\Thunderbird\\Profiles\\lu4sa0xf.default\\Mail");
    user_pref("mail.root.pop3", "C:\\Dokumente und Einstellungen\\nnnn\\Anwendungsdaten\\Thunderbird\\Profiles\\lu4sa0xf.default\\Mail");



    nnnn steht für meinen Namen


    das sind aber die Daten aus der Zeit von Win XP, denn die Pfadstruktur ist in Win 7 eine andere und auch die defaultangaben sind jetzt andere (siehe oben)


    korrigieren geht das ja nicht oder doch (im Editor?)

    Michael
    _________________________
    nette Menschen gibt es überall

  • Hallo,

    Zitat

    die Datei nennt sich prefs.zal


    Die gibt es in der Desktop-Version von Thunderbird nicht.
    Es könnte aber sein, dass MozBackUp diese erzeugt oder geändert hat.
    Welche Version von MozBackUp benutzt du?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • ich habe die 1.4.9-de benutzt


    was wäre, wenn ich diese 3 Zeilen einfach ändere (im Editor z.B.)?

    Michael
    _________________________
    nette Menschen gibt es überall

  • "Michael12353" schrieb:

    hier die fehlenden Zeichen und den Rest dazu ficqgoys.default\Mail\pop.gmx-1.net


    Hier haben wir's:
    dein aktuelles Profil heißt ficqgoys.default, in den mail.root-Pfaden steht aber lu4sa0xf.defaul, z. B. hier:
    user_pref("mail.root.pop3", "C:\\Dokumente und Einstellungen\\nnnn\\Anwendungsdaten\\Thunderbird\\Profiles\\lu4sa0xf.default\\Mail");
    Das kann der neue Account Manager von TB 24 nicht verdauen und reagiert mit der Fehlermeldung.
    Dazu mehr Bug 921371 "Can't edit account settings after update to version 24".

    Zitat

    die Datei nennt sich prefs.zal und hat u.A. diesen Inhalt


    Diese Endung ist mir noch nie begegnet, aber eben habe ich gesehen, dass mrb schon dazu einen Kommentar geschrieben hat.
    Ich rate, eine Sicherungs-Kopie der Datei prefs.zal zu erstellen, dann bei beendetem TB das Original in prefs.js umzubenennen.


    Zitat

    korrigieren geht das ja nicht oder doch (im Editor?)


    Du kannst entweder diese user_pref("mail.root...-Zeilen löschen oder den Konfig-Editor (Extras -> Erweitert -> Allgemein) öffnen, mail.root in die Suchzeile eingeben und die gefundenen mail.root-Einstellungen über R-Klick -> Zurücksetzen auf ihre Default-Werte zurück setzen.
    Nach dem Neustart von TB sollte die Fehlermeldung nicht mehr erscheinen, wenn du die Server-Einstellungen bearbeiten willst.

  • Danke :redface:


    das hat dann soweit geklappt ...


    Viele Grüße


    Michael :lol:

    Michael
    _________________________
    nette Menschen gibt es überall