Jahreszahl wird falsch angegeben statt 2014 z.B. 1430[erl.]

  • Thunderbird-Version: 31.0
    Betriebssystem + Version: OSX 10.9.4
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX):1und1


    Mein Problem ist, dass die Jahreszahl - also 2014 - nicht korrekt angezeigt wird und das weder bei von mir gesendeten
    noch bei empfangegen mails. Und vor allem ist das bei jeder mail in allen Ordnern so.
    Beispiel: eine mail, die ich am 21.07.2014 um 20:35 versandte, steht im Send-Ordner 19.07.1430 20:35.


    Vollkommen erschreckt, habe ich zunächst auf meinem anderen MAC Th geöffnet, um zu prüfen, ob der Fehler
    möglicherweise beim IMAP von 1und1 liegt. Erleichtert stellte ich fest, dass dort alles o.k. ist.


    Wer kann sich und mir das erklären und weiß Abhilfe?


    Danke und gute Grüße
    mischu

  • Guten Tag mischu! (<= Ja, so viel Zeit nehmen wir uns hier ... .)


    Ich würde jetzt in folgender Reihenfolge suchen:

    • Passiert das bei allen/einigen oder nur bei Mails eines bestimmten Absendern?
    • Stimmt die Systemzeit?
    • Und die BIOS-Zeit?
    • Stimmt die im System eingestellte Zeitzone (auch wenn das hier kaum eine Rolle spielen dürfte)
    • Welches Datum wird bei der gleichen Mail auf dem anderen Rechner angezeigt?
    • Welches Datum wird im Quellcode der betreffenden Mail angezeigt (Received:- und Date:- Zeilen)?



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,
    danke!
    Irgendwie hat die e-mail-info nicht geklappt.
    Gerade wollte ich meinen Notruf wiederholen und da fand ich Deine Antwort erst. Pardon


    Edit: Vollzitat gelöscht! Bitte zum Antworten die Buttons Antworten oder SchnellAntwort verwenden bzw. bei Einsatz des Buttons Zitieren nur das unbedingt Notwendige aufführen! Mod. graba


    Würde ein Photo - screenshot - helfen. Nur mag ich den - wegen dem Datenschutz der Absender - nicht so gerne öffentlich einstellen.


    Vielleicht hast Du ja noch eine "zündende" Idee.


    Da die email-Info nicht geklappt hat, "verspreche" ich jeden Tag aktiv ins Forum zu gehen.


    einen guten Abend Dir
    mischu

  • Hallo mischu,


    du siehst mich ratlos!

    Zitat

    bei allen-


    "Bei allen" und auch dass das Datum im Quellcode ja stimmt, und diese Mails auf einem anderen Rechner richtig angezeigt werden sagt mir, dass dieses Problem wirklich von deinem Thunderbird verursacht wird.
    Aber wo und warum? Ich muss passen! Das hatte ich noch nicht!


    Zitat

    bei denen vom aktuellen Tag erscheint nur die Uhrzeit.


    Das ist wirklich ein Feature! So ist es gewollt!


    Zitat

    Welches Datum wird bei der gleichen Mail auf dem anderen Rechner angezeigt?
    das "richtige"
    zumindest war das bis vorhin so, da hat TB auf 31.0 aktualisiert und der gleiche Fehler war dann auch dort.


    Interessante Aussage!
    Ich nutze ja ganz bewusst nicht die v31. Mal sehen, was andere Nutzer (mit v31) dazu sagen.


    Auf jeden Fall gibt es jetzt genügend Aussagen (korrekte Systemzeit und sonstige Zeiteinstellungen, auf anderen Rechnern korrekte Anzeige, korrekte Daten im Quelltext usw.) für eine weitere Suche.


    Ich schlage vor, dass du jetzt erst einmal wartest, ob sich ein anderer (Mac-nutzender?) Helfer der Sache annehmen kann. Sollte das nicht passieren, kannst du das Problem in eine Anfrage an eine Suchmaschine "verpacken". Und wenn auch das nichts bringt, bei BugZilla suchen oder selbst ein neues Problem posten. (Ist selbstverständlich alles auf englisch und damit nicht so mein Ding ... .)


    Sorry, dass ich dir nicht weiter helfen kann!


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,
    ich danke Dir und werde mal geduldig bleiben.
    Habe schon überlegt, ob ich den TB deinstalliere, neu aufsetze und dann aus dem MAC-mail-programm die Daten migriere.
    Vielleicht - wenn keiner sich meldet - versuche ich das mal.


    Habe übrigens nach der Vorgänger-Version von TB gesucht, finde aber nirgendwo einen download (für MAC),
    hast Du einen Tip.
    Vielleicht lässt es sich ja damit lösen.


    Übrigens habe ich gestern nacht noch entdeckt, dass diese abenteuerlichen Jahreszahlen nicht ganz total verblödet sind.
    Die 14 bei 14... bedeutet nämlich 20-14, die 13 bei 13.. = 20-13 etc.pp
    - wenigstens eine kleine Hilfe.


    Dir Dank und gute Grüße
    mischu

  • Hallo Peter,
    habe gerade doch noch einen download der Version24.7.0 gefunden,
    brauchst also mir keinen Hinweis mehr senden.


    gute Nacht und einen sonnigen Tag Dir morgen
    - wohnst ja um die Ecke -


    Mischu

  • hallo,
    wer hat noch eine Anregung, einen Tipp, denn noch habe ich dasselbe Problem
    gute Grüße
    mischu

  • Hallo mischu,


    hast du mal ein neues Profil erstellt? Tritt das Problem dann auch noch auf?


    Viele Grüße,
    tempuser

    Entwickler des Add-ons Mail Merge (Thunderbird / SeaMonkey) und Mitwirkender des Add-ons Cardbook (Thunderbird)

  • Hallo mischu,


    mir ist dein Thema erst gestern nach der Aktualisierung aufgefallen.
    Ich habe ein solches Problem noch nie gesehen, auch bei einer Suche mit "thunderbird wrong message date" lässt sich kein einziger Fall finden, in dem ein falsches Jahr im Datum angegeben wird.


    Habe ich richtig verstanden, dass du inzwischen ein "downgrade" auf die v24.7.0 getestet hast und dass auch danach das Problem weiterhin besteht?
    Hast du das selbe IMAP-Konto auch in Apple Mail eingerichtet und werden auch dort die Jahreszahlen falsch angegeben?


    Da wir völlig im Dunkeln tappen, solltest du unbedingt, wie es tempuser schon vorgeschlagen hat, Thunderbird in einem neuen Profil testen.
    Das ist, besonders bei einem IMAP-Konto, nicht aufwendig und lässt sich in wenigen Minuten durchführen.


    Wenn das Problem in der v24.7.0 jedoch nicht besteht, in der v31 aber auch in einem neuen Profil auftritt, ist wohl ein Bug Report fällig.


    Gruß

  • Guten Abend Ihr lieben Helfer,
    ich habe beide Vorschläge erprobt:
    1. über Terminal den Profilmanager geladen und in v31 ein neues Profil erstellt für eine,
    meine zentrale, e-mail-Adresse.
    Es bleibt bei den falschen Jahreszahlen.
    2. Thunderbird neueste Version (v31) deinstalliert, bei MAC in den Papierkorb gelegt.
    Dann Thunderbird 24.2.0.dmg - habe 24.7.0 nicht gefunden- installiert. Danach
    Thunderbird erneut gestartet.
    Auch dieser Versuch brachte keine Lösung. Es bleibt bei den falschen Jahreszahlen.
    3. IMAP-Konten sind gleich.
    In MAIL ist alles o.k.; d.h. die Datumsangaben sind korrekt z.B. 23.August 2014


    Leider habe ich keine besseren Nachrichten.


    gute Grüße
    mischu

  • Hallo Mischu,


    dein Fall ist bisher einzigartig und erklärlich.
    Der Vollständigkeit halber und um keine mögliche Ursache auszulassen, muss ich dich aber noch fragen, wo du die Datei "Thunderbird 24.2.0.dmg " herunter geladen hast, desgleichen von welcher Seite die Vorversionen von TB auf deinen beiden Macs stammen.


    Alle bisher erschienen Versionen von TB sind auf dieser offiziellen Seite von Mozilla veröffentlicht:
    http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/


    Ich würde trotz aller bisherigen Misserfolge noch folgenden Versuch durchführen:
    • lade die Datei "Thunderbird 24.7.0.dmg" von der o. g. Seite herunter, lösche deine aktuelle TB-Kopie aus dem Programmordner und installiere TB 24.7.0 durch Doppelklick auf das disk image, aber starte ihn noch nicht.
    • Gehe in deine User-Library und verschiebe den Ordner "Thunderbird" provisorisch auf den Schreibtisch (oder auch in "Dokumente", auf jeden Fall nicht löschen).
    • Starte TB 24.7.0 , erstelle eines deiner IMAP-Konten und überprüfe die Daten und Jahreszahlen.


    Besteht das Problem der falschen Jahreszahlen weiterhin, haben wir etwas Zeit vergeudet, du löschst bei beendetem TB den neu erstellten Ordner "Thunderbird" wieder aus der user-Library und setzt an gleicher Stelle deinen alten "Thunderbird"-Ordner ein.
    Danach lädst du die v31 von der o. g. Mozilla-Seite herunter und installierst sie anstelle der v24.7.0.


    Sollte das Problem wider Erwarten in der v24.7.0 nicht mehr auftreten, würde ich zunächst das Update auf v31 machen, und, falls das Problem nach dem Update nicht wieder auftaucht, mit dem neu erstellten Profil weiter arbeiten.
    Das bedeutet, du müsstest dann die anderen Konten erstellen, deine Erweiterungen installieren, deine Adressbücher aus dem zuvor verschobenen alten Thunderbird-Ordner importieren, in dem sich das Profil befindet, ....usw.

  • hallo,
    nachdem alle Tipps nichts gebracht haben und niemand Anderes dasselbe Problem hat, kam mir ein Zufall zu Hilfe.
    In der NotizenApp, die ich seit langer Zeit aufsuchte, weil ich eine uralte Notiz suchte, war die Jahreszahl ebenfalls so verändert wie in Thunderbird. In keinem anderen Programm/App, die ich ständig gebrauche, war alles korrekt. Ebenso in der Zeitzonen und Zeiteinstellung.
    Ich habe den Zeitserver auf Asien gestellt, den Ort - Vorort von Köln - bestimmen lassen, dann den Zeitserver wieder auf Europa und in der NotizenApp hatte ich die richtige Jahreszahl und in Thunderbird ebenfalls.
    Was da die wirkliche Ursache war - bleibt mir ein Rätsel.
    Was soll es, das Problem ist gelöst.
    Vielen Dank allen, die mitüberlegt haben.
    mischu

  • Vielen Dank für die Rückmeldung und Glückwunsch zu der originellen Lösung!
    Es war also eher ein Bug in den OS X System-Einstellungen (Zeitzone).
    Warum er sich nur in zwei Programmen ausgewirkt hat, wird sich wohl nie klären lassen.


    Gruß