Zeichenkodierung chaos (Antwort als entwurf speichern)

  • Thunderbird-Version: 31.2
    Betriebssystem + Version: Win7 x64
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): unterscheidliche


    Hallo,


    ich habe kurz gesucht, aber nur ein Thema gefunden, in dem sich anscheinend zufällig, auch bei frisch geschriebenen Mails die Zeichenkodierung beim Speichern als Entwurf ändert. Das Problem hier ist ähnlich aber anders:


    Beim Antworten auf manche (durchaus beim lesen korrekt angezeigte) Mails und abspeichern der Antwort als Entwurf kommt es nach dem erneuten öffnen des Entwurfs zu Zeichenchaos mit den Umlauten. Das passiert nicht bei allen E-Mails auf die man antwortet, aber ich habe noch nicht herausfinden können, was die E-Mails ausmacht bei denen es schief geht.


    Sollte man in dem Fall "alle Mails im Entwürfe Ordner unabhängig von der eigentlichen Kodierung" abspeichern? Oder geht es dann immer durcheinander?


    Vielen Dank.

  • Hallo,
    poste uns mal deine Einstellungen und zwar hier:


    Extras > Einstellungen > Erweitert > Allgemein
    hier interessieren nur die Kästchen ob angehakt oder nicht.
    Dann auf den Ordner gehen, in dem du die Mail gespeichert hast dann Rechtsklick > Eigenschaften > Allgemein
    ist das unter Kästchen angehakt oder nicht?
    In den meisten Fällen liegt es aber am versendenden Mailprogramm oder an der betr. Webseite.
    Wir haben solche Fälle schon gehabt, Ursache sind fehlerhafte Codes und falsche Deklarierungen.
    Um die genaue Ursache zu finden, müsstest du mir eine solche Mail im Original zukommen lassen also als *.eml Datei.
    wenn du das möchtest, melde dich per PN.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Vielen Dank für die Antwort!


    Extras/Einstellungen/Erweitert/Allgemein
    performance daten senden deaktiviert, sonst alles aktiviert (automatischer Bildlauf; sanfter Bildlauf; beim Start auf Standard prüfen; Windows Suche Ermöglichen; globale Suche und Nachrichtenindizierung). ... war das der richtige Tab für das Problem? :gruebel:


    Ordner "Entwürfe"/Eigenschaften/Allgemein
    Aktiviert: Nachrichten für globale Suche indizieren; Deaktiviert: Ordner auf neue Nachrichten Prüfen, wenn E-Mails für dieses Konto empfangen werden; Standard Kodierung: ISO-8859-15


    Kann dir eine Nachricht schicken (Header von Original und gespeichertem Entwurf?), aber das ist ja nicht nur ein Mal passiert. Ich tippe auch auf falsche Kodierung der eingehenden Nachricht.

  • Sorry, ich hatte dir den falschen Pfad gesendet, den du überprüfen sollst:
    Richtig ist:
    Extras > Einstellungen > Ansicht > Formatierung > Schriftarten > Erweitert


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hier kommen die nächsten Einstellungen:



    Sollte man den letzten Punkt aktivieren? geht da was schief?


    Danke :)

  • Nein, den letzten Punkt sollte man nicht aktivieren, damit der Empfänger den gleichen Zeichensatz erhält, den er auch normalerweise verwendet.
    Diesen Rat gab man noch vor 10 Jahren als nicht jeder Computer z.B. über Unicode (=UTF-8) verfügte. Tat er es nicht, war die Lesbarkeit der Mail eingeschränkt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • So arg wie im verlinkten Beispiel geht es nicht auseinander mit der Zeichenkodierung. Auch sehe ich nie kurz was aufblinken mit einer anderen Kodierung. Es sind wirklich nur die Sonderzeichen/Umlaute die für mich umgewandelt nach der typischen html Kodierung aussehen mit vielen / und &. Es passiert eben nur bei manchen eingehenden Mails, das der Entwurf so durcheinander Gerät, daher dachte ich, das überschreiben der Kodierung beim Entwurf speichern hilft vielleicht?

  • Zitat

    Es passiert eben nur bei manchen eingehenden Mails, das der Entwurf so durcheinander Gerät, daher dachte ich, das überschreiben der Kodierung beim Entwurf speichern hilft vielleicht?


    Dafür ist mir kein Weg bekannt, außer du stellst im Verfassenfenster die ursprüngliche Zeichenkodierung über > Optionen > Zeichenkodierung wieder her.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich dachte, das macht die Option "Wenn möglich, Standardkodierung für Antwort verwenden"? Also, dass sie die Zeichenkodierung überschreibt in der Antwortmail (und damit auch im gespeicherten Entwurf?). Seltsam ist auch, dass es nur beim Entwürfe speichern passiert, ist mir noch nie aufgefallen, dass es direkt eine Mail so verunstaltet, wenn nur "antworten" verwendet wird :-/

  • Zitat

    ch dachte, das macht die Option "Wenn möglich, Standardkodierung für Antwort verwenden"? Also, dass sie die Zeichenkodierung überschreibt in der Antwortmail (und damit auch im gespeicherten Entwurf?).


    Ja, aber genau das sollte man beim Antworten nicht tun, aus oben besagten Gründen.
    Ein alter Computer z.B. verfügt nicht über Unicode.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw