TB voller Fehler nach Update auf 38.2.0

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 38.2.0
    * Betriebssystem + Version: OSX 10.10.5
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): u.a. berlin.de, arcor.de
    * Eingesetzte Antivirensoftware: ESET cyber security
    * Firewall (Betriebssystem-intern/Externe Software):


    Hallo liebens Forum! Leider habe ich heute das Update auf Version 38.2.0 durchgeführt.
    Seither kann ich TB nicht mehr nutzen!


    Kurze Beschreibung: Ich nutze TB auf dem Mac und habe mein Profil und meine Nachrichtenordner extern auf einem USB Stick. Lief bisher immer problemlos. Bis nach dem Update.
    Ich habe ein Email Zertifikat, welches ich bisher problemlos nutzen konnte und dessen Passwort ich beim Starten von TB gefragt wurde.


    Seit dem Update:
    Es wird nicht mehr nach dem Zert PW gefragt... der Zertifikat Manager ist leer und wenn ich mein Zertifikat importieren will, passiert NICHTS, die Liste bleibt unverändert leer.


    Wenn ich meine Emails abrufen will, passiert NICHTS.


    Wenn ich eine Mail schreiben will kommt folgende Fehlermeldung:
    Senden der Nachricht fehlgeschlagen.
    Fehler beim Senden der Nachricht: Passwort für mail.berlin.de ist nicht verfügbar. Die Nachricht wurde nicht gesendet.


    Was ist hier schief gelaufen?? Was wurde alles gelöscht bzw. nicht übernommen?


    Freue mich auf eure Unterstützung.
    Lieben Dank.
    LG
    Tobi



    edit:
    Ich habe nun versucht eine alte Version zu installieren, zuerst die 38.1.0 und dann die 38.0.1 und das Problem lässt sich nicht mehr beheben! Ich kann kein Zertifikat mehr importieren und habe auch keine Möglichkeit meine IMAP/SMTP Passwörter anzugeben (welche bis zum Update gespeichert waren)...


    edit2:
    Mir ist gerade etwas in den Kontoeinstellungen aufgefallen... seit dem Update steht der Servertyp plötzlich auf POP statt IMAP!! Wie geht das und wie kann man das wieder ändern?

    3 Mal editiert, zuletzt von km65 ()

  • So... ich habe jetzt den Beweis dafür, dass es an dem Update liegt! Irgendwas wurde verändert!
    Ich habe jetzt mehrere alte Version versucht... und erst als ich die 31.8.0 installiert habe, war alles wieder OK. Es funktionierte alles, als wäre nie etwas gewesen.


    Also... was wurde an der Profilstruktur zwischen 31.8.0 und 38.0.1 verändert und ist nicht mehr kompatibel? Dazwischen gab es ja scheinbar nur betas....

  • Hallo Tobi,
    und willkommen im Forum!


    Du wunderst dich bestimmt, warum bis jetzt schon 55 Leute deinen Beitrag gelesen, aber noch keiner geantwortet hat.
    Genau darauf werde ich dir jetzt meine persönliche Antwort geben.


    Zwei Gründe sehe ich:

    • Du schreibst: "... und habe mein Profil und meine Nachrichtenordner extern auf einem USB Stick." Und ich sage dir, dass ein ernsthafter Helfer derartige Frickel-Bastellösungen nicht unterstützen wird! Kein Mensch weiß, was bei deiner "Lösung" passiert ist. Und wenn du es schon nicht weißt, woher sollen wir es wissen?
      Fakt ist, dass sich an der Profilstuktur nichts wesentliches verändert hat. Das Forum wäre voll von derartigen Problemen.
      Dass es bei einigen wenigen Usern Probleme gibt, rechtfertigt nicht eine derartige pauschale Aussage.
    • Du schreibst: "So... ich habe jetzt den Beweis dafür, dass es an dem Update liegt!"
      Nun, wer von uns Helfern will sich jetzt mit einem echten Fachmann anlegen, der schon "richtige Beweise" gesammelt hat? Ich jedenfalls nicht!


    Mein Rat:

    • Richte deinen TB so ein, wie er gemäß unserer Dokumentation standardmäßig eingerichtet ist. Selbstverständlich kannst du das Profil auf eine Datenpartition legen und mit dem Profilmanager auf dieses verweisen.
    • Überprüfe noch einmal penibel sämtliche Einstellungen und Pfade.
    • Poste exakt und vollständig sämtliche Fehlermeldungen und natürlich auch alle sonsigen Reaktionen des Thunderbird.
    • Führe den in der Doku beschriebenen Test mit telnet zur Prüfung der Erreichbarkeit der Server durch und poste hier die Kommandos und die Antworten der Server.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,

    Also... was wurde an der Profilstruktur zwischen 31.8.0 und 38.0.1 verändert und ist nicht mehr kompatibel?

    Ich bin kein Fachmann für IT-Sicherheit und kann deshalb keine Lösung zu deinem Problem vorschlagen.
    Trotzdem habe ich mir die "Thunderbird Notes" zur Version 38.0.1 https://www.mozilla.org/en-US/…bird/38.0.1/releasenotes/ angesehen und unter "Changes" folgendes gefunden:
    "Default to using SSL for XXMP and IRC.
    This might cause issues for self-signed certificates (Bug 1122567, Bug 1122666)."


    Ob dein Problem mit dieser Änderung zusammen hängt, weiß ich natürlich nicht.


    Gruß

  • Hi Mapenzi,


    Tobi schrieb, dass er ein Email Zertifikat nutzt. Aus seinem Posting geht nicht hervor, ob es sich um eines von einem etablierten TrustCenter handelt, oder ob es ein selbst signiertes ist.
    Wie ja im Forum allgemein bekannt ist, betreibe ich seit vielen Jahren eine "Prvat-CA" und stelle damit pro Jahr viele Hundert Zertifikate für daran interessierte Personen her. Darunter auch recht viele Leute aus dem Forum.


    Ich kann dir verbindlich bestätigen, dass auch mit dem TB v.38.2.0 diese selbst signierten Zertifikate perfekt für die Mailverschlüsselung mit S/MIME funtionieren. Vorausgesetzt natürlich, dass die betreffenden User die Herausgeber-Zertifikate meiner Zertifizierungsstelle korrekt installiert und denen das Vetrauen ausgesprochen haben.
    BTW: Gestern war ein Mac-User bei mir, und hat seine Zertifikate und Schlüssel in seine drei iDinger installiert - und natürlich erfolgreich mit mir getestet.


    Wobei es Probleme geben kann (nicht muss!), ist, wenn ein Mailserver mit selbst signierten Zertifikaten betrieben wird. Aber das wird vlt. einen Server betreffen und kein grundlgendes Problem darstellen.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Ich möchte mich hier mit niemanden anlegen und bin nur dankbar für jegliche hilfreiche Antworten. Warum du gleich so unangenehm wirst, kann ich mir nicht erklären.


    Findest du, dass das kein Beweis dafür ist, dass sich zwischen den Versionen etwas verändert haben muss, wenn es mit der alten 31.8.0 funktioniert und mit jeder Version danach nicht?


    Außerdem finde ich, dass du dich etwas widersprichst. Zunächst sagst du


    Peter schrieb:

    ein ernsthafter Helfer derartige Frickel-Bastellösungen nicht unterstützen wird

    und dann schreibst du



    Peter schrieb:

    Selbstverständlich kannst du das Profil auf eine Datenpartition legen und mit dem Profilmanager auf dieses verweisen.


    Ich persönlich weiß nicht, was du denkst bzw. wie ich das alternativ gelöst haben sollte als mit dem Profilmanager.


    Und selbstverständlich sind jegliche Mailserver über telnet verfügbar, doch dieser Test sollte eigentlich auch hinfällig sein, wenn ich schreibe, dass es mit der alten Version problemlos funktioniert.


    Nochmal zur Verbesserung meiner Angaben:
    Mein Zertifikat ist kein selbstgefrickeltes Bastelergebnis, sondern ein "Personal Authentication Certificate" von COMODO, welches ich erworben habe.



    Vielleicht hat ja doch noch einer eine Idee, an was das Problem liegen könnte. Irgendwelche Profileinstellungen / Pfadangaben müssen sich während diesen beiden Versionen verändert haben...


    Danke an alle, die gerne helfen wollen.
    LG

  • Hallo Tobi,


    zunächst, auch ich halte Deine Lösung mit dem Stick für suboptimal, um es mal zurückhaltend auszudrücken. Aber es sind Deine Daten, und ich glaube auch nicht, dass dies direkt mit dem Problem zu hat. Soweit, so gut.


    Insgesamt werde ich aber aus Deiner Problemschilderung nicht so ganz schlau. Was ist das für ein Zertifikat, von dem Du schreibst? Betreibst Du den Mailserver selbst? Ansonsten wüsste ich nicht, weshalb Du eine eigenes Zertifikat benötigen würdest, um Dich am Mailserver anzumelden.


    Ohne Gewähr, schon allein, weil ich den Zweck des Zertifikates nicht kenne: Lege Dir doch einfach mal ein neues Konto an. Am besten so, wie es dem Standard entspricht, also lokal auf dem Rechner. Das IMAP-Konto sollte rasch eingerichtet sein. Schau mal, ob das klappt.


    Ich kenne mich mit dem MAC nicht wirklich gut aus, schon gar nicht mit ESET auf dem Mac. AV-Programme sind aber ein klassischer Kandidat dafür, TLS-verschlüsselte Verbindungen zu stören. Vielleicht kann Mapenzi zum Thema ESET auf dem Mac mehr sagen.
    Sollte der Test mit dem neuen Profil nicht klappen, würde ich als nächstes ohne ESET testen, d.h. ESET für den Test deinstallieren.


    Ach ja, zu dem von Dir gewählten Titel. Du hast gerade ein Problem beschrieben. Und das ist vermutlich auch noch eines, das irgendwo in der Konfiguration begründet liegt. Dann so einen Titel zu wählen, ist nicht sehr weise und motiviert andere nicht gerade.


    Gruß


    Susanne

  • Hallo,

    Ich kenne mich mit dem MAC nicht wirklich gut aus, schon gar nicht mit ESET auf dem Mac. AV-Programme sind aber ein klassischer Kandidat dafür, TLS-verschlüsselte Verbindungen zu stören. Vielleicht kann Mapenzi zum Thema ESET auf dem Mac mehr sagen.

    Leider kann ich zur Verwendung von AV-Programmen auf Mac OS X nur wenig sagen, schon gar nicht zu ESET, da Thunderbird bei mir durch keinen Viren-Scanner überwacht wird.
    Ich überprüfe lediglich herunter geladene Dateien mit ClamXav.
    Aber ich glaube, Susanne hat durchaus Recht, die Fehlersuche in diese Richtung zu leiten.

    Ach ja, zu dem von Dir gewählten Titel. Du hast gerade ein Problem beschrieben.

    "voller Fehler" könnte doch ein Singular sein ;)


    Gruß

  • "voller Fehler" könnte doch ein Singular sein

    oder ein Tippfehler. Vielleicht sollte es heißen "voll der Fehler". Aber dann fehlt das "krass, ej" hinterdran. ;-)