Komprimieren nicht mehr möglich

  • Auch wenn dadurch das exakt selbe Problem in mehreren offenen Themen ist


    Ich kann erfolgreich einzelne komprimieren. Wähle ich jedoch die Option alle Ordner des Kontos komprimieren, dann erscheint die Fehlermeldung, dass wegen ungenügend Speicher nicht möglich ist.


    "Einige Ordner (z.B. 'Gesendet') konnten nicht komprimiert werden, da nicht genügend freier Speicherplatz zur Verfügung steht. Bitte löschen Sie einige Dateien und versuchen Sie es erneut."


    Auf dem PC ist alles zusammen gerade mal um die 700 MB groß.


    Auf dem Mailserver ebenso, es sind dort keine Limits erreicht.


    * Thunderbird-Version: 38.3.0
    * Betriebssystem + Version: Windows 10 64bit
    * Kontenart (POP / IMAP): Imap
    * Postfachanbieter (z.B. GMX): All-Inkl
    * Eingesetzte Antivirensoftware: Comodo Internet Security
    * Firewall (Betriebssystem-intern/Externe Software): Comodo Internet Security



    Enigmail nutze ich auch


    Das Problem trat plötzlich auf


    Fehlermeldung Komprimierung

  • Tritt das Problem auch ohne Comodo auf? Ich meine wirklich ganz ohne. Kannst Du Comodo für einen Test einmal deinstallieren?

  • Deinstallieren ist leider nicht möglich. Man kann jedoch Thunderbird auf die Whitelist in Comodo setzen.


    Ich versteh aber nicht, warum es an Comodo liegen sollte. Meiner Meinung nach kann das auch nicht daran, liegen, denn das komprimieren einzelner Ordner verursacht nicht die Fehlermeldung und Comodo meldet auch keine Ereignisse (HIPS meldet bei mir immer erst, bevor es sperrt).


    Edit: macht keinerlei Unterschied, auch wenn Thunderbird auf der Whitelist steht und die Module alle deaktiviert sind.

  • Deinstallieren ist leider nicht möglich

    Das wäre die erste legale Software, von der ich das höre. Muss man sich einen neuen Rechner kaufen, wenn man Comodo wieder loswerden möchte? ;-)


    Ich weiß nicht, ob es am Comodo liegt. Ich kenne die Ursache nicht. Deshalb hatte ich den Test ja vorgeschlagen. Schau Dich mal hier im Forum um, was Schutzsoftware schon für Effekte ausgelöst hat. Da wirst Du staunen.

    macht keinerlei Unterschied, auch wenn Thunderbird auf der Whitelist steht und die Module alle deaktiviert sind.

    Auch das ist nicht wirklich neu. Deshalb schrieb ich von deinstallieren. Aber warte ruhig nicht etwas. Vielleicht hat jemand anderes noch eine bessere Idee.

  • Edit: Vollzitat gelöscht! Bitte zum Antworten nur das unbedingt Notwendige aufführen! graba, S-Mod.



    Deinstallieren geht zwar, ist aber aus Sicherheitsgründen hier nicht wirklich produktiv.


    Es gab bislang nie Probleme mit Comodo und das letzte (größere) Update war erst vor einigen Monaten.


    Danach ging noch alles einwandfrei.


    Das Whitelisten hilft sehr wohl, da dann die Module nicht mehr blockieren bzw alles durchlassen. Auch das deaktivieren der Module in den erweiterten Einstellungen.


    Ich weiß nur noch, dass vor kurzem und jetzt vor einigen Tagen bei Thunderbird ein Update installiert wurde.
    Das war im Grunde das einzige, was sich geändert hat.


    Wäre es anders, dann würde ja noch nicht mal das manuelle Komprimieren eines einzelnen Ordners funktionieren.
    Aber das testweise manuelle Komprimieren von jedem Ordner funktioniert einwandfrei.


    Außer ich wähle die Funktion zum Komprimieren aller Ordner eines Kontos, dann erst kommt die Fehlermeldung.
    Das selbe Verhalten hat auch der andere Nutzer in dem verlinkten Thread. Und er nutzt nicht die gleiche Schutzsoftware wie ich. Kann also nicht daran liegen ;-)

    Einmal editiert, zuletzt von graba ()

  • Das war im Grunde das einzige, was sich geändert hat.

    Wenn Du wüsstest, wie oft wie das hier schon gelesen haben. Dein Comodo verändert sich täglich!
    Aber machen wir es kurz. Wenn Du eh so ein Experte bist und auf diesen Test verzichten kannst, dann musst Du warten, bis jemand anderes eine bessere Idee hat.

  • Könntest Du Dich bitte etwas klarer ausdrücken? Heißt das, Du hast Comodo komplett deinstalliert, keine andere AV-Software installiert und das Problem tritt weiterhin auf?
    Falls das der Fall sein sollte, dann teste als nächstes, ob das Problem auch auftritt, wenn Du den TB im Safe-Mode startest. Sollte das ebenfalls nicht helfen, dann erstelle ein ganz neues Profil, installiere keine Erweiterungen und teste erneut.
    Wenn das Problem auch mit einem neuen Profil und ohne AV-Programm auftreten sollte, muss ich passen.

  • Richtig.


    Auch im abgesicherten Modus von Thunderbird tritt das Problem auf.
    Comodo war deaktiviert. Die Windows-eigene Software Defender ist laut Einstellungen ebenfalls deaktiviert.


    Ich hatte bereits das bestehende Profil repariert, den Index neu aufgebaut und andere Lösungsvorschläge ausprobiert.


    Das Profil neu erstellen ist leider nicht möglich, da die Datenmenge der Emails zum runterladen wieder ewig brauchen wird.


    Das Problem hatten ja auch andere, hatte da auch bereits in einem anderen Thread geantwortet.


    Irgendwie scheint es da Probleme mit IMAP in Thunderbird zu geben, zumindest gibt es keine Probleme bei meinem Hosting-Anbieter und die Datenmenge pro Postfach ist noch nicht zu viel.

  • Comodo war deaktiviert.

    Deaktivieren und deinstallieren sind zwei verschiedene Dinge.

    Das Profil neu erstellen ist leider nicht möglich, da die Datenmenge der Emails zum runterladen wieder ewig brauchen wird.

    Von diesem Schritt hätte ich mir die größte Erfolgswahrscheinlichkeit versprochen.

    Irgendwie scheint es da Probleme mit IMAP in Thunderbird zu geben, ...

    Ich kann es nur schätzen, aber vermutlich gibt mehrere Millionen Benutzer des TB, die seit Jahren IMAP verwenden. Ein generelles Problem wäre da sicher schon aufgefallen.


    Aber mei, wenn Du meinen Vorschlägen so gar nicht folgen magst, kann ich mich nur noch aus diesem Faden verabschieden. Bei mir funktioniert der TB ja.

  • Wie gesagt, ich kann Comodo in den erweiterten Einstellungen alle Filter deaktivieren, die greifen dann auch nicht. Macht aber keinen Unterschied.


    Ich bin nicht der einzige, der das Problem hat:



    Fehlermeldung Komprimierung
    Fehlermeldung Komprimierung


    Ich überprüfe gerade, woran es genau liegt.


    Zumindest sind wir nicht die einzigen:
    https://bugzilla.mozilla.org/show_bug.cgi?id=1174485

    3 Mal editiert, zuletzt von Max2109 ()

  • Zumindest sind wir nicht die einzigen:

    Das habe ich ja auch nicht behauptet. Ich halte es auch durchaus für möglich, dass dies ein bug ist. Ich denke aber nicht, dass der, wie von Dir vermutet, etwas mit IMAP zu tun hat.
    Ich will Dir aus sagen weshalb: Das Komprimieren ist ein Vorgang, der sich auf lokale Dateien im mbox-Format auswirkt. Auf dem Server liegen die E-Mails aber gar nicht im mbox-Format vor. Genau genommen ist es für den TB gar nicht sichtbar, wie der Mailserver die Daten ablegt. Der TB selbst kann daher lediglich die lokalen Dateien komprimieren. Ergo denke ich nicht, dass dieses Problem mit IMAP zu tun hat.


    Da dieses Problem nicht bei jedem Benutzer auftritt, muss es außerdem einen bestimmten Umstand geben, unter dem dieser Fehler auftritt. Das kann das Betriebssystem sein (weil unterschiedliches Filesystem, anderer TB, ...), das AV-Programm oder eben etwas im Profil (ein Defekt, eine Erweiterung oder Überreste davon, ...). Deshalb wäre der Test ohne AV und mit einem neuen Profil, am besten gar mit deaktivierten "lokalen Bereithalten" meiner Meinung nach angezeigt. Das ist mit IMAP in wenigen Minuten erledigt.


    Damit wäre ein bug zwar nicht behoben, aber bei Dir würde er sich vielleicht nicht mehr äußern. Ich an Deiner Stelle hätte das schon längst ausprobiert anstatt hier zwei Wochen umanander zu wurschteln.


    Aber gut, Du hast nun oft genug mitgeteilt, dass Dir das zu viel Mühe ist. Außerdem scheinst Du nach wie vor nicht einzusehen zu wollen, dass das Deaktivieren einiger Funktionen im AV nicht bedeutet, dass dieses Programm nicht mehr aktiv ist und z.B. nach wie vor jede Datei, die geöffnet wird, untersucht. Mir ist Dein Problem deshalb ehrlich gesagt auch nicht mehr der Mühe wert.

  • Ich bin mir sicher, dass es nicht an Sicherheitssoftware liegt.


    Denn das manuelle komprimieren einzelner Ordner geht problemlos, auch mit den angeblich bettoffenen Namen.


    Jedoch das komprimieren unter Datei _ Alle Ordner komprimieren verursacht Probleme.


    Und genau dieses Problem konnten mehrerr verifizieren. Ebenso gibt es den Bugreport, auf den bislang noch niemand hingewiesen hat.


    Auf einem Windows 7 PC mit der selben Software (Comodo, Enigmail etc) tritt das Problem bislang nicht auf.


    Ein Hinweis auf richtigesBugreporting wie in dem Mozilla Ticket wäre hilfreich gewesen und hätte aus meiner Sicht als Softwareentwickler eindeutig sagen können, was das Problem ist.


    Entweder ist das ein Bug in der Windows-API (Dateisystem hat sich natürlich durch das Windows 10 Upgrade nicht geändert) oder ein Bug im Code von Thunderbird (Race Condition etc wie im Ticket erwähnt). Und laut Ticket ist das Problem noch nicht behoben.


    Die anderen, die das Problem hier bestätigen konnten nutzen kein Comodo ;-)


    Dass das lokal geschieht ist mir klar.


    Ich werde die Tage auf beiden Rechnern in die Debug Konsole schauen und kann dann mehr sagen.


    Nur so viel sei gesagt, das Problem tritt auch im abgesicherten Modus von Windows auf, also ohne geladene Treiber und Sicherheitssoftware ;-)


    Kann man hier andere Nutzer erwähnen oder verlinken und auf das Problem aufmerksam machen? Zb dieser eine Moderator und der andere Nutzer.

  • @Max2109
    damit du mit deiner Uneinsichtigkeit im Regen stehen bleibst, kann ich dir bestätigen, dass dein pers. AV bestimmt nicht die Ursache der Fehlermeldung ist.


    Ich nehme diesen Umstand seit einigen Monaten auf zwei Systemen, Win 7 + 8.1 mit MS AV wahr, gehe aber davon aus das die Komprimierung trotz dem funktioniert, zumindest die größe der Profilordner lassen mich in dem Glauben.

  • @kienberger Welche Thunderbird-Version verwendest du bzw ab welcher Version trat das auf?


    Seltsamerweise tritt das Problem auf einem anderen Windows 7 PC mit den IMAP-Konten nicht auf.


    Zumindest scheint es ein Bug zu sein, ich bin mir nur noch nicht sicher, ob es an Windows oder dem Code in Thunderbird liegt.


    Laut Bugzilla Ticket liegt es wahrscheinlich an GetDiskSpaceAvailable(), eine konkrete Ursache und Lösungen gibt es aber wohl bislang nicht.


    Leider sind im 38er-Zweig bislang keine Bugfies zu finden


    Selbst die try Builds basieren auf Thunderbird 41 (Beta ist aktuell 42 und Earlybird 43, aber ich bezweifel, dass das Problem dort behoben ist).


    Mal sehen ob sich noch einer der Mozilla-Entwickler dazu äußert.

  • Hi,


    Da kannst du aber lange darauf warten, denn von diesen (falls es überhaupt noch mehrere sind) liest hier garantiert keiner mit.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Deswegen habe ich doch bei dem verlinkten Bugzilla Ticket von Mozilla kommentiert (und hierher ebenfalls verlinkt, da dort auch paar deutsche Entwickler bei dem Ticket involviert sind, zum Beispiel Sebastian Hengst) ;-)

    2 Mal editiert, zuletzt von Max2109 ()

  • Welche Thunderbird-Version verwendest du bzw ab welcher Version trat das auf?

    die 38.3 , ab welcher Version weiß ich nicht. Ich verwende nach Bedarf in Abständen Xpunge und habe den Fehler eigentlich darin vermutet. Mir pers. ist die Meldung egal, da die Komprimierung einwandfrei durchgeführt wird und die par Klicks mehr oder weniger bringen mich nicht um.

    M.f.G. Kienberger

  • Xpunge habe ich auf keinem der PCs installiert, liegt meiner Meinung nach auch nicht da dran.


    Leider hat sich ja Mozilla selber weitgehend von Thunderbird zurückgezogen.


    Kritisch ist der Bug nicht, jedoch nervig, wenn man viele Ordner hat.

  • Also wenn ich da noch ein bisschen über die Situation nachdenke, um so zweifelhafter wird mir das Komprimieren bei einem IMAP Konto.
    Es werden ja nur die Lokalen, bzw. eventuell lokal bereit gehaltenen IMAP-Ordner mit Mails vorgehalten und müssen im Th gepflegt werden.
    Möglicher weise verschluckt sich der globale Komprimiervorgang am Zugriff auf die Ordner die vom Server bedient werden und dort gibt es ja nichts zum Komprimieren.
    Ich werde Xpunge mal dem entsprechen einstellen.

    M.f.G. Kienberger