Ordner gelöscht - wie mache ich Mails wieder sichtbar?

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Programm + Version: TB 38.4.0
    * Betriebssystem + Version: WIN7 64bit SP1
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): web.de
    * Eingesetzte Antivirensoftware: Avira Free Antivirus
    * Firewall (Betriebssystem-intern/Externe Software): Betriebssystem-intern



    Hallo miteinander,


    ich habe ein Problem und bisher keine passende Lösung in den anderen Threads gefunden.
    Ich habe zu meinem "Posteingang" einen Unterordner erstellt und in diesen alle dazugehörigen Mails hineingeschoben. Da ich mich beim Ordnernamen vertippt hatte, habe ich ihn umbenannt und beim Bestätigen hatte ich dann plötzlich zwei Ordner. In beiden Ordnern waren meine Mails. Also habe ich den mit Tippfehler gelöscht.
    Dummerweise hat mir TB beide Ordner gelöscht und die Mails sind weg!
    Nach Recherche im Internet habe ich in der imap-Datei geschaut und dort alle Mails gefunden. Alle haben den X-Mozilla-Status "0001" und den X-Mozilla-Status2 "00000000". Das ganze sieht bei allen Mails in etwa so aus:


    From - Sat Sep 12 13:14:57 2015
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00000000


    Angeblich bedeutet dies, dass die Mails gelesen sind und vorliegen, doch ich schaffe es nicht, sie in meinem TB wieder angezeigt zu bekommen. Ich vermutete, dass er Probleme hat, weil der Ordner, in dem sich die Mails zuletzt befanden, nicht mehr da ist. Also habe ich ihn erneut erstellt, aber im Ergebnis ändert sich nix.


    Wer kann mir helfen, bzw. gibt es noch eine weitere Möglichkeit, die Mails aus der imap-Datei wieder in ein "leserliches" Format zu bekommen?


    Vielen Dank im Voraus für eure Unterstützung!! :thumbsup:

  • Hallo TB-Novize,
    und willkommen im Forum!



    Versuche mal, das Add-on "ImportExportTools" zu installieren, und mit dessen Hilfe die von dir gefundene Mbox-Datei zu importieren.
    Das Problem, welches auftreten kann ist, dass diese Mbox-Datei kein richtiger Speicher ist (wie bei POP3 oder in den "Lokalen Ordnern", sondern nur ein dynamischer lokaler Cache. Dieser wird immer mit dem Zustand auf dem Server synchronisiert. Und da du ja (dummerweise) wieder einen gleichnamigen leeren Ordner angelegt hast, kann es passieren ... .
    (Andere Möglichkeit: du kopierst bei beendetem TB diese Mbox-Datei -ohne ohre Indexdatei- in den neu erstellten Ordner. Beim nächsten Start des TB sollte der Inhalt sichtbar sein.


    Falls du also in der bewussten Mbox nichts zum Importieren finden solltest, kannst du versuchen, mit dem Add-on "Recover deleted messages" den Status der evtl. als gelöscht markierten Mails wieder zurück zu setzen (oder einfach mit einem Texteditor).


    Fakt ist: Mails die sich bei dir lokal in einer Mbox befinden, lassen sich immer wieder importieren! Zumindest so lange, wie du nicht die Mbox komprimiert hast. (Komprimieren?? => Doku)


    Die wichtigste Regel, die du zukünftig immer beachten solltest:
    Auch wenn du als sicherheitsbewusster User selbstverständlich regelmäßig ein Backup deines TB-Userprofils ziehst, solltest du vor derartigen Reparaturen immer eine Sicherheitskopie machen. Damit hast du eine Rückfallposition, falls doch wider Erwarten etwas ungewolltes passiert!
    Wie du das TB-Userprofil sicherst, findest du in unserer Anleitung.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    erst einmal vielen Dank für deine ausführliche Antwort!
    Ich habe alle von dir genannten Möglichkeiten ausprobiert, es tut sich aber leider gar nichts ?(
    Die kompletten Ordner hatte ich gestern schon gesichert, da sollte nix schiefgehen :)


    Gibt es noch andere Lösungsansätze, die Mail aus dem imap-Ordner rauszubekommen?


    Grüße!

  • Hallo

    Ich habe alle von dir genannten Möglichkeiten ausprobiert, es tut sich aber leider gar nichts

    Bei mir funktioniert der Import einer Mbox-Datei aus einem Imap-Ordner, auch wenn das Bereithalten der Nachrichten des IMAP-Kontos auf dem Computer deaktiviert ist.


    Hast du versucht, die beiden Mbox-Dateien mit ImportExportTools in die Lokalen Ordner zu importieren?
    Also R-Klick auf "Lokale Ordner" > ImportExportTools > Mbox-Dateien importieren > usw....
    Man kann nämlich mit dem Add-on nicht in ein IMAP-Konto importieren.


    Gruß

  • Hast du versucht, die beiden Mbox-Dateien mit ImportExportTools in die Lokalen Ordner zu importieren?
    Also R-Klick auf "Lokale Ordner" > ImportExportTools > Mbox-Dateien importieren > usw....
    Man kann nämlich mit dem Add-on nicht in ein IMAP-Konto importieren.


    Gruß

    Hallo Mapenzi,


    das war die Lösung! :thumbup:
    Ich hatte zuerst einen Unterordner in "Lokale Ordner" angelegt und dort hinein konnte ich nix importieren. Erst durch die von dir genannte Vorgehensweise hat es auf Anhieb geklappt, herzlichen Dank dafür!


    Grüße