Fehlermeldung bei zu schneller Weiterleitung an denselben Server

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 45.3
    * Betriebssystem + Version: win7
    * Kontenart (POP / IMAP): pop
    * Postfach-Anbieter (z.B. GMX):all-inkl
    * Eingesetzte Antiviren-Software: antivir
    * Firewall (Betriebssystem-intern/Externe Software): intern
    * Router-Modellbezeichnung (bei Sende-Problemen):


    Hallo zusammen,
    wenn ich mittels Filter emails weiterleite ca. 10-30 Stück innerhalb von 10 bis 20 sec.(Beim abholen) Tritt folgender Fehler auf.


    Fehler beim Senden der Nachricht:
    Der Mail-server sendete eine ungültige Begrüßung: 4.7.0 dd*****.kasserver.com Error: too many connections from meineip.


    Der Provaider hat mir zurückgeschrieben.
    Sie stoßen beim senden von E-Mails an das SMTP-Limit. Es ist nur möglich 3 SMTP Verbindungen gleichzeitig von einer IP-Adresse zu öffnen.
    Sie versuchen noch eine vierte aufzumachen und erhalten dann diese Fehlermeldung.Bitte kontrollieren Sie daher die Konfiguration Ihres E-Mail Programms, um den Fehler zu beheben.



    Jetzt wollte ich Verbidungen herruntersetzten.Thundebird > Extras > Konten > Ihr Konto > Servereinstellungen > Erweitert > Maximale Anzahl der aufrecht erhaltenen Verbindungen.



    [IMG:http://www.robokalle.de/bilder/einstellungen1.jpg]



    hier sollte es sein, ist es aber nicht. :/


    Kann man das noch wo anders einstellen. z.B. about:configMFG. Kalle

    5 Mal editiert, zuletzt von graba ()

  • Hi Kalle,


    die Einstellung existiert nur für IMAP, dein Konto ist aber POP. Unabhängig davon bräuchtest du eine Einstellung, um die SMTP-Verbindungen zu limitieren, IMAP ist für dein Problem ja unschuldig. Leider kann ich dir bezüglich deines eigentlichen Problems nicht weiterhelfen, ich wüsste keine einfache Methode, ein SMTP-Limit zu setzen. Wobei Thunderbird ja eigentlich mit einer SMTP-Verbindung auch für mehrere Nachrichten hinkommt...


    Grüße,
    Dirk

  • Hallo Kalle,


    ich kenne diesbezüglich (SMTP) bei keinem Mailclient eine Einstellungsmöglichkeit. Ich denke, die Ursache liegt auf der Hand. TB kann Filter parallel abarbeiten. Du sendest deshalb eine große Anzahl neuer Mails, noch bevor die vorherigen fertig zum SMTP übertragen wurden. Das führt dazu, dass plötzlich mehr als die bei Deinem Provider erlaubten drei Verbindungen gleichzeitig nötig wären.


    Gruß


    Susanne

  • Hallo, vielen Dank für die schnellen Antworten.


    Das was Susanne geschrieben hat wird die Ursache sein.


    Gibt es da eine Lösung dafür. z.B. eine Pause im Filter.


    Oder eine andere möglichkeite dies 4-20 emails weiterzuleiten. (aber bitte nicht mit der Hand verschieben) .


    MFG.Kalle

  • Hallo,


    zwei Ideen meinerseits:


    leitest du zufällig an deine eigene E-Mailadresse weiter, die du auch bei Thunderbird als IMAP-Konto eingerichtet hast? => dann könntest du beim Filter verschieben, statt weiterleiten einstellen.


    Kannst du diesen Weiterleitungsfilter vielleicht beim Anbieter direkt erstellen? Dann leitet nicht Thunderbird weiter, sondern der Server.


    Grüße, Ulrich

  • Hallo, Ulrich



    Idee 1 geht nicht weil die weitergeleite email von einem anderen Programm eingelesen und ausgewertet wird.


    Idee 2 da muß ich mich mal bei meinen Provider schlau machen. Das wäre noch eine Option.


    Danke für die Tipps euch allen.


    MFG Kalle

  • Hallo zusammen,


    So gerade mal nachgeschaut. Email weiterleitung auf dem Server geht nur mit emailadresse. Ich benötige aber den Betreff zum auswerten der weiterleitung.


    Gibt es nich eine art Pause für das Senden beim Weiterleiten.


    MFg. Kalle

  • Hallo allerseits,


    Zitat

    Ich denke, die Ursache liegt auf der Hand. TB kann Filter parallel abarbeiten.

    kann man vielleicht bei Thunderbird grundsätzlich (als Workaround) die Parallelisierung abschalten (beim Testen von paralleler Software ist das ja immer wieder wichtig)? Ach, ihr seht: ich habe keine Ahnung ...


    (Ne, jetzt nicht hauen, war ja nur ne Idee...)


    Grüße, Ulrich

  • Hallo zusammen,


    Danke für die Hilfe.


    Ich werde am Montag den Filter dahingehen ändern das


    1. emails weitergeleitet werden
    2 auf Status prüfen ob weitergeleitet gesetzt ist
    3. die email in einen anderen Ordner verschieben



    Vielleicht bringt das ja etwas pause.


    Hat leider nicht viel gebacht 15 emails weitergeleitet 1 davon nicht angenommen. Fehler wie oben


    Gruß Kalle

    2 Mal editiert, zuletzt von robokalle ()

  • Hallo,


    Ich werde am Montag den Filter dahingehen ändern

    @Thunder
    Ich hatte überlesen, dass es nur um ein Filter geht. Somit liegt es wohl weniger daran, dass TB mehrere Filter parallel abarbeiten kann, als daran, dass ein Filter für sich bereits weiterleitet bevor die vorhergehende Aktion abgeschlossen ist. Am Resultat ändert das nichts, aber der Bug ist dann etwas anders.


    @robokalle
    Mir fehlt die Zeit es selbst zu testen. Könntest Du das einmal mit aktiviertem Logging testen? Am besten so, dass Du das Filter erst einige Minuten nach dem Start des TB manuell ausführst. Notiere die Uhrzeit, damit man den Zeitpunkt in den Logs rasch finden kann.
    Wie man das Logging einschaltet, weiß ich jetzt nicht aus dem Kopf. Es ist hier im Forum aber schon mehrfach beschrieben worden. Über die Suchfunktion sollte sich das finden lassen.


    Noch eine andere Frage. Wenn es zu diesem Abbruch kommt und man danach das Filter manuell erneut ausführt, werden dann die restlichen E-Mails ordnungsgemäß weitergeleitet? Oder kommt es durch den Abbruch zu einem "Verlust" der E-Mail, die gerade in Arbeit war? Falls das sauber funktioniert, wäre das nicht ein guter Kompromiss? Das wäre dann ja nur ein Klick.



    Gruß


    Susanne

  • Hallo zusammen,


    das mit logging kann ich machen. (erst am Montag da sind dann wieder mehrer emails auf einmal)


    Der Filter arbeitet weiter. Es kommen die Fehlermeldungen, Filter arbeitet weiter, die man dann wegklicken muss.
    Die emails werden als weitergeleitet gekennzeichnet.


    Sind aber nie auf dem Server angekommen.


    Am Mittwoch waren es 7 emails die weitergeleitet wurden. 3 kamen nicht an, 3 Fehlermeldungen.
    Am Donnerstag waren es 4 emails. Alle angekommen, keine Fehlermeldung


    Gruß Kalle

  • Hallo Kalle,



    Die emails werden als weitergeleitet gekennzeichnet. Sind aber nie auf dem Server angekommen.

    Das ist weniger schön. Damit erübrigt sich dann die Frage, ob ein erneutes Ausführen des Filters ein einfacher Workaround wäre.


    Gruß


    Susanne

  • Hallo Kalle,


    dann hast Du es ja schon gesehen. Der TB empfängt den Fehlercode vom Server


    [tmdedialog]SMTP Response: 421 4.7.0 meinServer.kasserver.com Error: too many connections from 188.193.221.119[/tmdedialog]


    Ich habe mit jetzt nicht die Mühe gemacht, aller Verbindungen durchzuzählen und zu schauen, wann sie jeweils geschlossen wurden. Mir sind z.B. einige Meldungen der Art
    [tmdedialog]SMTP connection error quitting 804b0002, ignoring [/tmdedialog]
    aufgefallen. Die erscheinen mir etwas komisch, weil man sieht, dass der Server zuvor auf ein Quit ganz ordentlich ein bye gesendet hat. Wenn Du das Log-File an den Bug hängen könntest, wäre das sicher hilfreich.


    Gruß


    Susanne

  • Hallo zusammen,


    zur Zeit ist es besonders schlimm. Von 42 e-mails die weitergeleite wurden sind 23 nicht angekommen. 23 Fehlermeldung wurde gemacht
    aber "weitergeleite" wurde bei jeder e-mail als Status gesetzt. :(


    Zur Zeit dauert aber das Senden von e-mails ca. 2-3 sek. Warscheinlich noch von den Hack auf die DNS-Verteiler oder was weis ich ????
    nach ca. 16 e-mails ging das senden wieder normal. ca.1 sec.


    Ich breuchte eigentlich nur eine Pause die ich in die Filter mit einbringen kann. Mann könnte so den Fehler etwas ausbügeln.


    Gruß Kalle

  • In dem Bug tut sich leider nicht viel. Probiere doch mal aus, was passiert, wenn Du die Anzahl der maximalen Verbindungen auf 3 setzt. Ich glaube nicht wirklich, dass sich dadurch etwas ändert, weil sich diese Einstellung auf die Verbindungen zum IMAP-Server bezieht und nicht auf den SMTP. Aber probieren geht manchmal über studieren.

  • Hallo SusiTux,


    der Menu-Punkt kommt aber nur wenn man IMAP einstellt. Bei POP3 erscheint der Punkt garnicht zur einstellung. :(
    Gruß Kalle