IMAP - Deaktivieren von Abrufen alle x min. verursacht unregelmäßigen Empfang

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60
    • Betriebssystem + Version: Win7 x64
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): GMX
    • Eingesetzte Antiviren-Software:
    • Firewall (Betriebssystem-intern/Externe Software):
    • Router-Modellbezeichnung (bei Sende-Problemen):


    Hallo,


    auch in der IMAP Grundeinstellung ruft TB, wie unter POP3, Nachrichten beim Programmstart und alle x min. vom Server ab.




    Da bei GMX und Web.de Emails vom Server in Richtung Programm gepush werden, wenn ich richtig informiert bin, habe ich „Beim Starten auf neue Nachrichten prüfen“ und „Alle x Minuten auf neue Nachrichten überprüfen“ deaktiviert.




    Nun kommt es bei mir seitdem vor, dass Emails erst in dem Augenblick abgerufen werden, wenn ich auf den Posteingang klicke.

    Meistens werden Emails aber an TB gepusht, sind also schon vorhanden, wenn ich nachschaue, bzw. ich werde per Popup auf den Eingang von Emails informiert.


    Ist das bei euch auch der Fall, dass Emails teilweise erst empfangen werden, wenn ihr auf den Posteingang klickt?

    Kann das mit meinen geänderten Einstellungen zusammenhängen?



    Weiterhin habe ich noch eine Frage zum Spamverdachtordner, der bei GMX-Konten in TB angezeigt werden kann, was praktisch ist. Bei Web.de gibt es einen solchen Ordner scheinbar nicht.


    Alle Spamverdacht-Mails werden bei mir immer erst abgerufen, wenn ich auf den Ordner in Thunderbird klicke. Tagelang siehe der Ordner von außen betrachtet leer aus, doch wenn ich auf dem Ordner klicke, kommen die ganzen Emails erst rein.


    Kann man irgendwie einstellen, dass die GMX-Spamverdachts-Emails auch gepusht werden?


    Danke!

  • Da bei GMX und Web.de Emails vom Server in Richtung Programm gepush werden

    Woher hast du diese Information? Wie soll das funktionieren? Ein pushen würde voraussetzen, dass Thunderbird ein Server wäre. Das wäre mir neu. Außerdem müsste deine Windows-Firewall die Kommunikation noch zulassen.


    Statt Spammails vom Provider aussortieren zu lassen, würde ich das dem Junk-Filter in Thunderbird überlassen.

  • 1.) Der Themenstarter kann durchaus mit dem "Pushen" Recht haben, wenn Thunderbird die IMAP-Verbindung zu den jeweiligen IMAP-Servern der Anbieter aufgebaut hat. Dafür gibt es die "Idle"-Einstellung in den erweiterten Server-Einstellungen bei den IMAP-Konten. Meines Erachtens muss dafür aber Thunderbird überhaupt erst die Verbindung aufbauen - und das geht genau mit dem Abrufen der Postfächer. Deshalb muss meinem Verständnis nach zumindest beim Programmstart oder in einem bestimmten Intervall das Postfach abgefragt werden - sonst wird erst gar keine Idle-Verbindung aufgebaut.


    2.) Es gibt leider einige Fallstricke bei dem Procedere. In den Einstellungen / Konten-Einstellungen / Ordner-Eigenschaften in Thunderbird sind nämlich relevante Optionen dazu verteilt. Schau Dir also auf jeden Fall die Ordner-Eigenschaften der gewünschten Ordner an, wo man festlegen kann, dass diese mit abgerufen (und auch nur dann die Idle-Verbindungen aufgebaut) werden sollen. In den erweiterten Server-Einstellungen der Konten findet man für das Idle-Kommando dann noch eine Option, die die Anzahl der parallelen Idle-Verbindungen (für jeden Ordner eine separate Verbindung!) begrenzt.


    Siehe unter anderem hier:

    https://www.thunderbird-mail.d…-Einstellungen-des-Kontos

  • Thunder : Du hast Recht. Es ist kein "Pushen". Der Client sendet das IDLE-Kommando an den Server, sofern dieser IDLE unterstützt. Damit wird die Verbindung vom Client aus initiiert.


    Thunderbird ist also wirklich kein Server.


    Der Client beendet den IDLE-Zustand auch wieder. Details: RFC 2177.


    Maxie : Wie Thunder schrieb musst du also die Häkchen wieder setzen, wie in deinem ersten Screenshot gezeigt.

  • Hallo,


    danke für die Hilfe!

    Der Themenstarter kann durchaus mit dem "Pushen" Recht haben, wenn Thunderbird die IMAP-Verbindung zu den jeweiligen IMAP-Servern der Anbieter aufgebaut hat. Dafür gibt es die "Idle"-Einstellung in den erweiterten Server-Einstellungen bei den IMAP-Konten.

    Die Einstellung habe ich nicht gefunden.

    Für mich ist das halt eine aufgebaute "Push-Verbindung", da die Mails ja in 95% aller Fälle bei Thunderbird eingehen ohne dass Thunderbird etwas tut.


    Die "Idle"-Einstellung muss ich noch mal suchen. Das kenne ich von Android Mailprogrammen.

    Da wird die Idle-Verbindung beispielsweise alle 24 min. erneuert.

    In Prinzip funktioniert es ja alles und daher werde ich es erstmal so lassen.

    Lediglich der Junk-Emailordner von GMX wird nicht automatisch gepusht.

    Die Junkmails werden immer erst geladen, wenn ich auf den Ordner klicke. Sie sind dann augenblicklich in weniger als einer sek. da.

    Wenn man nicht drauf klickt, wird der Junk-Ordner halt so angezeigt, als ob keine neuen Nachrichten vorhanden wären.


    Gehe ich in TB mit der rechten Maustaste auf einen beliebigen IMAP-Ordner, kann ich dort folgende Option anhaken:

    "Diesen Ordner auf neuen Nachrichten überprüfen, wenn Nachrichten für diese Konto empfangen werden."

    Setzte ich hier den Haken beim GMX-Junkordner, werden die Mails trotzdem erst empfangen, wenn ich auf den Ordner klicke. Es ändert sich also am Verhalten nichts.

    Womöglich liegt es dran, dass diese Mails nicht gepusht werden.


    Ich habe mir die Einstellungen bzgl. "Diesen Ordner auf neuen Nachrichten überprüfen, wenn Nachrichten für diese Konto empfangen werden." der anderen IMAP-Ordner angeschaut.

    Der Haken ist lediglich beim Posteingang gesetzt.

    Nun frage ich mich, ob ich ihn auch in allen anderen IMAP-Ordnern manuell setzen muss, damit Emails synchronisiert werden?


    Meines Erachtens muss dafür aber Thunderbird überhaupt erst die Verbindung aufbauen - und das geht genau mit dem Abrufen der Postfächer. Deshalb muss meinem Verständnis nach zumindest beim Programmstart oder in einem bestimmten Intervall das Postfach abgefragt werden - sonst wird erst gar keine Idle-Verbindung aufgebaut.

    Okay. Ich habe es jetzt wieder eingestellt, dass beim Start von TB auf neue Nachrichten überprüft wird, damit eine Idle-Verbindung aufgebaut werden kann.

    Alle x Minuten abzurufen macht bei Push/Idle ja keinen Sinn, doch werde ich hier dennoch wieder aktivieren und auf 30 min. setzen, damit eine möglicherweise verlorene Idle-Verbindung wieder aufgebaut wird:

    Der Client beendet den IDLE-Zustand auch wieder. Details: RFC 2177.


    Womöglich werden durch diesen Abruf dann auch alle 30 min. die Junkmails geladen.


    Ich werde berichten, falls Bedarf besteht.


    VG

  • Hallo,


    noch eine kurze Zusammenfassung:

    Die Einstellmöglichkeit der Idle-Verbindung habe ich immer noch nicht gefunden.


    Was die Einstellung "Diesen Ordner auf neuen Nachrichten überprüfen, wenn Nachrichten für diese Konto empfangen werden." bewirkt habe ich nicht herausfinden können.

    Scheinbar bewirkt die Einstellung gar nichts, denn auch wenn ich die Option im Ordner "Spamverdacht" angehakt habe UND alle 30 min. auf neue Nachrichten überprüfen lasse (also Push + manueller Abruf), werden die Spamverdachtsmails dennoch nicht geladen.

    Erst, wenn ich auf den Ordner Spamverdacht klicke, werden alle Spamverdachtsmails sofort vom Server runter geladen.


    Ich denke also tagelang, dass ich keine Spamverdachtsmails habe, solange ich den Ordner nicht "betreten" habe.


    VG

  • Hallo,


    ich möchte noch etwas richtig stellen.


    Die Emails, die vom Provider als Spam markiert wurden, gehen jetzt in TB ein und werden auch als neu eingegangene Emails angezeigt, ohne dass ich den Ordner aufgerufen habe.

    Ich werde sozusagen auf den Eingang von Spamverdachts-Emails aufmerksam gemacht.

    So soll es sein.


    Die Einstellung ist einfach, trotz IMAP, die Nachrichten alle x min, beispielsweise 45 min., abzurufen.

    Außerdem muss beim Spamverdachtsordner in TB "Diesen Ordner auf neuen Nachrichten überprüfen, wenn Nachrichten für diese Konto empfangen werden" aktiviert sein.

    Diese Einstellungen hatte ich schon mal erfolglos getestet.

    Warum es jetzt plötzlich doch funktioniert, kann ich nicht sagen.


    Anders als normale Mails werden Spamverdachts-Emails nicht gepusht, was auch nicht nötig ist.

    Sie kommen also mit einiger Verzögerung aufs System.


    VG

  • Community-Bot

    Hat das Label Erledigt hinzugefügt