Wiederherstellung des Thunderbird Profil Ordners nach Windows neusinstallation

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60.4.0
    • Betriebssystem + Version: Windows 10 64 Bit Build 17763
    • Kontenart (POP / IMAP): Imap
    • Postfach-Anbieter (z.B. GMX): Google + Universität
    • Eingesetzte Antiviren-Software: Eset Internet Security
    • Firewall (Betriebssystem-intern/Externe Software): Eset Internet Security
    • Router-Modellbezeichnung (bei Sende-Problemen): Fritzbox 7590


    Hallo zusammen,

    ich habe Windows neu aufgesetzt und würde gerne mein Thunderbird wiederherstellen. Dazu habe ich diese Anleitung hier verwendet https://support.mozilla.org/de…nutzerprofile-Thunderbird.
    Wenn ich danach Thunderbird starte sieht auch soweit alles normal aus, beide Konten sind da und auch alle Unterordner. Allerdings fehlen alle Addons (und besonder Lightning).


    Wenn ich Thunderbird dann nochmal beende und wieder neustarte sind alle Addons da und auch richtig eingestellt, aber es fehlen sämtliche Unterordner bei meinen beiden Konten.


    Hat jemand von euch eine Idee?

    Viele Grüße
    Lazy

  • graba

    Approved the thread.
  • Hallo Lazy,


    trotz der Screenshots ist es schwierig, sich ein Bild der Situation zu machen.

    Für mich sieht es aber so aus, als ob du zwei verschiedene Profile hättest.


    Bei geöffnetem Thunderbird gehe ins Menü Hilfe > Informationen zur Fehlerbehebung > Profilordner > Ordner anzeigen: ein Profilordner "xxxxxxxx.default" (oder so ähnlich) wird im Explorer angezeigt.

    Gehe in der Ordnerhierarchie eine Etage höher in den Ordner "Profiles": wie viele (Profil-) Ordner befinden sich darin und wie heißen sie?
    Gehe noch eine Etage höher in den Ordner "Thunderbird", suche die Datei "profiles.ini", öffne sie in einem Text-Editor und kopiere ihren Inhalt in deine nächste Antwort.


    Gruß

    Mapenzi

  • Hallo Mapenzi,

    vielen Dank für die schnelle Antwort. Ich habe nur einen Profil Ordner von meiner vorherigen Thunderbird Installation gesichert. Ich habe wohl 2 E Mail Konten in Thunderbird.

    Gemäß der Anleitung die ich verlinkt habe, habe ich Thunderbird mit dem Profilmanager gestartet, ein neues Profil namens "default" erstellt (so hieß auch das alte). Dann Thunderbird wieder beendet und alle Dateien aus meinem alten Profil Ordner in den grade neu erstellten unter Roamting > Thunderbird > Profiles > xxxxxxx.default kopiert.

    Um jetzt direkt auf deine Frage zu antworten:
    In dem Ordner Profiles befindet sich nur ein Ordner mit dem Namen: quenej8n.default
    Inhalt der Profiles.ini:


    [General]

    StartWithLastProfile=1


    [Profile0]

    Name=default

    IsRelative=1

    Path=Profiles/quenej8n.default



    Viele Grüße

  • Gemäß der Anleitung die ich verlinkt habe, habe ich Thunderbird mit dem Profilmanager gestartet, ein neues Profil namens "default" erstellt (so hieß auch das alte). Dann Thunderbird wieder beendet und alle Dateien aus meinem alten Profil Ordner in den grade neu erstellten unter Roamting > Thunderbird > Profiles > xxxxxxx.default kopiert.

    OK, das ist eine der Methoden zur Wiederherstellung bzw. Migration eines Profil und sie sollte eigentlich funktioniert haben.

    Der Ordner "Profiles" enthält offenbar nur den neu erstellten Profilordner quenej8n.default und die Datei profiles.ini stimmt damit überein.

    Dann ist es aber für mich unerklärlich, dass du beim Start abwechselnd völlig unterschiedliche Ansichten und Inhalte in Thunderbird hast. Darauf kann ich mir keinen Reim machen, so etwas habe ich noch nie gesehen und kann es bislang nur mit zwei Profilen erklären. Wie ich es auch drehe und biege, es macht keinen Sinn.


    Starte TB neu, und nehmen wir an du hast die Ansicht aus Bild 1.jpfg: gehe wieder ins Menü Hilfe > Informationen zur Fehlerbehebung > Profilordner > Ordner öffnen und mache einen Screenshot des Inhalts des Profilordners, in dem man oben im Explorer-Fenster den Pfad bis zum Profilordner sieht.

    Dann beende TB und starte ihn neu: wenn du jetzt die Ansicht von Bild 2.jpg hast, mache das gleiche wie zuvor und erstelle wieder einen Screenshot, der den Pfad zum Profilordner zeigt.


    Vielleicht hat aber einer der Mitlesenden eine Erklärung für dieses Rätsel, dann bitte ich sie/ihn sich einzumischen....

  • Danke nochmals für deine Antwort.

    Hier die zwei erwünschten Screenshots (Ich habe 2 nach der Art wie du es gewünscht hast gemacht, aber sie zeigen das gleiche)
    1. Unterordner funktionieren aber Erweiterungen nicht


    2. Unterordner funktionieren nicht, aber die Erweiterungen

  • Hier die zwei erwünschten Screenshots (Ich habe 2 nach der Art wie du es gewünscht hast gemacht, aber sie zeigen das gleiche)

    Moment mal, da stimmt doch was nicht.

    Du hast in deiner Antwort #3 angegeben, dass der neue Profilordner "quenej8n.default" heißt, und so steht es auch in der Datei "profiles.ini".

    In den neuen Screenshots heißt der Profilordner aber "v53wspts.default" !! Da ich deinen Bildschirm nicht sehen kann, habe ich immer noch keine Erklärung dafür. Wo hast du denn den Profilordner "quenej8n.default" gefunden und wie lautet der Pfad zu diesem Profilordner?

  • Das liegt daran, dass ich den Thunderbird Ordner in Roaming Löschen musste und ein neues Profil anlegen musste um das beschriebene Verhalten zu reproduzieren. Die Unterordner sind nämlich nur im aller ersten Start da. Sobald ich Thunderbird dann beende und neustarte sind die Unterordner weg aber dafür funktionieren alle Erweiterungen. Entschuldige die Verwirrung.

  • Es tut mir leid, vielleicht ist es auch schon etwas spät am Abend. Aber ich verstehe rein gar nichts von deiner Erklärung in Beitrag #7.

    Kann jemand anders einspringen, der hier durchblickt?

  • Mit welchem TB - 32bit oder 64bit - gesichert?

    Mit welchem TB - 32bit oder 64bit - neu installiert?

    -----------------
    mfg
    matt59

  • Das überrascht mich jetzt allerdings.

    Kann man denn, je nachdem ob man TB 32bit oder 64bit startet, aber immer im selben Profil, solche Unterschiede sehen?

    Ich kann das hier unter macOS nicht nachvollziehen, da ich schon seit Jahren nur noch die 64bit Versionen benutze und keine Wahl mehr habe, wie es mit früheren Versionen noch möglich war.

  • Danke euch beiden nochmal für die Antworten.

    Matt59 hat glaube ich recht. Auf meiner alten Windows Installation hatte ich 64 bit installiert und auf der jetzigen neuen im Eifer des Gefechts nur 32bit.
    Es hat auch etwas bewirkt. Als ich dann nach dem kopieren der alten / gesicherten Profildaten Thunderbird gestartet habe war alles so wie gewollt. Alle Unterordner da und auch alle Addons funktionierend.
    Beim nächsten Neustart von Thunderbird waren aber alle Unterordner wieder weg.

  • Ok, Problem gelöst. Ich glaube es war einerseits die falsche Bit Variante, aber den größeren Anteil hatte wohl mein Antiviren Programm (Eset). Es hat verhindert, dass das Google Authtenfizierungs Fenster sich öffnet, weshalb beim nächsten Start die Unterordner nicht abgerufen werden konnten.

    Vielen Dank nochmal für die Hilfe.

  • @Mapenzi
    Du hast nicht Unrecht mit der Verwunderung:
    Für TB unter Windows gilt: Das Profilverzeichnis bei 32/64bit ist identisch - die Programmverzeichnisse aber unterschiedlich!


    Da auch noch immer TB 64bit unter WIndows nicht offiziell freigegeben ist und deren Nutzung nicht empfohlen wird, weil es eben noch viel Fehler hat. war es meineseits nur eine Vermutunmg das hier ein Problem sein könnte.

    Zum anderen hatte ich im Bekanntenkreis nun schon öfter das Problem des nicht mehr korrelkt funktionieren TB, wenn Backup und Rücksicherung mit unterschiedlichen bit-Versionen erfolgten.

    -----------------
    mfg
    matt59