Filter funktionieren nicht mehr

    Thunderbird-Version: 60.9.1 (32-Bit)

    Wurde gerade auf eine neue Versionsreihe aktualisiert: Nein

    Betriebssystem + Version: 10/64

    Kontenart: IMAP

    Postfach-Anbieter: GMX

    Eingesetzte Antiviren-Software: Windows Defender


    Hallo zusammen!


    Seit einiger Zeit funktionieren meine Filter nicht mehr, die zuvor jahrelang problemlos funktionierten.

    Also nichts von dem Filter funktioniert: Weder farblich markieren noch in die entsprechenden Ordner kopieren




    Habe die Filter auch schon mal neu eingerichtet, der neue Filter funktioniert aber auch nicht.


    Auch mit einem portablen und auf dem gleichen Rechner betriebenen Thunderbird 68.5.0 funktionieren die Filter nicht.

    Für diese Konten und dazugehörige Filter gibt es Thunderbird nur auf einem Rechner.


    Hat jemand eine Idee, warum meine Filter versagen?


    edit:


    Wenn ich die Filter manuell ausführe, funktioniert es.


    Edited 2 times, last by Mental ().

  • Mental

    Changed the title of the thread from “Filter funktionieren nichtm ehr” to “Filter funktionieren nicht mehr”.
  • Hi,


    vielleicht gibt es Aufschluß, wenn du mal das Filterprotokoll aktivierst (Knopf unten rechts im Filterdialog).

    Ansonsten kann auch etwas defekt sein. mrb hat hier öfters mal darauf hingewiesen, dass die Datei msgFilterRules.dat eine Fehlerquelle sein könnte. Am besten mal hier im Forum danach suchen: https://www.thunderbird-mail.d…lterRules.dat+automatisch

    Habe nun folgendes gemacht:

    Alle msgFilterRules.dat gelöscht und Filter neu eingerichtet. Filter funktionieren trotzdem nicht.

    Das Filterprotokoll ist leer.


    mail.imap.filter_on_new steht auf "true"


    Kann mir nicht vorstellen, dass nur ich das Filterproblem habe. Die Ergebnisse der Verlinkung helfen mir nicht weiter, da es dort keine anderen Lösungsmethoden gibt.


    Was kann ich noch tun?


    Habe jetzt mal ein neues E-Mailkonto und einen Filter eingerichtet.


    Mit diesem neuen Konto funktioniert der Filter auch nicht.


  • Hallo Mental,


    ändere doch einmal die Reihenfolge im Filter:


    1) Gelesen markieren

    2) Schlagwort hinzufügen

    3) Kopieren in ...

    4) Kopieren in ...


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

    Habe jetzt die Filter gelöscht und einen neuen einfachen Filter eingerichtet.


    Der Filter ist (Beispiel) in konto1@gmx.de eingerichtet.

    Dieser Filter beinhaltet 2 Einträge




    Bild 1:

    Sende ich von Konto konto1@gmx.de eine mail nach konto2@gmx.de,

    funktioniert der Filter und die mail wird in den Ordner "Offen..." in Konto konto1@gmx.de kopiert. Das ist OK.


    Bild2:

    Sende ich eine mail von konto2@gmx.de nach konto1@gmx.de,

    funktioniert der Filter nicht. Das heißt, die gesendete mail wird nicht in den Ordner "Offen..." in Konto konto1@gmx.de kopiert.


    konto1@gmx.de gehört mir und konto2@gmx.de habe ich mir testweise eingerichtet. Ansonsten wäre konto2@gmx.de ein Fremdkonto eines anderen Rechners.


    Das hat bis vor kurzem ja funktioniert. Bekam ich vom Fremdrechner eine mail, funktionierte der Filter.

    Schickte ich von meinem Rechner zum Fremdrechner eine mail, funktionierte der Filter.


    edit:


    Welche Funktion hat eigentlich der Haken bei "Versand" ? Wenn ich das richtig in Erinnerung habe, gab es bis vor einiger Zeit "Versand" nicht.


  • Dieses hier hast du schon durch? Besonders Punkt 9 ist wohl passend. Darüber steht

    Quote

    There are some long standing issues where you can successfully run filters manually, but they will not run automatically. This appears to be a configuration specific bug that never got fixed, not a regression bug. Despite its age it's only recently that a few bug reports have been written about it.

    Edited once, last by localhost ().

    Dieses hier hast du schon durch? Besonders Punkt 9 ist wohl passend. Darüber steht

    Da hast du meinen Thread verlinkt.


    Korrigiere den Link doch mal, der auf die Quelle verweist.


    OK Danke. Habe ich gelesen.


    Und dann ist mir eingefallen, dass es zeitlich hinkommt, dass der Filter, der für eingehende Nachrichten bisher funktionierte, seit ich Windows 10 habe, eben nicht mehr automatisch funktioniert. Manuell ausgeführt funktioniert der Filter.


    Für gesendete Nachrichten funktioniert der Filter ja nach wie vor auch automatisch und manuell.


    Habe dann testweise das Thunderbird-Profil als Ausnahme beim Defender definiert. Mal sehen, ob sich etwas ändert.


    Aber noch mal meine Frage:

    Kann jemand das Problem nachvollziehen bzw. hat es auch so wie ich es beschrieben habe?

    Glaube ja nicht, dass es hier niemanden gibt, der nicht mit Filtern so arbeitet wie ich.


    Werde es testen und mich dann melden.


    Die Ausnahmeregelung brachte keine Änderung.


    Es bleibt so wie beschrieben.


    Bei euch funktionieren die Filter alle automatisch?


  • Ich habe gerade mal einen neuen Filter angelegt, der bei entsprechendem Betreff eine ankommende Mail in einen Ordner verschiebt und habe mir selbst Mails geschickt. Das Verschieben klappt problemlos, sowohl manuell als auch automatisch.

    Du bist sicher, dass du nicht z.B: irgendwo ein Leerzeichen zuviel in der Bedingung hast?

    Du bist sicher, dass du nicht z.B: irgendwo ein Leerzeichen zuviel in der Bedingung hast?

    Habe ich kontrolliert, Leerzeichen gibt es nicht.


    Es ist ja so, dass die schon seit langer Zeit bestehenden Filter betroffen sind. Und bei diesen Filtern habe ich ja nichts geändert. Es funktionierte irgendwann mal bei den eingehenden Nachrichten nicht mehr.


    Wie ich schon schrieb, habe ich mit einer neuen Mailadresse einen einfachen Filter eingerichtet. Klappte damit ja auch nicht.


    Ich habe keine Ahnung, was die Ursache sein könnte.


    Wie ich schon schrieb:

    Manuell ausgeführt funktioniert der Filter.


    Edited once, last by Mental ().