Fremde "Sender-Email-Adresse" im Header

If you suddenly cannot receive any more emails

Please read the notes on the latest two most common causes of problems!

Please click here!

This red box disappears when you click on the X in the top right corner.


  • Hallo,

    ich habe ein Problem mit dem Header. Bisher gab es bei meinen Emails im Header immer nur "Von" und "An", vllt noch "CC" oder "BCC".
    Seit heute oder höchstens seit gestern taucht bei mir in jeder Email, die ich erhalten, egal von wem, eine fremde "Sender"-Emailadresse auf. Aber immer die Gleiche. Wenn ich selbst eine neue Email schreibe, ist alles normal. Doch wenn ich später bei gesendet schaue, steht dort auch immer diese fremde "Sender"-Email-Adresse. (Der Empfänger meiner Emails sieht das aber nicht, ist nur bei mir so.)


    Das Merkwürdige ist nun, dass sämtliche Emails, die ich je mit Thunderbird abgerufen habe, und das sind locker 6-8 Jahre, nun überall diese fremde "Sender"-Emailadresse plötzlich drinsteht. Egal ob im Eingang oder im Ausgang, obwohl ich mit dieser Emailadresse vor einem Monat zum ersten Mal Kontakt hatte.


    Kann mir einer helfen? Wieso steht diese Emailadresse nun in jeder Email im Header? Was bedeutet das? Wie bekomme ich das weg? Das ist echt kurios. :huh:?(:/


    Habe Thunderbird: 78.2.2 (32.bit)

    Win10 Pro 64bit, Version 2004 vom Juli 2020

    Ich nutze IMAP

    Postfachanbieter sind strato und mail

    Virensoftware: Bitdefender

  • Hall user312,


    das ist ein merkwürdige Phänomen. Ich kann Dir leider nur mit einer Standard-Lösung helfen: Hast Du es schon mal in TBs abgesicherten Modus getestet. Vielleicht schießt eine Erweiterung quer.


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten. Außerdem sind sie käuflich.


    Windows 10 Home (64 Bit) | Thunderbird 91 (64 Bit) | Firefox (64 Bit) | Avira Free Security Suite | Fritzbox 7490 | Posteo / web.de | CardBook | OpenPGP

    Android 9 Pie | K9-Mail | OpenKeychain | Business Calendar 2 | DAVx2 | ICSx2

  • Die mystischen Selbstheilungskräfte von TB - niemand weiß wieso, aber sie funktionieren.:mrgreen:


    Gruß

    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten. Außerdem sind sie käuflich.


    Windows 10 Home (64 Bit) | Thunderbird 91 (64 Bit) | Firefox (64 Bit) | Avira Free Security Suite | Fritzbox 7490 | Posteo / web.de | CardBook | OpenPGP

    Android 9 Pie | K9-Mail | OpenKeychain | Business Calendar 2 | DAVx2 | ICSx2

  • Hallo,


    ich muss diesen Tread hier leider noch einmal öffenen.

    Ich habe seit kurzem genau dieses oben beschriebene Problem.

    Beim Neustarten von TB ist es auch weg, kommt dann aber nach gewisser zeit wieder.

    TB ist 78.7.0 (64-Bit)

    Weiss hier jemand einen Ausweg?

    Es ist auch auf mehreren PC's mit unterschiedlichen Installationen.


    Christian

  • Hallo,


    eine aus meinem Adressbuch. die ist aber von einer ganz anderen Email. Ich habe sie auch schon aus dem Adressbuch entfernt, dennoch steht sie darin. Wichtig ist aber sicher: EGAL, bei welcher email, welches Konto und welche Zeit in der vergangenheit, es ist immer die selbe Email Adresse.



    grüße

  • Dann würde ich mal im abgesicherten Modus starten und sehen, ob es dann weg ist.


    Wenn ja, danach ALLE AddOns deaktivieren und nach und nach wieder zuschalten, bis es wieder auftaucht.


    Eventuell kannst du ja mit dem TO auch mal vergleichen, welche AddOns ihr BEIDE benutzt, das würde es vielleicht eingrenzen


    Falls du so auf den Übeltäter stößt, bitte hier angeben, wer es war :ziehtdenhut:

    Gruß Thomas
    TB 91.2.1 64 bit & BB aktuell
    Win 10 pro 64 bit
    AV: ESET - FW: BS
    IMAP bei Nameserver in UK, Outlook und Guhgel

  • eine aus meinem Adressbuch.

    Also keine fremde Adresse sondern eine in dieser Stelle zwar falsche aber bekannte. Dann gehe es mal etwas systematischer an. Zunächst liefere mal die oben erfragten Information nach. Also diese hier:


    • Thunderbird-Version (konkrete Versionsnummer:(
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (alte und neue Version angeben):
    • Betriebssystem + Version:
    • Kontenart (POP / IMAP):
    • Postfach-Anbieter (z.B. GMX):
    • Eingesetzte Antiviren-Software:
    • Firewall (Betriebssystem-intern/Externe Software):
    • Router-Modellbezeichnung (bei Sende-Problemen):

    Dann erstelle vor allen anderen Aktionen ein Backup des Profils. Im nächsten Schritt überlege, ob eine Erweiterung installiert hast oder in der Vergangenheit installiert hattest, die hier ursächlich sein könnte.

    Dann teste es im Safe-Mode des Thunderbird. Testen heißt hier, schaue sowohl ob der Fehler ganz weg ist - also auch rückwirkend auf alte Mails - oder nur für neue oder gar nicht.

    Bleibt der Fehler, versuche es mit der Option "Ordner reparieren", immer noch in Safe-Mode.

    Hilft auch das nicht, schaue dir betroffenen Mails im Quelltext an, sowohl über Strg+u also auch direkt mit einem Texteditor in der Mailbox-Datei. Steht fort auch der falsche Sender?

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo erstmal,


    ich habe mich soeben hier registriert, da ich das selbe Problem wie user312 und ckgth habe.

    Nochmal kurze Problembeschreibung, wie der Fehler bei mir aussieht:

    • mail von Person/absender A, wird angezeigt durch das Header-Feld "Von: "A" bzw. "From: "A"
    • darunter zu sehen ist das Feld "Sender" mit einer vollkommen anderen Mailadresse einer Person, die jedoch kenne und die in meinem Adressbuch ist.


    Hier ein paar Informationen nach der Vorlage von Susi:


    • Thunderbird-Version (konkrete Versionsnummer:( 78.7.0 (ist aber auch schon in einmal in einer der letzten Versionen aufgetreten, also nicht erst seit 78.7.0)
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (alte und neue Version angeben): vor kurzem, ist aber nicht ursächlich, siehe Antwort 1
    • Betriebssystem + Version: Windows 10 Pro 64 Bit
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): selbst gehostet: MDA "Cyrus" + MTA "Postfix" + Spamassassin
    • Eingesetzte Antiviren-Software: Windows Defender
    • Firewall (Betriebssystem-intern/Externe Software): Windows Firewall + selbst gehostete "nftables"-Firewall
    • Router-Modellbezeichnung (bei Sende-Problemen): -/- (Empfangs-/ Darstellungs-Problem)
    • eingesetzte Addons: "Provider für Exchange ActiveSync", "Sieve", "TbSync"


    Ein paar evtl. hilfreiche Beobachtungen:

    • Gleicher (falscher) "Sender" bei allen Mails
    • Nach einem Neustart von Thunderbird ist das Problem verschwunden

    Besonders interessant:

    Sehe ich mir den per strg+u den Mail-Header an, gibt es in der betreffenden Mail gar kein Feld "Sender". Lediglich Return-Path, Received, X-Sieve, Received, From, To, Subject, MIME-Version, Content-Type, Content-Transfer-Encoding, X-Cron-Env, Message-Id und Date.


    Es scheint sich also um einen reinen Darstellungsfehler seitens Thunderbird zu handeln, so mein EIndruck.

  • Sehe ich mir den per strg+u den Mail-Header an, gibt es in der betreffenden Mail gar kein Feld "Sender"

    Eben. Ich habe diese Art Anzeige auch im Thunderbird noch nie bewusst gesehen. Deshalb liegt es nahe, dass das von einer Erweiterung kommt. Wichtig wäre halt, zu prüfen, ob der Name dieses Senders irgendwo in Quelltext auftaucht. Vermutlich wird er das nicht. Dann wäre es ein reines Thunderbird-Thema.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hi Susi,


    danke für deine Antwort.

    Sehe ich mir den per strg+u den Mail-Header an, gibt es in der betreffenden Mail gar kein Feld "Sender"

    Eben. Ich habe diese Art Anzeige auch im Thunderbird noch nie bewusst gesehen. Deshalb liegt es nahe, dass das von einer Erweiterung kommt. Wichtig wäre halt, zu prüfen, ob der Name dieses Senders irgendwo in Quelltext auftaucht. Vermutlich wird er das nicht. Dann wäre es ein reines Thunderbird-Thema.

    Nein, die bei "Sender" aufgeführte Mailadresse steht nirgends im Quelltext. Spannend finde ich auch: ich habe meinen eigenen, gewöhnlichen Posteingang in Thundebird. Zusätzlich habe ich einen "geteilten" Posteingang. Also ein Postfach, auf das ich mit anderen Personen gemeinsam zugreife, die ebenfalls Accounts auf meinem Mailserver haben.


    Vorhin habe ich zufällig festgestellt, wann der Fehler auftritt:

    1. ich starte Thunderbird
    2. ich gehe in den gewöhnlichen Posteingang und klicke auf beliebig viele Mails - kein Sender
    3. ich gehe in den geteilten Posteingang und klicke auf unterschiedliche Mails. Manchmal taucht der Sender sofort beim Klick auf die erste Mail auf, manchmal erst beim Klick auf eine 2. oder 3. Mail
    4. Gehe ich nun zurück in den gewöhnlichen Posteingang und klicke dort wieder auf eine Mail, steht dort nun auch dieser Sender, der bei Punkt 2 noch nicht da war

    Ich werde mal AddOns deaktivieren und dann wieder sukzessive aktivieren.


    Edit: Der Fehler tritt auch auf, wenn alle Addons deaktiviert sind und ebenfalls im abgesicherten Modus (mit dann weiterhin deaktivierten Addons).

  • Ursache gefunden!!


    Sieht für mich nach einem Bug in Thunderbird aus.


    Schritte zum Reproduzieren:

    1. Thunderbird öffnen
    2. Beliebiges Postfach öffnen
    3. Mail von einem Outlook-Gruppenpostfach öffnen, das über einen Header-Eintrag "Sender" verfügt
    4. Feld Sender: "mailadresse" wird zusätzlich zu Von, An und Betreff im Thunderbird-UI sichtbar
    5. Zu beliebiger anderer Mail wechseln
    6. Feld Sender: "mailadresse" ist weiterhin als Angabe für die nun andere Mail im Thunderbird-UI sichtbar
    7. Testweise Mail von einem anderen Gruppenpostfach (ebenfalls mit Headerfeld Sender) öffnen
    8. Nun wird diese andere Mailadresse als Sender jeder beliebigen Mail angezeigt
    9. Das Feld wird bis zum Beenden von Thunderbird angezeigt und wird immer um die zuletzt angezeigte (Gruppenpostfach-)Sender-Adresse aktualisiert

    Ich hatte zum Testen nur Gruppenpostfach-Mails mit gefülltem "Sender"-Feld. Möglicherweise ist es irrelevant, ob es sich um eine Gruppenpostfach-Mail handelt sondern hängt nur davon ab, ob es das Feld Sender gibt.

  • Damit scheint die Vermutung bestätigt, dass es ein Problem des Thunderbird ist. Wenn der Name nicht im Quelltext enthalten ist, kann er nur vom Thunderbird selbst kommen. Teste zunächst mal mit einem neuen Profil. Ohne jede Erweiterung und ohne Adressbuch. Mir ist nach wie vor unklar, woher dieses Feld "Sender" überhaupt kommt.

    Gibt es eine Besonderheit bzgl. des Senders? Vielleicht im Adressbuch, in der Domain, ein Filter, ... ?

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hallo Susi,


    du hattest deine Nachricht kurz nach meiner letzten geschrieben. Daher vermute ich, dass du meine zweite Nachricht (hatte zwei nacheinander geschrieben) noch nicht gelesen hattest. Ich hatte in der Zwischenzeit mehr oder minder die Ursache gefunden bei #13


    Damit scheint die Vermutung bestätigt, dass es ein Problem des Thunderbird ist. Wenn der Name nicht im Quelltext enthalten ist, kann er nur vom Thunderbird selbst kommen. Teste zunächst mal mit einem neuen Profil. Ohne jede Erweiterung und ohne Adressbuch. Mir ist nach wie vor unklar, woher dieses Feld "Sender" überhaupt kommt.

    Gibt es eine Besonderheit bzgl. des Senders? Vielleicht im Adressbuch, in der Domain, ein Filter, ... ?

  • Daher vermute ich, dass du meine zweite Nachricht (hatte zwei nacheinander geschrieben) noch nicht gelesen hattest.

    In der Tat.

    Mail von einem Outlook-Gruppenpostfach öffnen, das über einen Header-Eintrag "Sender" verfügt

    Also gibt es doch etwas im Quelltext. Zumindest bei einigen Mails. Good Catch!


    Feld Sender: "mailadresse" ist weiterhin als Angabe für die nun andere Mail im Thunderbird-UI sichtbar

    Das heißt, dieses Feld mitsamt Inhalt ist nur ein "Relikt", Thunderbird vergisst quasi, das bei der nächsten Mail auszublenden?


    Dann bleibt noch die spannende Frage, ob user312 und ckgth auch eine Verbindung zu Outlook herstellen können.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Relikt trifft es ganz gut. Aber ja, das meine ich. Thunderbird zeigt es erst auf Basis der Einen Mail an, „vergisst“ dann aber, es beim Anzeigen einer anderen Mail es wieder auszublenden.


    Andere, ähnliche Theorie: die Felder Von, An und Subject werden immer angezeigt und ansprechend aktualisiert. Sender ist kein Standardfeld und wird evtl. erst gefüllt, dann aber nicht mit „Null“ bzw „leer“ aktualisiert bzw. geleert, wenn eine neue Mail angezeigt wird. Nur eine Theorie.

  • Ich habe mir zum Test eine E-Mail aus dem Firmenaccount per Outlook (den Maiclient , nicht die Domain) geschickt. Es gibt dort kein Feld "Sender". Das deutet darauf hin, dass dieses Feld nicht vom Client sondern vom Provider Outlook kommt.


    Wenn du es konstant reproduzieren kannst, wäre wohl ein Bug-Eintrag angebracht. Schau zuvor mal, ob es den nicht vielleicht sogar schon gibt.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Ich habe mir zum Test eine E-Mail aus dem Firmenaccount per Outlook (den Maiclient , nicht die Domain) geschickt. Es gibt dort kein Feld "Sender". Das deutet darauf hin, dass dieses Feld nicht vom Client sondern vom Provider Outlook kommt.


    Wenn du es konstant reproduzieren kannst, wäre wohl ein Bug-Eintrag angebracht. Schau zuvor mal, ob es den nicht vielleicht sogar schon gibt.


    Es gibt bereits einen Bug-Report dazu. Hab meine Schritte zum Reproduzieren mal übersetzt und dort gepostet:
    https://bugzilla.mozilla.org/show_bug.cgi?id=1681919

  • Na dann, behalte die Bug mal im Auge. Immerhin ist es keine Leiche, die dort schon seit Jahren schlummert.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)