Nachrichten lassen sich nicht entgültig löschen seit Upgrade auf 102.x

  • Hallo TB-Profis,


    ich nutze TB 102.1.0 (64Bit) auf Win 10 mit diversen IMAP-Konten bei verschiedenen Anbietern (z.B. gmx, 1und1 und weitere). Zur Verwaltung nutze ich bei allen Konten "Beim Löschen einer Nachricht: Als gelöscht markieren". Seit dem Update auf TB 102.x kann ich Mails zwar als gelöscht markieren, wenn ich dann aber "Alle ordner des Kontos kompriemieren" auswähle, bekomme ich die Antwort "ungefähr 0 KB freigegeben" und die als gelöscht markierten Nachrichten sind alle noch da. Wenn ich nun auf einem anderen Rechner (TB Portable 9x.x, Win10) die Ordner komprimiere, sind sie in beiden TB-Instanzen gelöscht.


    Hat jemand eine Idee, wie ich mein Problem lösen kann? Den Trick mit dem Löschen der Trash-Dateien im Profil-Ordner habe ich bereits erfolglos durchgeführt.


    Danke!


    • Thunderbird-Version 102.1.0


    • Betriebssystem + Version WIN 10 Pro 21H1


    • Kontenart (POP / IMAP) IMAP


    • Postfachanbieter (z.B. GMX) GMX, 1und1, IServ, freenet


    • Eingesetzte Antivirensoftware Windows Defender


    Einziges Add-On: Provider für Google-Kalender


    • Firewall (Betriebssystem-intern/Externe Software) Windows Defender

  • Verwendest Du klassisch Mbox als Speicherformat für die Konten in Thunderbird auf Deinem PC? Oder verwendest Du Maildir als Speicherformat (wenn JA, dann hast Du dies bewusst ausgewählt und müsstest es wissen)?

  • Moin,


    ich habe nichts bewusst geändert, die Dateien im ImapMail-Ordner haben die Endung .msf. Daher meine Vermutung: klassisch Mbox.

  • haben die Endung .msf. Daher meine Vermutung: klassisch Mbox.

    Die Index-Dateien *.msf gibt es sowohl bei den Mbox-Dateien (die haben dann keine Endung und haben einfach immer sinngemäß den Namen des jeweiligen Ordners aus Thunderbird) als auch beim Maildir-Format (da gibt es dann Unterordner mit cur und tmp, worin sich jede einzelne E-Mail im *.eml-Format befindet.

  • Ich glaube, dass es einen Bug im Zusammenhang mit dem "Expunge" der Mails auf dem IMAP-Server gibt. Allerdings kann ich leider nicht sagen, ob dieser Bug Dein Problem beheben wird.


    Gerade gefunden: https://bugzilla.mozilla.org/show_bug.cgi?id=1776727