"Ordner wird bearbeitet ..."-Meldung beim Abrufen

  • Hallo, habe ein Problem ähnlich einigenhier schon geposteten Fällen, aber sämtliche Hilfen konnten mich nicht weiterbringen.


    Ich habe seit kurzem beim Abrufen meiner 8 POP3-Postfächer bei jedem einzelnen die Meldung "Dieser Ordner wird bearbeitet. Bitte warten Sie, bis die Bearbeitung abgeschlossen ist, um Nachrichten abzurufen.", während in der Statusleiste unten links im TB angezeigt wird "Verbinden: Host kontaktiert, sende Login-Daten...".


    Es läuft definitiv kein Anti-Virenprogramm, leider kann ich nicht beurteilen ob mehrere Prozesse des TB gleichzeitig auf den Datenbestnad zugreifen und der Fehler daher rührt. Habe alle Filter deaktiviert.


    Vielleicht ist dazu interessant zu wissen dass ich alle E-Mails über einen globalen Posteingang laufen lasse und sie mir nachher sortiere, teils per Filter, teils per Hand.


    Sowohl das Sichern der Daten und importieren in ein reines Profil als auch das komplette neu installieren des TB brachten keinen Erfolg.


    Danke schonmal im Voraus.

  • Zitat

    Vielleicht ist dazu interessant zu wissen dass ich alle E-Mails über einen globalen Posteingang laufen lasse und sie mir nachher sortiere,


    Darin liegt vermutlich das Problem.
    TB ruft alle Konten quasi parallel ab und wenn alle Ergebnisse im gleichen Ordner landen sollen (dem geimeinsamen Posteingang) kommt es schon vor, das sich die Prozesse gegenseitig blockieren.
    Abhilfe schaft wohl hier entweder versetztes Abrufen aller Konten oder die Einrichtung verschiedener Eingangsordner für jedes Konto.


    gruß
    nuja

  • "nuja" schrieb:

    Abhilfe schaft wohl hier entweder versetztes Abrufen aller Konten oder die Einrichtung verschiedener Eingangsordner für jedes Konto.


    Hmmm... also auch wenn ich nur ein Konto manuell abrufe kommt das Problem, zumal er ja ein gutes Jahr lang ohne Motzen das Ganze immer schön sequentiell abgerufen hat - macht er ja jetzt auch,eines nach dem anderen und jedes Mal der gleich Fehler.


    Könnte es auch mit zu großen Mbox-Dateien zusammenhängen? Hat sich nämlich einiges angesammelt in den letzten Jahren...


  • Leider trifft beides nicht zu, habe sowohl Anti-Virenprogramm deaktiviert als auch alle Ordner komprimiert und die Indexdateien neu erstellen lassen.


    Wie gesagt, habe viel probiert aber komme nicht weiter :) Meine größte Mbox-Datei ist übrigens 700MB groß, an der Größenbeschränkung vom Dateisystem sollte es also auch nicht scheitern. :(

  • Halo,


    hat denn sonst keiner einen Plan? Halte es schon für ein interessantes und lösenswertes Problem, sofern es wirklich ein Problem der Nebenläufigkeit (wären wohl eher Threads als Prozesse?) ist.


    Hoffe mir kann noch jemand helfen.


    Ach ja, auf einmal lässt sich das eine Konto ständig fehlerlos abrufen, die anderen aber nicht - leider kann ich keinen signifikanten Unterschied zwischen den Konten feststellen... :(

  • Habe jetzt noch alle Eingangskonten bis auf 3 entfernt, immer noch keine Besserung in Sicht :(

  • Hallo,


    Thunderbird läuft wieder einwandfrei. Habe alle Konten mit den Benutzername/Passwort-Einstellungen gelöscht, neu angelegt - und schwups: keine Probleme mehr.


    Hoffe wenn das hier jemand liest kann er so das nervtötende Fehlersuchen schneller sein lassen.

  • Hallo Leute,


    ich habe ein ähnliches Problem. Bei (fast) jedem Start von TB frägt er mich, ob ich die Ordner komprimieren möchte. Beantworte ich es mit "Ja", so kommt die Meldung, dass die Ordner gerade in Benutzung sind. Mit den Nebeneffekten, dass z.B. Regeln nicht mehr richtig bearbeitet weden.


    Meine Vermutung ist nun, dass TB die Ordner komprimiert und gleichzeitig versucht neue Mails darin abzulegen mit dem Ergebnis, dass dies nicht geht, weil im Zugriff.


    Warum wartet TB mit dem Abholen von Mails nicht, bis die Komprimierung beendet ist oder ein anderer Ansatz: Warum optimiert TB nicht seine Ordner, bevor es beendet wird?


    Gibt es eine Möglichkeit dieses Verhalten dahingehend zu beeinflussen?


    Bye


    Ralf

  • ralf,


    da bist du nicht alleine
    bei mir macht TB das selbe und zwar schon stundenlang
    hatte auch den virenscanner abgeschaltet, es tut sich nichts.


    ingrid

  • Hallo zusammen,


    ich habe das auch - aber nur mit einer meiner beiden Installationen.


    Daher wollte ich der Sache auf den Grund gehen.


    - prüft mal im Safe-Mode ob evtl. eine Erweiterung diesen Zustand verschärft
    - deaktiviert das automatische Abholen der Mails und testet ob es nur beim Abholen von einem bestimmten Konto auftritt. Es kann sein dass während des abholens der Mail vom Server die Mbox-Datei für andere Prozesse gesperrt wird.
    - Wie groß ist eure Training.dat - in meinem Fall ist sie schon auf 1.5 MB angewachsen - auch das kann eine rasche Bearbeitung der Mail verhindern.
    - falls der Virenscanner euer Profil jemals gescannt hat, solltet ihr auch in Erwägung ziehen alle msf-Dateien mit Ausnahme der von virtuellen Ordnern einmal zu löschen.


    Bei mir brachte schon das "ausmisten" von nicht mehr benötigten Erweiterungen eine deutliche Entlastung (ich hatte hier mit dem Filemon einige Tests gemacht, welche Erweiterung in ihr GUID-Verzeichnis schreibt während man die Mails abruft), obwohl das Problem wohl der langsame Zugriff auf ein Konto ist (bzw. eine zu große Training.dat - evtl. muss ich die wohl mal löschen).


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo,


    also für mich ist das ein klarer Bug. Tritt bei mir seit 2.0.0.0 auf mehreren Rechnern auf, unter Linux, kein Virenscanner, keine globale Inbox, viele relativ kleine Ordner.
    Mehrere Beiträge zum Thema, aber keine Lösung...
    Die trainings.dat löschen? Hmm, schade drum, oder...?
    Kennt jemand den genauen Wortlaut der o.g. Meldung auf Englisch? Ich wette, es gibt schon einen Bugzilla-Eintrag.


    muzel

  • Hallo muzel,


    also ich habe das Problem trotz aller Versuche immer noch gehabt, aber bin mal wieder einen Schritt weiter. Bei mir war noch ein Filter-Log eingeschaltet - ich habe jetzt mal das Logging der Filter für dieses Konto deaktiviert und das Protokoll gleich mit entsorgt. Danach war schlagartig ruhe mit dieser Meldung.


    Was auch hilft, ist kurz in den Offline-Modus gehen wenn wirklich noch ein anderer Prozess auf den Ordner zugreift. Danach kann man gleich wieder auf Online-Modus gehen und dann geht der Abruf meistens sofort. Die Training.dat habe ich ja auch noch in Verdacht - Sie könnte eines Tages zu groß sein, und beim Abruf die Verarbeitung so weit verzögern dass man diese Meldung doch häufiger bekommt.


    Edit: während ich diese Nachricht schreibe habe ich noch mal manuell abgerufen und prompt die Meldung wieder bekommen :( aber einmal kurz offline gegangen (Meldung ob man alle Nachrichten vorher runterladen will mit nein beantwortet) und dann wieder auf online und sofort abgerufen - jetzt kam eine Meldung vom Mailserver, dass der ein Problem hat (so in der Art das gerade ein anderer Zugriff stattfindet) - ich denke mal dass sich hier mein Anfangsverdacht bestätigen würde (langsamer oder nicht ganz fehlerfreier Zugriff auf den Mailserver).


    Am besten daher so ein Konto als separates Konto anlegen und den Abruf nicht mehr automatisch machen sondern grundsätzlich manuell.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro