Zeilenumbruch beim Verfassen

  • Hallo,


    tut mir leid, dass ich das Thema noch mal anspreche, aber für mein Problem habe ich bisher im Forum keine Lösung gefunden.


    Seit neuestem - imho seit Update auf Version 1.5.0.5 - wird beim Verfassen einer E-Mail (Neu oder Antwort spielt keine Rolle) im Editorfenster nicht mehr am Fensterrand umgebrochen, sondern es befindet sich am unteren Fensterrand (ebenfalls neu) ein Scrollbalken und ich kann ca. 100 Zeichen schreiben (65 sind eingestellt) bis wieder am Zeilenanfang begonnen wird.
    Wenn ich das Editorfenster weiter aufziehe verkleinert/verschwindet der Scrollbalken zwar irgendwann, aber ich möchte kein Editorfenster, dass über beinahe die gesamte Monitorbreite geht.


    Vorher war der Scrollbalken nicht da, egal wie breit das Editorfenster war, und es wurde korrekt am Fensterrand umgebrochen.


    Speichere ich die Mail z.B. als Entwurf wird der Zeilenumbruch übrigens korrekt nach der eingestellten Zeichenzahl vorgenommen.


    Hier zwei Sreenshots, einmal mit, einmal ohne Schrift:


    http://foto.arcor-online.net/p…/400_3366636263346539.jpg
    http://foto.arcor-online.net/p…/400_6337643933353662.jpg


    Ich bestehe ja nicht darauf, dass bereits im Editorfenster nach eingestellter Zeichenzahl (=65) ein Umbruch angezeigt wird, aber am Fensterrand und ohne diesen Scrollbalken sollte es schon sein.


    Würde mich über Lösungshinweise sehr freuen.

  • Hallo,


    ich stubse das Thema noch mal nach oben, weil das Problem immer noch besteht und ich das selbe Problem nun auch noch auf einem zweiten Rechner nachvollziehen kann, nachdem ich eben auf 1.5.0.5 upgedatet habe.


    Da ich zunächst keine Einstellungen verändert habe, es vorher tadellos funktionierte und erst seit dem Update auftritt, habe ich den Verdacht, dass es eben mit diesem Update zu tun hat.


    Hat vielleicht noch jemand diese "Erscheinung" oder kennt Abhilfe?


    Gruß


    Krempelbox

  • "Krempelbox" schrieb:

    Da ich zunächst keine Einstellungen verändert habe, es vorher tadellos funktionierte und erst seit dem Update auftritt, habe ich den Verdacht, dass es eben mit diesem Update zu tun hat.


    Normal ist das nicht, auch nicht beim Update.


    Evtl. kommt es aber dadurch "ans Licht".


    Probiere doch mal, TB im Mode "No Extensions" zu starten und teste.


    Ist das Problem dann auch da?

  • Hallo,
    immer wieder habe ich mal im Forum geschaut, ob mein Problem mit dem Zeilenumbruch vielleicht mittlerweile gelöst ist: Ich habe den Umbruch nach 72 Zeichen beim Schreiben eingestellt, Thunderbird "schreibt" aber bis zum rechten Fensterrand weiter. Ich klicke jedesmal "neu umbrechen" an, finde das aber keine Lösung, zumal die Fehlfunktion bis vor einiger Zeit nicht auftrat. Habe alles probiert, was im Forum stand.
    Grüße von ctrunk

  • Habe das gleiche Problem: kein Umbruch beim Verfassen, trotz eingestellter 72 Zeichen (steht auch so in der prefs.js). Würde ich gerne ändern, weil Mails mit mehr als 120 Zeichen Zeilenlänge sind nicht gut lesbar, finde ich.
    Version 1.5.0.4

  • Nebenbei: Wichtig ist, zu unterscheiden zwischen dem Verfassen-Fenster und der Nachrichtenansicht.


    Wenn ihr wollt, könnt ihr probieren, "format=flowed" Abschaltung zu aktivieren in den Einstellungen -> Erweitert -> Konfiguration bearbeiten:

    mailnews.display.disable_format_flowed_support


    und/oder evtl.


    mailnews.send_plaintext_flowed

  • @ allblue: Hat leider nichts gebracht. Ich bin wirklich ratlos, denn ich verwende zuhause und auf der Arbeit TB mit den gleichen Einstellungen. Zuhause werden die Umbrüche anstandslos gemacht, auf der Arbeit läuft der Text immer bis zum rechten Rand.

  • Mir ist Folgendes aufgefallen: Wenn ich einen Text, bei dem der Zeilenumbruch wie gehabt nicht funktioniert und immer die ganze Zeile vollgeschrieben wird, als Entwurf abspeichere und später wieder aufrufe, ist der Umbruch wie gewünscht da (nach 72 Zeichen). Also das müßte doch zu machen sein, daß das auch ohne diesen Umweg automatisch passiert?

  • "ctrunk" schrieb:

    Mir ist Folgendes aufgefallen: Wenn ich einen Text, bei dem der Zeilenumbruch wie gehabt nicht funktioniert und immer die ganze Zeile vollgeschrieben wird, als Entwurf abspeichere und später wieder aufrufe, ist der Umbruch wie gewünscht da (nach 72 Zeichen).


    Bei mir ist es ehr umgekehrt ;) (und nach meiner Meinung korrekt).


    Zunächst: Ich spreche hier von Reintextmails.


    Im Verfassen-Fenster wird nach 72 Zeichen während des Schreibens korrekt umbrochen. Nach dem Speichern als Entwurf wird mir in der Nachrichtenansicht (!) der Text korrekt als format=flowed am rechten Fensterrand umbrochen (genauso nach dem Senden). Rufe ich die Mail aus dem Ordner Entwürfe wieder auf, ist alles wieder nach 71 Zeichen umbrochen.


    Probleme mit dem Umbruch während des Schreibens kenne ich nur beim Antworten auf Mails bestimmter Absender.


    Ideen:
    - Wir vergleichen die Einstellungen zum Verfassen.


    oder


    - Du postest hier mal den Header einer solchen Mail (die enthaltenen E-Mailadressen dann bitte verfälschen) und ich vergleiche mal mit meinem

  • Hallo allblue,


    sorry für die Verspätung, hier ein paar Angaben zu meinen Einstellungen/Verfassen (weiß nicht so recht, was wichtig sein könnte, daher schreibe ich alles mögliche mal ab):


    Allgemein:
    "quoted printable": nein
    Tastaturkürzel bestätigen: ja
    speichern jede Minute
    Reintext-Nachrichten umbrechen nach 71 Zeichen


    Rechtschreibprüfung:
    nicht aktiviert


    Du schlägst auch vor, daß ich den Header einer Mail poste, in der nicht umbrochen wird. Habe jetzt eine Weile rumprobiert, brauche aber nun doch Tips, wie das geht.


    Freundlichgruß, C.

  • "ctrunk" schrieb:


    Reintext-Nachrichten umbrechen nach 71 Zeichen


    Ich sehe grad, dass ich obenmal 71 statt 72 geschrieben hatte, war ein Tippfehler von mir.

    Zitat

    Du schlägst auch vor, daß ich den Header einer Mail poste, in der nicht umbrochen wird. Habe jetzt eine Weile rumprobiert, brauche aber nun doch Tips, wie das geht.


    Markiere eine Mail (im Gesendet-Ordner oder Entwürfe) und gehe zu Menü Ansicht -> Nachrichten-Quelltext.


    Kopiere mal alle Zeilen, die mit "Content" beginnen hier hinein, vielleicht sieht man was ...

  • Hallo allblue,


    hier unten nun der "Nachrichten-Quelltext" einer Mail. Der Nachrichtentext selbst läuft im Thunderbird-Fenster wie gehabt über die ganze Breite und wird erst ganz am rechten Rand umbrochen statt nach den eingestellten 72 Zeichen. Ist was zu erkennen für Dich?


    Freundlichen Gruß von ctrunk


    +++++++++++


    From - Mon Jun 04 11:54:55 2007
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00000000
    FCC: mailbox://m7840511-4@mail.tuxwerk.de/Sent
    X-Identity-Key: id2
    BCC: ctrunk@web.de
    Message-ID: <4663E16F.9090909@kyosk.net>
    Date: Mon, 04 Jun 2007 11:54:55 +0200
    From: <ctrunk@kyosk.net>
    X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=0; uuencode=0
    User-Agent: Thunderbird 1.5.0.12 (Windows/20070509)
    MIME-Version: 1.0
    To: ctrunk@infocanarias.com
    Subject: xx
    Content-Type: text/plain; charset=ISO-8859-1; format=flowed
    Content-Transfer-Encoding: 7bit


    Hallo,


    eine Nachfrage bei den Vorbesitzern eine Nachfrage bei den Vorbesitzern
    eine Nachfrage bei den Vorbesitzern
    eine Nachfrage bei den Vorbesitzern eine Nachfrage bei den
    Vorbesitzernine Nachfrage bei den Vorbesitzer
    eine Nachfrage bei den Vorbesitzern ine Nachfrage bei den
    Vorbesitzerine Nachfrage bei den Vorbesitzerine Nachfrage bei den
    Vorbesitzerine Nachfrage bei den Vorbesitzerine Nachfrage bei den

  • Interessanterweise habe ich seit einigen Tagen EXAKT dasselbe Problem. Obwohl ich Thunderbird schon seit einer frühen 1.x benutze, ist das Problem vorher noch nie aufgetaucht, dafür aber - seit es existiert - umso nerviger und umfangreicher.


    Ich zitiere einfach mal frei aus einem anderen Forum heraus:



    Antwort:



    Dann ich wieder:


    Zitat


    Erstmal danke für deine Antwort.


    Zugegebenermaßen: es löst das Problem. Allerdings wird dann nur der Text der alten Email (d.h. der Email, auf die ich gerade antworte) umgebrochen. Mein eigener Text kann dennoch weiterhin als 1-zeiler bis ins Nirwana geschrieben werden. Ausserdem muss ich die Funktion dann bei JEDER Mail einzeln ausführen, was für mich bei der Menge an Emails, die ich pro Woche beantworte, absolut nicht akzeptabel ist.


    Antwort:


    Zitat


    In diesem Fall verwende die Erweiterung Autorewrap:
    http://autorewrap.mozdev.org/index.html


    (uninteressanten Teil entfernt)


    Mein letztes Posting vor ca. 30 min:


    Zitat


    Gut, ReWrap taugt zumindest soweit, dass ich die Mails nicht ständig selbst umbrechen muss. Allerdings wird der Umbruch dann aber dennoch nicht bei meiner eigenen Mail vollzogen, was bedeutet, dass ich hier weiterhin nicht "fließend" (d.h. am Stück) schreiben kann, sondern bei entsprechender Stelle dann jeweils selbst Enter drücken muss, um an den Anfang der nächsten Zeile zu gelangen.


    Dennoch steht mein Entschluss fest, das Email-Proggi zu wechseln, sofern sich dieser äußerst nervige Fehler nicht beheben lässt.


    Interessant auch, dass ich meine Mails gesichert habe, dann TB2 de- und die 1.5.xx installiert habe und selbst dort - obwohl anfangs nicht vorhanden - der Fehler nach wenigen Minuten wiedder vorhanden war. Ein Ärgernis ohnegleichen. Alle TB-bezogenen Ordner habe ich natürlich vor dem installen der 1.5.xx entfernt, es können also keine alten Einstellungen übernommen worden sein.




    Sorry, wenn ich so viel quote, aber imho stellt es den Sachverhalt besser dar, als wenn ich nur das letzte Posting von mir quoten würde.


    Anybody help? :cry:



    Grüße
    FF




    /edit & nachtrag:
    TB jetzt NOCHMAL runtergeschmissen, alle einstellugnen und folder gelöscht und die 2er draufgehauen. jetzt NUR das profil der email-addy, wo das problem wohl am ehesten liegen dürfte, draufgehauen und in den settings step-by-step alles umgestellt und eingerichtet... und es funktioniert ALLES. keine fehler, kein gar nichts. es funzt, wie es soll. korrekte umbrüche und alles. wahahaha, blebb blebb blebb, überall sind bunte farben und rosafarbene fliegende milchkühe... und aus ihren eutern kommt milch mit honig und aus ihrem hintern alpenmilch-schoki...



    PROBLEMLÖSUNG GEFUNDEN!
    Problem hat sich übrigends gelöst, kaum zu glauben. Step-by-Step bringts also doch.


    Extras-> Konten-> Verfassen & Adressieren -> [X] Nachrichten im HTML-Format verfassen.


    Funzt jetzt alles wunderbar, sogar ohne das Plug-In.


    Mag denn keiner das gute alte Plain-Text mehr? Naja, was solls.

  • Hallo,


    auch bei mir hat die Installation von Autorewrap für das Mail-Verfassen nichts gebracht. Das Umschalten auf "Nachrichten im HTML-Format verfassen" kann wirklich nicht die Lösung sein. In manchen Foren kriegt man auf die Finger geklopft, wenn man solche Nachrichten abliefert. Und der open-source-Gemeinde geht sowas Unökonomisches doch gegen den Strich, oder?


    Bin weniger genervt als der Vorredner, wäre aber froh, wenn ein Genie den Knopf findet.


    Gruß, ctrunk

  • "ctrunk" schrieb:

    auch bei mir hat die Installation von Autorewrap für das Mail-Verfassen nichts gebracht. Das Umschalten auf "Nachrichten im HTML-Format verfassen" kann wirklich nicht die Lösung sein.


    Das sehe ich auch so. Es könnte sinnvoll sein, wenn du noch einmal in einem neuen Profil testest, ob das da alles auch so auftritt.

  • Hallo allblue,


    wie Du vorschlugst, habe ich in Thunderbird ein neues Konto erstellt und darin eine neue Nachricht geschrieben. Leider erfolgt der Umbruch weiterhin nicht, wie eingestellt, nach 72 Zeichen, sondern erst ganz rechts im Fenster.


    Gruß, ctrunk

  • ctrunk :
    du sollst ja auch ein neues Profil erstellen. du hingegen hast offenbar in deinem bestehenden profil nur ein neues konto eingerichtet ;)

  • allblue :


    danke für den Tip (mal wieder). Tatsächlich funktioniert der Umbruch in dem neuerstellten Profil nun wie vorgesehen. Heißt das denn aber nun, daß ich da alles (immerhin 4 Konten) wieder von vorne einrichten muß, mit Extensions, Erscheinungsbild und allem Drum & Dran? Na ja, in einem ruhigen Moment vielleicht, sprich in ein paar Monaten...


    Wobei man dann ja offenbar nicht dagegen gefeit wäre, daß der Fehler irgendwann aus heiterem Himmel wieder da ist. Denn wir wissen damit ja nicht, woran's liegt. Oder?


    Gruß, C.

  • "ctrunk" schrieb:

    Tatsächlich funktioniert der Umbruch in dem neuerstellten Profil nun wie vorgesehen.


    Gut.

    Zitat

    Heißt das denn aber nun, daß ich da alles (immerhin 4 Konten) wieder von vorne einrichten muß, mit Extensions, Erscheinungsbild und allem Drum & Dran?


    Da du nicht genau weißt, wo die Ursache war, bringt es nix, die Sachen rüberzukopieren.


    Also neu einrichten und Mails aber importieren - die hätte man ja doch schon gerne wieder ;).