Zeilenumbruch beim Verfassen

  • allblue :


    Die Neueinrichtung werde ich nicht vornehmen, weil ich ja nicht weiß, ob es mir nicht früher oder später wieder so geht (anderen Forumsteilnehmern ist das ja auch passiert), daß der Umbruch plötzlich aus unerfindlichen Gründen nicht mehr klappt.


    Das heißt, ich warte, bis eine neue Version von Thunderbird oder ein Add-on das Problem repariert, und klicke bis dahin geduldig auf "Neu umbrechen", ehe ich eine Mail abschicke. Ich will ja, daß meine Adressaten keine ewig langen Zeilen lesen müssen.


    Thanks anyway! C.

  • Quote from "ctrunk"

    Die Neueinrichtung werde ich nicht vornehmen, weil ich ja nicht weiß, ob es mir nicht früher oder später wieder so geht (anderen Forumsteilnehmern ist das ja auch passiert), daß der Umbruch plötzlich aus unerfindlichen Gründen nicht mehr klappt.


    Vielleicht bekommst du aber diesmal mit - wenn es überhaupt passiert - was du gerade vorher geändert hattest und findest so die Ursache.

    Quote

    Das heißt, ich warte, bis eine neue Version von Thunderbird oder ein Add-on das Problem repariert, und klicke bis dahin geduldig auf "Neu umbrechen", ehe ich eine Mail abschicke.


    Das wird nicht passieren, denke ich, da es nicht um ein Problem geht, dass viele haben. Ich selbst nutze TB schon länger und habe das Problem z.B. nicht.


    Die Ursache liegt eindeutig nicht im Programmteil von TB, sondern in deinem Profil (sonst würde es nicht mit dem neuen funktionieren).


    Bei späteren Updates wird dein Profil nicht angetastet - dein Problem bleibt also bestehen.

    Quote

    Ich will ja, daß meine Adressaten keine ewig langen Zeilen lesen müssen.


    Das wiederum ist eine völlig andere Frage, die hier im Thread noch nicht behandelt wurde.


    Wie der Empfänger deine Reintext-Mails sieht, kannst du kaum beeinflussen, das stellt er selbst ein. D.h. nur weil du lange Zeilen siehst, sieht er die nicht unbedingt auch.


    Du hast ja oben den Quelltext einer Mail hier hineinkopiert. Diese Mail würde bei mir absolut normal aussehen, behaupte ich mal ;).

  • allblue :


    Vielleicht bin ich der Sache jetzt auf die Spur gekommen. Ich habe mit den eingestellten Schriftarten (unter Einstellungen/Ansicht/Schrift) herumprobiert. Offenbar sind die allermeisten Schriften, die Thunderbird mir jeweils auflistet, in Wirklichkeit nicht mit dem Umbruch nach 72 Zeichen vereinbar - vor allem diejenigen Schriften, die ich am liebsten verwenden würde. Aber mit "Times New Roman Special" zum Beispiel klappt es, und zwar auch unabhängig von der eingestellten Schriftgröße.


    Klappt das auch bei den anderen, die dasselbe Problem berichten?


    Gruß, c.

  • Hallo,
    hast du schon mal probiert den passenden Eintrag in about:config auf true zu stellen?


    mail.compose.wrap_to_window_width


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Edited once, last by mrb ().

  • Hi,


    wie Du schon mitgekriegt hast, bin ich nicht so der große Crack in PC- und Forumsdingen. Aber ich lerne gern dazu. Wie ich "true" finde (heißt so das Forum o.ä.?), weiß ich nicht. In der Konfigurations-Zeile "mail.compose.wrap_to_window_width" steht bei mir "Standard - boolean - false", aber das sagt mir nichts.


    Gruß, C.

  • Quote from "ctrunk"

    bin ich nicht so der große Crack in PC- und Forumsdingen. Aber ich lerne gern dazu. Wie ich "true" finde (heißt so das Forum o.ä.?), weiß ich nicht.


    "True" ist englisch und heißt "wahr" im Gegensatz zu "false" (=falsch).

    Quote

    In der Konfigurations-Zeile "mail.compose.wrap_to_window_width" steht bei mir "Standard - boolean - false", aber das sagt mir nichts.


    Ok so. (Übrigens ändert sich False bei Doppelklick auf True.)


    Vergleiche vielleicht mal diese Einstellungen:



  • kann ich leider nicht beurteilen, da die von dir genannten schriftart bei mir gar nicht vorhanden ist. lediglich das "normale" times new roman. anbei ein screenshot meiner derzeitigen einstellungen. wie schon erwähnt, da ich meine konten-einstellungen von plain-text auf html-mails umgestellt habe, funktioniert jetzt alles einwandfrei. zufrieden bin ich aber nicht.


  • Quote from "funfact"

    dann müssen wohl hunderte, wenn nicht sogar tausende tb-anwender auf deutsch gesagt einfach "zu blöd" dazu sein, ihn richtig anzuwenden.


    Dann müssen Abertausende es aber irgendwie hinkriegen offensichtlich (Spaßkonter) ;).


    Hier im Forum bringt der Suchbegriff "zeilenumbruch" 35 Threads. Oft geht es dabei um den Punkt "format=flowed" oder anderes, der aber hier in diesem Fall nicht zu passen scheint.


    Lies die Threads bitte, wenn du eine Aussage zur Häufigkeit treffen möchtest!


    Im Ernst: Von "blöd" redet niemand, trotzdem wird die Ursache im Profil liegen. Anscheinend glaubst du mir das aber nicht. Du hast immer noch nicht verstanden, dass ein Problem im Profil nicht unbedingt mit von dir getätigten Einstellungen zu tun haben muss.


    Ich kann mir nämlich nicht vorstellen, dass beim Runterladen macht eine Version erwischen, mit der es klappt, andere eine Version, mit der es nicht klappt. ;)


    Ein Test mit einem neuen Profil dauert nur wenige Minuten - wieso probierst du es nicht einfach aus? Das frage ich mich wirklich.


    Nebenbei:
    Zu deinem Screenshot: Stell mal testweise als Größe 13 Pixel ein, ebenso als minimale Schriftgröße, zudem die Bildschirmauflösung.


    Weiterhin ist nicht klar, ob du bei Reintextmails variable Breite gewält. Probier auch mal feste Breite.

  • funfact :


    Ein Vorschlag: Erstelle mal eine Mail, in der dann der Umbruch nicht klappt und die Zeile bis hinten vollgeschrieben wird. Dann über Einstellungen/Ansicht/Schrift/Schriftarten verschiedene Schriften (und evtl. auch Schriftgrößen, wie allblue das vorschlägt) durchprobieren. Bei mir war das so, daß nach dem Abspeichern der neuen Einstellung im Mail-Entwurf dann gleich der Effekt zu sehen war. Dauert also nicht lang.


    Das ist vielleicht (falls erfolgreich) eine nervensparendere Variante als andere. Ich bin jetzt jedenfalls zufrieden, auch wenn das Spektrum der Schriften, die ich problemlos einsetzen kann, eingeschränkt sein mag.


    Gruß, ctrunk

  • allblue :
    schön, wie auch immer. ich habs im 1.5er nicht hinbekommen und dann spaßeshalber nochmal die 2er drübergeschmissen (bevor die frage wieder kommt: JA, mir IST klar, dass alle einstellungen übernommen werden! :evil: ). man hofft ja bekanntlich immernoch auf wunder, aber wie zu erwarten war, hat sich nichts getan, der fehler bestand weiter.


    okay, sys.steuerung -> software. tb2 deinstallt, den restlichen kram unter doks&einstellungen gelöscht und zuletzt die wurzel allen übels unter c:\programme\ entfernt. reboot & kaffee.


    tb2 installt und alle konten in der reihenfolge angelegt, wie ich es seit jahren tue. ich beherberge insg. 3 konten (d.h. 3 email-adressen). danach noch den rss-reader. KEINE einstellungen oder details in den konten geändert, sondern NUR die emails aus dem "problem-account" reinkopiert (JA, in die richtige Stelle bzw. Konto!). der ursprüngliche pfad zu jenen war


    Code
    1. C:\Dokumente und Einstellungen\(Benutzername)\Anwendungsdaten\Thunderbird\Profiles\(kryptische Zeichen).default\Mail\mail.b*******e-1.com


    tb2 gestartet, mails sind vorhanden. eine typische problem-mail geöffnet, ursprünglicher text wird korrekt umgebrochen.
    neuen text an den anfang der mail gesetzt... und siehe da... ER BRICHT IMMER NOCH NICHT UM! :evil:
    ein ewiger 1-zeiler ohne jeden gedanken an einen umbruch. wie schon die x-tausend versuche zuvor.


    ich bin inzwischen wirklich kurz vorm explodieren (entschuldigt, aber ich denke, es ist wirklich nachvollziehbar) und erwäge c:\ zu formatieren, zumal mein anti-viren-tool soeben einen nicht entfernbaren trojaner (oder wars n wurm? ach, was weiss ich), in dem zuvor vom tb im doks&einstellungen-ordner gemachten backup gefunden hat (allerdings nicht in dem "problem-profil").


    ich hoffe, ihr erspart mir diesen letzten schritt, da ich z.zt. weder den nerv noch den platz auf anderen hdd's / cd's / dvd's für backups, vor allem aber nicht die zeit habe, jetzt ein komplett neues sys aufzusetzen.



    au revoir
    ff



    ps: achja, bevor ichs vergesse: mit den schrift-settings habe ich sowohl vor wie auch nach der de- bzw. reinstall rumprobiert. die schrift wurde zwar entsprechend geändert wie ctrunk es schon beschrieben hat aber von einem ordentlichen umbruch war nirgends was zu sehen.

  • Mir fällt leider nichts weiteres mehr zur Ursachenforschung ein. Wenn du tatsächlich alles von TB entfernt hast (Programmordner und Profilordner), TB neu runtergeladen und installiert hast und es direkt nicht funktioniert, ist Ende der Weisheit. Wenn es bei allen so wäre, wäre ja Alarmstufe Rot.

  • nachdem ich win2k entnervt aufgrund des problems aufgegeben hatte und auf c:\ reinen tisch gemacht habe, funktioniert jetzt alles einwandfrei.


    am besten ich spiele gar nicht groß an den settings herum... :lol:


    trotzdem danke für die kompetente hilfestellung.


    grüße
    ff

  • Auch bei mir hat das Umschalten auf HTML mein Problem gelöst. (Verwende noch 1.5.0.13). Scheinbar kann das Programm einen geqoteten Text, der urspünglich HTML war, in der Anzeige (Plain Text) nicht umbrechen wenn das Verfassen auf plain Text eingestellt ist..... Wenn sowohl gequoteter Text als auch Antworttext in HTML ist, scheint's zu funktionieren, jedenfalls bei mir.


    Weiß jemand, ob das in der Version 2.0x behoben ist?


    Gruß
    Mausebär

  • Ich behaupte mal wild ;), dass einige hier im Thread das Ganze noch nicht erfasst haben. Ist auch nicht supereinfach. Außerdem lesen hier viele mit. Daher nochmal etwas in Kürze:


    Bei Reintext ist es beim E-Mail-Programmen (wie z.B. TB) mit Beherrschung von "format=flowed" normal, dass beim Schreiben nicht unbedingt nach 72 Zeichen umbrochen wird. Der Umbruch ist abhängig von der Fensterbreite. Wenn ein Programm "format=flowed" nicht beherrscht (oder deaktiviert hat), dann werden die Zeilen automatisch nach 72 Zeichen umbrochen.


    Durch den Befehl "Neu umbrechen" kann man natürlich einen Zeilenwechsel erzwingen.


    Die Anzeige im eigenen Mailprogramm hat dabei nichts zu tun mit der Anzeige beim Empfänger. Die Anzeige beim Empfänger hängt von dessen Einstellungen ab (und von seinem E-Mail-Programm).

  • Vielleicht häte ich mein Problem etwas genauer spezifizieren sollen.... :oops:
    Bei mir war der gequotete Text nicht umgebrochen, nicht der Schreibtext.
    Da tut man sich sehr schwer wenn man sehen will, was der Sender geschrieben hat (z.B. auf einzelne Punkte einzugehen).
    Der gequotete Bereich hat dabei das ">"-Zeichen vor jeder Zeile, ist gesamthaft in Blau und nicht umgebrochen!


    Mit der Umschaltung auf "in HTML verfassen" war das Problem schlagartig erledigt, habe jetzt die Quoting-Balken links u. rechts innerhalb des Fensters und der gequotete Text ist sauber umgebrochen. :D


    Gruß,


    Mausebär