Kopfzeilen Mailweiterleitung abschalten [Notlösung gefunden]

  • Hallo und schönen Nachmittag!


    Gibt es eine Möglichkeit, die sämtlichen Headerinfos in einer Mail, die ich weiterleite abzuschalten, also dass der Empfänger der weitergeleiteten Mail nur den Text bekommt und von wem die Mail weitergeleitet wurde und nicht sämtliche Referenzdaten etc?


    Es kann mitunter gerade für Braillezeilenleser recht mühsam sein, wenn man erst eine Bildschirmseite runterlesen muss, um zum eigentlichen Text der weitergeleiteten Nachricht zu kommen.
    Dass ich weder in der F.A.Q. noch im Forum dazu was gefunden habe, liegt vermutlich daran, dass meine Begabung im Färhten lesen nicht dem entspricht, was man eigentlich von einer Rothaut erwartet. *um gnade winsel*.
    Oder geht das überhaupt nicht?


    Nicht nur ich, sondern auch die Leute, denen ich Mails weiterleite, und die mit Braillezeile arbeiten, werden es Euch danken, wenn es dafür doch eine Lösung gibt.

  • Hallo Muzel!


    vielen Dank für Deine Antwort.
    Mailredirect habe ich installiert und verwende es auch in vielen Fällen, jedoch gibt es leider Situationen, wo eine Mail wirklich weitergeleitet werden muss und nicht umgeleitet werden darf, da ich als weiterleitender Absender aufscheinen muss. Ich kam wegen so einer Sache sogar mal schon in den Verdacht, dass ich Headerdaten gefälscht habe, weil ich eine Mail, anstatt sie weiterzuleiten, umgeleitet habe und natürlich der Originalabsender aufschien. das ist in manchen Fällen echt praktisch, und ich liebe dieses Add-On, aber manchmal muss eben die Mail wirklich weitergeleitet sein, um keinen falschen Eindruck zu erwecken. Und genau desalb kann ich auch "als neu bearbeiten" in solchen Fällen nicht verwenden.
    In the Bat hatte ich es so, dass ich als Absender aufschien, und da drunter dann wirklich nur stand: Das ist eine weitergeleitete Mail von Name Emailadresse
    und dann gleich Beginn Originaltext und wenn der zu ende war Ende Originaltext, und so in deer Art wäre es super, wenns da irgendwas gäbe.


    Die Kopfzeilen in der Ansicht stehen bei mir auf keine, die schalte ich wirklich nur dann bewusst ein, wenn ich diese Informationen benötige. Im Mailkörper der weiterzuleitenden Mail scheinen sie aber dennoch alle brav auf.
    Bleibt mir da wirklich nur mehr die gute alte Handarbeit, sie manuell rauszulöschen, ehe ich die Mail weiterleite, damit der Empfänger sich damit nicht herumschlagen muss? :-(
    Ich setze ja auch Quicktext pro ein, aber kenn mich nur sehr eingeschränkt damit aus, und Scriptschreiben kann ich überhaupt nicht, aber gäbe es da vielleicht u. U. die Möglichkeit eine Vorlage zu basteln, die die Headerdaten bis auf Originalname und E-Mailadresse aus dem Mailtext löscht?
    Unter den Variablen habe ich zumindest nichts gefunden, was für mich darauf schließen ließe, dass das funktionieren könnte :-(

  • Schönen Vormittag!


    Zuerst mal ein großes Sorry, weil ich hab vermutlich gepfuscht und wenn ich was mache, dann gründlich :-(
    Irgendwas muss ich wohl mißverstanden haben, denn ich dachte, wenn für eine Anfrage, die ich selber gestellt habe, eine Lösung aufgetaucht ist, wäre der Betreff im ersten Beitrag zu ändern. Das habe ich jetzt versucht, aber irgendwie klappte das nicht so wirklich :-( Ich dachte nämlich, da würde sich dann der Betreff im gesamten Thread ändern, und das ist - zumindest bis jetzt, nicht passiert, entweder meine Schlussfolgerung ist falsch oder ich hab was beim Ändern falsch gemacht oder beides :-(


    Aber nun zu meiner Notlösung für Mailweiterleitungen, wenn der Body nicht sämltiche Headerdaten enthalten soll, zugegeben, nicht optimal und ich freue mich, wenn wem was Besseres einfällt, aber immerhin, eine Lösung ists.
    Ich kopiere die Originalnachricht, die ich weiterleiten möchte, in die Zwischenablage. Dann gehe ich auf Mail weiterleiten im Kontextmenü. und lösche den gesamten Mailbody. Vorher habe ich mir mit Quicktextpro eine Vorlage gebastelt, die Absender, Datum und Betreff der Originalnachricht enthält, was sich mit der Variablen Orgheader wunderbar bewerkstelligen lässt, und dann füge ich nach dieser Vorlage den 'Text der Originalnachricht aus der Zwischenablage ein.
    Da sollten die Headerdaten wirklich als Weiterleitung aufscheinen und trotzdem muss der Empfänger nicht den gesamten Quellcode im Text überlesen, bis er zur eigentlichen Nachricht kommt.
    Umleiten ist deshalb auch in dem Fall nicht wirklich praktisch, weil - zumindest soweit ich festgestellt habe - man da nichts mehr zum Text hinzufügen kann, bei mir scheinen bei einer Umleitung nur die Adressfelder und der Betreff auf, ich komme aber nicht mehr in den eigentlichen Mailtext. Und meist ist es so, wenn ich eine Mail an jemanden weiterleite dann kriegt der auch eine Begründung, warum er diese Mail weitergeleitet bekam.
    Vielleicht hilfts ja jemandem.

  • Hi Rothaut,


    Du bist richtig vorgegangen, der Titel ändert sich nur im ersten Beitrag.
    Evtl. mit [ ] die Änderung deutlich machen

    Zitat

    Re: Kopfzeilen Mailweiterleitun abschalten [Notlösung gefnunden]

    ;)

  • Zitat von "rum"

    Hi Rothaut,


    Du bist richtig vorgegangen, der Titel ändert sich nur im ersten Beitrag.
    Evtl. mit [ ] die Änderung deutlich machen

    ;)


    Hallo rum!


    Vielen Dank für Deine Antwort und den Hinweis mit den Klammern, ich habe die jetzt im ersten Beitrag meines Threads dazugefühgt.

  • Hallo Rothaut!


    Ich weiß nicht, ob ich dein Anliegen richtig verstanden habe. Du möchtest, dass der Empfänger einer weitergeleiteten Mail möglichst wenige Kopfzeilen sieht, sie sollen in der Mail aber trotzdem vorhanden sein?


    Nun, der Umfang der Kopfzeilen im Mailbody wird beim eingebundenen Weiterleiten durch die Einstellung "Ansicht >> Kopfzeilen >> Normal" auf ein Minimum begrenzt. In diesem Fall erscheinen im Textteil lediglich die Header "Betreff:", "Datum:", "Von:" und "An:" der Originalmail. Sofern vom Erstversender benutzt, taucht auch noch "Antwort an:" auf. Das wären vier oder fünf Zeilen, die keine ganze Seite beanspruchen. Nur mit der Einstellung "Ansicht >> Kopfzeilen >> Alle" wird es wirklich umfangreich.


    Eine andere Möglichkeit wäre, eine Mail nicht eingebunden, sondern als Anhang weiterzuleiten ("Extras >> Verfassen >> Allgemein >> Nachrichten weiterleiten: Als Anhang"). Auch da kannst du eigenen Text mitzusenden, allerdings nicht innerhalb des Textes der Originalmail. Wenn man in TB für das Lesen einer solchen Mail "Ansicht >> Anhänge eingebunden anzeigen" deaktiviert, sieht man weder im Body der Weiterleitungsmail noch im Body der durch einen Doppelklick geöffneten anhängenden Originalmail irgendwelche Headerzeilen. Für komfortables Lesen muss also auch der Empfänger die richtigen Einstellungen vornehmen, soweit es sein Programm zulässt. Thunderbird macht's möglich. ;)


    Gruß, Sünndogskind_2

  • Guten Abend Sündogskind_2


    Zitat von "Sünndogskind_2"

    Hallo Rothaut!


    Ich weiß nicht, ob ich dein Anliegen richtig verstanden habe. Du möchtest, dass der Empfänger einer weitergeleiteten Mail möglichst wenige Kopfzeilen sieht, sie sollen in der Mail aber trotzdem vorhanden sein?


    Ja, genau, im Mailbody sollen so wenig wie möglich da sein, denn wenn es einer wirklich sehen will, kann er sich ja den Quelltext anzeigen lassen.


    Zitat

    Nun, der Umfang der Kopfzeilen im Mailbody wird beim eingebundenen Weiterleiten durch die Einstellung "Ansicht >> Kopfzeilen >> Normal" auf ein Minimum begrenzt. In diesem Fall erscheinen im Textteil lediglich die Header "Betreff:", "Datum:", "Von:" und "An:" der Originalmail. Sofern vom Erstversender benutzt, taucht auch noch "Antwort an:" auf. Das wären vier oder fünf Zeilen, die keine ganze Seite beanspruchen. Nur mit der Einstellung "Ansicht >> Kopfzeilen >> Alle" wird es wirklich umfangreich.


    Vielen Dank für diesen Hinweis, mit "Normal" trifft das ganz genau zu, was Du schreibst. Das Fatale an der Sache ist nur, warum ich drauf nicht gekommen bin, dass wenn die Ansicht auf "keine" steht, in der weitergeleiteten Mail im Body alle zu sehen sind. Ich verstehe nicht, wieso das so ist, aber ich habs grad ausprobiert, und 3mal nachgelesen, ob wirklich Keine und nicht alle aktiviert sind. Drum kam ich nicht drauf, dass bei "normal" weniger angezeigt werden, als bei "keine".
    Auf jeden Fall vielen herzlichen Dank für den Tipp.



    Zitat

    Eine andere Möglichkeit wäre, eine Mail nicht eingebunden, sondern als Anhang weiterzuleiten ("Extras >> Verfassen >> Allgemein >> Nachrichten weiterleiten: Als Anhang"). Auch da kannst du eigenen Text mitzusenden, allerdings nicht innerhalb des Textes der Originalmail


    Das geht leider nicht bei meinen Mailinglisten, da wir aus Sicherheitsgründen Anhänge gesperrt haben, also eine Mail an meine Listen nur eingebunden weitergeleitet werden kann.
    Trotzdem aber ein herzliches Danke.
    Weil mit den wenigen Kopfzeilen, die bei Ansicht "Normal" im Mailtext auftauchen, können sicher alle gut leben.
    Ein Rätsel wirds aber bleiben, warum "keine" mehr sind als "normal :-)


    So, und ich hab grad vorhin festgestellt, , dass in meinem ausgebesserten Betreff von heute Vormittag sich 2 Vertipper eingeschlichen haben, die ich erst jetzt bemerkt und korrigiert habe, na hoffentlich waren das jetzt wirklich alle :-)


    *duck und weg*.

  • Zitat von "Rothaut"


    Vielen Dank für diesen Hinweis, mit "Normal" trifft das ganz genau zu, was Du schreibst. Das Fatale an der Sache ist nur, warum ich drauf nicht gekommen bin, dass wenn die Ansicht auf "keine" steht, in der weitergeleiteten Mail im Body alle zu sehen sind. Ich verstehe nicht, wieso das so ist, aber ich habs grad ausprobiert, und 3mal nachgelesen, ob wirklich Keine und nicht alle aktiviert sind. Drum kam ich nicht drauf, dass bei "normal" weniger angezeigt werden, als bei "keine".


    Hallo Rothaut,


    bei mir finde ich unter > Ansicht > Kopfzeilen nur die Auswahl zwischen Alle und Normal.

  • Hallo Wolf!


    Ich hab das nicht erfunden, *großes rothautehrenwort*. Bei mir gibts Unter Ansicht im Kopfzeilenmenü
    folgende Einträge: alle, kurz, keine, normal, extended normalview und anpassen.
    Leider habe ich nur mein Wort als Beweis :-(

  • Andere Idee:


    Die Erweiterung QuoteAndComposeManager verspricht eine Option zum Löschen von Elementen im Header beim Weiterleiten. Das muss aber in den Einstellungen der Erweiterung aktiviert werden.


    Zitat:

    Zitat

    option to delete some elements from forward headers; By default all these options are not active, you must enable them from options panel, available from Tools --> Extensions --> QuoteAndComposeManager --> Options/Preferencer or with the shortkey CTRL-8.


    Ich habe die Erweiterung nicht, habe deshalb nicht getestet.

  • Hallo Wolf!
    Ja, Erweiterungen hatte ich auch schon in Verdacht, bei mir sind ca 25 Stück davon im Thunderbirdeinsatz. Aber ich denke, am ehesten könnte TB_Header_Tools_Extension_0.6.6.xpi diese Einträge hinzugefügt haben. Nur eben die Reaktion ist seltsam, dass eben ein aktiviertes "keine" bei Weiterleitungen mehr Kopfzeilen in den Text bringt, als ein aktiviertes "normal" - Verstehe eine(r) Computer :-(

  • Dieses "Keine" kommt ganz bestimmt von der Erweiterung "Mnenhy". Ich hatte die vor einiger Zeit auch mal getestet und habe dabei mit der Headerdarstellung dieselbe Erfahrung gemacht wie Rothaut. Schließlich fand ich die Erweiterung für mich überflüssig. Und klar, bei 25 Erweiterungen verliert man leicht den Überblick darüber welche was macht. Deswegen habe ich auch nur 24. ;)

  • Schönen guten Morgen miteinander!


    Sündogskind_2 Volltreffer!
    "Mnenhy". ist der böse Bube. Als ich das Ding deaktiviert hatte, waren auch nur mehr "normal" und "alle" als Eintrag im Kopfzeilenmenü vorhanden.
    Ich hatte "Mnenhy".mal installiert, ganz am Anfang, als ich den Vogel ganz kurz hatte und auch noch nicht im Forum mein Unwesen trieb. Ich habe irgendwo gelesen- glaube in einer Mailingliste - dass wenn "Mnenhy". zusammen mit Enigmail aktiv ist, die Funktion "nur dem Absender antworten" auch bei Mailinglisten funktionieren soll, allerdings geschafft hab ich das nie, denn beide Add-Ons sind für mich ein Buch mit nicht nur 7, sondern mindestens 4mal 7 Siegeln :-( Den Enigmail hatte ich bald wieder deaktiviert, weil der wollte immer was verschlüsseln, und da habe ich doch keine Ahnung, aber davon wie immer jede Menge :-)


    Mit "Mnenhy". konnte ich zwar auch nicht wirklich was anfangen, aber es hat mich nicht gestört, aber jetzt ists auch deaktiviert, also habe ich jetzt auch nur mehr 24 Add-Ons am Laufen :-)


    QuoteAndComposeManager habe ich ausprobiert, konnte aber keine Wirkung feststellen. Ich hatte das Kontrollkästchen, show only few headers in den Einstellungen, Registerkarte Forwording aktiviert, aber je nach Ansicht, wenn "alle" Kopfzeilen aktiviert war, kamen brav alle im Mailkörper der weiterzuleitenden Mail, wenn "normal" aktiviert war, kamen nur Betreff, Absender, Empfänger und Datum egal, ob das Kontrollkästchen im aktivierten 'Add-on, aktiv war oder nicht.


    Auf jeden Fall Euch allen ein großes Danke für Eure Hilfe und Eure Bemühungen.