Thunderbird hat ein Problem festgestellt und...

  • hallo,
    wiederholt ist bei mir folgendes Problem aufgetreten:


    Wenn ich Nachrichten aus dem Posteingang in Ordner verschiebe
    und/oder
    Nachrichten markiere und lösche


    kommt irgendwann die Meldung
    "Thunderbird hat ein Problem festgestellt und muss beendet werden"
    anschließend werde ich gefragt, ob ich einen Bericht senden will, kann mir eine endlose Datei anschauen - dann ist Schluss.
    starte ich Th. neu, dann tut es so, als ob nichts gewesen wäre...


    Soll ich das nächstemal auf "Bericht senden" klicken, damit jemand nachlesen kann, wo das Problem liegt?
    (WinXP-vers.5.1-SP2 - Thunderbird 2.0.0.9 mit 4 vd. Konten)


    Gruß aus Franken
    obi-48

  • Hallo,
    es schadet bestimmt nicht, aber dadurch wird dir auch nicht geholfen.
    Ich würde lieber den Ursachen deiner Abstürze auf den Grund gehen.


    Zunächst alle Ordner komprimieren und danach den Index der Ordner zurücksetzen.
    Also:
    Den Index der Ordner zurücksetzen:" Rechtsklick auf den Ordner, Eigenschaften, Index wiederherstellen".
    Sollte das nicht helfen,
    starte TB im safe-mode und untersuche das Verhalten.
    Hilft auch das nicht, erstelle ein neues Profil mit einem Konto kontrolliere das Verhalten dort.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich habe das alles mal genauer durchgespielt:
    Das Problem tritt NICHT auf beim Verschieben von Nachrichten in andere Ordner, außer der jeweilige Papierkorb ist beteiligt!


    Ordner komprimieren-Index wiederherstellen:= keine Änderung
    Menü: ALLE Ordner eines Kontos komprimieren und I. wiederherstellen


    --> hier tauchte plötzlich ein "Entwurf" wieder auf, der zwar immer als ungelesen markiert war, aber nie aufrufbar ?!
    --> gelöscht, vermutliches Ende meines Problems


    danke für die Tipps

  • Zu früh gefreut, nach meinem "Erfolgsbericht" von neulich :(


    Wenn ich genügend Nachrichten aus einem Posteingang in Ordner verschiebe und anschließend auf ein anderes Konto/ Posteingang wechsle, kommt wieder diese Meldung.
    Erneutes Komprimieren und Index-Wiederherstellen --> momentan läufts ohne Absturz, aber wie lange???
    was kann ich sonst noch tun - deinstallieren und wieder neu installieren???

  • Hi!


    Zitat von "obi-48"

    was kann ich sonst noch tun - deinstallieren und wieder neu installieren???


    Das wird sicher nichts bringen. Halte stattdessen deinen Virenscanner vom TB-Profilverzeichnis fern, indem du ihn richtig einstellst. Gute Anleitungen dazu gibt's auf Andreas Münzberg's Board - Virenscanner.


    Gruß, Sünndogskind_2

  • Zitat von "Sünndogskind_2"

    Hi!
    ... Halte stattdessen deinen Virenscanner vom TB-Profilverzeichnis fern, indem du ihn richtig einstellst. Gute Anleitungen dazu gibt's auf Andreas Münzberg's Board - Virenscanner.
    Gruß, Sünndogskind_2


    Tipp auch befolgt - übrigens sehr schön beschrieben! - bringt auch nichts!!!!


    Resümee:
    wenn ich angekommene und gelesene Nachrichten lösche, und anschließend auf ein weiteres Konto wechsele, steigt thunderbird aus.
    -- regelmäßig und ziemlich lästig!


    ich habe bisher folgende Tipps befolgt:
    - Alle Ordner eines Kontos komprimieren-Index wiederherstellen
    - Virenscanner (Avira Antivir) vom Profilverzeichnis und von den *.ini Dateien "fernhalten"


    Gibts sonst eine Möglichkeit, herauszukriegen, was da "abläuft"
    Ich wollte doch "nur" ein gutes und sicheres emailprogramm!

  • Führe den 2.Teil meines ersten Beitrages aus.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Führe den 2.Teil meines ersten Beitrages aus.
    Gruß


    well done - Thunderbird im Protected mode gestartet, ziemlich viel und lange alles ausprobiert, was sonst zum Absturz führen würde = Dateien verschieben bzw. löschen


    --> nichts ist passiert/ kein Absturz - alles so wie ich es gerne wollte...


    nächster Schritt ??
    (Tschuldigung dass ich so blöd frage, aber für mich ist winXP neu, hatte vorher langelange einen win98-PC, da kannte ich mich besser aus)

  • Hi obi


    "Safe Mode" (dein protected Mode) bedeutet, Thunderbird wird ohne alle Add-ons gestartet. Weil jetzt alles wieder richtig funktioniert bedeutet das, eine von dir installierte Erweiterung ist der Verursacher der Probleme.


    Ich würde jetzt alle Erweiterungen deaktivieren und dann eines nach dem anderen wieder "einschalten" und Thunderbird jedes mal neu starten. Wenn die Probleme wieder beginnen, hast du den Verursacher gefunden und kannst ihn endgültig deinstallieren.


    Ich weiss, etwas umständlich, aber leider nicht zu umgehen.


    Bruno

  • Zitat von "bme"

    Hi obi
    "Safe Mode" (dein protected Mode) bedeutet, Thunderbird wird ohne alle Add-ons gestartet. Weil jetzt alles wieder richtig funktioniert bedeutet das, eine von dir installierte Erweiterung ist der Verursacher der Probleme.
    Bruno


    ich werde es mal probieren, aber ich habe überhaupt nur 2 Erweiterungen installiert:
    - Talkback 2.0.0.9
    - AccountEx(de) 0.2.3 f. Ex-/Import der Kontoeinstellungen


    Ich habe momentan auch keine Netzwerke installiert (ausser DFÜ), die im safe-mode nicht gestartet würden, sodass TB dann besser funktionierte...


    Mir ist das alles sehr suspekt :rolleyes:

  • Hi und guten Tag,

    Zitat


    Mir ist das alles sehr suspekt

    und da Du erst relativ frisch den TB nutzt, würde ich ein neues Profil erstellen, oder mit mrbs Worten

    Zitat von "mrb"

    Führe den 2.Teil meines ersten Beitrages aus.
    Gruß

    , wobei jetzt der 3. Teil seines Beitrages drankommt,
    die Konten neu anlegen und die Mails importieren, dann hast Du vermutlich dauerhaft Ruhe.
    Ändere einfach den Namen Thunderbird in den Anwendungsdaten auf thunderbird_alt und beim nächsten Start wird TB ein neues Profil anlegen (Konten einrichten..)
    Der Profilordner?

    Zitat

    sieh mal hier: http://www.thunderbird-mail.de/lexicon/#Profile
    oder gib mal %appdata%\thunderbird entweder in Start/Ausführen oder im Windows Explorer (nicht Internet Explorer :wink: ) in die Adresszeile ein


    Achtung: bei direkter Suche dran denken, das der Anwendungsordner ein versteckter Ordner ist.
    Klar: erst TB beenden und immer bei Arbeiten im Profil: erst den Profilordner durch kopieren sichern...

  • Zitat von "rum"

    Hi und guten Tag,
    ...
    wobei jetzt der 3. Teil seines Beitrages drankommt,
    die Konten neu anlegen und die Mails importieren, dann hast Du vermutlich dauerhaft Ruhe.


    dein Wort "in Gottes Ohr" - aber es scheint wirklich zu klappen...
    bei mir hat sich alles etwas verzögert, weil ich am 12. meinen dsl-Anschluß bekam, und mich anderweitig ein wenig herumgeärgert habe :confused:


    also, ich hoffe das wars!!!
    (was denn eigentlich???)

  • Grüß Gott obi-48,

    Zitat von "obi-48"


    dein Wort "in Gottes Ohr" - aber es scheint wirklich zu klappen...

    das freut mich. Nun kannst du mit deinem neuen DSL ja rasant mit dem Donnervogel zu deinen Mails fliegen.

    Zitat


    also, ich hoffe das wars!!! (was denn eigentlich???)

    na ja, ob meine Worte wirklich gehört wurden..? Man könnte beim Thema bleibend sagen "die Wege des Herren sind unergründlich" ;)

  • Zitat von "rum"

    Grüß Gott obi-48,

    na ja, ob meine Worte wirklich gehört wurden..? Man könnte beim Thema bleibend sagen "die Wege des Herren sind unergründlich" ;)


    Tut mir leid, aber langsam habe ich den Eindruck, dass "da" was nicht stimmt!!
    Ich habe alles menschenmögliche getan - s.o.:
    - Antivir "ausgeschlossen" vom Scannen der TB-Anwendungsdaten sowie aller *.inis
    - Konten neu installiert
    - Ordner öfters komprimiert
    - heute auch nochmals im safe-mode gestartet


    ==> wenn ich irgendwelche Nachrichten egal von welchem Konto lösche, steigt TB aus!!
    ==> neu auch im safe-mode


    Ich habe auf einem Notebook TB ebenfalls installiert, mit allen Vorsichtsmassregeln
    ==> gleiches Phänomen!!!!!!


    WIR SIND NOCH NICHT FERTIG !!! :cool: :rolleyes:

  • hallooooo


    niemand antwortet - es ist echt ein Problem, weil nach jedem Löschen bzw. Verschieben in den Papuerkorb TB aussteigt


    Hilfeeee

  • Hi obi-48,


    ich kann deinen Frust sehr gut verstehen.
    Bitte verstehe auch, warum dir niemand antwortet: es hat niemand eine Lösung! Soll vorkommen.


    Alle sonst helfenden Lösungsansätze wurden genannt und ausgeführt.
    Fakt ist, dass der TB "normalerweise" recht stabil funktioniert. Darunter verstehe ich:
    - sauber konfigurierter Virenscanner (er ist der Verursacher der meisten Probleme! => zum Test deinstallieren)
    - sonstige "Sicherheitssoftware" (über deren Sinn man gut diskutieren kann ...)
    - eine zumutbare Größe der Mailordner
    - möglichst wenige bzw. nur die notwendigen Erweiterungen installiert
    - eine regelmäßige "Pflege" des Profiles (komprimieren, indizieren)
    - und natürlich keine Hardware- und sonstigen Betriebssystem-Problemen.


    Vielleicht sind meine Vorschläge etwas überspitzt, aber ich gehe den Sachen auch gern auf den Grund - und kann nicht ruhen, bis ich ein Problem gelöst habe.


    Ich würde jetzt (da alles andere schon versucht wurde) mit dem letzten Punkt beginnen. Systemlog auf maximale Geschwätzigkeit konfigurieren und regelmäßig beobachten. Nachdenken, ob sonstige ungewöhnliche Effekte auftreten, auch die, über welche man sonst einfach so hinweggeht. (Windowsuser sollen da ja sehr leidensfähig sein ... .)
    Auch würde ich mir die maximal mögliche Sicherheit verschaffen, dass das System frei von Schadcode ist. Wir wollen es nicht ausschließen. Also: eine Knoppicillin-DVD beschaffen und arbeiten lassen.
    Dann mal eine Nacht den "memtest86" laufen lassen. Sicher ist sicher.
    Ein voller scandisk-Lauf und eine Defragmentierung (nimm OO, wenn du hast ...) können auch nicht schaden.


    Den TB deinstallieren, Programmverzeichnis händisch löschen, Profil umbenennen, TB starten. Keine Erweiterungen und dafür ein Testprofil. Testen ... .
    (Aber das hast du ja schon gemacht ...)


    Frage zum Papierkorb:
    Du machst nicht etwa imap und nutzt den Papierkorb auf dem Server des Providers? Wir hatten schon einige Probleme bei derartigen Verschiebe- und Kopiervorgängen, zum Beispiel mit dem gesendet-Ordner.
    Versuche mal mit "Sofort entfernen"



    Ja, mehr fällt mir auch nicht ein. Und ich denke solche Maßnahmen wie "Regmon" und "Filemon" sind zwar möglich, aber imho an dieser Stelle overkill ... .


    viel Erfolg!


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • hallo Peter,



    erst mal zu diesen Punkten - letzteres kann ich als Ing. nur unterstreichen, deswegen bohre ich bei euch ja auch weiter!!


    also
    * ich bin der Meinung, dass der avira-antivir sauber konfiguriert ist - entsprechend A. Münzbergs Hilfe, ausserdem habe ich diesen Pseudovirus mal durchlaufen lassen - alles ok.


    * darüber hinaus benutze ich keine weitere "Sicherheitssoftware" - lediglich den Win-"pseudo"-firewall bzw. einen Standard-konfig.Firewall im (dsl-) Router


    * "zumutbare Größe der Mailordner" - Ich habe 3 Konten separat vom lokalen Ordner
    - wenn das die Anzahl der Nachrichten meint:
    ich lasse nie mehr als ca. 10 stehen - die wichtigen werden als Datei gespeichert, und dann alles gelöscht ==> hier passiert der Ausstieg!



    * Aktive Erweiterungen lediglich das "TalkBack", "MagicSLR", deaktiviert "AccountEx"


    * "eine regelmäßige "Pflege" des Profiles (komprimieren, indizieren)" - Komprimieren lasse ich regelmässig jeweils >Ordner eines Kontos< (leider erst NACH einem Absturz)


    - zum "Indizieren" habe ich eine Frage: das geht ja nur über >Eigenschaften eines Ordners< >Index wieder herstellen< ODER?
    - was bewirkt das eigentlich??


    * HW bzw. Betriebssystem-Probleme habe ich aktuell keine (holzklopf...), vor allem der LapTop ist ja (von einem Profi) frisch installiert...


    ciao erstmal - um das "dicke" Ende von deinen Tipps bemühe ich mich demnächst
    Günther

  • Hallo,

    Zitat

    zum "Indizieren" habe ich eine Frage: das geht ja nur über >Eigenschaften eines Ordners< >Index wieder herstellen< ODER?
    - was bewirkt das eigentlich??


    Prinzipiell das selbe wie das Löschen der Datei *.msf.
    Nach dem Löschen wird diese (nach Neustart von TB) wieder neu erstellt und eingelesen.
    Da diese Indexdatei nicht absolut fehlerfrei läuft, sollte man sie gelegentlich zurücksetzen.
    In ganz bestimmten Fällen muss man sie sogar löschen, weil das Zurücksetzen nicht "angeschlagen" hat.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Bei mir klappt das wiederherstellen der Index-datei nach dem Löschen der *.msf leider nicht
    Habe TB 1.5.0.14.
    Das war passiert:
    - beim Runterfahren von Windows Rechner zu früh spannungslos gemacht (evtl. einige TB files nicht vollständig gespeichert)
    - Beim Neustart war kein Profil, kein Konto, und keine Mails mehr da - TB war komplett jungfräulich
    - Inbox, Trash, Sent Dateien (die ohne Dateiendung) mit email- Inhalten waren noch da, ebenso die dazugehörigen *msf Dateien aber die Zuordnung scheinte nicht mehr zu klappen.
    - Habe darauf hin - wie empfohlen - die*.msf Dateien gelöscht und gehofft, dass sie beim TB-Neustart neu angelegt werden.
    - Aber selbst nach einer halben Stunde immer noch keine *msf Dateien neu angelegt.
    Hat jemand einen Tip wie ich die Mails in der Inbox (ca 750 Kb) wieder anzeigen kann ?

  • Hallo und willkommen im Forum.

    Zitat

    Beim Neustart war kein Profil, kein Konto, und keine Mails mehr da - TB war komplett jungfräulich


    Zitat

    Inbox, Trash, Sent Dateien (die ohne Dateiendung) mit email- Inhalten waren noch da,


    Also irgendwie sind deine Angaben widersprüchlich.
    Wenn die besagten Dateien da sind, muss auch ein Profil da sein.
    In deinem Fall wird also TB ein neues Profil angelegt haben.
    Es wäre auch denkbar , dass die prefs.js, beschädigt wurde und eine neue leere von TB erstellt wurde.
    Wie auch immer musst du jetzt ein Profil wieder neu aufbauen und mit den alten Ordnern und Adressbuch dort migrieren.
    Zuvor lies das:
    "Die Dateien im Profil kurz erklärt"
    "Das Profil-Verzeichnis finden"
    Falls aber evtl. mehrere prefs.js im Profil vorhanden sind, hilft auch diese Methode:
    http://www.thunderbird-mail.de…iewtopic.php?f=27&t=34665
    Ansonsten ein neues Profil einrichten.
    Wenn du Probleme mit dem Adressbuch hast oder weitere Fragen hast, frage ruhig nochmal hier nach oder starte eine Suche danach im Forum. Passiert einem das das erste Mal, steht man gewöhnlich erstmal auf den Schlauch.
    Für die Zukunft denke daran, regelmäßig deinen Profilordner zu sichern.
    Ich lasse das mit einem SyncTool automatisch machen. Habe ich wichtige Mails erhalten, wird sofort eine Zusatzsicherung gemacht auf eine externe Festplatte.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw