Verzögerung, TB "hakt" beim Schreiben

  • Seit einiger Zeit stottert mein TB (Version 2.0, Vista Home Premium 32bit)) beim Schreiben. Jedesmal, wenn das Programm während des Verfassens einer Mail beim Server auf neue Post überprüft, setzt das Schreiben aus. Ich tippe, aber nichts erscheint, und das Geschriebene erscheint dann auch nicht einfach später, so wie das gelegentlich passiert, wenn einfach nicht genug Arbeitspeicher vorhanden ist. Ich kann erst wieder schreiben, wenn die Überprüfung auf neue Mails abgeschlossen ist. Any suggestions?

  • Hallo,
    ein Neustart bringt dann auch keine Besserung?
    Um evtl. Ursachen zu erforschen, würde ich zunächst TB im safe-mode starten.
    Hilft das nicht, testweise ein neues Profil erstellen und das Verhalten von dort überprüfen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo nikofilm,


    hast Du ein oder gar mehrere Wörterbücher und die sofortprüfung am Laufen?
    Scannt ein Virenscanner?

  • Hallo zusammen,


    mir ging´s Anfang dieses Jahre genauso wie nikofilm:


    Beim Schreiben einer Email ging der thunderbird.exe-Prozess im Taskmanager in unregelmäßigen Abständen für ca. 10sec. auf 50% CPU-Last. Für diesen Zeitraum "stand" der Email-Editor. Andere Prozesse laufen parallel hierzu ohne Probleme. Da ich keine Lösung fand, erstellte ich ein komplett neues Profil und hatte bis vergangene Woche Ruhe.


    Seit Anfang der Woche habe ich nun wieder das Problem. Ein normales Arbeiten ist mit diesem Zustand nicht möglich. Die Aussetzer nerven ziemlich. Eine eindeutige Ursache kann ich nicht sehen. Das Verhalten ist unabhängig von zur Verwendung kommenden Virenscannern (AVG/Antivir) und unabhängig davon, ob eine Rechtschreibprüfung aktiviert ist oder nicht.


    Ich stehe für (fast) alle Schandtaten bereit, die dabei helfen die Ursache für dieses Haken zu beseitigen.


    Gruß
    rothy

  • rum ,

    Zitat

    hast Du ein oder gar mehrere Wörterbücher und die sofortprüfung am Laufen?


    Bei dieser Verzögerung kann ich überhaupt nicht schreiben, damit habe ich laufend zu tun.


    rothy ,

    Zitat

    Das Verhalten ist unabhängig von zur Verwendung kommenden Virenscannern (AVG/Antivir


    Du hast mehrere Virenscanner/Firewalls?
    Wie schaltest du sie denn ab?
    Machst du nach dem Abschalten einen Windows-Neustart?
    Du hast nicht das Abscannen des Profilordner ausgenommen?
    Wenn das geschieht, hast du mal die Prozesse kontrolliert (strg+alt+enf), die da gerade mit viel Speicherbelastung laufen?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hi,


    neben den beiden "Hauptverdächtigen" fällt mir nur noch das automatische Speichern, speziell auf einem IMAP-Server, ein.


    Ich würde also:


    1. die Indexdateien neu erstellen lassen
    2. den Virenwächter testweise komplett deaktivieren, dessen Start verhindern, Neustart
    3. alles, was mit Wörterbüchern und Rechtschreibung zu tun hat, deaktivieren
    4. die automatische Speicherung deaktivieren


    und dann testen ... .


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • "mrb" schrieb:

    Du hast mehrere Virenscanner/Firewalls?


    Nein, die Virenscanner habe ich nacheinander mit Blick auf Auswirkungen auf Thunderbird probiert.

    "mrb" schrieb:

    Wie schaltest du sie denn ab?


    Ich deaktive den Service. Hatte aber auch eine Deinstallation erfolglos probiert.

    "mrb" schrieb:

    Machst du nach dem Abschalten einen Windows-Neustart?


    Bei Deaktivierung des Services nicht. Bei Deinstallation schon.

    "mrb" schrieb:

    Du hast nicht das Abscannen des Profilordner ausgenommen?


    Ja, so läuft z. Zt. AVG.

    "mrb" schrieb:

    Wenn das geschieht, hast du mal die Prozesse kontrolliert (strg+alt+enf), die da gerade mit viel Speicherbelastung laufen?


    Ja, thunderbird.exe mit 50% CPU-Last (wie oben beschrieben), ansonsten ist alles mit 0-3% im "grünen Bereich".


    "Peter_Lehmann" schrieb:

    Hi, neben den beiden "Hauptverdächtigen" fällt mir nur noch das automatische Speichern, speziell auf einem IMAP-Server, ein.


    Das wäre eine Möglichkeit. Ich habe vier IMAP-Konten aktiv. Werde ich probieren.

    "Peter_Lehmann" schrieb:

    1. die Indexdateien neu erstellen lassen


    Wie mache ich das?

    "Peter_Lehmann" schrieb:

    2. den Virenwächter testweise komplett deaktivieren, dessen Start verhindern, Neustart


    Habe ich bereits mehrfach getan, aber ich probier´s nochmal.

    "Peter_Lehmann" schrieb:

    3. alles, was mit Wörterbüchern und Rechtschreibung zu tun hat, deaktivieren


    Ist bereits deaktiviert, ohne Erfolg.

    "Peter_Lehmann" schrieb:

    4. die automatische Speicherung deaktivieren


    Ist bereits deaktiviert, ohne Erfolg.


    Sobald ich neue Erkenntnisse gewonnen habe, werde ich mich hier melden.


    Gruß
    rothy

  • So, jetzt habe ich keinen Virenscanner mehr installiert.
    Neustart durchgeführt und die unter meinem Beitrag vom 2. Mär 2008, 22:44 aufgeführten Punkte erledigt.


    Thunderbird hakt immer noch. Am Verhalten hat sich überhaupt nichts geändert.
    Es muß irgendwas mit der thunderbird.exe selbst zu tun haben.
    Selbst während ich hier unter Firefox den Forumbeitrag schreibe und Thunderbird im Hintergrund läuft, ohne dass ich eine Email verfasse, steigt die CPU-Auslastung des thunderbird.exe-Prozesses im Taskmanager auf 50%.
    Übrigens: Sobald ich Thunderbird Offline schalte, bleibt die Last wesentlich länger bei 0-5% (ca. 4-5min.).
    Sobald ich wieder Online schalte, hakt Thunderbird ca. alle 30-40sec.


    Gruss
    rothy

  • Hallo,
    merkwürdig, mache folgendes:
    starte TB zunächst im safe-mode, hilft das nicht, erstelle ein neues Profil und probiere es von dort. Den Tipp hatte ich ja schon am Anfang gegeben.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • hallo mrb,


    safe mode bewirkt keine veränderungen am verhalten.


    mit einem neuen profil wird´s wahrscheinlich - wie beim letzten mal - funktionieren.
    ich möchte gerne herausfinden, woran es liegt.
    sonst ist die wahrscheinlichkeit ja hoch, dass ich alle 5-6 Monate ein neues Profil erstelle.


    gruß
    rothy

  • Starte doch mal das Verfassenfenster ohne das Hauptfenster:


    Start, Ausführen, thunderbird -compose
    Ok drücken.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • in diesem Editor-Fenster (thunderbird.exe -compose) hakt nichts. Alles super.
    ich habe auch den avg-virenscanner nochmal installiert. selbst mit dem, läß sich in dem Fenster problemlos und flüsig scheiben.


    Gruß
    rothy

  • Hallo,
    so habe mir mal den Thread noch einmal durchgesehen.
    Bitte lasse dir die Größe der Ordner anzeigen.
    Wie das geht, steht hier:
    3.2 Info-Spalten anzeigen lassen
    Und dann nenne mir die Größe aller Posteingangsordner.
    Du sagtest ja, in einem neuen Profil geht es. Mit der Zeit wird es wieder schlechter.
    Warum?Weil sich irgendetwas verändert.
    Was kann sich verändern? Die Größe der Ordner.
    Wie oft verkleinerst du und komprimierst diese?

    Zitat

    neben den beiden "Hauptverdächtigen" fällt mir nur noch das automatische Speichern, speziell auf einem IMAP-Server, ein.


    Wessen IMAP-Servers?
    Wie viele POP/IMAP-Konten hast du?
    Auf welcher Zahl steht die "maximale Zahl der gleichzeitig aufrecht erhaltenen Server-Verbindungen"?
    Gruß



    EDIT: Hi mrb, ich habe den versehentlich doppelten Beitrag gelöscht! Gruß rum

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:

    Und dann nenne mir die Größe aller Posteingangsordner. Wie viele POP/IMAP-Konten hast du?


    Ich habe 11 aktive Postfächer, davon 8 IMAP-Konten. Meisten haben bis zu 20MB. Drei 34, 68 und 110MB.

    Zitat

    Wie oft verkleinerst du und komprimierst diese?


    sporadisch, vielleicht einmal im Monat.

    Zitat

    Wessen IMAP-Servers?


    ist ein managed Server

    Zitat

    Auf welcher Zahl steht die "maximale Zahl der gleichzeitig aufrecht erhaltenen Server-Verbindungen"?
    Gruß

    Auf 5, sollte ich hier besser mal einen höheren Wert eintragen?


    Gruß

  • Hallo,
    leere alle POP-Posteingangsordner. Mails zum Aufbewahren haben das nichts zu suchen.
    Komprimiere nach dieser Aktion alle diese Ordner.

    Zitat

    ist ein managed Server


    Erkläre mir das näher.
    Auf diesem Gebiet kenne ich mich nicht aus.
    Könnte das die Ursache sein?

    Zitat

    Auf welcher Zahl steht die "maximale Zahl der gleichzeitig aufrecht erhaltenen Server-Verbindungen"?
    Auf 5, sollte ich hier besser mal einen höheren Wert eintragen?


    Nein eher auf 1oder 2 stellen. Gerade weil du relativ viele IMAP-Konten hast.
    Die Verbindungen addieren sich nämlich und es kamen deswegen bei mir Fehlermeldungen,
    dass die zulässige Anzahl überschritten war.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    ich habe jetzt alles, was mir einfiel ausprobiert und auch länger getestet.


    Die Größe oder Anzahl der POP3- oder auch IMAP-Konten haben auf das Verhalten anscheinend keinen Einfluß.
    Eine Änderung der maximalen Zahl der gleichzeitig aufrecht zu erhaltenen Server-Verbindungen hat ebenfalls keinen spürbaren Einfluß auf das Verhalten.


    Ich denke, es hängt irgendwie mit den Filtern (Junk und Emailverteilung in Ordner) zusammen.
    Zumindest habe ich jetzt mit einem Profil das Problem, dass die Filter, die ich definiere nicht mehr gespeichert werden.
    Die Ausführung der Junk-Filter benötigen eine "kleine" Ewigkeit.


    Ich habe zum Testen die ganze Geschichte einmal auf Vista-Mail umgestellt... da gibt´s kein Problem....
    ...ich will nicht auf MS umsteigen... :-( habe aber wirklich keine Idee mehr - und es nervt einfach total.


    Gruß
    rothy