Fehler beim automatischen Update auf TB 2.0.0.21

  • Heute wurde mir das automatische Update der neuen Version TB 2.0.0.21 angezeigt, bei der Installation
    erschien allerdings folgende Fehlermeldung, sodass das automatische Update nicht installiert werden konnte.


    Fehler oder Bug ?


    [IMG:http://img3.imagebanana.com/img/anwq6324/thumb/Thunderbird2.0.0.21.jpg]


    Wer weiß Rat ?

    Thunderbird-Version: TB 45.1.0
    Betriebssystem + Version: Windows 10 Home
    Kontenart (POP / IMAP): imap.gmx.net
    Postfachanbieter (z.B. GMX): gmx


    Gruß Spiderman. ;)

  • Hallo, (<- Begrüßung)


    Irgendwas greift bei dir auf die genannte Datei "MapiProxi.dll" zu und verhindert ein Löschen.


    Versuche und teste der Reihe nach:


    1. Prüfe zunächst im Taskmanager von Windows, ob thunderbird.exe selbst als Prozess aktiv ist > beenden.


    2. Hast du Logitech-Sachen installiert (Webcam?) > Beenden - auch im Task-Manager von Windows


    3. Versuche manuell die genannte Datei umzubenennen und danach neu upzudaten.


    4. Deinstalliere Thunderbird und installiere die neue Version. Dein Profil mit allen Einstellungen/Mails usw. bleibt unangetastet - jedoch kann ein Backup des Profilordners nicht schaden.

  • Bula,


    also da scheint es wirklich ein Problem zu geben, denn ich bekam gestern abend die Meldung des neuen Updates und habe mich "blöderweise" einmal dazu hinreißen lassen, dies sofort auszuführen.


    Ergebnis = ich kann Thunderbird nicht mehr nutzen ??????????? :cry: :aerger:


    Auch eine komplette Reinigung/Deinstallation mit Säuberung der Registry und und und, brachte kein Ergebnis.


    Wenn ich nun eine andere Version von Thunderbird installiere, also Vorgängerversion, bleibt es dabei, Thunderbird weigert sich, bei mir zu arbeiten.
    Auch habe ich das "alte" Profil nach Sicherung komplett gelöscht und dachte nun sollte es aber klappen, leider verkehrt gedacht.


    Direkt nach dem Update konnte ich Thunderbird nicht mehr starten, nach einem Neustart startet Thunderbird, allerdings nicht vollständig und friert ein "(keine Rückmeldung)
    Ich kann dann das Programm nicht schließen, auch nicht über den Taskmanager, alles was bleibt, ist Neustart.


    Nachdem ich nun so ziemlich alles versucht habe, hoffe ich auf etwas Hilfe hier im Board.


    Wo kann sich noch etwas verstecken, was selbst bei einer Neuinstallation den ordnungsgemäßen Ablauf von Thunderbird behindert.


    Hatte die letzte Version von Thunderbird laufen, verwende Win XP Pro SP 2


    Freue mich über etwas Hilfe


    Fijianer

  • "Fijianer" schrieb:

    Ergebnis = ich kann Thunderbird nicht mehr nutzen ??????????? :cry: :aerger:


    Hi, evtl. wurde das Update nicht vollständig durchgeführt.


    Gehe mal in dieses Verzeichnis deines Windows-Admin-Kontos:


    C:\Dokumente und Einstellungen\%deinBenutzername%\Lokale Einstellungen\Anwendungsdaten\Thunderbird\Mozilla Thunderbird


    Dort die Dateien "active-update.xml" und "updates.xml" sowie den Inhalt des Ordners "updates" löschen (nicht den Ordner selbst löschen).

  • Hi Allblue,


    habe gerade einmal alles überprüft, bzw. so gemacht wie Du geschrieben hast.


    Kein Erfolg, Thunderbird läßt sich nicht starten.


    Was mir aber im Taskmanager aufgefallen ist, es laufen Thunderbird Prozesse, einen davon kann ich nicht löschen.


    Immer wenn ich versuche Thunderbird zu starten, kommt ein Prozess hinzu, diese kann ich aber löschen, nur den, der ca. 7.000 k Speicherauslastung verursacht, bekomme ich nur durch Neustart gelöscht/beendet.


    Die anderen Prozesse liegen bei rund der Hälfte Speicherauslastung.


    Was kann mich nun noch hindern, Thunderbird wieder wie gewohnt Normal zu nutzen ?


    Wo kann noch etwas hängen, was den Vogel nicht fliegen läßt ??


    Bin solche Probleme eigentlich nicht gewohnt und ärgere mich mächtig darüber daß ich gestern diesem Update zugestimmt habe. Konnte aber wirklich nicht wissen, das es solche Probleme mit sich bringt und mir nun die komplette Nutzung von Thunderbird vermiesen will.


    So dann will ich mal auf weitere Hilfe und Ratschläge warten.


    Grüße aus dem Süden

  • Nach den Schritten oben und System-Neustart dann


    - mal in einem neuen Profil testen (-> Profilmanager benutzen, siehe Anleitung links)
    - evtl. nun nochmal sauber deinstallieren, neu herunterladen, neu installieren

  • Zusätzlich zu meinem genannten Problem muss ich noch hinzufügen, dass nach dem Versuch des Updaten mein Thunderbird nicht gestartet werden konnte.
    Es erschien ein Fenster, wo ich die thunderbird.exe suchen sollte.


    Im Task-Manager laufen eigenartigerweise zwei Thunderbird Prozesse; einer mit fast 6500 kb.


    Da der Thunderbird nicht mehr startete, habe ich ein Backup ( komplettes Backup von Acronis von C.:\ ) zurückgespielt und arbeite nun wieder mit TB 2.0.0.19.


    Allerdings möchte ich eine Lösung gerne wissen, damit ich später gefahrlos auf die neue Version 2.0.0.21 updaten kann. :)

    Thunderbird-Version: TB 45.1.0
    Betriebssystem + Version: Windows 10 Home
    Kontenart (POP / IMAP): imap.gmx.net
    Postfachanbieter (z.B. GMX): gmx


    Gruß Spiderman. ;)

  • Solange du deinen Profilordner/Profilverzeichnis (Das Profil-Verzeichnis finden) immer als Backup hast, kann nichts passieren. Zudem kannst du normalerweise gefahrlos Thunderbird deinstallieren/neuinstallieren ohne dass deinen Mails/Einstellungen usw. etwas passiert. Das Profil wird nicht angetastet.


    Was ist aus meinen zwei Vorschlägen oben geworden?

  • Bula,


    es scheint wirklich so als wenn Spiderman & ich das gleiche Problem haben, denn wie nun geschrieben, startet sein Vogel auch nicht. Und auch sind bei ihm mehrere Prozesse am Laufen.


    Ich habe nun leider nicht gerade ein komplettes Backup für diesen Fall vorliegen, allerdings selbst nach einem "kompletten" Säubern des PC's läßt sich Thunderbird nicht wieder installieren.


    Deshalb meine Frage, wo kann da noch etwas hängen, was dem Donner-Vogel das freie Fliegen verwehrt.


    Ich habe ein Backup meines Profils vorliegen, danach, wie oben gesagt den kompletten PC von allem was irgendwie in Programmen, Registry usw. nach Thunderbird aussah, gesäubert, allerdings scheint es so, als wenn da noch irgendwo in einer Ecke etwas ist, denn es läßt sich selbst mit einer Neuinstallation nichts erreichen.


    Irgendeine Idee ??


    So ein Problem hatte ich noch mit keiner Version von Thunderbird oder mit einem Update.


    Gut das ich nicht alleine mit diesem Problem bin, würde sonst ein wenig an mir zweifeln.

  • Heute wurde mir das automatische Update der neuen Version TB 2.0.0.21 angezeigt, bei der Installation
    erschien allerdings folgende Fehlermeldung, sodass das automatische Update nicht installiert werden konnte.


    Dieser Fehler von "Spiderman" erschien gestern auch bei mir.
    Deinstallation der alten Version scheiterte an "mozMapi32.dll", die nicht zu löschen war.
    Eine Neuinstallation der Vers. 2.0.0.21 ins alte Verzeichnis scheiterte daran, dass diese schöne "mozMapi32.dll" nicht überschrieben werden konnte.
    Habe dann das alte Verzeichnis bis auf die Datei "mozMapi32.dll" gelöscht und die neueVersion daneben installiert.
    Frage: wie kann man dieser schönen "mozMapi32.dll" evtl. endgültig den garaus machen ?


    Betriebssystem ist Windows XP, aktuelle Version.

  • Hallo Graba,


    ich bin nun ein wenig irritiert, denn so wie ich die verschiedensten Meldungen hier im Board beurteile scheint es wohl jede Menge Probleme mit diesem letzten Update zu geben.


    Ich selber benutze Firefox und auch Thunderbird seit es diese gibt und habe auch die entsprechenden Vorgängerversionen benutzt.


    Bis zu diesem Update, welches ich idiotischerweise habe installieren lassen, lief bei mir alles ohne Probleme.


    Ich würde bitten, eventuell auch einmal die vorherigen Beiträge hier im Thread zu beantworten, denn ich hänge nun wirklich und weiß nicht mehr weiter.


    Möchte aber auch nicht so ohne weiteres Thunderbird den Rücken kehren, weil ich ja, wie schon gesagt eigentlich zufrieden bin/war.


    Wie ist es zu verstehen, wenn ich nach einer kompletten Säuberung meines PC's, alles was irgendwie mit Thunderbird zu tun hat sollte beseitigt sein, die folgenden Probleme habe:


    1. Thunderbird wird installiert, in genau dem Weg den TB vorschlägt.
    2. Nach Abschluß der Installation möchte ich TB starten
    3. Es läuft die "Eieruhr" eine kurze Zeit, aber dann passiert weiter nichts.
    4. Wenn ich auf den Taskmanager gehe, sehe ich einen Thunderbird Prozess mit ca. 7000 k
    5. Nach nochmaligem Versuch TB zu starten kommt ein neuer Prozess mit ungefähr der Hälte an k hinzu
    6. Diesen Prozess kann ich löschen, aber der erste Prozess ist nicht löschbar, ich muß dann den PC neustarten
    7 Auch ein Start im abgesicheten Modus bringt NICHTS.


    :help: :help: :help: :help:


    Warum läuft ein Prozess, aber kein Fenster von Thunderbird wird angezeigt.


    Da ich einige Mails unter TB habe, die ich benötige und auch gerne bearbeiten würde, freue ich mich, wenn es irgendwie etwas Hilfe geben könnte, von Leuten die etwas tiefer in der Materie stecken.


    Ist auf jedem Fall in meinen Augen nicht sehr hilfreich, wenn mit einem automatischen Update solche Probleme auftreten.


    Ich habe Win XP SP 2, Norton Internet Security 2009, keine Logitech Software inst. eigentlich ist alles so, wie es vor dem Update war, nur mein Donnervogel ist abgestürzt. :cry: :aerger:


    Vielleicht noch interessant, ich bekomme keine Fehlermeldungen irgendeiner Art.


    Grüße aus dem Süden

  • Hallo, offensichtlich haben einige User ein Problem, aber die große Mehrheit wohl nicht. Es werden auch mehrere DInge hier vermischt, das Problem mit der Datei "mozMapi32.dll" , Prozessproblem (evtl damit zusammenhängend) und verlorene/nicht sichtbare Mails (das letzte sollter nichts mit den anderen Problemen zu tun haben, eine Suche im Forum sollte hier hoffentlich helfen, die Mails zu importieren - wenn nicht, vielleicht bitte nochmal in einem anderen Thread melden).


    Dies hier könnte ein Hinweis zur Lösung des ersten Problemes sein:

    "pgs" schrieb:

    Habe dann das alte Verzeichnis bis auf die Datei "mozMapi32.dll" gelöscht und die neueVersion daneben installiert.
    Frage: wie kann man dieser schönen "mozMapi32.dll" evtl. endgültig den garaus machen ?


    Bisher hat keiner berichtet, ob er geprüft hat, ob die Datei als schreibgeschützt markiert ist.


    Zudem könnte es hilfreich sein, Thunderbird mal nicht direkt zu starten, sondern mit dem Profilmanager und ein neues sauberes Profil zu erstellen. Möglicherweise geht das ja.

  • Hi Allblue,


    also ich habe meinen Rechner komplett gesäubert, wie ich meine, alles an Resten von Thunderbird runtergeschmissen, das alte Profil auf einem externen Laufwerk gesichert.


    Vielleicht kannst Du mir mal sagen, wo ich überall noch suchen kann, soll, muß um wirkllich alles clear zu haben. :)


    Das Problem trat auf, als ich beim Auftauchen des Updatesfensters gesagt habe, OK updaten.
    Nach der Installation sollte ja eigentlich dann Thunderbird mit der neuen Version starten.


    Dies geschah nicht, sehr ungewöhnlich, denn wie schon gesagt, es ict nicht das erste Mal, das ich mit Thunderbird arbeite.


    Als alles an Versuchen nicht half, habe ich erst einmal im Taskmanager geschaut und gesehen, daß ein Prozess von Thunderbird aktiv ist.
    Allerdings keinerlei Fenster auf dem Screen, was kann das sein ?


    Ok habe mir dann gedacht irgend etwas ist wohl beim Update schiefgelaufen, habe mir also hier von der Seite die neue Version gezogen und drüber installiert. Normalerweise hatte ich damit noch nie Probleme.


    Aber diesmal ............... nichts.


    Also Profil gesichert, dann komplett deinstalliert, gesäubert und auch in der Registry alles, was irgendwie auf Thunderbird hinweisen könnte, gelöscht.
    Dann habe ich es erst einmal mit der neuen Version von Thunderbird, also der Version 2.0.0.21 versucht, also eine komplette Neuinstallation ans Laufen zu bringen.
    Wieder nichts, gleicher Effekt wie vorher.


    Dann also wieder alles gesäubert und die alte Version, die ich hier vorliegen habe installiert, allerdings mit gleichem Ergebnis :cry:


    Thunderbird startet zwar nach der Installation, also ich habe Ja gesagt, nachdem die Installation abgeschlossen war und starten lassen, aber das Ergebnis ist: Ich haben keine Chance momentan mit Thunderbird zu arbeiten :cry: :aerger:


    Selbst im abgesicherten Modus passiert nichts.


    Du kannst sicher verstehen, daß ich etwas angefressen bin, denn mein System lief eigentlich recht rund und ohne Probleme und nun habe ich schon 24 Stunden "verschwendet"


    Irgendeine Idee, wie ich das Problem lösen kann ?


    Grüße aus dem Süden

  • Ich möchte zu meinem Problem noch hinzufügen, dass auch ich keine Logitech Cam o.ä. installiert habe.


    Mittlerweile habe ich ein komplettes Backup von C:\ wieder zurückgespielt, da mein TB auch nicht startete.


    Nun warte ich auf die neue, vllt. überarbeitete Version des "Donnervogels", denn auch ich möchte mich nicht von diesem Programm trennen. Daher behalte ich momentan die alte Version 2.0.0.19; die läuft wenigstens fehlerfrei. :zustimm:

    Thunderbird-Version: TB 45.1.0
    Betriebssystem + Version: Windows 10 Home
    Kontenart (POP / IMAP): imap.gmx.net
    Postfachanbieter (z.B. GMX): gmx


    Gruß Spiderman. ;)

  • Hmm, nach vollem "säubern" des Rechners mit anschl. neuem Herunterladen von offizieller Quelle, kann ja eigentlich sowas nicht passieren.


    Wenn tatsächlich nichts mehr auf dem Rechner ist, muss ja auch z.B. die vorletzte Version laufen.


    Zu einer vollen sauberenDeinstallation gehört:


    1. Deinstallation über Systemsteuerung > Software
    2. Löschen des Ordners "Thunderbird" in C:\Dokumente und Einstellungen\%Benutzername%\Anwendungsdaten\
    (Das Profil ist dann natürlich weg!)
    3. Löschen des Ordners "Thunderbird" in C:\Dokumente und Einstellungen\%Benutzername%\Lokale Einstellungen\Anwendungsdaten\ (Nicht mit Punkt 2 verwechseln!)
    4. Löschen des Ordners "Mozilla Thunderbird" in C:\Programme\


    Registry macht eigentlich keine Probleme.

  • Hallo und guten Tag,


    Fijianer

    Zitat

    Ich habe Win XP SP 2, Norton Internet Security 2009, keine Logitech Software inst. eigentlich ist alles so, wie es vor dem Update war, nur mein Donnervogel ist abgestürzt

    aber nur eigentlich und ich nehme an, deine Firewall NIS ist da anderer Meinung.
    Wenn du alles rund um TB entfernt hast und dann TB neu installiert und gestartet hast, sich aber weiterhin nichts tut, kann es m.E. nur daran liegen. TB 2.0.0.19 war von NIS freigegeben und wurde durch Update geändert => Blockade, TB wird nun mit jeder Version geblockt, solange es eine thunderbird.exe ist, jegliche Änderung, egal ob zurück zur alten Version oder wie auch immer, ist ja schließlich wieder eine Änderung und den Status davor merkt sich NIS nicht, auch nicht den, der ehemals freigegebenen.


    Fazit: aus den Regeln alles mit TB entfernen und neu erkennen lassen.

  • Bula aus Fiji,


    rum
    Also das mit der Firewall kann eigentlich nicht sein, denn normalerweise würde NIS ja nicht verhindern, daß das Programm startet, sondern "nur" den Zugriff auf das Netz.
    Bei mir ist es aber so, daß zwar Prozesse von Thunderbird laufen, aber keinerlei Anzeige, also das "normale" Thunderbird-Fenster mit allen Mailkonten gezeigt wird.


    Ich habe aber nun auch in der Zwischenzeit, weil ich gerade ein wenig mit Arbeit eingedeckt bin, ein etwas älteres Backup aufgespielt und meine Daten mühsam :cry: per Hand in diese Insatllation eingespielt.
    War zwar etwas mühsam, aber Ihr werdet es nicht glauben, nun ließ sich auch die neue Version von Thunderbird ohne Probleme installieren.


    Also ich möchte wirklich mal wissen, was da beim Update passiert ist, das Gute ist ja, daß ich nicht der Einzige bin dem so etwas passiert ist.


    In Zukunft wird vor jedem Update irgendeines Programms erst einmal ein Abbild gezogen, dann bin ich auf der sicheren Seite, Acronis sei Dank. Damit wird die Datensicherung wirklich zum Kinderspiel und auch die Wiederherstellung.


    Grüße aus der Südsee

  • Hallo, Leute !


    Ich wollte mich hier im Forum noch mal informieren, ob der von mir genannte Fehler in einem Update schon behoben ist.
    Denn ich werde vom "Donnervogel" fast täglich gefragt, ob ich auf Version TB 2.0.0.21 updaten möchte.
    Natürlich mache ich das nicht, denn ich möchte mir die Arbeit des Backup-Zurückspielen ersparen. :zustimm:


    Auch erstaunt es mich sehr, dass es auf Grund der zahlreichen Fehlermeldungen noch nicht gelungen ist, eine neue Version seitens der Entwickler zu erstellen. Ich bin zwar nicht so fit in diesen Dingen, aber bei Mozilla Firefox klappt das immer zügig. ;)


    Fazit: Ich werde erst auf die nächste Version updaten, wenn diese fehlerfrei läuft. Das kann ja im Sinne aller Anwender und Entwickler sein, oder ? :hallo:

    Thunderbird-Version: TB 45.1.0
    Betriebssystem + Version: Windows 10 Home
    Kontenart (POP / IMAP): imap.gmx.net
    Postfachanbieter (z.B. GMX): gmx


    Gruß Spiderman. ;)

  • Hallo Spiderman,


    also ich würde es einmal versuchen, nicht mit dem Update sondern mit einer "vollständigen" Programminstallation.


    Denn ich hatte ja das gleiche Problem, daß mir beim Update irgend etwas zerschossen wurde.


    Habe dann ein etwas älteres Backup aufgespielt, meine Daten mühsam :cry: :aerger: von Hand restauriert und danach klappte dann auch die "neue" Installation von Thunderbird 2.0.0.21 ohne Probleme.


    ;) Zieh Dir aber vorher bitte wieder ein Image, ist einfacher, wenn es nicht funktionieren sollte ;)


    Grüße aus dem Süden