Umlaute bei BCC (immer noch) falsch

  • Hallo allerseits,


    ich bin nicht sicher, ob das hier das richtige Unterforum ist, aber hier es geht ja um Addressierung.


    Wie ihr in der Signatur seht, komme ich vom alten Mozilla und dort gab es bereits das gleiche Problem. Folgender link

    Code
    1. mailto:Süß<suess@web.de>?cc=Süßer<suesser@web.de>&bcc=Süßest<suessest@web.de>


    führt zu folgendem Ergebnis:


    AN: Süß <suess@web.de>
    CC: Süßer <suesser@web.de>
    BCC: S%C3%BC%C3%9Fest <suessest@web.de>


    Ist dieser Bug wirklich nicht behoben? Oder kann man ihn irgendwie umgehen? Wohlgemerkt: Umlaute und Sonderzeichen machen nur im BCC-Teil Ärger, bei to: und cc: nicht!


    Nachtrag: die Signatur wird leider nicht angezeigt, daher auf diesem Wege:
    WinXP: vorher Mozilla 1.7.6 von 2005, jetzt Thunderbird 2.0.0.23 und Firefox 3.5.2


    Edit: Da es kein spezielles Adressbuch-Problem zu sein scheint, habe ich deinen Thread verschoben. Mod. graba

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Hallo und Willkommen im Forum.


    Bei wem tritt denn der Fehler auf? Beim Empfänger des Bcc sicher nicht, weil dieser seine Mailadresse gar nicht sieht.
    Erkläre mal genau, wo (Webseite, Word) dieser Link bei dir steht, den du ausführst, damit ich das nachvollziehen kann. Auch interessiert mich wie du den Link ins Bcc-Feld bringst, normalerweise wird er ins AN-Feld platziert.
    TB macht den Fehler nicht, wenn man die Bcc-Adresse aus dem Adressbuch einfügen lässt oder direkt eintippt. Das habe ich überprüft.
    Noch etwas: unter Extras, Einstellungen, Verfassen, Allgemein, ist dort das zweite Kästchen von oben angehakt?
    Schlingo hat übrigens Recht. Trotz allem technischen Fortschritt sollte man auf Umlaute im Header (also Mailadresse und Betreff) verzichten. Falls dich die Problematik interessiert, hier ein paar Links:


    http://www.zid.tuwien.ac.at/zidline/zl04/umlaute.html
    http://einklich.net/usenet/techrules.htm#umlaute
    http://www.rhusmann.de/kuerzel/kuer20j2.htm


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat

    Bei wem tritt denn der Fehler auf? Beim Empfänger des Bcc sicher nicht, weil dieser seine Mailadresse gar nicht sieht.

    Na, bei mir, dem Versender!

    Zitat

    Erkläre mal genau, wo (Webseite, Word) dieser Link bei dir steht, den du ausführst, damit ich das nachvollziehen kann.

    Den ganzen Ausdruck kannst Du direkt mit "Start -> Ausführen" eingeben oder er kann so auf einer Webseite stehen (mit <a href="mailto:usw">mail senden</a> oder Du machst einen Rechtsklick auf Deinen Desktop und legst eine neue Verknüpfung an, die genau diesen mailto:-Ausdruck als Befehlszeile enthält. Starte die Verknüpfung und Dein Mailprogramm (hoffentlich Thunderbird) geht mit einem Verfassen-Fenster auf. Die Adressen sind dann, wie in meiner Erstnachricht steht, entsprechend dargestellt.

    Zitat

    Auch interessiert mich wie du den Link ins Bcc-Feld bringst, normalerweise wird er ins AN-Feld platziert.

    Ich verstehe Deine Frage nicht: alles hinter mailto: betrifft das An-feld, alles nach cc= und bcc= halt die entsprechend anderen Teile einer neuen mail. Es gibt natürlich auch noch subject= und body= (siehe http://de.selfhtml.org/html/verweise/email.htm)


    Hintergrund: ich muss, ähnlich einem newsletter, immer wieder mal mails an etwa 200 bis 300 Empfänger versenden und diese Adressen sind gegeneinander durch die Verwendung von BCC geschützt. Die Adressen werden aus einer Excel-Tabelle jedesmal frisch ermittelt, daher geht auch keine Lösung per Liste direkt in Thunderbird. TB wird programmgesteuert aufgerufen und der ganze mailto:-Ausdruck auf der Kommandozeile übergeben, so wie dies das Betriebssystem auch machen würde.


    Alles ist bestens mit Umlauten bei allen Teilen dieses Aufrufes, nur bei der Interpretation des BCC-Teiles mach TB halt Mist! :-(

    Zitat

    TB macht den Fehler nicht, wenn man die Bcc-Adresse aus dem Adressbuch einfügen lässt oder direkt eintippt.

    Absolut richtig, daher ist mein workaround auch so, daß mein Programm die ganze mail als mailto:-Ausdruck zusammenstellt, also mit allem, was nötig ist incl. Betreff (subject=) und Mailtext (body=). Bevor ich TB starte, lade ich alle Adressen für den BCC-Teil Komma-separiert ins Clipboard. Sobald das Verfassenfenster auf ist, gehe ich ins Adressfeld, wechsele auf BCC und füge die Adressen vom Clipboard ein. Nach dem Return braucht TB einen Moment (bei 250 Adressen ist das halt so) und dann ist alles so, wie es sein soll. Das ist halt umständlich und es ist halt ein Bug in der mozilla-engine, der schon immer drin ist!

    Zitat

    Noch etwas: unter Extras, Einstellungen, Verfassen, Allgemein, ist dort das zweite Kästchen von oben angehakt?

    Nein, habe ich nicht an, ändert aber nichts hinsichtlich dieses Problems.

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Hallo,
    lange Rede kurzer Sinn:
    der Fehler tritt auch bei mir auf.
    TB kodiert im Bcc-Feld falsch. Dort müsste mit "quoted printable" kodiert werden, was nicht geschieht.
    "quoted printable" erkennt man im Quelltext (strg+U) an den "?Q?" Zeichen im Betreff und in den anderen Header-Zeilen..
    Meine Vermutung: das ist ein Bug.
    Versuche mal, ihn bei Bugzilla zu finden: https://bugzilla.mozilla.org/
    Ansonsten: dort melden.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat

    der Fehler tritt auch bei mir auf.

    Ja klar, er tritt schon immer bei jedem WIN-User unter allen WIN-Versionen auf. Ob das auch auf anderen BS-Plattformen so ist, weiß ich nicht, vielleicht kann es ja mal ein Linux-User probieren:


    Einfach mal folgende HTML-Datei erstellen

    Code
    1. <HTML><HEAD><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1"></HEAD>
    2. <BODY>
    3. <A HREF="mailto:Süß<suess@web.de>?cc=Süßer<suesser@web.de>&bcc=Süßest<suessest@web.de>&subject=Betreffzeile mit äöü und ß&body=Nachrichtentext mit äöü %0dund ß in zweiter Zeile">Umlaut-Mail</a>
    4. </BODY></HTML>


    Datei aufrufen, link Umlaut-Mail anklicken und Ergebnis mitteilen!

    Zitat

    Meine Vermutung: das ist ein Bug.

    Vermutung trifft es nicht wirklich, es ist ein Bug!

    Zitat

    Versuche mal, ihn bei Bugzilla zu finden

    Habe ich, aber ich steige dort nicht durch, wie ich nach 'BCC' und 'umlauts' suchen soll. Und es gibt wohl verschiedene Sucheingabefelder, die bei gleicher Eingabe trotzdem verschiedene Ergebnisse bringen. :gruebel:

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Hallo,
    ich bin mit der Zeit vorsichtig geworden mit der Behauptung, es handele sich um einen Bug. Es ist zu verlockend, dieses spontan anzunehmen.


    Je mehr ich mich mit deinem Problem beschäftige, komme ich nämlich zu dem Ergebnis, dass TB dabei unschuldig ist.
    Warum?
    Ich habe abwechseln Outlook Express und Windows Live MAil zum Standard gemacht und was war das erstaunliche Ergebnis?
    Beide mache es noch schlechter.
    beide schreiben nicht mal das An-feld korrekt.
    Dort steht:
    Süß<suess@web.de>
    Süßer<suesser@web.de>
    Süßest<suessest@web.de


    Auch im Betreff und im Body sind in allen Mailklienten die Umlaute falsch.
    Bsp.:
    Betreff: Betreffzeile mit дць und я


    Nachrichtentext: Nachrichtentext mit дць und Ñ in zweiter Zeile.


    TB schreibt immerhin "nur":


    Nachrichtentext mit дць
    und я in zweiter Zeile


    Jetzt verstehst du vielleicht, warum man mit Umlauten vorsichtig sein muss.
    Es gibt nämlich keinen Standard für HTML in Mails. Das ist seit Jahrzehnten bekannt und hat sich bis heute nicht geändert.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat

    TB schreibt immerhin "nur":


    Nachrichtentext mit дць
    und я in zweiter Zeile

    Äh, das verstehe ich nicht, denn bei mir, Konstellation siehe Signatur, ist auch das alles korrekt!! Wieso bei Dir nicht?


    Zitat

    Es gibt nämlich keinen Standard für HTML in Mails

    Wir sind nicht "in mails". Wir wollen einem Programm namens "Thunderbird" eine Kommandozeile "mailto:blabla" übergeben. Das ganze in einer HTML-Datei mit einem link zu tun, ist eine Variante, aber ich hatte auch noch andere angegeben, z. B. die Eingabe in der Startleiste über Ausführen.... Dann ist der Browser bereits außen vor.Oder Du gibst den ganzen Parameter eingequoutet in der Eingabeaufforderung ein, das Mailprogramm natürlich vorangestellt:


    Code
    1. C:\Programme\TB\thunderbird.exe "mailto:Süß<suess@web.de>?cc=Süßer<suesser@web.de>&bcc=Süßest<suessest@web.de>&subject=Betreffzeile mit äöü und ß&body=Nachrichtentext mit äöü %0dund ß in zweiter Zeile"


    Ach ja, vielleicht hilft es ja bei Outlook und Konsorten, die Umlaute und das ß im HTML-Beispiel (und nur dort!) umzuformen:


    Ä %C4 ä %E4
    Ö %D6 ö %F6
    Ü %DC ü %FC
    ß %DF


    Bei mir ändern diese Codes allerdings nix. Alles stimmt trotzdem immer noch, nur der BCC-Teil ist immer noch falsch!

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Zitat

    Wir wollen einem Programm namens "Thunderbird" eine Kommandozeile "mailto:blabla" übergeben.


    Ich habe nicht den Browser als Schuldigen genannt, sondern das Betriebssystem.
    Vergiss nicht, dass bei jedem Übergang die Zeichenkodierungen eine Rolle spielen. Da muss oft konvertiert, kodiert werden. Auch gibt es ANSI und Ascii, Unicode u.a.. In vergangener Zeit gab es sogar erhebliche Probleme mit der Zwischenablage wegen des Zeichensatzes, da lief überhaupt nichts mehr mit Umlauten. Noch heute gibt es Probleme mit Umlauten in Anhängen.
    Da ich kein Experte bin und die genauen Ursache dieses Desasters nicht kenne, kann ich leider hier nicht weiterhelfen.
    Konsequenz so leid es mit tut: Keine Umlaute im Header!
    Solltest du aber einen Weg finden, dein Problem zu lösen, lasse es mich bitte wissen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Da Du keinerlei Infos über Dein BS bzw. TB gemacht hast, würde mich das Ergebnis meiner Rückfrage trotzdem interessieren: Bei mir und den meisten WIN-Usern geht außer dem BCC-Teil nichts schief, bei Dir aber offensichtlich doch der Mailtext! Woran liegt das?


    Hast Du das jetzt mal mit der Kommandozeile nachvollzogen? Hast Du wenigstens mal ein Sonderzeichen in der HTML-Datei umkodiert und geschaut, ob sich etwas bei Outlook verändert/verbessert? (Ich habe kein Outlook und hatte es nie!)


    Zitat

    Da ich kein Experte bin und die genauen Ursache dieses Desasters nicht kenne, kann ich leider hier nicht weiterhelfen.

    Naja, es ist eigentlich ganz einfach: in der Mozilla-engine hat man einfach vergessen, bei der Übergabe der Kommandozeile auch den BCC-Teil zu parsen - that's it! Alle anderen Teile werden ja von TB korrekt erkannt und gewandelt!

    Zitat

    Vergiss nicht, dass bei jedem Übergang die Zeichenkodierungen eine Rolle spielen. Da muss oft konvertiert, kodiert werden.

    Ja, stimmt ja alles, aber hier geht es nicht darum, daß alle Sonderzeichen schiefgehen, sondern nur die im BCC-Teil. Also macht TB eigentlich (fast) alles richtig!

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Also, das ist ja wirklich interessant!


    Mein Werkzeug: WinXP Pro Version 2002 SP3 + Thunderbird 2.0.0.23


    Ich habe folgende Zeile benutzt:

    Code
    1. "*Programmpfad*\thunderbird.exe" -compose "to=Süß<suess@example.com>,cc=Süßer<suesser@example.com>,bcc=Süßest<suessest@example.com>,subject=Test umlaute üßöä,body=mein üßöä Nachrichtentext"


    Diese Zeile habe ich als *.bat gespeichert und ausgeführt:
    Ergebnis:

    Code
    1. An: S³¯ <suess@example.com>
    2. CC: S³¯er <suesser@example.com>
    3. BCC: S³¯est <suessest@example.com>
    4. Betreff: Test umlaute ³¯÷õ
    5. Body: mein ³¯÷õ Nachrichtentext

    Das ist - so glaube ich - auch nicht verwunderlich, da es dem DOS-Zeichensatz entspricht (bin mir allerdings nicht sicher).


    Dann habe ich diese Zeile in "Start" -> "Ausführen" kopiert + "Enter" (In Notepad geschrieben und mit der Zwischenablage gearbeitet),
    Ergebnis:

    Code
    1. An: Süß <suess@example.com>
    2. CC: Süßer <suesser@example.com>
    3. BCC: Süßest <suessest@example.com>
    4. Betreff: Test umlaute üßöä
    5. Body: mein üßöä Nachrichtentext


    Ich kann mit VBA in Verbindung mit Excel gut umgehen, daher würde mich deine jetzige Lösung interessieren, und ich kann dir helfen, sie zu verbessern . Vielleicht erreichen wir ja ein zufriedenstellendes Ergebnis (bei Interesse VBA-Code + "problematische Adressen" posten!). Bitte gib dann auch deine Excelversion an.


    Grüße, Ulrich

  • Zitat

    Also, das ist ja wirklich interessant!

    Absolut, denn: mit "-compose" in Thunderbird oder Mozilla zu arbeiten, kam mir noch nie in den Sinn, weil ich diese Syntax der Kommandozeile für eine Mailerstellung bis zu Deiner mail nicht kannte - vielen Dank für diesen Hinweis!


    Da der Teil von Thunderbird, der "-compose" bearbeitet, andere korrekte Routinen zum parsen benutzt, als der für "-mailto:", funktioniert es damit! "-compose" gab es bereits bei Mozilla und ich wußte es nicht! :wall:

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Hallo,


    na das ist ja erfreulich, dass is dann doch noch klappt. "compose" habe ich übrigens im Wiki hier gefunden.


    Hier noch ein VBA-Schnipsel, der zwar sehr viele Variablen verwendet, doch für viele Anfänger relativ gut zu lesen ist.
    Klar, dass du da noch einige Schleifen benötigen wirst...


    Grüße, Ulrich

  • Danke für das listing, losgehts, ich habe das gleich mal gestest und bin nun doch etwas ernüchtert. Ein paar Sachen für Dich zum Knacken: :cry:


    Betrifft den body-Teil. Versuche doch mal, folgenden Nachrichtentext herzustellen:

    Code
    1. Name: Hans Wurst
    2. Telefon: 0815-4711
    3. Fax: 0815/4712
    4. Wir müssen es schaffen / sicherstellen, daß der Text am Leben bleibt! Und wie bekommen wir 'einfache' und "doppelte" Anführungszeichen rein?


    Hier geht es um folgende Dinge:


    - Einrückung durch Leerzeichen gehen verloren (s. Tel. und Fax)
    - newlines?
    - Anführungszeichen?
    - Komma im Text
    - bei " / " wird der Textscan abgebrochen


    Bei mir gibt es da mit der compose-Methode Probleme, bei mailto: nicht!

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Hallo BeZehZeh,


    ohne deinen VBA-Code kann ich nicht viel sagen.


    Zunächst möchte ich darauf hinweisen, dass ich die Vermutung habe, dass du html-Mails verschicken willst. Das kann ich nicht empfehlen, bzw. da bin ich auch der absolut falsche Ansprechpartner, da ich mich mit html nicht auskenne.


    • Einrückung durch Leerzeichen gehen verloren (s. Tel. und Fax) => Wenn eine html-Mail erstellt wird, werden die Leerzeichen "geschluckt". Wenn in TB als Voreinstellung ReinText eingestellt ist, klappt das mit den Leerzeichen.
      Für html-Mails: Leerzeichen durch "&nbsp;" ersetzen. -> das hilft auch nur bedingt, und schafft noch keine schöne Tabelle. Denn wenn der Mailclient nicht jedem Buchstaben die selbe Breite einräumt, dann hat man wieder keine "saubere Kannte".
      html + "feste Breite" wird von TB zwar gut angezeigt, aber wie sieht's beim Empfänger aus?! -> wäre für mich keine Option!
    • newlines? => vbNewLine oder alternativ Chr(13) klappen bei mir bei der Übergabe hervorragend. Evtl. gibts es Alternativen. Für html-Mails nur vbNewline verwenden.
    • Anführungszeichen? -> habe durch ausprobieren herausgefunden, dass sie doppelt eingesetzt werden müssen.
      Also im Code entweder: """" (innerhalb des Strings) oder & Chr(34) & Chr(34) & . siehe Beispiel
    • Komma im Text: ich sehe da keine Probleme. Aber vielleicht hast du übersehen, dass ich die einzelnen Strings in Hochkommas gepackt habe?
    • bei " / " wird der Textscan abgebrochen: ich weiß nicht, was du mit "Scan" meinst? Bei mir tritt das Phänomen nicht auf.


    Dein Beispiel:


    Poste doch einfach deinen relevanten Codeteil.
    Und was hast du unter "Extras" -> "Konten" -> "Verfassen & Addr" -> "Nachrichten im Html-Format verfassen" eingestellt?



    Grüße, Ulrich


    [edit: Falls das nicht eindeutig gewesen sein sollte: der Code ist für ReinText-Nachrichten gedacht![/edit]

  • Zitat

    Zunächst möchte ich darauf hinweisen, dass ich die Vermutung habe, dass du html-Mails verschicken willst.

    Nein, auch nur pleintext und ist auch so eingestellt. Deshalb war ich ja so verwundert, daß die Einrückungen nicht funktionierten! Es lag daran, daß ich den kompletten Parameter nach -compose nicht in doublequotes setzte. Denn einen Einzelparameter wie body='Nachrichtentext hier weiter' in singlequotes zu setzen, reicht dem BS nicht als Quote aus und es reduziert alle Leerzeichen darin auf eines! Das BS erkennt singlequotes nicht als quote an. Dadurch ging auch das mit / schief, denn das wurde von thunderbird oder dem BS wohl als /parameter interpretiert wie bei /help und bei mir war daher bei dem / die mail zu Ende.


    Nun aber zu Deinen und meinen Tests. Das größte Problem stellt natürlich die Darstellung der hier notwendigen drei Trenner Komma, singequote und doublequote dar. Bei den Anführungszeichen nehme ich mal bewußt die englische Ausdrucksweise, denn die ist griffiger und eindeutiger. Versuche mal folgendes Ergebnis im body-Teil zu erreichen:


    Code
    1. 'singlequotes' sind eigentlich kein Problem!
    2. Aber 'singlequotes', vor allem vor einem Komma, schon!


    Damit singlequotes auch als Inhaltszeichen verwendet werden können, sucht thunderbird hier das Ende eines Parameters vermutlich mit dem string ', zu finden, denn sowas funktioniert ja: "body='Mittendrin sind 'singlequotes' ja erlaubt',subject='Betreff'". Das gleiche Spiel haben wir dann bei den doublequotes mit Leerzeichen dran. Da muss man viel probieren, bis man da eine allgemeingültige Lösung hat.


    Bin gespannt auf Deine Versuche

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Hallo,


    das ist ein Problem, zu dem ich keine gute Lösung parat habe.


    Zwei Ideen:
    1. Wie wäre es diesen Fall zu auszuschließen, indem man zwischen die singlequotes mit anschließendem Komma noch ein Leerzeichen setzt:

    Code
    1. strBody = Replace(strBody, "',", "' ,")

    Das sieht natürlich bescheiden aus, ist mir schon klar.




    2.Eine andere (programmiertechnisch äußerst unschöne Alternative) wäre, den Befehl SendKeys zu benutzen:

    Code
    1. '...
    2. Call Shell(strShell, vbNormalFocus)
    3. If InStr(strBody, "',") > 0 Then
    4. Application.Wait (Now() + TimeValue("00:00:02")) '2sec warten -> evtl. nicht nötig
    5. Application.SendKeys ("^{END}") 'Ende der E-Mail anspringen
    6. For i = InStr(strBody, "',") To Len(strBody)
    7. Application.SendKeys (Mid(strBody, i, 1)) 'jeden Buchstaben einzeln
    8. Next
    9. End If


    Achtung, der Code kann nicht sinnvoll aus der VBA-Entwicklungsumgebung aufgerufen werden, dazu bitte Excel benutzen.
    Diese Vorgehensweise kann ich nicht wirklich empfehlen, da es sehr fehleranfällig ist. Wenn eine Signatur von Thunderbird eingesetzt wird, geht das sowiso schief.


    Ich bin - was das betrifft - mit meinem Latein am Ende und würde dir empfehlen, diese Frage in einem VBA-Forum zu stellen z.B. office-loesung.de. Dort treiben sich Menschen rum, die sich teilweise sehr viel besser auskennen, als ich.
    Ein anderes, weniger bekanntes aber dafür mit sehr viel Kompetenz besetztes Forum ist das von Peter auf online-excel.de.
    Falls du eine Lösung findest, würde ich mich über eine kleine Info auch freuen.


    Tut mir leid, dass ich dir wahrscheinlich nicht wirklich weiterhelfen kann.
    Grüße, Ulrich

  • Zitat

    Ich bin - was das betrifft - mit meinem Latein am Ende und würde dir empfehlen, diese Frage in einem VBA-Forum zu stellen

    Nein, denn wir (beide) haben kein Problem mit der programmtechnischen Umsetzung, sondern mit dem Aussehen und dem korrekten Inhalt des Parameters schlechthin, der Thunderbird übergeben werden muss. Wie der dann übergeben wird, ist erstmal egal!


    Ich hoffte natürlich, daß hier auch ein paar Entwickler von TB mitlesen und in den Code reinschauen könnten, wie man Quotezeichen ausmaskiert. Üblicherweise hat man ja, wie z. B. in javascript auch, ein Zeichen wie den \, mit dem Sonderzeichen eingegeben werden können. Aber wie lautet dieses Zeichen beim TB-Parameter -compose?


    Und dass man aus ', dann ein ' , macht, ist eher schlecht. Da mache ich lieber aus allen singlequotes im body-Teil doublequotes und beschäftige mich nur mit den dann auftretenden doublequotes-Problemen.


    Hast Du da mal was gestestet?


    Im übrigen: während ich hier in diesem thread so schreibe, hallt es ganz gewaltig, denn ich glaube, wir sind mittlerweise alleine hier! :pale:

    Thunderbird 17.x
    WinXP
    POP3 und IMAP
    diverse Provider (z.B. GMX)

  • Hallo,

    "BeZehZeh" schrieb:


    Ich hoffte natürlich, daß hier auch ein paar Entwickler von TB mitlesen und in den Code reinschauen könnten, wie man Quotezeichen ausmaskiert.


    das ist sehr unwahrscheinlich. Da müsste man sich schon eher hier http://forums.mozillazine.org/viewforum.php?f=50 "austoben".

    Zitat


    Im übrigen: während ich hier in diesem thread so schreibe, hallt es ganz gewaltig, denn ich glaube, wir sind mittlerweise alleine hier! :pale:


    Ihr seid hier nie alleine. Abgesehen von "Wolfgang" werdet ihr auch von uns beobachtet, nein gelesen. :mrgreen:

  • Hallo ihr beiden,


    ich habe in den Syntax_Rules nachgeschaut, doch über das Problem wird keine Aussage gemacht.


    Schön zu wissen, dass man nicht alleine ist :-) , doch glaube ich nicht so recht an eine Lösung hier. Vielleicht versuchst du es einmal im von Graba verlinkten Forum...
    Falls du eine Lösung finden solltest, wäre ich über einen Post hier dankbar.


    Viel Erfolg noch!
    Ulrich