[✔] TB 3.0.0 und div. Kaspersky-Progr. vertragen sich nicht

  • EDIT:
    Die Problematik ist mit der Version Thunderbird 3.0.1 behoben worden, siehe Thunderbird 3.0.1 veröffentlicht


    Mod. rum
    Sorry & Danke, Amsterdammer, für das jetzt mal vorausgesetzte Verständnis, dass ich den Beitrag editiere!




    Kurz nach dem Release von Thunderbird 3 ist bekannt geworden, daß Thunderbird 3 und bestimmte Kaspersky Programme mit einander inkompatibel sind. Wer Thunderbird 2 und ein Kapersky Programm nutzt, welches das globale Add-On "Kaspersky Anti-Spam" installiert hat, sollte nicht auf Thunderbird 3 upgraden, da Thunderbird 3 in diesem Fall mit einer weißen Benutzeroberfläche erscheint, auf der man nichts sieht.


    Hintergrund:
    Kaspersky installiert auf Thunderbird 2 ein globales Add-On (Kaspersky Anti Spam). Globale Add-ons sind Erweiterungen, die von anderen Programmen ungefragt in Thunderbird (oder Firefox) installiert werden und sich meistens nicht deinstallieren lassen. Es sind in diesem Fall die Dateien klthbplg.dll und IKLAntiSpam.xpt.


    Abhilfen
    (wer bereit auf Thunderbird 3 umgestiegen ist), alles bei geschlossenem Thunderbird:


    entweder
    1. Deinstalliere Thunderbird
    2. Lösche verbliebene Ordner und Dateien aus dem Programmverzeichnis.
    3. Spiele Dein Backup des Profilordners von Thunderbird 2.0.0.23 zurück.
    4. Installiere Thunderbird 2.0.0.23


    oder
    1. ...
    2. ...
    3. Installiere Thunderbird angepasst in einem anderen Verzeichnis als "Thunderbird", z.B. in "Thunderbird 3" (das Du selber anmachen musst).


    oder
    1. Suche und lösche die Dateien klthbplg.dll und IKLAntiSpam.xpt im Programmverzeichnis
    2. Starte TB 3 im Safe Mode
    3. Versuche das abgegraute Add-On "Kaspersky Anti Spam" zu deinstallieren
    4. Schliesse Thunderbird 3 und starte erneut im normalen Mode.

    Allen, die Pech gehabt haben, viel Erfolg bei der Reparatur. Die o.g. Abhilfen sind von mir aus verschiedenen englischsprachigen Quellen übersetzt, aber nicht getestet, da ich kein Kaspersky-Programm nutze.


    Der Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=533692

    9 Mal editiert, zuletzt von Amsterdammer ()

  • Interessant, ich habe absolut kein Problem mit TB3 und Kaspersky.



    Was ich aber unter TB2 öfters hatte waren Probleme beim Updaten.


    Die Lösung ist hier in den Foren aber auch zu finden. Kaspersky deaktivieren, Update durchführen und schon gehts wieder.



    Frage mich allerdings auch wieso die zwei sich nicht vertragen.

  • Komisch, wollte gerade updaten und habe den Hinweis noch entdeckt.


    Habe daraufhin bei mir in Thunderbird unter "Extras"->"AddOns" nachgeschaut. Fazit so ein Addon steht da bei mir überhaupt nicht
    drin.Werden diese nicht angezeigt??


    Nutze noch Kaspersky Internet Security 2009.
    Vielleicht liegt das auch nur an der 2010 Version von Kaspersky!?


    Gruss
    muecke

  • Nicht jedes Kaspersky Programm macht das,
    und: erst muss Thunderbird auf dem Rechner sein, dann Kaspersky installiert werden; umgekehrt (erst Kaspersky, dann TB installieren) passiert gar nichts

  • Zitat

    Thunderbird 3.0 und Kaspersky vertragen sich nicht!


    Man sollte das präzisieren, Irrtümer sind sonst vorprogrammiert :!:


    TB3 und KIS vertragen sich nicht, denn nur in KIS gibt es das Antispam-Modul und somit das entsprechende TB-AddOn .
    Ich nutze dagegen KAV 2010 ( 9.0.0.736), damit gibt es mit TB3 keinerlei Probleme.

    *TB 45.0 / Theme: Standard (leider!)

  • "waterbird" schrieb:


    Man sollte das präzisieren, Irrtümer sind sonst vorprogrammiert :!:
    TB3 und KIS vertragen sich nicht, denn nur in KIS gibt es das Antispam-Modul und somit das entsprechende TB-AddOn .
    Ich nutze dagegen KAV 2010 ( 9.0.0.736), damit gibt es mit TB3 keinerlei Probleme.


    Ich habe das bewusst allgemein formuliert, da z.Zt. noch nicht exakt (!) deutlich ist, welche der vielen Versionen von Kaspersky dies nun verursacht und welche nicht,

  • Gute Idee, wollte ich vorhin auch darum bitten, im Kasperksy-Forum wurde das schon bemängelt dass man den Thread erst suchen muss. :zustimm:


    @ Amsterdammer:

    Zitat

    welche der vielen Versionen von Kaspersky dies nun verursacht und welche nicht,


    Auf jeden Fall kann man KAV ausklammern, wie ich schon schrieb: in KAV gibt es das Antispam-Modul samt TB-Addon nicht.

    *TB 45.0 / Theme: Standard (leider!)

  • Kann jemand mal hier auflisten, welche Versionen von Kaspersky das globale Add-On "Kaspersky Anti-Spam" in Thunderbird installiert? Dann kann ich die Warnung im Wiki präzisieren.

  • Wer kein Problem mit Kaspersky hat, Glückwunsch, ich hatte....
    So funktioniert es:
    TB3 downloaden
    Internetverbindung kappen
    Kaspersky (oder anden Virusscanner - InternetSecuritySuite) abschalten - anscheinend kann übrigens auch Norton Probleme verursachen
    TB3 Benutzerdefiniert installieren
    Speicherpfad, bzw. Ordnernamen ändern (bei mir von "Thunderbird" zu "Thunderbird 3.0" im selben Verzeichnis
    fertig installieren.
    Bei der Nachfrage "online gehen?" Kaspersky o.ä. wieder einschalten und online gehen
    alle Ordner vorhanden!
    Gruss


    und dann hatte ich noch ein Problem mit nicht funktionierendem Adressbuch in Thunderbird3:
    addon "MoreFunctionForAddressbook 0.5.6.1" deaktivieren und alles ist gut (bei mir)
    Zumindest bis TB4
    ;-)


    und am Wochenende versuche ich einen IMAP Konto bei 1und1 anzulegen.
    Wenn ich meinen PC nicht hätte, was würd ich nur mit meiner ganzen Freizeit machen? :D

  • merci leute,
    bin dem link im 1.Post gefolgt und habe die Dateien klthbplg.dll und IKLAntiSpam.xpt im Thunderbird-Ordner gelöscht.


    Danach Thunderbird einfach deinstalliert und wieder neuinstalliert und siehe da, alles geht :D:D


    Jetzt zeigt Thunderbird auch im Addon-Manager an, dass das Plugin deaktiert wurde und nicht mit Thunderbird 3 kompatibel ist. Genial ;);)


    Zur Info:
    Habe KIS 2010 9.0.0.736 (aktuellste Version)
    und bin von der letzt aktuellsten Thunderbird 2er-Version auf die 3-er umgestiegen...


    Wie gesagt, dass Problem gibt es sicherlich nur in Kombo mit Kaspersky Internet Security.


    Mein Tipp:
    Kaspersky Internet Security neuinstallieren bzw. reparieren und die Komponente "Anti-Spam" nicht installieren lassen.
    Danach kann man getrost den Umstieg wagen, da das Modul weg ist...
    Jedoch einfaches deaktierten in Kaspersky selber von dem Modul Anti-Spam geht nicht, es muss schon komplett deinstalliert werden..


    Danke nochmal allen :):)

  • "lavo" schrieb:

    Wie gesagt, dass Problem gibt es sicherlich nur in Kombo mit Kaspersky Internet Security.


    Wie oft denn noch ? :gruebel:
    Das Antispam-AddOn wird nur von KIS 2010 in TB installiert- in KAV( Kaspersky Antivirus) gibt es kein AntiSpam :!:


    @ Amsterdammer:

    Zitat

    Kann jemand mal hier auflisten, welche Versionen von Kaspersky das globale Add-On "Kaspersky Anti-Spam" in Thunderbird installiert?


    Alle 2010er KIS-Versionen ! [ 9.0.0.463 / 9.0.0.736 ]
    P.S. vor .463 gab es auch noch 1 Version, ist mir leider entfallen.

    *TB 45.0 / Theme: Standard (leider!)

  • Es liegt nicht an Kaspersky, sondern an einem noch zu behebenden Programmfehler von Thunderbird 3.0.


    Ich konnte Thunderbird 3.0 als update von Thunderbird 2.0.0.23 von wie folgt installieren - ohne Fehler:


    Ich habe folgenden Weg gewählt:


    Das Programm Thunderbird 3.0 von einem anderem PC aus mit Hilfe der kostenlosen Fernsteuersoftware "Teamviewer" oder über Netztwerk installieren; jedoch in einem anderem Verzeichnis als dem ursprünglichen, z.B. C:\Programme\Mozilla Thunderbird 3.0.
    Anschließend alten Ordner C:\Programme\Mozilla Thunderbird (in dem thunderbird 2.0 installiert war) löschen.


    So hat es geklappt, nach langem rumprobieren.


    Probleme mit winfax konnte ich so auch schon mal unter windows XP SP3 lösen.

  • Hallo und willkommen im Forum :)

    "jokling" schrieb:

    Es liegt nicht an Kaspersky, sondern an einem noch zu behebenden Programmfehler von Thunderbird 3.0..


    Das sehen die Entwickler von Kasperky aber anders

    Zitat

    Apparently, according to the in built Update Wizard, the Anti Spam Add On that is part of Build 736 is not currently compatible with Thunderbird 3, which has just been released by Mozilla. The wizard states that as part of the upgrade process the KIS add on (plus a couple of others that I use) will be disabled and not re-enabled until Thunderbird detects that the is a newer compatible version).


    Quelle

  • Zu meinem Beitrag vom 13. Dez 2009, 14:15 möchte ich folgendes ergänzen:


    Einfach thunderbird von 2.0 auf 3.0 updaten, thunderbird 3.0 aber in einem anderen Ordner installieren (z.B. C:\Programme\Mozilla Thunderbird 3.0), dann den alten Ordner C:\Programme\Mozilla Thunderbird\ löschen. Die Installation von einem anderen PC aus über "Teamviewer" oder Netzwerk ist nicht notwendig!


    So hat die Intsallation auf all meinen PC's funktioniert - trotz Kaspersky internet security.


    Alle E-mail Ordner sind wieder sichtbar, und thunderbird 3.0 funktioniert perfekt.

  • Danke für diesen Hinweis, genau das Problem hatte ich auf einem von bisher drei PCs auf denen ich TB 3.0 installiert habe, überall auf denen ist Kaspersky Internet Security 2010 mit allen aktuellen Updates installiert. Bei zwei gings problemlos, der dritte gerade eben machte die bewschriebenen Probleme. Ich habe aber als das Problem auftauchte, wieder TB 2.0 installiert, und da war alles wieder da. Nach obiger Beschreibung habe ich eben die beiden Dateien umbenannt, so dass sie nicht mehr geladen werden, habe dann das Kaspersky Antispam-Modul in TB 2.0 deaktiviert, und anschließend TB 3.0 installiert. Jetzt ist alles in Butter, danke für den Tipp. Jetzt habe ich die Tage noch den vierten PC zum Updaten.

  • Hi !


    Wollte mich mal erkundigen, ob es zum Lösen des oben genannten Problems, Aktivitäten gibt oder nicht ?


    Edit: Ich habe deinen Beitrag hierhin überführt, da es nicht sinnvoll ist, zu deiner Frage einen eigenen Thread zu eröffnen. Mod. graba

  • "Mod. graba" schrieb:

    Edit: Ich habe deinen Beitrag hierhin überführt, da es nicht sinnvoll ist, zu deiner Frage einen eigenen Thread zu eröffnen. Mod. graba


    hi
    geht ok, wenn die frage beantwortet wird :mrgreen:

  • Hallo, nun hatte ich heute den dritten PC mit diesem Problem. Hier aber konnte ich das Problem nicht durch Löschen der beiden Dateien lösen, denn ich habe sie nicht im Thunderbird-Programmverzeichnis finden können! Ich habe solche Dateien nur im Kaspersky-Verzeichnis finden können, dort kann man sie aber nicht löschen. Mir blieb dort nichts anderes übrig, als auf 2.0.0.23 zurück zu gehen, und das Update zu unterbinden.