Endlos Indizierung

  • Hallo alle,


    bin die Tage auf TB 3.1 umgestiegen. Nun hab ich das Problem, dass TB meine Mails laufend indiziert. In allen möglichen Ordnern.
    Hab alle Postfächer, 7 an der Zahl, einzeln (also nicht diese neue Gesammtansicht) mit ca 25-30.000 Mails (nein, löschen bzw wegschieben ist nicht möglich).


    Durch die ganze Indizierung hängt der ganze Rechner immer wieder für paar Sekunden. Hab jetzt schon die Indizierung ausgeschalten, hoff dass hierdurch nur die Suche etwas länger braucht. Aber ganz Sinn kann das ja nicht machen, dass er immer wieder alle Mails neu indiziert oder?


    Grüßle
    Grim

  • guten Morgen und willkommen im thunderbirdforum!


    Naja 30.000 Mails, da sollte zumindest das Profil regelmäßig gesichert sein.
    Ich weiß eigentlich nur von einem Freund, der nach dem Umstieg auch ungefähr die Menge an Mails hatte, und der Vogel einen Tag und eine Nacht mal indiziert hat, seitdem aber brav startet und nichts mehr dergleichen tut.
    Bei mir indiziert der Vogel immer nur die Mails, dieneu kommen, nachdem die 1. Indizierung abgeschlossen war.

  • Huhu,


    die erste Indizierung hat er auch gemacht, war knapp 6 Stunden damit beschäftigt. Nur macht er das immer und immer und immer wieder :(
    Vorallem hab ich teilweise keine Ahnung, welche Ordner der grade indiziert, weil die Anzahl die er in der Statusleiste anzeigt , mit keinem Ordner übereinstimmt.

  • selbe hier.
    TB indiziert endlos jenseits der tatsächlichen MailMenge , während die % stets 99%-100% anzeigt.


    Dazu vorher die Meldung:
    Die Sicherheitskomponenten der Anwendung konnten nicht initialisiert werden. Der wahrscheinlichste Grund dafür sind Probleme mit Dateien im Profilverzeichnis der Anwendung. Bitte überprüfen Sie, ob das Verzeichnis keine Lese- oder Schreibbeschränkungen hat und Ihre Festplatte nicht voll oder fast voll ist.
    -usw.


    Problem besteht seit Rechner und TB (3.0.1) neu installiert wurde und mit neuem Benutzer auf altes Profil verwiesen (profiles.ini angepasst). Lädt auch die alte Profil-Dateistruktur, aber nun endlos Indizierung und kein Zugriff/öffen von Ordnern. Indizierung stopp nur per Programm schließen.


    Auch TB deinstalliert, neu installiert, msf. Dateien gelöscht und Rechte für neuen Benutzer vollständig freigegeben - nichts genutzt. Auf Admin Konto mit neuem Profil gehts, bräuchte aber alte Mails etc. auf neuem Benutzer.


    Wie noch vorgehen?


    Danke!

  • Hallo Graba,


    (tb vers. 3.0.4 / POP / XP)


    im abgesichertern Modus komme ich nur in den admin account, bzw. wenn ich dort im TB das Häkchen netferne wirkt sich das nicht aufs neue Benutzerkonto aus.


    Die Sicherheitskomponenten Meldung übrgens gelöst (einmal signons.txt - cert8.db - key3.db - secmod.db gelöscht).


    Bleibt das Indizierungsproblem. Bei 30.000 höre ich auf, so viele sind es auch nicht. Nochmal gegraben:
    -die profiles.ini ist angepasst auf altes profil
    - panacea verweist (noch) auf falschen pfad (c:\\ etc...)
    - in die prevs.js habe ich noch nicht hineingeschaut, nötig?


    Os.

  • Hallo, nebenbei:


    Im aktuellen TB 3.0.5 läuft die Indizierung (angeblich) schneller :).

  • stimmt, habe auch 3.0.5 statt 3.0.4 laufen (versehen), läuft wirklich schnell, war schon über 50.000............ kein halten mehr

  • So, und nun? Ich weiß hier nicht weiter, Indizierung läuft ungehindert weiter..

  • interessant:
    " Thunderbird wird bereits ausgeführt, reagiert aber nicht. Um ein neues Fenster öffnen zu können, müssen Sie zuerst den bestehenden Thunderbird-Prozess beenden oder Ihren Computer neu starten. "


    Diese Meldung erhalte ich wenn ich das Profil mal umbenenne, TB also nicht drauf zugreifen kann. TB wird aber "bereits ausgeführt", auch nach Neustart. Und im Task-Manager nirgens ein TB Prozess zu sehen.


    Wenn Profil wieder rückbenannt, geht endlos Indizierung wieder von vorne los. Vielleicht jemand vom Mozilla entwickler team erreichbar? Und wo? Danke!

  • ah gut, mal in bugzilla nachgeschaut, also
    https://bugzilla.mozilla.org/show_bug.cgi?id=561613
    und
    https://developer.mozilla.org/en/Thunderbird/Gloda_debugging


    beziehen sich wohl auf das Problem.


    Feinerweise bietet TB ja auch eine Fehlerkonsole (dadurch gerade erst entdeckt -ups),
    und meine Fehler sind *fast* identisch mit siehe bugzilla links oben:


    Component returned failure code: 0x80004001
    (NS_ERROR_NOT_IMPLEMENTED)
    vs.
    [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) <- mein Problem


    Vielleicht kann hier jemand damit was mit anfangen? Errors in readonly database sieht für mich nach Dateiberechtigung aus? Dabei ist der Folder eigentlich komplett ent-schützt worden. mhm...


    Konsole:


    und letzter eintrag wiederholt sich dann endlos

  • MOment, nach Ordnerfreigabe (über admin) Problem gelöst, alte Mails da. (erster Eindruck)


    _ dabei hatte ich das schon vor 2 tagen getan. Dh., es fehlte da ein zweites Häkchen nach "Ordner im Netzwerk freigeben" zusätzlich "Netzwerkbenutzer dürfen Ordner verändern"!


    Das wars wohl. Grüße und Danke für den Support. OS.

  • Für dieses Problem wurde bereits auf verschiedenen Kanälen berichtet (bugzilla, getsatisfaction.com/mozilla_messaging). Jetzt wurde der bug 562860 "reaktiviert" mit der Fage nach dem Status.


    Wie sind die Erfahrung zwischenzeitlich mit neueren Versionen, zB. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8 ) Gecko/20100802 Thunderbird/3.1.2 (meine derzeit installierte Version)
    Keine Probleme mit dem indizieren! (Übrigens auch nicht unter WINxp).


    Ein Hinweis zu Profilen!
    Es wird hier von "übernommenen" Profilen bei Neuinstallationen berichtet. Ich würde unbedingt davon abraten! Wenn etwas mit den Mozilla Applikationen krum läuft, dann ist das erste und beste Mittel ein neues Profil anzulegen. Die Übernahme der Mails kann händisch erfolgen (einfaches Verschieben von Dateine bzw. Verzeichnissen --- wird in verschiedenen Beiträgen beschrieben).
    Die Neu-Installation unter Beibehaltung eines alten/bestehenden Profils hat (höchst wahrscheinlich) noch kein Problem gelöst.


    Also Bitte an die mit den "Indizierungsschwierigkeiten" --> Rückmeldung AUCH wenn und warum das Problem gelöst ist. Dient allen!


    Danke


    Günter