Ordner lassen sich nicht kopieren/löschen [erledigt]

  • Hallo zusammen,


    ich wollte heute meinen Umzug auf den neuen Rechner vollziehen und deshalb mein Thunderbird-Profil kopieren, um es dann auf den neuen Rechner zu installieren (auf dem alten Rechner läuft Windows XP Professional und Thunderbird Version 3.0.1).


    Das Kopieren des Profils funktionierte aber nicht, es kam immer die Fehlermeldung, dass ein bestimmter Ordner in den Lokalen Ordnern nicht kopiert werden könne. Ich habe zuerst alle Anhänge aus den entsprechenden Mails im betroffenen Ordner gelöscht, dann (nach weiterem erfolglosen Versuch) den kompletten Ordner. Die Thunderbird-Konten habe ich komprimiert.


    Aber: Dieser Ordner lässt sich nicht löschen, weder im Programm selbst (da steht er hartnäckig noch drin), noch via Explorer im Profil. Der Hammer ist: Sobald ich die msf-Datei im Explorer anfasse, um sie zu löschen, kann ich noch nicht mal das Kontextmenü öffnen, es stürzt vielmehr gleich der ganze Explorer ab.


    Welche Lösungsmöglichkeiten gibt es noch? Danke vorab und viele Grüße
    Dorothee

  • Guten Morgen und willkommen im Thunderbirdforum!
    Ist Thunderbird geschlssen, während Du im Explorer die Atkon durchführst?
    Es könnte helfen, den PC neu zu starten, und sofort in den explorer zu gehen ins Profil, ohne thunderbird forher geöffnet zu haben.

  • Hallo Rothaut,


    ja, Thunderbird ist geschlossen, während ich im Explorer versuche, die Datei zu löschen. Und den Rechner habe ich schon mehr als einmal wieder neu gestartet, bevor ich diese Aktion durchgeführt habe. Ich scheine einzigartig zu sein mit diesem Problem, oder? :wall:

  • Hi,
    da hat sich halt was verklemmt, und Windows ist der Meinung, die Datei (welche eigentlich - vielleicht brauchen wir sie gar nicht?) ist noch im Zugriff. Kann auch ein Hardware-Problem sein (chkdsk/defragmentieren...)

  • Hallo Dorothee


    und willkommen im Thunderbird-Forum!


    Ich würde mal Windows im abgesicherten Modus starten und dann versuchen, die Datei im Explorer zu löschen.

  • Danke für die Hilfe bislang - der abgesicherte Modus hat leider auch nicht geholfen. Ist das alles zu fassen? Kann ich irgendwie mein Thunderbird-Profile kopieren ohne diese eine blöde Datei? Frag' ich jetzt mal ganz unbedarft ... Ich kann doch nicht 12 GB Mails auf dem alten Rechner lassen!

  • Hallo nochmal!


    Wie heißt denn die Datei?
    Normalerweise müsste es schon gehen, dass Du ohne diese Datei alles andere kopierst, nur wenns ein Mailordner ist, dann kanns halt sein, dass die Mails verloren sind, die da drin waren.

  • Die Datei heißt einfach "Name" ohne Endung, eine dazugehörige msf-Datei gibt es auch, der übergeordnete Ordner hat die Endung sbd. Wenn die Mails in der einen Datei weg sind, die sich hier so hartnäckig der Löschung widersetzt, ist das kein Drama. Wenn alle Mails aus dem übergeordneten sbd-Ordner weg sind, wäre das eine Katastrophe, die brauche ich unbedingt.


    Aber wie kann ich ein Profil unter Ausschluss einer bestimmten Datei kopieren? Quasi von Hand, Datei für Datei?

  • Genau, die endungslose Datei ist die Nervensäge. Laut Explorer hat sie 110.749 KB. Im Thunderbird selbst zeigt mir der entsprechende Ordner genau null Inhalt an (in der endungslosen Datei sind doch die Mails aus dem Ordner, und der Ordner ist der, der die Endung msf hat, richtig?) Irgendwo hat sich Windows/Thunderbird wohl verklemmt, als ich die Mails direkt im Thunderbird aus dem Ordner gelöscht habe.


    Ich hoffe, ich kann mich verständlich machen. :help:

  • Die Ordnergröße im TB und die Dateigröße im Explorer stimmen selten überein, weil TB gelöschte/verschobenen Mails nur entsprechend markiert und nicht mehr anzeigt. Das physikalische Entfernen führt der Vogel dann beim komprimieren (hat nichts mit zippen zu tun) vor. Siehe Punkt 12 der Anleitung.
    Die *.msf ist die Indexdatei der endungslosen Maildatei, also das "Inhaltsverzeichnis". Siehe dazu Punkt 11 der A...
    12 GB: das spricht dafür, dass du nie komprimiert hast oder deine Mailordner viel zu voll sind!
    Wie groß sind denn die endungslosen Dateien im Explorer, die Mailordner in TB? =>Extra Folder Columns

  • Komprimiert habe ich durchaus, allein in den letzten Tage ca. 634-mal. ;-)


    Die Mailordner sind unterschiedlich voll, reicht von 6.800 KB bis hin zu 746.000 KB (oberster Ausreißer), die meisten zwischen 20.000 und ca. 60.000 KB. Ist das wirklich zu viel?

  • Hi,

    Zitat


    Ist das wirklich zu viel?

    nein. Ich halte Posteingänge möglichst leer, Arbeitsordner wie Gesendete etc. so bei max 200 MB und "Archiv"-Ordner bei 400-500 MB. Also ist danach nur der Ausrutscher ein Ausrutscher.
    Wenn du die Datei derzeit nicht weg bekommst, kannst du erst Mal ein neues Profil erstellen, dort die Konten einrichten und mit ImportExportTools (Mboximport enhanced) die Mails rüberholen. Aber das ist natürlich nur Kosmetik. Ich kenne leider kein Tool, um Dateien trotz Weigerung des OS zu löschen, aber da gibt es mit Sicherheit was. Frag mal in den Win-Foren nach.

  • Alles klar, besten Dank, das ist erstmal ein gangbarer Weg - ein zweites Profil lege ich gleich an. Und dann suche ich mir jemand in irgendeinem Windows-Forum, dem ich aufs Dach steigen kann! :rolleyes:

  • Zitat von "Gatinha"

    Dieser Ordner lässt sich nicht löschen, weder im Programm selbst (da steht er hartnäckig noch drin), noch via Explorer im Profil. Der Hammer ist: Sobald ich die msf-Datei im Explorer anfasse, um sie zu löschen, kann ich noch nicht mal das Kontextmenü öffnen, es stürzt vielmehr gleich der ganze Explorer ab.


    Hallo Dorothee :)


    versuche es mal in der Konsole: Start - Ausführen (bzw. Win-R) - "cmd" (ohne die Anführungszeichen). Stichwort: xcopy /?, del /? bzw. rd /?. Oder unter Start - Ausführen: "%WinDir%\hh.exe ms-its:%WinDir%\Help\ntcmds.chm::/ntcmds.htm".


    Zitat


    Welche Lösungsmöglichkeiten gibt es noch? Danke vorab und viele Grüße


    Bitte und HTH
    Gruß Ingo

  • Hi Ingo,


    noch mehr Support - super, vielen Dank!. Weil ich auch noch ein bisschen was arbeiten muss zwischendrin, bin ich noch nicht dazu gekommen, das zweite Profil anzulegen und zu testen, ob das geht.


    Also - in der Konsole bin ich, die Hilfe hab ich mir auch anzeigen lassen, jetzt stand da:
    C:\Dokumente und Einstellungen\Mein Name> und dahinter blinkte der Cursor. Ich habe eingegeben: "del [C:][Dokumente und Einstellungen/Mein Name/Anwendungsdaten/Thunderbird/Profiles/xxxxxxxx.default/Mail/Local Folders/Ordnername.sbd/] Dateiname [/p]"
    Antwort: "Ungültige Option - "Mein" - und als ungültig bezeichnet diese Kiste meinen Vornamen im Pfad. Was mal wieder beweist: Technik lebt. Und sie ist böse. :freak:


    Ich gestehe: Von diesen Tiefen meines Rechners habe ich keine Ahnung. Was habe ich falsch gemacht? Was kann ich besser machen?


    Danke und Grüße!
    Dorothee

  • Zitat von "Gatinha"


    Was habe ich falsch gemacht?


    Hallo Dorothee :)


    Du hast den Pfad nicht in Anführungszeichen eingeschlossen. Da der Pfad Leerzeichen enthält, wird das als Trennzeichen angesehen. Btw, statt den Schrägstrichen (Slashes "/") hast Du auf der Konsole schon den Backslash ("\") benutzt? Sonst kann das nicht funktionieren.


    Zitat


    Was kann ich besser machen?


    Den Pfad bis zu "Anwendungsdaten" kannst Du mit der Umgebungsvariablen %appdata% abkürzen. Ich würde zunächst direkt in den Ordner wechseln. Dann brauchst Du für das DEL-Kommando nur den Dateinamen (falls dieser Leerzeichen enthält, musst Du auch den in Anführungszeichen einschließen; die schaden übrigens nie):


    Code
    1. C:
    2. CD "%appdata%\Thunderbird\Profiles\xxxxxxxx.default\Mail\Local Folders\Ordnername.sbd"
    3. DEL "Dateiname" /P


    Noch eleganter geht es mit dem Powertoy Open Command Window Here. Damit klickst Du im Explorer einfach mit der rechten Maustaste auf den gewünschten Ordner, wählst die entsprechende Option und es öffnet sich direkt ein Konsolenfenster mit diesem Pfad.


    Zitat


    Danke und Grüße!


    Bitte und HTH.
    Gruß Ingo

  • HA! Das Ding ist weg! :D


    Ich habe mich noch ein bisschen in die DOS-Befehle eingefuchst und mich dann per "cd"-Befehl bis ins passende Verzeichnis vorgearbeitet (nachdem ich kapiert hatte, dass Verzeichnis = Ordner) und dann "del Dateiname" eingegeben, das hat auch funktioniert. Sei gepriesen, Ingo, ganz herzlichen Dank, das war grandios.


    Viele Grüße!
    Dorothee