Zeichencodierung die soundsovielte

  • Hallo, liebe Zeichensatzspezialisten!
    rothaut hat gepfuscht, aber wenn ichnur wüsste wo.
    thunderbird 3.1.2, Win7, Home Premium, 64 Bit, Imap.
    Gestern erhielt ich von einem Teilnehmer einer Mailingliste den Hinweis, dass eine Mail von mir leer ankam.
    Bei mir wurde die Mail als Anhang angezeigt, ich habe in Ansicht Zeichencodierung automatisch auf universell gestellt, in den ordnereigenschaften auf Westlich Windows 1252.
    Wenn ich nun den Quelltext meiner gesendeten Mail angucke, kommt Folgendes:


    Thunderbird/3.1.2
    MIME-Version: 1.0
    To: Konferenztisch der Redaktion Radio BLINDzeln <E-mail-Adresse>
    Subject: sorry, soorry sorry!
    Content-Type: text/plain; charset=X-VIET-VPS
    Content-Transfer-Encoding: 8bit


    Das Kontrollkästchen allen Nachrichten Standardcodierung zuweisen und automatische Bestimmung ignorieren ist deaktiviert.
    Wo zum Geier hab ich was verstellt? Und naja für einen vietnamesischen Zeichensatz, so zumindest deute ich das Charset, liest sich die Mail eigentlich recht gut.
    Aber meine Vogelwelt ist total durcheinander. Kann mir bitte wer sagen, wo ich da Vogelmist gebaut habe?
    Vielen Dank!
    Nachtrag:
    Antworte ich aber auf eine Mail, die mir in Iso 88-59-1 geschrieben wurde, ist meine Codierung korrekt. Also nur bei neuen Mails schreibe ich offensichtlich teilweise vietnamesisch. Kann sich da wer einen Reim draufmachen?

  • Hallo Rothaut,


    Ich kann auch nur im Nebel stochern, aber was steht z.B. in der prefs.js bzw. about:config bei mailnews.send_default_charset?


    Grüße aus dem verregneten Dresden,
    muzel

  • Hallo Muzel!


    Vielen Dank für Deine Antwort!


    Bei allen Geiern und Donnervögeln, wie kommt das dorthin? Du hast es nämlich gerochen, da steht:
    mailnews.send_default_charset;X-VIET-VPS
    Ich war in den letzten Wochen nüchtern (Rothautehrenwort). Wie konnte ich das einstellen? Hast Du eine Ahnung, oder wer anderer, wie das hatte passieren können, einfach deshalb, weil ich 1. eine neugierige Rothaut bin, und 2. vielleicht in Zukunft vermeiden kann, dass ich wieder so in die Falle laufe.


    Jetzt hab ichs mal zurückgesetzt auf Iso 8859-15.
    Ich hoffe, das merkt sich das Vogeltier auch.


    Vielen Dank nochmal und viele Grüße aus dem verregneten Dorf in Niederösterreich bei 15 Grad *zitter*

  • Hallo Rothaut,


    das ist jetzt vielleicht OT, aber ich hatte vor einigen Tagen ein ähnliches, aber schlimmeres Erlebnis:
    Als ich nach einer Weile nach dem Lesen und einordnen von Mails wieder schreiben wollte, erschienen nur kryptische Kraxel, die sich als chinesische Schriftzeichen entpuppten. Das erstreckte sich aber auf alle Programme des Computers, und ich musste feststellen, dass als Eingabemöglichkeiten nur noch 8 verschiedene chinesische Kodierungen möglich waren... Eine Wiederherstellung des vorherigen Status war schwierig, da natürlich Kennworte usw. nicht mehr einzugeben waren, aber ich schaffte es dann nach zwei Tagen doch.
    Als vermutliche Quelle entdeckte ich eine kleines Tool, mit dem man überflüssige Sprachen und Schriften entfernen kann - es hatte bei mir aber alle außer den chinesischen entfernt (wohl der Herkunftsort des Tools). Vielleicht liegt bei Dir etwas Ähnliches vor, allerdings war Deine Reparatur wesentlich schmerzloser.


    Gruß
    raiSCH

  • Hallo!


    Danke für diesen Hinweis, aber ein solches Tool habe ich nicht auf meinem Rechner, auch nichts Ähnliches, zudem konnte ich ja die Antworten auf Mails im richtigen Zeichensatz verfassen, also da lagen die Dinge völlig anders.