Problem mit Dateiendungen der Anhänge

  • Ich habe ein Problem mit Dateianhängen:


    TB 5, POP3, Win7/64bit


    Ich habe einige E-Mails mit Anhängen. Diese werden auch als Anlage angezeigt, jedoch ohne Dateiendung. Ich habe in manchen Mails 4 Anhänge und sie werden alle durchnummeriert mit den Bezeichnungen "Attachment 0", "Attachment 1", "Attachment 2" und "Attachment 3" angezeigt.
    Leider jedoch ist kein Programm mit den Anlagen verknüpft, da sie ja keine Endung wie .jpg, .pdf ...... haben.


    Wenn ich die Anlagen speichere und dann umbenenne (ist ein wenig auf Zufall aufgebaut ob. .doc, .pdf, .jpg........) und die richtige Dateiendung erwische, dann kann ich die Anlage öffnen.


    Wenn in einem Mail Bilder integriert sind (z.B. Logos, Fußleisten, etc.) so werden die ebenfalls als Attachment in der Anlage angezeigt. Wie immer ohne Endung.


    .mpg und .pps werden hingegen richtig angezeigt und ich kann sie auch aus dem TB heraus öffnen.


    Was kann da passiert sein, bzw. los sein?


    Bitte um Hilfe, Bernhard

  • Hallo Bernhard,


    und willkommen im Forum!
    Schau bitte mal in den Quelltext rein, ob dort der Name des Anhanges korrekt eingetragen ist.
    Passiert das bei allen Mails mit anhang, also von allen Absendern?
    Hast du in deinem Betriebssystem die anzeige der Endung aktiviert (ja, die WinDOSe unterdrückt diese Anzeige per default!)?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Leider ist im Quelltext auch nur von den Attachments die Rede (Also nur Attachment0, ohne dateiendung..)
    Ich glaub es steht auch was von Content-Type: application/octet-stream drinnen.


    Habs jetzt leider nicht genau im Kopf weil das bei einem PC von einem Freund war.


    Er hat auch gemeint, er hätte manche Anlagen schon mal ansehen können und plötzlich gings nicht mehr. Konnte das aber nicht nachvollziehen.
    Mit den Endungen in Windows klappt alles. Nach dem Speichern ist die Datei tatsächlich ohne Endung gespeichert. Nach dem umbenennen klappt ja dann alles.


    Es passiert scheinbar nicht bei allen Absendern.


    Ich hatte auch schon die MS Security Essentials in Verdacht - hab mal auf AVG umgestellt und gebeten, die Mails weiter zu beobachten, ob das wieder auftritt mit den Attachments.

  • "hsmautern" schrieb:

    Leider ist im Quelltext auch nur von den Attachments die Rede (Also nur Attachment0, ohne dateiendung..)


    Das sagt mir, dass der TB "gar nicht anders kann". Er bekommt die Mail bereits mit den falschen Angaben geliefert.
    So müsste es korrekt sein:

    Code
    1. Content-Type: application/pdf <= es handelt sich hier um ein .pdf
    2. Content-Length: 57832
    3. Content-Disposition: attachment; filename="RGxxxxxxxxxx.pdf" <= das ist der Name des Anhanges
    4. Content-Transfer-Encoding: base64


    Zitat

    Es passiert scheinbar nicht bei allen Absendern.


    Das bestätigt mir, dass es sich um ein Problem bei bestimmten Absendern handelt.


    Zitat

    Ich hatte auch schon die MS Security Essentials in Verdacht - hab mal auf AVG umgestellt und gebeten, die Mails weiter zu beobachten, ob das wieder auftritt mit den Attachments.


    Das vermute ich weniger, denn siehe den zweiten Punkt.
    Dann würde es immer auftreten.


    Unabhängig davon ist es IMMER ein guter Tipp, bei fast allen Problemen mit dem TB einen sauberen Systemstart völlig ohne "Sicherheits"-Software durchzuführen. Also diese Programme so zu konfigurieren, dass die nicht mit dem System starten, Reboot und neu testen. Temporär, um diese als fehler auszuschließen, sehe ich da auch kein sicherheitsproblem darin. Selbstverständlich keine Anhänge ausführen ... .


    Ein zweiter guter Tipp ist es, sich selbst eine Mail (hier: eben mit Anhang) zu senden.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!