Thunderbird sucht nach Umzug nicht vorhandenes Profil [erl]

  • Hallo,
    ich habe nach einer Neuinstallation von Windows mein Thunderbird Profil mit Hilfe von MozBackup wieder hergestellt. Leider habe ich erst jetzt erfahren, dass dieses Forum dieses Programm nicht empfiehlt. Bitte seht es mir nach, vielleicht hat mein Problem ja nichts mit MozBackup zu tun.


    Jedesmal wenn ich Thunderbird starte erscheint ein Fenster mit der Meldung:


    "Die Datei mailbox:///C|/Dokumente und Einstellungen/Username/Anwendungsdaten/Thunderbird/Profiles/alv4k6ly.default/Mail/Local Folders/Inbox konnte nicht gefunden werden. Bitte überprüfen Sie die Adresse und versuchen Sie es nochmals."


    Das Seltsame dabei ist: Wenn ich die Meldung weg klicke, funktioniert Thunderbird ganz normal und ich habe zugriff auf alle meine Konten, da TB ein anderes Profil benutzt. In den Konteneinstellungen verweisen alle Mailkonten auf das richtige, vorhandene Profil. Zudem bezieht sich dieser Pfad in der Fehlermeldung doch auf ein Profil unter Windows XP, ich nutze aber Windows 7. Ich habe zwar mein Profil seit den XP-Zeiten beibehalten und mit umgezogen, jedoch war die letzte Installation auch schon kein XP mehr. Und dort hat Thunderbird keine Zicken gemacht (Was vielleicht doch auf MozBackup als Ursache hindeutet :confused:)


    Das Schrittweise deaktivieren der Addons und auch eine Neuinstallation von Thunderbird hat keine Besserung gebracht.


    Wo könnte ich denn noch nachschauen, warum Thunderbird dieses tote Profil sucht? Ich gehe mal davon aus, dass ich irgendeine Konfigurationsdatei per Hand säubern muss, aber welche?


    Gruß


    Fränkl



    Thunderbird-Version 12.0.1:
    Betriebssystem + Version Win7 Ultimate 64:
    Kontenart (POP / IMAP) beide:
    Postfachanbieter verschiedene (z.B. GMX):

    4 Mal editiert, zuletzt von fraenkl.rlp ()

  • Hallo fraenkl.rlp und willkommen im Thunderbird-Forum,


    Du kannst den Pfad überprüfen und ändern, indem Du in die Konteneinstellungen gehst und dort unter dem jeweiligen Konto ganz unten den Pfad nachsiehst.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 32 Bit | Firefox 64 Bit | Avira Free Security Suite

  • Hallo,


    alle meine vorhandenen Mailkonten, sowohl POP als als auch imap, verweisen auf das korrekte Profil. Ich kann auch keine Fehlfunktion beim Abrufen der mails erkennen.


    Der einzige "Fehler" ist die Fehlermeldung selbst, da diese sich auf ein nicht (mehr?) genutztes Profil bezieht.


    Wo kann man denn noch Pfade einsehen und ändern?


    Gruß Fränkl

    Einmal editiert, zuletzt von fraenkl.rlp ()

  • Hallo Fränkl,


    zunächst stelle den Windows Explorer so ein, dass er auch versteckte Dateien anzeigt. Danach navigierst du zu:


    C:\Users\*deinBenutzername*\AppData\Roaming\Thunderbird


    Dort findest du den Ordner "Profiles". Wie viele Profile sind dort enthalten und wie heißen sie?


    Weiterhin findest du die "Profiles.ini". Dies ist der Ort, wo Thunderbird nachschaut, welches Profil es per Default benutzt. Öffne sie mit dem Editor. Du findest etwa folgendes:


    ________________________
    [General]


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/bcol2fpk.default


    Default=1
    _________________________


    Du siehst hier den Profilnamen des Standardprofils im Klarnamen. Vergleiche ihn zunächst mit dem Namen aus dem Ordner "Profiles" und melde dich dann noch einmal!

  • Hallo,


    In dem Pfad C:\Users\*meinBenutzername*\AppData\Roaming\Thunderbird befindet sich nur ein einziges Profil: hx9wz823.default.


    In der profiles.ini taucht auch nur dieses auf:


    ------------------------------------
    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/hx9wz823.default
    Default=1
    ------------------------------------


    Genau dieses Profil taucht auch in allen Konteneinstellungen als Pfad auf.


    Wenn ich doch nur wüsste, welcher Programmteil auf das andere Profil alv4k6ly.default zugreifen will....


    In der Fehlerkonsole tauchen kurz nach dem Programmstart folgende Einträge auf. Könnt ihr damit was anfangen?
    [IMG:http://dl.dropbox.com/u/18119911/Fehlerkonsole1von2.jpg]
    [IMG:http://dl.dropbox.com/u/18119911/Fehlerkonsole2von2.jpg]


    Gruß

    Einmal editiert, zuletzt von fraenkl.rlp ()

  • Hallo,


    "fraenkl.rlp" schrieb:

    alle meine vorhandenen Mailkonten, sowohl POP als als auch imap, verweisen auf das korrekte Profil


    ja, das mag sein, aber oben schreibst Du

    "fraenkl.rlp" schrieb:

    "Die Datei mailbox:///C|/Dokumente und Einstellungen/Username/Anwendungsdaten/Thunderbird/Profiles/alv4k6ly.default/Mail/Local Folders/Inbox konnte nicht gefunden werden.


    und das ist der Lokale Ordner. Überprüfen den noch mal.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 32 Bit | Firefox 64 Bit | Avira Free Security Suite

  • Zitat

    und das ist der Lokale Ordner. Überprüfen den noch mal.



    Nein die Fehlermeldung beschreibt doch einen Pfad von einem Windows XP System. Diesen gibt es doch auf meinem Windows 7 nicht. Ich hab schon vor längerem von XP auf 7 gewechselt, warum diese Fehlermeldung jetzt erst erscheint ist mir ein Rätsel.


    Auch der Profilname der Fehlermeldung existiert bei mir nicht. Nicht in den Konteneinstellungen und auch nicht im Thunderbird Profilverzeichnis.


    Die Fehlermeldung meldet ein nicht vorhandenes Profil, welches warscheinlich irgendwann mal existiert hat, aber jetzt nicht mehr benutzt wird. Es funktioniert ja alles, nur die Fehlermeldung nervt.

  • Nein, soweit ich das hier nachvollziehen kann, zeigt die Fehlermeldung ein nicht vorhandenes Konto ("Discovering folders for account...") und das scheint mir der Lokale Ordner zu sein. Also nochmals da nachsehen, wo ich oben schon erwähnt habe und nicht die POP- oder IMAP-Kontenpfad, sondern den Lokalen Ordnerpfad überprüfen.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 32 Bit | Firefox 64 Bit | Avira Free Security Suite

  • "fraenkl.rlp" schrieb:


    die Fehlermeldung beschreibt doch einen Pfad von einem Windows XP System. Diesen gibt es doch auf meinem Windows 7 nicht.


    Hallo :)


    soweit richtig.


    Zitat


    Ich hab schon vor längerem von XP auf 7 gewechselt, warum diese Fehlermeldung jetzt erst erscheint ist mir ein Rätsel.


    Ich tippe auf MozBackup.


    Zitat


    Die Fehlermeldung meldet ein nicht vorhandenes Profil, welches warscheinlich irgendwann mal existiert hat, aber jetzt nicht mehr benutzt wird. Es funktioniert ja alles, nur die Fehlermeldung nervt.


    Im Ordnerbaum Rechtsklick auf den "Posteingang" unter "Lokale Ordner", dann "Eigenschaften". Was steht unter "Adresse"?


    Gruß Ingo

  • Schmeiß mal


    "StartWithLastProfile=1"


    aus der profiles.ini raus. Also ersatzlos löschen, so dass im Bereich "General" gar nichts steht.
    Vorher natürlich am besten den gesamten Hauptordner einmal sichern, sofern noch nicht geschehen.

  • Hallo,


    schau doch mal bei beendetem TB im Profil mit einem Editor in die Datei prefs.js und suche nach dem String, was findest du dort?

  • Hallo,


    ein neuer Tag um frisch und gut gelaunt an die Arbeit zu gehen :)
    vielen Dank für eure Unterstützung soweit. :top:


    slengfe und schlingo
    Achso, ich hab immer nur in den Kontoeinstellungen geschaut. In den Eigenschaften des lokalen Ordners steht auch der richtige Pfad und nicht der Pfad aus der Fehlermeldung:


    mailbox:///C:/Users/mein username/AppData/Roaming/Thunderbird/Profiles/hx9wz823.default/Mail/Local Folders/Inbox


    Ich hab vorsichtshalber auch die anderen Ordner überprüft, jedoch keinen falschen Eintrag gefunden.


    Voyager
    Ich hab den Thunderbird Hauptordner gesichert und bin bereit für Experimente ;) Wenn ich die profiles.ini so bearbeite, dann startet TB fast wie gehabt. Der einzige Unterschied ist, dass die besagte Fehlermeldung nun zweimal aufgeht. Vielleicht ein Hinweis?... Auf jeden Fall hab ich die profiles.ini wieder in den Ursprungszustand versetzt.


    rum
    Ich habe in der Datei pref.js eine Zeile gefunden, die den exakten Pfad aus der Fehlermeldung enthält. Desweiteren aber auch noch drei weitere Zeilen, in denen der zwar ein anderer Pfad, aber auch der Windows-XP-Ordner "Dokumente und Einstellungen" auftaucht. Folgende vier Zeilen habe ich gefunden:


    user_pref("browser.download.dir", "C:\\Dokumente und Einstellungen\\Fränkl\\Desktop");
    user_pref("mail.root.none", "C:\\Dokumente und Einstellungen\\Fränkl\\Anwendungsdaten\\Thunderbird\\Profiles\\alv4k6ly.default\\Mail");
    user_pref("mail.root.pop3", "C:\\Dokumente und Einstellungen\\Fränkl\\Anwendungsdaten\\Thunderbird\\Profiles\\alv4k6ly.default\\Mail");
    user_pref("mailnews.start_page.url", "mailbox:/C|/Dokumente und Einstellungen/Fränkl/Anwendungsdaten/Thunderbird/Profiles/alv4k6ly.default/Mail/Local Folders/Inbox");


    Soll ich lieber die ganze Datei posten?


    Was mir noch aufgefallen ist, vielleicht ist es aber auch unwichtig: Im Windows Pfad C:\Users gibt es nun einen Ordner, der die selbe seltsame Schreibweise hat wie in der ersten fehlerhaften Zeile weiter oben. Also nicht "Fränkl" sondern "Fränkl". Und darin befindet sich als einzige diese Ordnerstruktur C:\Users\Fränkl\AppData\Local\libimobiledevice. Im untersten Ordner sind diese 6 Dateien, keine Ahnung wo die herkommen, ich hab nach der Windows Neuinstallation alle Programme frisch installiert, also kein Backup oder Image zurück gespielt.


    [IMG:http://dl.dropbox.com/u/18119911/Ordnerinhalt1.jpg]




    Was ist denn nun sinnvoller, die pref.js bearbeiten/reparieren (keine Ahnung was ich da wo und wie ändern müsste) oder lieber TB neu aufsetzen und meine mails wieder einbauen? Wobei mir auch dies kompliziert erscheint. Ich kann ja nicht einfach den Thunderbird-ordner reinkopieren, da sind ja die falschen Konfigurationsdaten drin.


    Gruß Fränkl

  • Hallo,


    du hast ja nun eine Kopie des Profils.
    Erstelle nun noch mal eine der prefs.js und dann bearbeite die prefs.js, natürlich bei beendetem TB :rolleyes:
    Die erste Zeile sagt, wo Downloads abgelegt werden, Zeile 2 und 3 sind Pfade zum lokalen Ordner und die 4. Zeile definiert wohl die Anzeige der Startseite, falls nicht der Default Wert beibehalten wurde.
    Alle vier Zeilen sind wohl aus dem alten Profil. Ich würde sie entfernen und TB starten, wenn das funzt, ist gut, wenn nicht, benenne einfach die Kopie in prefs.js und du bist wieder auf dem derzeitigen Stand und kannst dann evtl. in neues Profil erstellen und die Mails und Adressen rüber ziehen, das kann man dir dann ja erklären.

  • Hallo,


    ich hab jetzt aus der pref.js die genannten 4 Zeilen komplett gelöscht. TB bringt nun keine Fehlermeldung und bis jetzt scheint alles zu funktionieren :P


    Dann möchte ich mich bei euch allen für eure Hilfe bedanken :top:


    Wenn ich in Zukunft wieder in die Verlegenheit kommen sollte TB neu installieren zu müssen, scheint es jawohl auszureichen einfach den TB-Ordner zu sichern und wieder herzustellen, oder? Sind da auch alle Addons und deren Einstellungen mit drin? Das war nämlich der Grund, warum ich ursprünglich MozBackup gewählt hab, die Sorge, sonst alles wieder einzeln einrichten zu müssen.


    Gruß Fränkl

  • Hi,


    Lies mal Punkt 11 der Anleitung bzw. Fragen & Antworten (ist auf dieser Seite ganz oben per Button erreichbar) und schau mal hier: Profil [der Ordner mit den 8_wilden_Buchstaben.default, wobei auch default sonstwie heißen kann, z.B. ghw63k9g.test oder ghw63k9g.MeineMails...
    siehe=> Thunderbird-Menü Hilfe>Information zur Fehlerbehebung>Profilordner>Beinhaltenden Ordner anzeigen und Dateien im Profil kurz erklärt]


    Ich kopiere ab dem Ordner ..\thunderbird\.., dann habe ich die profiles.ini und im Ordner Profiles alle Profile.