Thunderbird löscht Leerzeichen im Text nach dem Senden einer

  • Thunderbird-Version: 17.0
    Betriebssystem + Version: Win XP + Version 2002 - Service Pack 3
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): CNT


    Hallo zusammen,


    seit einigen Tagen habe ich das Phanomen, dass Thunderbird nach dem Senden von Emails einige Leerzeichen in meinem Text weg lässt.


    Als Beispiel hier der Quelltext einer Mail:



    Manchmal hat man zwar ein paar Aussetzer, aber in letzter Zeit habe ich verdammt viele fehlende Leerzeichen entdeckt.


    Hat jemand eine Idee woran es liegen kann bzw. wie ich es abstellen kann ?


    Vielen Dank für die Hilfe

    Einmal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Hallo jak-man


    und willkommen im Thunderbird-Forum!


    Hast du dir mal eine Kopie der Mails selber per BCC zugeschickt, fehlen dann in der empfangenen Mail Leerzeichen.


    Teste mal im Thunderbird-SafeMode (Abgesicherter Modus) (dazu TB mit gedrückter Umschalttaste starten oder in TB=> Hilfe>Mit deaktivierten Addons neu starten)


    Passiert das auch mit TB 17.0?

  • Hallo,
    mich interessiert, wo denn genau im Text die Leerzeichen weggelassen werden. Ohne Kennzeichnung kann man ja nur raten.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Moin Moin,


    vielen Dank schonmal für eure Tipps. Werde das mal testen und mich wieder melden.


    Ja, es passiert auch mit Thunderbird 17.0.


    Mal schauen was passiert wenn ich einige Zeit im abgesicherten Modus arbeite.


    Die Leerzeichen werden total sporadisch weg gelassen. Ich kann da leider überhaupt keine bestimmte Abfolge etc. erkennen. Es gibt einige Mails da ist mal alles ok und die nächste sieht aus, als wenn man im Schreibunterricht nur eine Teilnehmerurkunde erhalten hat...


    Melde mich


    Danke

  • Moin Moin,


    habe soeben den abgesicherten Modus wieder abgestellt, denn das Problem trat trotzdem auf. Ok, es war bei einer längeren Test-Mail nur 1 Fehler, aber das nervt trotzdem.


    Gibt es noch irgendwelche Ideen ?


    Vielen Dank

  • Hallo!


    Ich habe seit gut 1 Monat dasselbe Problem. Thunderbird 17.0.2 löscht scheinbar willkürlich Leerzeichen aus gesendeten Mails. Schicke ich mir selber Mails über die unterschiedlichsten Accounts, kann ich den Fehler nicht reproduzieren. Er wird im Gesendet-Ordner dummerweise nur in den Mails sichtbar, die ich fremden Leuten geschickt habe. Ich weiß also nicht, ob sie mit den Fehlern raus sind, oder die Leerzeichen erst nach dem Senden entstehen. Woran könnte das liegen?


    Grüße
    MKB™

  • Hallo,
    und du lässt auch wie empfohlen bei jeder Mail auch eine Bcc an dich selbst senden?
    Ich kann mir eigentlich nicht vorstellen, dass es verschiedene Versionen dieser einen Mail geben soll.
    Das Problem tritt also sowohl im Quelltext als auch im Nachrichtenfenster auf?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Guten Morgen,


    habe nun seit längerem nicht mehr hier rein geschaut, aber das Problem mit dem Löschen der Leerzeichen hat sich leider nicht erledigt.


    Zu deiner letzten Mail, ich sende jede Mail in bcc an einen weiteren Account von unserer Domain. Da kann man die fehlenden Leerzeichen ebenfalls "beobachten". Wenn ich in Kopie von einer anderen Mail unserer Domain gesetzt werde, kann man die fehlenden Leerzeichen ebenfalls "sehen".


    Muss schon sagen das Ganze ist ziemlich nervig und sieht nach Außen nach starkem Analphabetismus aus :-))


    Grüße

  • Thunderbird 17.0.2
    Kontoart: IMAP
    Betriebssystem MAC OS X 10.7.5


    Hallo Jak-Man


    Das genau gleiche Problem habe ich auch. Komme mir auch schon vor wie einer aus der Hilfsschule. Dabei arbeite ich im Gegensatz zu Dir mit einem MAC und nicht mit Windows, benutzte die Version 17.0.2 und die Kontoart IMAP. Also eine total andere Konfiguration.


    Das Problem liegt ganz eindeutig bei Thunderbird und natürlich auch bei den Entwicklern von Thunderbird. Die leben in irgend einer Parallelwelt. Feed-back von Usern kommt dort überhaupt nicht an. Probleme werden immer erst einmal auf die Benutzer abgeschoben. Allerdings ist das eine globale Krankheit die man überall beobachten kann.


    Die Lösung für Dein Problem lautet also schlicht und ergreifend: Weg von Thunderbird! Es gibt genügend andere leistungsfähige und gute Mail-Programme und wenn Dich der Abschied zu stark schmerzen sollte, kannst Du es ja in ein paar Monaten nochmals versuchen und wieder zurück wechseln. Früher oder später wird auch bei Thunderbird jemand über diesen Bug stolpern und ihn beheben. Bis dahin viel Spass mit Outlook.


    Gruss von Paperino

  • Hallo,

    Zitat

    Die leben in irgend einer Parallelwelt. Feed-back von Usern kommt dort überhaupt nicht an. Probleme werden immer erst einmal auf die Benutzer abgeschoben


    Ich weiß wirklich nicht, woher du diese Behauptung entnimmst.
    Erstens gibt ein englischsprachiges Forum, in dem sogar die Chefentwickler mitlesen und Antworten schreiben und evtl. Probleme an die richtigen Kollegen weiterleiten oder einen Bugreport schreiben.
    Das weiß ich deshalb so genau, weil ich einen Großteil der Mails innerhalb des Entwicklerkreises zusammen mit einigen wenigen Powerusern mitlese und ich täglich Berichte und Fragen von Usern zu Gesicht bekomme, die Probleme mit TB haben.
    Die Entwickler nehmen diese sehr ernst und es folgen sofort Maßnahmen, um diese Probleme zu beheben.
    Sehr wichtige werden sogar auf einer Sonderseite angesprochen.
    https://support.mozillamessaging.com/en-US/kb/ask
    Aber in der Tat sind viele Probleme auf den User zurückzuführen, weil diese sich nie mit der richtigen Bedienung auseinandergesetzt haben und niemals die unzähligen sehr guten Hilfsangebote zur Kenntnis genommen haben.
    Die meisten wissen noch nicht mal, was "Komprimieren" bedeutet und dass zu viele Mails in Posteingängen (die leer sein sollten) zu Datenverlusten führen können.


    Wenn du kostenlose leistungsfähige Mailprogramm kennst, die erheblich besser sind und mehr kostenlose Add-ons anbieten, bitte nenne sie uns. Von alle, die ich bisher getestet habe, war ich sehr enttäuscht z.B. Windows Live Mail, Opera Mail.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb


    Genau so eine Antwort habe ich erwartet.


    Deinem Wunsch komme ich trotzdem gerne nach:


    Apple liefert mit seinen Geräten schon in der Grundkonfiguration ein Gratis-Mail-Programm das sich durchaus sehen lassen kann. Es ist mir am Ende egal wie viele Add-Ons ein Mailprogramm anbietet wenn ich durch die Benutzung eben dieses als grammatikalischer Vollidiot abgestempelt werde.


    Ich war jahrelang sehr zufrieden mit Thunderbird. Leider ist jetzt "time to say goodby".


    Grüsse von Paperino

  • Ach und das Programm ist auch für den Desktop geeignet und kostenlos?
    Wie auch immer, Apple und deren Geräte sind für mich tabu.
    "Verapplen" kann ich mich nämlich auch alleine.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Moin Moin mrb,


    deine Hilfestellung haben wir hier zur Kenntniss genommen, nur leider hilft sie keineswegs weiter.


    Wie oben schon mehrfach angemerkt, gibt es ein sehr ärgerliches Problem beim Versenden über Thunderbird. Kannst du uns dazu auch eine Lösung geben? Das wäre sehr nett und würde die Hilfsbereitschaft und Problemlösung bzgl. Thunderbird wieder in den Vordergrund dieses Threads rücken.


    Vielen Dank im Voraus und wir freuen uns alle über hilfreiche Tips.


    Grüße

  • Sorry, aber unrichtige Behauptungen darf ich schon noch korrigieren, auch wenn sie offtopic sind?
    Selbst wenn ich dir weiterhelfen könnte und ich das Problem hier nachvollziehen könnte, könnte ich dir vermutlich auch nicht weiterhelfen.
    Das einzige was ich dir raten kann, das Problem in einem neuen Profil zu überprüfen, um auszuschließen, dass das Profil defekt ist.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    in über 20 Berufsjahren u.a. im IT-Support bin ich auch ab und zu über solche "verloren gegangene Zeichen" gestolpert und fast immer wars die Tastatur, die gelegentlich aussetzt oder wegen Krümeln o.ä. ab und zu eine Taste vor Erreichen des Kontaktes blockiert. Ganz früher waren öfters abgenutzte Kontakte bei Folientastaturen schuldig, heutzutage sind es meist schwächer werdene Batterien in kabellosen Funktastaturen, die solche Aussetzer bewirken. Seltener brechen Federn unter einzelnen Tasten, eher haken sie mal aus aus ihren grazilen Befestigungen. Die Leertaste ist besonders anfällig durch ihre Länge, je nachdem, wo man sie erwischt, verkantet sie auch gern mal.


    Die Frage ist immer, wann solche Aussetzer auffallen. Vielschreiber schimpfen über die Textverarbeitung, Leute mit sicheren (langen) Kennwörtern schimpfen über die Anmeldesever usw. .... hier KÖNNTE es auch sowas sein und evtl. nur im Thunderbird auffallen, wenn sonst wenig geschrieben wird.


    Freundliche Grüße
    Drachen

  • Drachen ,


    Danke für die Antwort. Auch eine nicht zu unterschätzende Möglichkeit.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo zusammen,

    Zitat von "Drachen"

    ...bin ich auch ab und zu über solche "verloren gegangene Zeichen" gestolpert und fast immer wars die Tastatur, die gelegentlich aussetzt oder wegen Krümeln o.ä. ab und zu eine Taste vor Erreichen des Kontaktes blockiert.


    eine mögliche Ursache, keine Frage,...ich bin da allerdings noch etwas skeptisch:
    Es wurde hier noch nicht geklärt, in welchem Modus die Betroffenen ihre Nachrichten verfassen - HTML (Schriftart-Größe) / Reintext - und wie die jeweiligen Einstellung der Sende-Optionen sind.


    Durch Zufall bin ich über diesen Thread gestolpert: Some of my spaces are disappearing
    Der OP hat folgenden Bug angelegt: Superfluous font tags in HTML mail cause spaces to disappear
    In einem ähnlich gestrickten Bug gibt es eine gute Beschreibung den Fehler zu reproduzieren: Comment 11


    Ich kann mit ihr den Fehler reproduzieren -->Ansicht der Nachricht in Reintext -->Fehlende Leerzeichen, ohne Krümeleinfluss ;-)


    Gruß
    muellerpaul

    --
    Hier könnte Ihre Werbung stehen

  • Hallo müllerpaul,


    na klar, reiner Zufall ... ;-)


    Ich habe den bug nur überflogen, aber wenn ich nichts wichtiges übersehen habe, dann sind zwei Workarounds denkbar:


    1. Die E-Mails in Reintext verfassen
    2. In HTML-E-Mails die Schriftgröße nicht auf small ändern bzw. auf default belassen


    Kannst Du das bestätigen?


    Gruß


    Susanne

  • Hallo Susanne,

    Zitat

    Kannst Du das bestätigen?


    kann ich so beastätigen, wobei ich das jetzt nicht groß ausgetestet habe, mein Leidensdruck ist dann doch zu klein ;-)


    Fakt ist, dass bei Voreinstellung einer Schriftgröße in den HTML-Optionen (Extras->Einstellung->Verfassen), die größer/kleiner als "mittel" ist und beim Verfassen die Backspace-Taste benutzt wird um Fehler zu korrigieren, sich im HTML-Code diese "überflüssigen" font-tags innerhalb eines Wortes zeigen: <font size="-2"> bis <font size="+3">


    Fehlende Leerzeichen im Reintext-Part konnte ich bislang nur mit der Schriftgröße klein (-1), bzw. sehr klein (-2) produzieren. Hier mal ein von TB erzeugter HTML-Code (unter massiven Einsatz der Backspace-Taste), den man ja mal im Verfassenfenster über Einfügen->HTML selbst einfügen kann, als Entwurf speichert und sich ihn mal als Reintext und HTML anzeigen lässt.


    Feste Breite / klein



    Gruß
    muellerpaul

    --
    Hier könnte Ihre Werbung stehen

  • Hallo muellerpaul,


    danke für's Gegenchecken. Da ich zumindest privat meine E-Mails in ASCII schreibe, ist auch


    Zitat von "muellerpaul"

    ... Leidensdruck ist dann doch zu klein


    Ich halte dies dennoch für einen ziemlich üblen bug, denn insbesondere im Berufsleben kommt so manch einer ja nicht um HTML herum. Gut, dass dank Deiner Recherche nun etwas mehr Klarheit herrscht und man den Fehler vermeiden kann.


    Gruß


    Susanne