Thunderbird löscht Leerzeichen im Text nach dem Senden einer

  • Nur eine Frage zur Info:
    da Thunderbird ja auch immer zusätzlich Reintext in den Quelltext schreibt (auch bei Einstellung Original-HTML), ist der von diesen Leerzeichen ebenfalls betroffen?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ich vermute, dass nein. Allerdings habe ich den Fehler bei meinem Test nicht reproduzieren können. Ich bekomme zwar ebenfalls diese <font size=-"1">-tags, aber die Leerzeichen sind alle vorhanden:



    Gruß


    Susanne


    Edit: Ich habe gerade obigen Quelltext nochmals kontrolliert und siehe da: Im Reintext fehlt das Leerzeichen zwischen "HTML" und "(HTML ist böse ...)". Im "vertagten" HTML-Code selbst ist es aber da. Deshalb war mir das zunächst nicht aufgefallen.
    Das heißt, bei meinem Test trat der Fehler zwar auf, er betrifft aber nur den Reintext-Teil der zuvor in HTML verfassten E-Mail.

    2 Mal editiert, zuletzt von SusiTux ()

  • Hallo mrb,


    Ja, analog der Anzeige im Reintext-Format fehlen die Leerzeichen dann natürlich auch im Quelltext.


    Man kann dann schon sehr ins grübeln/zweifeln kommen, wenn man im HTML-Verfassenfenster die Nachricht als okay betrachtet hat (keine fehlenden Leerzeichen zu erkennen)
    und sie nun an eine Adresse versendet, für die im Adressbuch der Eintrag "Reintext bevorzugtes Nachrichten-Format" vorhanden ist. Die Nachricht geht ja dann nur als Reintext
    raus und landet ebenfalls als Reintext im Ordner Gesendet.


    Somit hat man erst mal keine Möglichkeit die Ursache für die fehlenden Leezeichen zu erkennen. Der verbaselte HTML-Code (Verursacher) ist ja nicht mehr im Quelltext vorhanden. Gleiche Problematik auch, wenn jemand das HTML-Verfassenfenster zum schnellen/einfachen formatieren nutzt (Unterstreichung, kursiv, unsortierte Liste etc.), Nachrichten prinzipiell aber nur als Reintext versendet (so eingestellt in den Sende-Optionen).


    Gruß
    muellerpaul

    --
    Hier könnte Ihre Werbung stehen

  • Hallo Susanne,

    Zitat von "SusiTux"

    Ich bekomme zwar ebenfalls diese <font size=-"1">-tags, aber die Leerzeichen sind alle vorhanden


    --> mehr backspace bitte :mrgreen:


    Gruß
    muellerpaul


    Edit:
    Ich bin mir nicht ganz sicher, ob es für das Reproduziern der "fehlenden Leerzeichen" maßgeblich ist:
    Die Sofort-Rechtschreibprüfung sollte aktiviert sein. Es werden dabei dann komischerweise "halbe Wörter" als falsch gekennzeichnet, obwohl sie richtig geschrieben sind.

    --
    Hier könnte Ihre Werbung stehen

  • Zitat

    Es werden dabei dann komischerweise "halbe Wörter" als falsch gekennzeichnet, obwohl sie richtig geschrieben sind.


    Ich meine, dass es dafür einen Bugreport gibt. Das Problem ist im getsatisfaction-Form jedenfalls bekannt.


    Ein ähnliches Problem habe ich (oder hatte ich?) bei per Filter verschobenen bestimmten Mails. Hierbei wurden Teile des HTML-Tags (oft nur ein bis zwei Zeichen) von der untersten Zeile nach ganz oben verschoben, welches einen Zusammenbruch der gesamten Mail zur Folge hatte und sogar den Betreff betraf. Diese Mails waren dann unbrauchbar, konnten aber über eine Korrektur des QT wieder voll lesbar gemacht werden.
    Ich weiß auch nicht mehr hundertprozentig, ob der Fehler nur auf die Filter zurückzuführen war. Er ist aber schlagartig nicht mehr aufgetreten.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Nur eine Frage an die Beteiligten:
    ist der Bug bei euch noch vorhanden?
    Ich konnte ihn bis jetzt hier nicht nachvollziehen.
    Der Reintextpart der Mail ist im Postausgang mit Leerzeichen, wobei ich das Setzen des überflüssigen Tags im HTML-Part bestätigen kann.


    Danke und
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ja, ich kann den Fehler nach wie vor nachvollziehen. Allerdings habe ich dasselbe merkwürdige Resultat wie oben:


    • Ich stelle die Schriftgröße in den Einstellungen auf "klein". (Der Fehler scheint nicht aufzutreten, wenn man erst beim Verfassen auf "klein" umstellt. Dann gibt es auch keine <font size="-1> < sondern <small>-tags)
    • Ich verfasse eine HTML-E-Mail unter massivem Gebrauch der Backspace-Taste.
    • Sowohl die E-Mail im Sent-Folder (lokal) als auch die empfangene E-Mail zeigen den Fehler, allerdings nur im Reintext-Teil, wie oben im Quelltext kopiert. Die HTML-Ansicht ist völlig ok.


    Gruß


    Susanne

  • Danke Susanne,
    ich werde das noch mal mit deinen Angaben testen. Vielleicht hatte ich auch die Backspace-Taste zu wenig betätigt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Das Problem besteht unverändert fort... auch in der Version 24.2.0. Damit disqualifiziert sich Thunderbird für den geschäftlichen / dienstlichen Gebrauch.
    Neben den regelmäßig ausfallenden Leerzeichen tritt auch in meiner Thunderbirdversion das Problem auf, dass die Rechtschreibung an einigen Stellen Wörter zur Hälfte als falsch geschrieben markiert. Da scheint es irgendeinen grundlegenden Formatierungsfehler in Thunderbird zu geben. Man kann beobachten, dass sich auch OCR-Software wie beispielsweise das Übersetzungsprogramm Babylon schwertut, die markierten Wörter trennscharf einzulesen.


    Ein weiteres - sehr ärgerliches - Phänomen: Versucht man nach dem Abfassen einer selbstgeschriebenen Mail oder bei der Antwort auf eine erhaltene Mail im Text Leerzeilen zu löschen - insbesondere am Anfang des Textes - geht regelmäßig die ganze Formatierung verloren und Thunderbird macht aus einen Text mit diversen Absätzen einen einzigen unübersichtlichen Textblock...


    Schade. Sonst ist Thunderbird ja ganz nett. Aber damit wird es für den nicht privaten Mailaustausch unbrauchbar...

  • Hallo 43vc5vft,


    auch wenn es mich nicht unmittelbar betrifft, stimme ich Dir nach wie vor zu, dass dies ein sehr unschöner bug ist. Du könntest jedoch mithelfen, einen Fix dafür zu bekommen. In dem zugehörigen, vom müllerpaul genannten bug steht z.B. schon seit Ende September:


    Zitat von ":Aryeh Gregor"


    Is this specific to forwarding in the mail client? Can anyone reproduce in, e.g., <http://www-archive.mozilla.org/editor/midasdemo/>?


    Also, can anyone reproduce in Thunderbird 24, which has bug 812638 fixed? This sounds like it might be related, because of the random useless font tags. Probably there's some other underlying bug here, but if the bug is no longer exposed in the most recent versions, this doesn't have to be prioritized.


    Das wäre die richtige Stelle, an der Du Deine Testresultate posten solltest. Die Helfer hier können den bug nicht beheben.


    Gruß


    Susanne


    @neiss: Wie man doch von einem fehlenden Leerzeichen zur Werbung gelangt. Naja, schauen wir mal auf die Uhr ... ;-)

  • Hallo graba,


    keine 15 Minuten und das, ohne dass ich den Meldebutton genutzt hätte - Respekt :-)


    Gruß


    Susanne

  • So , hallo erstmal,
    bin neu, was man mir nachsehen möge.


    Also ich habe viel geschrieben gesehen und dieses Thema wurde irgendwann Anfang ´13 eröffnet, wenn ich richtig sehe.
    Nun ist es März ´14 ich sehe aber keine Lösungsvorschläge zum Grundproblem.


    Die Symptomatik ist bei mir die gleiche , auf TB 24-0.3. auf OSX Maveriks.


    Hat jemand nun eine fundierte Ahnung wo der Fehler liegt oder wie man Ihn mit Blick auf eine Lösung bearbeitet?


    Schonmal vorab: Nein es liegt nicht am Keyboard oder einem Plugin. :mrgreen:


    Danke all den Fleißigen hier im Voraus

  • Hallo,

    Zitat

    Nun ist es März ´14 ich sehe aber keine Lösungsvorschläge zum Grundproblem.


    Nein, die können nur von den Entwicklern kommen, wie du ja siehst, sind unsere Möglichkeiten ausgereizt. Und die Priorität für dieses Problem scheint an unterster Stelle zu sein.
    Hier lesen auch keine Entwickler mit und der verlinkte Bugreport wird von viel zu wenig Usern unterstützt.
    Solche Sachen verlaufen oft im Sande.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw