Rechtschreibung mit deutschem Wörterbuch [erl.]

  • Thunderbird-Version: 17.0
    Betriebssystem + Version:Windows XP


    Das addon Deutsches Wörterbuch habe ich runtergeladen und in der Einstellung auch Sprache Deutsch ausgewählt. Trotz Neustart wird die Rechtschreibung mit dem engl. Wörterbuch getestet. Was mache ich falsch?
    segelboot

  • Hallo und willkommen im Forum!
    Wo hast du welche Sprachdatei heruntergeladen?
    Wie hast du die Sprache "umgeschaltet"


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Edit: Vollzitat gelöscht! Bitte zum Antworten die Buttons Antworten oder SchnellAntwort verwenden bzw. bei Einsatz des Buttons Zitieren nur das unbedingt Notwendige aufführen! Mod. graba


    danke für schnelle Antwort.


    Ich habe auf der Thunderbird-Seite das DE-Wörterbuch als neues addon heruntergeladen und dann auf der "Verfassen-Seite" unter "Extras" "Einstellungen" als Rechtschreibsprache: deutsch ausgewählt.
    Entschuldigung, wenn ich mich nicht richtig ausdrücke, aber ich mache das zum erstenmal selbst.
    Gruß segelboot

  • hallo, danke allen, die mir helfen wollen - Ich habe gerade was ausprobiert und habe die Lösung selbst gefunden: Im addon.Manager die Addon Engl und span.-Wörterbuch gelöscht. Jetzt ist nur noch das deutsche drin.
    Damit kann dieser Thread beendet werden-
    segelboot

  • Trotzdem kann man bei drei Sprachen im Verfassenfenster problemlos diese wechseln.
    Darum meine Frage: wie du sie wechseln wolltest.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    funktioniert der Button "Rechtschreibung" bei dir nicht (oder Rechts-Klick auf ein "falsch" geschriebenes Wort - -> Sprachen)?



    Bei Benutzung mehrerer fremdsprachlicher Wörterbücher empfiehlt sich der Gebrauch des Add-ons Dictionary Switcher 1.3.2, der die Rechtschreibprüfung automatisch auf die gerade benutzte Sprache umstellt. https://addons.mozilla.org/en-…ddon/dictionary-switcher/
    Zwei Voraussetzungen :
    die Wörterbücher müssen in der Kategorie "Erweiterungen" installiert sein und nicht in "Wörterbücher";
    die Einstellung "extensions.dictionary-switcher.autodetect" muss im Konfig Editor auf den Wert "true" umgeschaltet werden.

  • Hi,


    also, ich hab' mir auch das Addon heruntergeladen und alles funktioniert supi :flehan:
    xxxxxxxxxxxxxxxxxxxxxxx
    Ist für mich echt eine Erleichterung


    Viele Grüße
    Gerd


    Edit: Spam-Link wurde entfernt. Mod. graba

  • Hallo zusammen,


    ich hole mal den Thread wieder nach oben, da ich das gleiche Problem mit dem voreingestellten Wörterbuch (Deutsch) habe, das nach jedem Öffnen von TB immer wieder automatisch auf das Wörterbuch (Englisch) umgestellt wird. Das macht mich langsam richtig blöde und ich finde keine Lösung !!!!



    Das sind meine installierten Erweiterungen:



    Schon mal besten Dank für Eure Hilfe


    Micha

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490

    Einmal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Hallo Micha,


    eine schnelle Antwort, warum diese Probleme mit dem Wörterbuch bei dir auftreten, kann dir wohl niemand geben.
    Ich setze aber voraus, dass du alles, was in diesem Thread bereits geschrieben wurde, gelesen und auch umgesetzt hast. Eine Wiederholung dessen halte ich also nicht für erforderlich.


    Das einzige was mir auffällt ist, das du wohl zu den Weltmeistern bei der Installation von Add-ons zählst. Weniger ist oftmals mehr! Zumal sich nicht jedes Add-on unbedingt mit allen anderen verträgt. Deshalb fangen wir mit den Add-dons an.
    - Starte den TB im Safe-mode und deaktiviere sämtliche Add-ons
    - Lade dir hier: Wörterbücher für die Rechtschreibprüfung in Thunderbird das Wörterbuch runter und installiere es.
    - Teste den TB ohne Add-ons und nur mit dem installierten Wörterbuch.
    - poste uns das Ergebnis.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Zitat von "Peter_Lehmann"

    Hallo Micha,


    - Teste den TB ohne Add-ons und nur mit dem installierten Wörterbuch.
    - poste uns das Ergebnis.


    MfG Peter


    Hi Peter,


    habe nun TB nur mit dem engl. & dt. Wörterbuch gestartet, alle sonstigen Erweiterungen waren deaktiviert, Deutsch wurde in der Rechtsschreibung als Standard definiert. Nach Neustart war aber wieder Englisch als Standard definiert. Ich vermute und befürchte, dass aufgrund dieses Hinweises...


    http://www.rrze.uni-erlangen.d…mail/woerterbuecher.shtml


    Zitat


    In Mozilla Thunderbird ist standardmässig nur ein englisches Wörterbuch enthalten, auch in der deutschen Version. Die Rechschreibprüfung aber ist aktiviert, was zur Folge hat, dass wenn man in deutscher Sprache seine Mails verfasst, dort die Rechtschreibung beanstandet wird.


    immer wieder in den Tiefen des System voreingestellt wird.


    Gruß


    Michael

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490

  • Zitat von "Dinole"


    Hallo Michael,


    die von dir zitierte Aussage stimmt nicht. Ich habe mir eben die deutsche Version von TB herunter geladen und getestet.
    Im Gegensatz zu anderen Versionen, z.B der französischen), wird mit der deutschen Version überhaupt kein Wörterbuch installiert, weder ein deutsches noch ein englisches.
    Du hättest eigentlich eine Lösung schon in meinem obigen Beitrag finden können:
    http://www.thunderbird-mail.de…opic.php?p=331400#p331400


    Bei Benutzung der Rechtschreibprüfung mit mehreren Wörterbüchern empfiehlt sich das Installieren eines "Dictionary Switcher" Add-ons.
    Statt "Automatic dictionary switching" würde ich mal einen anderen Switcher testen.
    Du hast die Auswahl zwischen vier anderen "Switchern":
    • Dictionary Switcher for Thunderbird 1.1.5 https://addons.mozilla.org/fr/…nary-switcher-for-thunde/
    • Dictionary Switcher 1.3.2 https://addons.mozilla.org/fr/…ddon/dictionary-switcher/
    • Smart Dictionary Switcher 1.0 https://addons.mozilla.org/fr/…mart-dictionary-switcher/
    • Markov Dictionary Switcher 1.0 https://addons.mozilla.org/en-…rkov-dictionary-switcher/
    Wenn du diese Add-ons testest, denke daran, dass im Konfig-Editor die Einstellung "extensions.dictionary-switcher.autodetect" auf den Wert "true" umgeschaltet werden muss.
    Leider funktioniert die Autodetektion der geschriebenen Sprache durch diese Switchern nur mit Wörterbüchern, die in der Rubrik "Erweiterungen" installiert sind, und nicht in "Wörterbücher".
    Ich selber benutze seit Jahren den uralten Markov, der selbst in TB 17 noch funktioniert.


    Das TB-Add-on "Quick Locale Switcher" hat keinen Einfluss auf die Wahl des "spell checkers" und hat nur Sinn, wenn man mehrere "Sprach-Pakete" installiert hat, weil man TB nach Wahl in verschiedenen Sprach-Versionen benutzen will.


    Gruß

  • Zitat von "Mapenzi"


    Leider funktioniert die Autodetektion der geschriebenen Sprache durch diese Switchern nur mit Wörterbüchern, die in der Rubrik "Erweiterungen" installiert sind, und nicht in
    Gruß


    Genau das würde ich gerne wissen, wie das funktionieren soll. Ziehe das Add-On in die Erweiterungen, auftauchen tut es aber beim Wörterbuch.
    Das Englische Wörterbuch taucht bei den Erweiterungen auf, das Deutsche Wörterbuch dagegen bei den Wörterbüchern.


    Eigentlich war aber meine Frage, warum immer beim TB-Start automatisch das Englische Wörterbuch und nicht das voreingestellte Deutsche Wörterbuch angewendet wird.


    Was Deinen Beitrag betrifft


    Zitat von "Mapenzi"


    Du hättest eigentlich eine Lösung schon in meinem obigen Beitrag finden können:
    viewtopic.php?p=331400#p331400


    kann ich schon zwischen den beiden Sprachen wählen, aber wie gesagt, es ist Anfangs immer Englisch

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490

  • Zitat von "Dinole"


    Genau das würde ich gerne wissen, wie das funktionieren soll. Ziehe das Add-On in die Erweiterungen, auftauchen tut es aber beim Wörterbuch.
    Das Englische Wörterbuch taucht bei den Erweiterungen auf, das Deutsche Wörterbuch dagegen bei den Wörterbüchern.


    Die neuesten Versionen der Wörterbücher werden fast alle standardmäßig in "Wörterbücher" installiert, so z.B. auch der "German Dictionary 2.0.3" https://addons.mozilla.org/en-…/addon/german-dictionary/ (den ich benutze).
    Es gibt aber einen Trick, um diese Versionen in "Erweiterungen" zu installieren:
    im Beispiel des German Dictionary 2.0.3, die Datei "german_dictionary-2.0.3-fn+fx+sm+tb.xpi" dekomprimieren", die install.rdf-Datei in einem Text-Editor öffnen, die 7. Zeile <em:type>64</em:type> entfernen, die Änderung sichern, den Ordner "german_dictionary-2.0.3-fn+fx+sm+tb" und die install.rdf-Datei gleichzeitig markieren und die beiden zusammen komprimieren.
    Die resultierende Archiv.zip-Datei umbenennen in german_dictionary-2.0.3-fn+fx+sm+tb.xpi.
    Das so modifizierte Add-on wird automatisch in den Erweiterungen installiert.


    _____

    ______


    Zitat

    Eigentlich war aber meine Frage, warum immer beim TB-Start automatisch das Englische Wörterbuch und nicht das voreingestellte Deutsche Wörterbuch angewendet wird.


    Das kann ich auch nicht erklâren. Eigentlich sollte ja das zuletzt benutzte WB memoriert werden.
    Aus diesem Grunde benutze ich schon lange einen Dictionary Switcher, der die geschriebene Sprache nach ungefähr 4 bis 6 Wörtern "erkennt" und automatisch das zugehörige WB wählt!
    Ich brauche es also nicht mehr manuell selber das WB zu wechseln, und das funktioniert auch, wenn ich innerhalb einer Nachricht mehrfach die Sprache wechseln muss.

  • Zitat von "Mapenzi"


    Es gibt aber einen Trick, um diese Versionen in "Erweiterungen" zu installieren:
    im Beispiel des German Dictionary 2.0.3, die Datei "german_dictionary-2.0.3-fn+fx+sm+tb.xpi" dekomprimieren", die install.rdf-Datei in einem Text-Editor öffnen, die 7. Zeile <em:type>64</em:type> entfernen, die Änderung sichern, den Ordner "german_dictionary-2.0.3-fn+fx+sm+tb" und die install.rdf-Datei gleichzeitig markieren und die beiden zusammen komprimieren.
    Die resultierende Archiv.zip-Datei umbenennen in german_dictionary-2.0.3-fn+fx+sm+tb.xpi.
    Das so modifizierte Add-on wird automatisch in den Erweiterungen installiert.


    Vielen Dank, habe ich so gemacht, Wörterbuch taucht nun in den Erweiterungen aber leider nicht als WB an sich auf.


    Ich glaube, hier ....


    den Ordner "german_dictionary-2.0.3-fn+fx+sm+tb.???" und die install.rdf-Datei gleichzeitig markieren und die beiden zusammen komprimieren.
    Die resultierende Archiv.zip-Datei umbenennen in german_dictionary-2.0.3-fn+fx+sm+tb.xpi.


    liegt der Wurm begraben.


    Vielen Dank


    Michael

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490

  • Zitat von "Dinole"


    Vielen Dank, habe ich so gemacht, Wörterbuch taucht nun in den Erweiterungen aber leider nicht als WB an sich auf.


    Ich verstehe nicht was du mit "aber leider nicht als WB an sich" meinst.
    Ein WB, das in der Rubrik "Erweiterungen" installiert ist, bleibt ein Wôrterbuch.
    Schließlich wurden bis vor kurzem noch alle WB in dieser Rubrik installiert.
    Willst du sagen, dass das WB German Dictionary 2.0.3 nach dieser Manipulation bei dir nicht funktioniert?
    I

    Zitat

    ch glaube, hier ....
    den Ordner "german_dictionary-2.0.3-fn+fx+sm+tb.???" und die install.rdf-Datei gleichzeitig markieren und die beiden zusammen komprimieren.
    Die resultierende Archiv.zip-Datei umbenennen in german_dictionary-2.0.3-fn+fx+sm+tb.xpi.


    Dazu kann ich im Augenblick nichts sagen, das hängt von meiner oben gestellten Frage ab, was "aber leider nicht als WB an sich" bedeutet.
    Wenn beim Zurück-Komprimieren zur .xpi-Datei etwas schief gelaufen wäre, hättest du das WB gar nicht installieren können.


    Vielleicht habe ich mich nicht recht verständlich gemacht:
    ich will dir bei deinem kleinen Problem mit der Rechtschreibprüfung helfen, damit du nicht jedes Mal manuell das WB wechseln musst.
    • Dazu habe ich geraten, eines der Dictionary Switcher Add-ons zu installieren, die die geschriebenen Wörter analysieren und automatisch das entsprechende WB zur Rechtschreibprüfung anwählen.
    Wenn du einen der von mir vorgeschlagenen Dictionary Switcher testest, musst du aber zuvor das Add-on "Automatic dictionary switching 1.5.0" deaktivieren oder deinstallieren.
    • All diese Dictionary Switcher arbeiten bisher aber nur mit WB, die in "Erweiterungen" installiert sind, und noch nicht mit denen, die sich in "Wörterbücher" befinden.
    • Deshalb habe ich die Anleitung dazu gegeben, wie man die install.rdf-Datei abändern kann, um die jüngsten Versionen der WB in "Erweiterungen" zu installieren statt in "Wörterbücher", wo sie jetzt in der Regel standardmäßig von TB installiert werden.

  • Hallo,


    ich Danke Dir vielmals für Deine Hilfe und habe alles so umgesetzt, wie es von Dir vorgeschlagen wurde, das sind:


    Datei umgewandelt
    Wörterbuch wurde unter "Erweiterungen" installiert
    "About:Config-Eintrag" wie gefordert..





    aber leider kann das "Deutsche Wörterbuch" nicht ausgewählt werden, es ist nur das "Englische Wörterbuch" auswählbar.



    Ich bin leider hiermit mit meinem Latein am Ende.


    Vielen Dank


    Michael

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490

  • Hallo,
    Frage zur Info:
    Steht denn das deutsche Wörterbuch in der Kategorie "Erweiterungen"? Das kann man auf der Abb. nicht genau erkennen. Wenn es nicht dort steht, kann der Switcher auch nicht funktionieren.
    Übrigens funktionieren der Markov-Switcher und Dictionary-Switcher einwandfrei - mit 3 Sprachen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    ja, nach der Modifikation der ursprünglichen XPI-Datei, steht das Deutsche Wörterbuch unter den "Erweiterungen".
    Ohne Modifikation stand das unter der Rubrik "Wörterbücher".


    Ich habe bestimmt einen Fehler bei der Komprimierung der überarbeiteten Datei gemacht, ich weiß aber nicht welchen !


    Übrigens, wenn ich den Markov-Switcher installieren will wird mir eine Inkompatibilität mit TB 17.0.7 angezeigt.


    Viele Grüße


    Michael

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490

  • Zitat von "Dinole"


    Hallo,


    Hallo,
    als Spätaufsteher komme ich erst jetzt wieder ins Forum ;)
    @ mrb: vielen Dank für deine schnelle Hilfeleistung!

    Zitat

    ja, nach der Modifikation der ursprünglichen XPI-Datei, steht das Deutsche Wörterbuch unter den "Erweiterungen".


    Da steht es doch am richtigen Platz, damit ein dictionary Switcher wie Markov-Swicher darauf zurück greifen kann.
    Somit hast den "Hack" in der WB-Datei richtig durchgeführt! ;)

    Zitat

    Ohne Modifikation stand das unter der Rubrik "Wörterbücher".


    Normal, das ist die Default-Rubrik für die neuesten WB !

    Zitat

    Übrigens, wenn ich den Markov-Switcher installieren will wird mir eine Inkompatibilität mit TB 17.0.7 angezeigt.


    TB verweigert, ältere "nicht kompatible" Add-ons zu installieren.
    Das kann man ganz leicht umgehen indem man zunächst das Add-on "Disable Add-on Compatibility Checks 1.3" installiert: https://addons.mozilla.org/fr/…addon/checkcompatibility/
    Das ist zwar noch ein Add-on mehr, aber ein nützliches.
    Dafür kannst den den "Add-on Compatibility Reporter" raus werfen, der in den neueren Versionen von TB (und FF) für die Nutzer keinen Vorteil mehr bringt.


    Nach Installierung von "Disable Add-on Compatibility Checks" akzeptiert TB auch das Installieren des Markov-Switcher!
    Jetzt brauchst du nur noch in den Einstellungen des Markov-Switcher alle Sprachen anzuhaken, deren WB du installiert hast.
    Der Switcher wählt dann beim Schreiben in einem Verfassen-Fenster automatisch das entsprechende WB zur Rechtschreibprûfung aus.



    Du kannst meine kleine Vidéo betrachten, in der man in Echtzeit sieht, wie der Markov-Switcher die Sprache zur Rechtschreibprüfung wechselt:
    http://s1274.photobucket.com/u…rkov_zpsdb241dad.mp4.html

  • Hallo zusammen,


    Danke für Eure Hilfestellung, "Mapenzi", Deine letzten Hinweise habe ich umgesetzt und das ist das Ergebnis :nixweiss: Es wird einfach nicht das Deutsche WB gefunden :flop:



    Danke


    Michael

    Viele Grüße


    Michael


    Win 8.1 * 64 & Win 7 * 64 / AV & FW Norton Security 22.12.0.104
    pop.1und1.de:995 SSL/TLS Passwort, normal
    smtp.1und1.de:587 STARTTLS Passwort, normal true

    FRITZ!Box 7490