Anhang einfügen und Thunderbird hängt sich auf

  • Thunderbird-Version: 17.02
    Betriebssystem + Version: Windows Server 2003 SP2
    Kontenart (POP / IMAP): IMAP


    Hallo,


    ich habe ein wahrscheinlich nicht einfach zu lösendes Problem.
    Installiert war Thundebird 2. Nach dem Auftreten des Problems auf 11er Version geupdated. Selbes Problem. Aktuell auch mit der neuesten 17.02 gestestet.
    Thunderbird hängt nach dem Einfügen einer Datei als Anhang für ca. 5 - 10 min. Danach ist das Verfassen Fenster wieder normal benutzbar, bis eventuell ein erneuter Anhang einen weiteren "Hänger" verursacht. Dazu ist zu sagen, dass ab und zu Anhänge ohne Hänger hinzugefügt werden können, aber kein Muster oder bestimmter Dateityp erkennbar.
    Ich kann leider nicht genau sagen was am System geändert wurde, als dieses Problem auftrat.
    Vermutlich ist der Virenscanner ESET file security verantwortlich, da er sich in Thunderbird einklingt.
    Folgendes habe ich schon getestet:


    - Safe Modus
    - neues Profil
    - als Admin arbeiten
    - Ereignisanzeige durchsehen
    - Virenscanner Eset file security deinstalliert


    Ich könnte noch den abgesicheren Modus von Windows probieren.
    Eine Neuistallation wäre sehr aufwendig und soll eigentlich verhindert werden.


    Vielleicht hat jemand eine Idee, was man noch testen könnte. :help:


    Mit freundlichen Grüßen
    gigathunder

  • Hallo,

    Zitat

    Vermutlich ist der Virenscanner ESET file security verantwortlich, da er sich in Thunderbird einklingt.


    Ja, der stände bei mir an oberster Stelle der Verursacher.
    Auch eine Überprüfung im safe-mode wäre sinnvoll:
    In TB > Hilfe > "Mit deaktivierten Add-ons neu starten" und den Button "Im abgesicherten Modus weiterarbeiten" verwenden oder Start mit gedrückter Umschalt-Taste.
    Dann:
    Vielleicht hilft es auch, in der erweiterten Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten") den Eintrag mail.compose.attach.dir mit Rechtsklick zurückzusetzen und TB neu zu starten.
    Wenn das abgehakt ist, kann ich mir außer einem Rechte-Problem eigentlich nur Sicherheitssoftware als ursächlich vorstellen.
    Wir hatten das Thema schon ein paar Male.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    vielen Dank für die schnelle Nachricht.
    Ich habe alles probiert und nichts hat geholfen.


    Gegen den Tip mit der Compose-Dir spricht, dass ja zufällig manche Anhänge gehen und dann nur ab und zu ein Hänger auftritt.


    Ich habe noch folgendes probiert:


    ESETUninstaller hat die letzten "Zuckungen" der bisher installierten Virenscanner (das war NOD und Eset file security) entfernt.


    Eset file security integriert sich in Thunderbird bis Version 5. Das habe ich damals bei der installation auch ausgewählt (hab ich nachgelesen im Install-Log) - es war ja noch Version 2 von Thunderbird drauf.
    Eventuell wurde da irgendwas installiert, was zurückgeblieben ist bei dem Update auf Thunderbird 11 bzw. 17.


    Kann ich Version 5 über die 11er installieren, sodass das Plugin wieder aktiv wird?
    Kann mir diese jemand per PN zukommen lassen?


    Interessant ist noch, dass im Taskmanager bei dem Hänger der Leerlaufprozess auf 99 ist.
    Im Abgesicherten Modus von Windows war zusätzlich bei den Anwendungen noch ein Eintrag für das Anhängen vorhanden, was im normalen Modus nicht der Fall ist. Aber auch im abgesicherten Modus war bei dem Hänger der Leerlaufprozess auf 99.


    Vielleicht hat ja doch noch jemand eine Idee, was man noch tun könnte.


    Mit freundlichen Grüßen
    gigathunder

  • OK, dann bleibt dir nur der Weg über ein neues Profil mit zunächst über ein einziges Konto.
    Überprüfe das Verhalten dort.
    Klappt es dort, bleibt dir die Migration aus dem alten Profil nicht erspart.
    Davor deaktiviere in ESET alle Maßnahmen, die Mails und das TB-Profil betreffen und mache einen Systemneustart.
    Mailprogramme und Sicherheitssoftware sind niemals Freunde und eine spezielle Konfiguration ist unabkömmlich.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo Leute.


    Ich habe ein ähnliches Problem. (TB fiert ein wenn ich Anhang anklemmen will)


    Dies tut er allerdings schon wenn ich TB frisch installiere. Ich hab vorher TB gelöscht sowie auch den kompletten Thunderbird Ordner welches das Profil beinhaltete.


    Sobald er das Fenster öffnen soll passiert... nix.
    Freeze.


    Mara

  • Hallo,
    und welche Sicherheitssoftware hast du, die das TB-Profil abscannt?

    Zitat

    Ich hab vorher TB gelöscht sowie auch den kompletten Thunderbird Ordner


    Das heißt, du musstest beim Neustart deine Konten und Einstellungen alle neu machen?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Edit: Vollzitat gelöscht! Bitte zum Antworten die Buttons Antworten oder SchnellAntwort verwenden bzw. bei Einsatz des Buttons Zitieren nur das unbedingt Notwendige aufführen! Mod. graba



    Das war der Grund. Ich wollte mit komplett leerem neuem Profil usw das ganze Testen. Ergebnis war das selbst bei frisch install das selbe Problem besteht.


    AV Soft auf der Kiste ist nach wie vor MS Security Essentials 4. War auch vorher als es noch klappte drauf... Ist nix verändert worden.


    Mara

  • Zitat

    AV Soft auf der Kiste ist nach wie vor MS Security Essentials 4. War auch vorher als es noch klappte drauf... Ist nix verändert worden.


    Das heißt auf Computern nichts. Es genügt eine Softwareänderung bei einem der Programme und es läuft nicht mehr wie es sollte.
    Du musst der Software das Abscannen des TB-Profils verbieten und überprüfen, ob durch das Tool nicht die Servereinstellungen in TB verändert wurden.
    Nach der Änderung einen Systemneustart machen. Noch besser wäre es, die Sicherheitssoftware testweise ganz auszuschalten und den Vorgang in Thunderbird wiederholen. In dieser Zeit brauchst du ja nicht ins Internet gehen und lässt deinen Browser geschlossen.


    Profile verwalten (Anleitungen)


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Edit: Vollzitat gelöscht! Bitte zum Antworten die Buttons Antworten oder SchnellAntwort verwenden bzw. bei Einsatz des Buttons Zitieren nur das unbedingt Notwendige aufführen! Mod. graba



    Ich hatte den Scanner bereits abgeschaltet. (Das war einer der ersten Ideen)


    Das TB Profil hat imho aber nichts damit zu tun das das Window sich einfach nicht öffnet. Meine Vermutung ist das irgendeine Runtime auf der TB basiert ein Update erfahren hat und deswegen nichts mehr geht. (Win7 32bit)


    Zumal ich extra TB komplett gelöscht hatte mit seinen erstellten Ordnern im USER dir als auch nach neu install (und start mit leerem neuen Profil) das selbe Problem noch immer vorhanden war. (bzw ist)


    Daher bin ich etwas ratlos.


    Edit: Das ausschliessen sowohl des TB Folders als auch des USer dirs von TB hat keinen erfolg gebracht.



    Mara

  • Hattest du den AV komplett deaktiviert und danach einen Windows-Neustart gemacht?

    Zitat

    Zumal ich extra TB komplett gelöscht hatte mit seinen erstellten Ordnern im USER dir


    TB legt zwei verschiedene Profilordner an, welchen Pfad genau meinst du?


    Du hattest TB mit einem neu heruntergeladenen Installer neu installiert?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Folgendes habe ich nun ausgeführt:


    1. Thunderbird 17 deinstalliert
    2. Thunderbird 5 (weil dort noch das Eset Plugin funktionieren sollte) installiert in einem neuen Verzeichnis.
    3. Thunderbird als Admin gestartet und neues Profil angelegt.
    -> keine Probleme mehr :o)


    4. Als Benutzer angemeldet und Thunderbird gestartet
    -> altes Profil wurde genommen -> Probleme
    5. neues Profil als Benutzer erstellt -> Probleme


    Bei Admin und bei Benutzer sind jeweils keine Plugins und auch keine Addons aktiviert. Das Eset-Plugin taucht nicht auf, man kann es also nicht aktivieren ohne die Software zu reinstallieren.


    Der Unterschied zwischen Admin und Benutzer:
    Bei den Anhängen wird beim Admin kein Dateisymbol angezeigt!
    Beim Benutzer hingegen schon!


    Wenn nun noch einen Tipp hat wie ich als Benutzer auch wieder normal arbeiten kann dann her damit.


    MFG


    gigathunder

  • Zitat

    Wenn nun noch einen Tipp hat wie ich als Benutzer auch wieder normal arbeiten kann dann her damit.


    Das kann ich leider nicht, da ich seit geraumer Zeit, nämlich nach der Septemberausgabe von c't , mir keine eingeschränkten Benutzerkonten mehr antue, ist mir zu lästig und hilft eigentlich nur bei Mehrbenutzerverwendung.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:


    Das kann ich leider nicht, da ich seit geraumer Zeit, nämlich nach der Septemberausgabe von c't , mir keine eingeschränkten Benutzerkonten mehr antue, ist mir zu lästig und hilft eigentlich nur bei Mehrbenutzerverwendung.
    Gruß


    Ich habe es auch gelesen und war sehr enttäuscht. Im Grunde haben Sie seit vielen Jahren nur EINE Lücke für Kafu (Keine Autostarts für User) gefunden. Leider entwickeln sie es nicht weiter.


    Ich werde mal ein neues Windows Profil anlegen. Das wäre noch eine Idee. Als Admin arbeiten ist die Notlösung.


    Jippi, mit dem neuen Profil funktioniert nun das Anhängen auch wieder mit normalen Benutzerrechten.

  • Hallo,


    seit gestern tritt das Problem wieder auf.
    Ein Unterschied besteht darin, dass vor den Datei-Anhängen das Dateisymbol angezeigt wird. Das war die letzte Zeit, als sich Thunderbird nicht aufhing nicht der Fall.


    Testweise wollte ich mit dem Webmailer arbeiten und stelle mit Erstauen fest, dass der Firefox beim Auswählen einer Datei für das Hochladen ebenfalls hängt.


    Mit dem Prozess Explorer habe ich herausgefunden, dass in beiden Fällen folgendes Auftritt:


    Die ntdll.dll ist in beiden Fällen an der Adresse 0x39efb im Status State:Wait:DelayExecution
    Die ContextSwitches steigern sich kontinuierlich über 10000. CPU Auslastung ist 0.
    In diesem Zustand hängt Thunderbird und Firefox.


    Anschließend geht der Status in Wait:WrQueue über und der Anhang ist eingefügt.


    Vieleicht hat jemand eine Idee, was man machen könnte oder in welchem Forum / Newsgroup man Hilfe bekommen könnte.


    Mit freundlichen Grüßen


    gigathunder

  • Ich habe noch einmal den ProcessExplorer benutzt um den DLL Stack anzuzeigen.
    Dabei war immer die PDFShell.dll.
    Nach Deinstallation des Acrobat Readers (aktuellste Version) tritt das Problem nicht mehr auf. :o)