Der angegebene Ordner ist zum Abspeichern von Nachrichten...

  • Hallo Wolfgang,


    wenn der oben angeführte Lösungsweg bei Dir wirklich nicht funktioniert, dann existieren vielleicht neben den o.g. Pfadangaben in Deiner pref.js noch weitere Verweise auf ungültige Pfade und unterliegen nun der Überprüfung. Manche Erweiterungen hinterlassen dort ja auch ihre Spuren.


    Die prefs.js solltest Du aber nur anfassen, wenn Du genau weißt, was Du tust. Schnell ist ein Wert geändert oder gelöscht, dessen Auswirkung man nicht sofort sondern erst nach Wochen spürt. Wie diese besagten Werte z.B., die sich in diesem Fall erst nach Jahren bemerkbar machten.


    Mein Rat dazu: teste mit einem neuen Profil.


    Gruß


    Susanne

  • Quote from "graba"

    Hallo Wolfgang, [So viel Zeit sollte sein!]
    willkommen im Thunderbird-Forum!


    Hast du dich auch mit dem Nachtrag von Mapenzi beschäftigt?
    :arrow: Re: Der angegebene Ordner ist zum Abspeichern von Nachrichte


    Hatte ich gesehen, konnte ich aber nichts mit anfangen außer zurücksetzen. Und das hat bei mir ja nicht leider geklappt.
    Leider habe ich bei Mapenzi keine andere Lösungsmöglichkeit rausgelesen?!
    Gruß
    Wolfgang

    Edited once, last by Eisbaer2 ().

  • Quote from "SusiTux"

    Hallo Wolfgang,
    ...
    Mein Rat dazu: teste mit einem neuen Profil.
    Gruß
    Susanne


    Hallo Susanne,
    danke für den Rat. Genau den Aufwand wollte ich vermeiden, da hängt ja doch ziemlich viel am Profil, alleine die ganzen Kontoeinstellungen, Filterregeln, gelernte SPAMs,...
    Mal sehen, ob sich noch was Konkreteres ergibt.
    Danke & Gruß
    Wolfgang

  • Quote from "Eisbaer2"


    Hatte ich gesehen, konnte ich aber nichts mit anfangen außer zurücksetzen. Und das hat bei mir ja nicht leider geklappt.
    Leider habe ich bei Papenzi keine andere Lösungsmöglichkeit rausgelesen?!


    Hallo,


    ich habe in dem bewussten Beitrag keine Lösung vorgeschlagen, denn diese wurde ja von TGIF gefunden und öffentlich gemacht.
    In meinem Nachtrag habe ich lediglich versucht zu erklären, wann und warum diese Fehlermeldung in der neuesten Version von TB erscheinen kann.
    Vielleicht hast du versucht, den Pfad zum lokalen Ordner des Nachrichtenspeichers umzustellen auf einen Ordner, der von TB 24 als dafür nicht geeignet angesehen wird?


    Gruß

  • Quote from "Mapenzi"


    Hallo,
    ich habe in dem bewussten Beitrag keine Lösung vorgeschlagen, denn diese wurde ja von TGIF gefunden und öffentlich gemacht.
    In meinem Nachtrag habe ich lediglich versucht zu erklären, wann und warum diese Fehlermeldung in der neuesten Version von TB erscheinen kann.
    Vielleicht hast du versucht, den Pfad zum lokalen Ordner des Nachrichtenspeichers umzustellen auf einen Ordner, der von TB 24 als dafür nicht geeignet angesehen wird?
    Gruß


    Hallo Mapenzi,
    danke für deine Antwort.
    Weisst du (oder jemand anderes) denn, welche Kriterien einen Ordner auszeichnen, "geeignet" zu sein? (oder eben das Gegenteil: "nicht geeignet" zu sein)?
    Gruß
    Wolfgang

  • Hallo Wolfgang,


    Quote from "Eisbaer2"

    Genau den Aufwand wollte ich vermeiden ...


    Ja, das klassische Problem - der Mensch ist bequem. Darauf trifft man hier immer wieder. Oftmals kann ich das nicht wirklich verstehen. Klar, wer macht sich schon gern Arbeit. Andererseits stellt sich immer die Frage, was am Ende mehr Aufwand bedeutet, einmal g'scheit oder dreimal g'schlampert?


    Die Ursache für das Problem scheint recht eindeutig zu sein: Die Entwickler haben aufgrund des o.g. bugs eine Überprüfung auf "verbotene" Pfade eingeführt, dabei aber offenbar nicht bedacht, dass Altlasten in der prefs.js vorhanden sein können, wie z.B. die ungültigen, verwaisten Pfadangaben, die TGIF gefunden hat.
    Solche Altlasten scheinen in Deinem Profilordner auch vorhanden zu sein. Um das zu überprüfen, schlug ich vor, zunächst testweise ein neues Profil anzulegen. Das dauert nur wenige Minuten.


    Ich bin mir ziemlich sicher, dass sich das Problem damit erledigen wird. Somit hast Du natürlich Recht, letzendlich würde dann der Aufwand, das Profil komplett einzurichten, auf Dich zukommen. Doch auch das hält sich in Grenzen. Die E-Mails, die Adressbücher und auch Training.dat kannst Du aus dem alten Profil übernehmen.


    Du kannst natürlich auch warten, bis jemand noch andere solcher alten Einträge in seiner pref.js findet oder selbst danach in deiner suchen. Nur, ob sich das mit Deinen "Leichen" deckt oder Du gar am Ende noch mehr Schaden anrichtest, lässt sich nicht vorhersagen.




    Gruß


    Susanne


    P.S.: Ganz vergessen. Zur Übernahme der Daten (also der E-Mails etc.) findest Du im Forum und in den Anleitungen Hinweise.

    Edited 2 times, last by SusiTux ().

  • Quote from "Eisbaer2"

    Genau den Aufwand wollte ich vermeiden, da hängt ja doch ziemlich viel am Profil, alleine die ganzen Kontoeinstellungen, Filterregeln, gelernte SPAMs,...
    Mal sehen, ob sich noch was Konkreteres ergibt.
    Danke & Gruß
    Wolfgang


    Hallo Wolfgang,
    Leg doch ein neues Profil an und übernimm alle Dateien aus dem alten. Damit kannst du dann gefahrlos alles ausprobieren (Zurücksetzen in der Konfigurationsdatei). Wenn es nicht klappt, löschst du das Profil, wenn es klappt, kannst du das alte löschen.
    Ich habe in meiner Konfigurationsdatei noch verschiedene andere veraltete Ordner gefunden und gleich mit zurückgesetzt.


    Gruß
    Naomi

  • Hallo Zusammen,


    ich habe genau das gleiche Problem. Ich habe heute eine Backup mit MozBackUp 1.5.1 durchgeführt. Danach habe ich ein älteres Backup, welches ich mit einer Thunderbirdversion 17.0.7 durchführte zurückgespielt. Ich hatte etwas in Nachrichten gesucht, die ich in der Zwischenzeit gelöscht hatte. Danach habe ich richtig viel Schwierigkeiten gehabt als ich einfach wieder die aktuelle Sicherung, die ich also heute durchgeführt hatte, wieder zurückgespielt habe. Nichts klappte mehr, z. B. waren die Einstellungen für meinen Mailserver, die der Provider zwischenzeitlich geändert hatte, nicht mehr da.


    Daher habe ich mich dann entschlossen im Ordner APPData\Roaming\Thunderbird\Profiles die Unterordner zu löschen. Ich habe mich schon gewundert wieso da mehrere Ordner zu finden sind obwohl ich nur ein Defaultprofile habe.


    Also nachdem ich also die Profile gelöscht hatte habe ich die Sicherung wieder zurückgespielt. Zum Test habe ich dann eine Email an mich selber geschickt, das hat geklappt und der Empfang hat auch geklappt. Auch war jetzt unter APPData\Roaming\Thinderbird\Profiles nur ein Profil vorhanden. Dann bin ich aber unter Email-Einstellungen gegangen und bekomme den nun hier schon vielfach zitierten Fehler. Danach war ein 2. Profil unter AppData\Roaming\Thunderbird\Profiles da.


    Wieso wird da jetzt ein 2. Profil erstellt?


    Wenn ich dieses jetzt angebe, weil ja angeblich unter dem anderen nicht gespeichert werden kann, sind alle meine eingehenden und ausgehenden Emails weg.


    Ich verstehe es nicht.

  • So, ich habe es jetzt pragmatisch gelöst.


    In der profile.ini habe ich den neu entstandenen Profilnamen angeben. Wieso aber Thunderbird einen neuen Profilordner anlegt ist mir ein Rätsel. Natürlich habe ich dann alle Daten manuell (Windows Explorer) aus dem alten Profil in das neue Profil kopiert. Den Ordnernamen des alten Profils habe ich mal geändert und anschließend Thunderbird gestartet.


    Jetzt kann ich die Einstellungen editieren.
    Mail Empfang und Versand klappt auch.


    Den alten Ordner habe ich jetzt gelöscht.


    SELTSAM - das alles

  • Windows 7 32bit mit SP 1, Thunderbird 24.0


    Ich kann die Problemlösung von „ratsuchend“ bestätigen. Thunderbird legt offensichtlich bei jeder Neuinstallation einen neuen Profilordner an. In der profiles.ini (unter Windows 7 hier zu finden: C:\Users\[Benutzername]\AppData\Roaming\Thunderbird) kann man den Pfad zum bisherigen Profil angeben. Hier als Beispiel mein Eintrag:


    Code
    [General]
    StartWithLastProfile=0
    [Profile0]
    Name=default
    IsRelative=0
    Path=E:\Programme\Internet\Mozilla Thunderbird\Profiles\[profilname].default


    StartWithProfile=0 ist standardmäßig auf 1 gesetzt, was aber zur Folge hat, dass die Zeile mit der Pfadangabe gar nicht ausgelesen wird (wenn ich es richtig beobachtet habe).


    An der pref.js musste ich gar nicht rumfummeln, die Änderung der INI-Datei genügte.


    Wichtig: vor allen Änderungen immer eine Datensicherung machen. Unter Windows geht es am einfachsten mit MozBackup.

  • Hallo,
    willkommen im Thunderbird-Forum!

    Quote from "Torsten-Kelsch"

    Unter Windows geht es am einfachsten mit MozBackup.


    Wir empfehlen nicht MozBackup, da schon etliche User Probleme damit meldeten.
    :arrow: Backup-Alternativen:
    - Eine Sicherung (Backup) Ihres Profils erstellen
    - Personal Backup von Rathlev
    - Regelmäßige Profilsicherung - einfach gemacht ...

  • Hallo ratsuchend und Torsten-Kelsch,


    ich möchte euren Enthusiasmus ja ungern enttäuschen. Ihr bringt hier einiges durcheinander und macht es damit anderen Hilfesuchenden unnötig schwer.


    Ursache und Lösung des hier ursprünglichen Problems sind weiter oben geschildert. Eine Lösungsmöglichkeit - die m.E. bessere, weil sicherere - ist das Anlegen eines neuen Profils. Genau das habt ihr gemacht. Somit ist es nicht weiter verwunderlich, dass diese Lösung bei euch funktioniert hat :-)


    Auch dies:


    Quote from "Torsten-Kelsch"

    An der pref.js musste ich gar nicht rumfummeln, die Änderung der INI-Datei genügte.


    ergibt sich daraus. Neues Profil - neue prefs.js


    Quote from "Torsten-Kelsch"

    Thunderbird legt offensichtlich bei jeder Neuinstallation einen neuen Profilordner an.


    TB legt normalerweise nur dann ein Profil an, wenn er kein bestehendes findet. Was bei Dir dazu geführt hat, dass mehrere Profile vorhanden waren, kann ich Dir mit den wenigen Informationen nicht sagen. Aber es hat nichts mit dem in diesem Thread behandelten Problem zu tun und verwirrt m.E. nur. Besser Du machst dafür einen eigenes Thema auf.


    Und bitte nehmt euch den Hinweis von graba zu Herzen. Ihr könnt ja mal in diesem Forum nach mozbackup suchen. Ich weiß nicht, ob der Abend reicht, alle damit verbundenen Problemmeldungen zu lesen.


    Gruß


    Susanne

  • Hallo,


    wollte nur mitteilen das ich genau das gleiche Problem auf 2 Computer habe.


    Habe folgendes festgestellt: Wenn man auf "Verfassen" klickt, dann kann ich bei mir die Konteneinstellungen
    ändern.


    Vielleicht hilft dies bei der Fehlerursache?


    Mit freundlichen Grüßen
    hajue1234


  • DANKE TGIF
    genau das hat bei mir das Problem auch gelöst ohne das ich neues Profil anlegen musste und so.
    Eigentlich war ich hier noch nicht angemeldet im Forum, aber da mir das so schnell geholfen hat, war ich euch ein Dankeschön schuldig.


    DANKE!

  • Hi!


    Also das Bereinigen der prefs.js hat bei mir nix gebracht.
    Also muss ich jetzt ein neues Profil erstellen und alles übertragen?


    Danke, Gruß
    MK

  • Hallo,


    Kannst du die verbliebenen "mail.root..."-Pfade deiner prefs.j-Datei hier einstellen und gleichzeitig den Namen deines TB-Profils angeben, damit wir vergleichen können?


    Quote

    Also muss ich jetzt ein neues Profil erstellen und alles übertragen?


    Nicht unbedingt, auf jeden Fall nicht sofort.
    Es gibt außerdem die Möglichkeit, auf die Version TB 17.0.9esr zu wechseln.


    Gruß

  • Danke für deine schnelle Antwort!


    Code
    user_pref("mail.root.none", "E:\\Sonstiges\\Thunderbird\\Mail");
    user_pref("mail.root.none-rel", "[ProfD]Mail");


    In der profiles.ini steht:

    Code
    [Profile0]
    Name=Markus
    IsRelative=0
    Path=E:\Sonstiges\Thunderbird


    Gruß
    MK

  • Laut dem Profilpfad in deiner profiles.ini-Datei hast du deinen Profilordner auf das externe Laufwerk E kopiert und in "Thunderbird" umbenannt, danach den Profilpfad geändert oder ein neues Profil erstellt und E:\Sonstiges\Thunderbird angewählt. Eigentlich alles OK soweit.

    Quote from "ähM_Key"
    Code
    user_pref("mail.root.none", "E:\\Sonstiges\\Thunderbird\\Mail");
    user_pref("mail.root.none-rel", "[ProfD]Mail");


    TB 24 prüft nur dann die Pfade zu den lokalen Nachrichtenspeichern, wenn sich der Profilordner an seiner Standardlokalisation befindet, z.B. C:\Users\username\AppData\Roaming\Profiles\ unter den neueren Windows-Versionen, aber nicht, wenn dieser an einen anderen Ort verschoben wurde, was bei dir der Fall ist.
    Mir ist nicht ganz klar, warum du immer noch die Fehlermeldung bekommst, denn der Pfad "mail.root.none" zum Nachrichtenspeicher von "Local Folders" (= "none") erscheint mir korrekt.
    Wenn du ein POP-Konto hast, müsste der entsprechenden "mail.root.pop3"-Pfad genau so gelautet haben.


    An deiner Stelle würde ich einfach von der prefs.js-Datei, so wie sie jetzt ist, eine Sicherungskopie machen, dann im Original bei beendetem TB die Zeile user_pref("mail.root.none", "E:\\Sonstiges\\Thunderbird\\Mail"); löschen und TB neu starten.
    Statt sie in der prefs.js-Datei zu löschen, kannst du auch die entsprechende mail.root-Einstellung im Konfig Editor per R-Klick zurücksetzen und TB neu starten.
    Wenn was schief läuft, setzt du einfach die gesicherte prefs.js-Datei wieder ein anstelle der gerade geänderten.


    Gruß

  • Danke für deine ausführliche Antwort.
    Leider hatte ich das schon probiert. Nach dem Start von TB ist wieder alles wie vorher.
    Gruß, Markus