Markierter Text kann nicht verlinkt werden

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 31.3.0
    * Betriebssystem + Version: Win 7
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX):Gmail


    Die Funktion den markierten Text mit einen Link zu verehen funktioniert nicht. Das Fenster für den vorgesehenen Link geht wohl auf, das markierte Wort erscheint in der oberen Zeil, die Zeile für den Link nimmt jedoch den kopierten Link nicht bei dem Mausklick an. Der Link erscheint gar nicht, das aufgeklappte Menue ist leer.


    Danke für die Hilfestellung.
    Gruesse
    Jathostreeter

  • Danke für die Umleitung mit dem Einfügen des Links. Ich hoffe, dass der Thunderbird sich beim nächstenupdate wieder selbst korrigiert, denn der Umweg ist ziemlich nervende.


    Dank und Gruss

  • * Thunderbird-Version: 31.3.0
    * Betriebssystem + Version: Win 7
    * Kontenart (POP / IMAP): POP bzw. IMAP
    * Postfachanbieter (z.B. GMX): yahoo.de bzw. web.de


    Dies ist auch eins meiner Probleme noch: nur, dass ich den Hyperlink im Mozilla-Adressfeld kopiere, aber im Tb-Einfügefeld (vom "Hyperlink"-Button) keine Option zum Einfügen habe bei rechtem Mausclick. In hellgrau steht in einem Schriftfenster "(keine benannten Anker oder Überschriften auf dieser Seite)".
    Und wenn ich auf "Durchsuchen" klicke, kommt nicht mehr wie früher links eine Button-Auswahl von Quellen sondern sofort das Dateienfenster. D.H. ich kann nur noch bestenfalls eine Mozilla-Datei anhängen, aber keinen link zu einer Seite einfügen. "Erweitert" ist auch hellgrau/nicht anklickbar, ebenso "OK", sodass ich nur noch abbrechen kann.
    Das ist echt nervig, wenn ich einen Text verfasse, mit mehreren Verweisen. Ist bei beiden Konten/-arten.


    (und verschiedene Schriften, wie früher gern comic sans, lassen sich auch nicht mehr einstellen - reagiert einfach nicht)

  • Zitat

    (und verschiedene Schriften, wie früher gern comic sans, lassen sich auch nicht mehr einstellen - reagiert einfach nicht)


    Hallo,


    kann es sein, dass du eine Textmail verfasst statt einer HTML-Mail? Das würde erklären, wieso du keine Schriftwart auswählen kannst - und dann vermutlich auch keine Schriftgrößen, unterstrichen usw..


    Und was meinst du mit "Mozilla-Datei"?


    MfG
    Drachen

  • ad 1: email-Format habe ich (unter Optionen - email-Format) auf "automatisch bestimmen. Aber auch, wenn ich eins der andern einstelle tut sich da nix in der Ansicht (habe noch keinen Empfänger gefragt, wie es ankommt bei denen). Schriftgröße und Art funktionieren - wobei ich in der in inline-angehängten Nachricht die Schrift immer größer eingefügt kriege und dann Satzweise kleiner machen muss - ich kann also nicht die ganze markierte eingefügte Nachricht auf 1 klick kleiner kriegen.


    Ich habe auch nie was verändert in den Einstellungen gegenüber früher - das habe ich urplötzlich nach einem vor vielleicht 2-3 Monaten entdeckt.


    ad 2: Mit Mozilla-Datei meine ich: da ich keine link-Adresse einfügen kann in den "Hyperlink" sondern lt. Angebot nur Dateien vom Laptop einfügen kann, müsste ich die website mit Mozilla speichern und könnte dann die komplette website als Datei anhängen (was ich aber ungern so herum-schicken möchte) .

  • allo Heike,


    ad 1: email-Format habe ich (unter Optionen - email-Format) auf "automatisch bestimmen.


    Drachen meint Extras > Konten-Einstellungen > [Kontenname] > Verfassen & Adressieren > Nachrichten im HTML-Format verfassen.
    Wo du "Optionen > Email-Format > automatisch bestimmen" gefunden hast, ist mir unbekannt.
    Aber offenbar hast du das Verfassen im HTML-Format angehakt.


    Zitat

    ad 2: Mit Mozilla-Datei meine ich: da ich keine link-Adresse einfügen kann in den "Hyperlink" sondern lt. Angebot nur Dateien vom Laptop einfügen kann, müsste ich die website mit Mozilla speichern und könnte dann die komplette website als Datei anhängen (was ich aber ungern so herum-schicken möchte) .


    Hast du denn schon mal folgende Vorgehensweise versucht?
    Du zeigst die Seite, die du in deiner Email verlinken willst, in einem Browser an und kopierst (Ctrl + C) ihre URL aus der Adressleiste in die Zwischenablage.
    Im Verfassen-Fenster von TB schreibst du deinen Text, markierst das Wort, das in einen Link "umgewandelt" werden soll, gehst zu "Einfügen" > "Link..." , und fügst per Ctrl + V die Adresse (URL) deines Links in das Feld "Link-Adresse" ein:



    Danach klickst du auf "OK" und sofort wird der Link-Text in der Nachricht in einen (vom Empfänger anklickbaren) Hyper-Link umgewandelt:



    Ist das wirklich so kompliziert? ;)

  • OK: Danke -
    ad 1: Stimmt: dort war es angehakt. Wenn ich im Verfassen über Extras - Konteneinstellung - Verfassen - bei HTML-Format den Haken wegnehme, dann ist die komplette Zeichen-Zeile unterhalb der Betreffszeile, mit den Schrifteinstellungs-Optionen, inkl Hyperlink-usw.-Buttons weg. Auch ist im Tab Optionen (links neben Extras) die Option "email-Format" weg.
    Und wenn ich "link einfügen" anklicke, ist das markierte Wort weg und stattdessen der ellenlange link da.
    Beim zweiten Versuch grade habe ich auch nicht mal mehr den Tab "Einfügen" vorgefunden, mit der Option "als link einfügen" - d.h. ich kann nur noch normal den vollen link in die email einfügen.


    Wenn ich den Haken dort wieder reinmache, und eine neu zu verfassende aufrufe, dann ist die Zeichen-Zeile wieder da - und auch im Options-Tab oben neben Extras die Möglichkeit "email-Format->" wieder da (oberhalb "Priorität->") - das ist das wo ich ursprünglich "automatisch" angehakt hatte und sich bei keiner andern Auswahl etwas einstellen ließ, was die Schriftauswahl funktionieren lassen würde. Ebenso ist der Tab "Einfügen" zwischen Format und Ansicht wieder da.


    ad 2): Ich bin bisher immer über den Button in der Symbol-Leiste unter Betreff gegangen. Ich habe es jetzt aber auch mal über den Tab "Einfügen" probiert und habe dasselbe Problem: in die in deinem Screenshot blau umrandete Fensterzeile läßt sich nix ablegen - bei rechtem mausklick habe ich auch nicht die Option "einfügen" - das heißt der link läßt sich nicht aus der Zwischenablage abrufen - und stattdessen erscheint daneben blass die oben genannte Fensterzeile "(keine benannten Anker oder Überschriften auf dieser Seite)" . Diese Zeile verschwindet leider, sobald ich vom rechten Mausklick auf das screenshot-Programm wechsel.


    Ich habe einen Screenshot gemacht, aber ich weiß nicht, wie ich ihn hier im Antwortfenster einfügen soll: wenn ich auf den "Bild-einfügen" Button oben gehe, dann fragt er im auftauchenden Fenster sowohl bei "Bild-Info" als auch bei "link" nur nach einer URL. Oder muss ich da den Desktop-Pfad reingeben aus den Bild-"Eigenschaften"? (Ich dachte URL ist eine Bezeichnung nur für website-Adressen?)


    PS: falls jetzt die Frage kommen sollte, welches Antivirus-Programm ich habe: Avira Premium. :huh: 1x pro Woche voll durchgescannt neben dem Echtzeit-Scan. Und die neueste Version runtergeladen und überinstalliert hatte ich natürlich auch schon versucht.

    Einmal editiert, zuletzt von Heike W ()


  • ad 1: Stimmt: dort war es angehakt. Wenn ich im Verfassen über Extras - Konteneinstellung - Verfassen - bei HTML-Format den Haken wegnehme, dann ist die komplette Zeichen-Zeile unterhalb der Betreffszeile, mit den Schrifteinstellungs-Optionen, inkl Hyperlink-usw.-Buttons weg. Auch ist im Tab Optionen (links neben Extras) die Option "email-Format" weg.


    Das ist völlig normal, dass in Reintext-Mails keine Schriftformatierung vorgenommen und auch keine Text-Links erzeugt werden können.
    Dafür sind ja HTM-Mails da!
    Natürlich (und das hatte ich völlig vergessen, da ich nur Reintext-Mails verschicke) kann man bei schon geöffnetem Verfassen-Fenster über "Optionen" > E-Mail-Format von HTML auf Reintext wechseln oder umgekehrt.


    Zitat

    ad 2): Ich bin bisher immer über den Button in der Symbol-Leiste unter Betreff gegangen. Ich habe es jetzt aber auch mal über den Tab "Einfügen" probiert und habe dasselbe Problem: in die in deinem Screenshot blau umrandete Fensterzeile läßt sich nix ablegen -


    Du brauchst nur einen Mausklick in die leere Zeile für die Link-Adresse zu machen, dann sollte sie "aktiv" sein wie in diesem screen shot:



    Und dann kannst du deine gespeicherte Adresse mittels der Tastenkombination Ctrl + V einzufügen.
    Wenn das bei dir nicht funktioniert, solltest du das im abgesicherten Modus von TB testen:
    die Umschalttaste drücken beim Start von TB.


    Zitat

    bei rechtem mausklick habe ich auch nicht die Option "einfügen" -


    Das ist der Bug, den ich schon in meiner ersten Antwort erwähnt hatte.

  • Ich weiß "ganz einfach" ;( - aber wenn ich diesen mausklick mache, kommt das zuerst genannte Problem - und zwar auch im abgesicherten Modus, wie ich gerade ausprobiert habe:
    nix ablegbar in der Fensterzeile,
    nebenfenster mit dem Anker-text in hellgrau,
    "ok" und "erweitert" auch in hellgrau nicht anklickbar, sodass ich nur noch abbrechen kann.
    Und das ganze bei angehaktem HTMLmit "automatisch"-email-format ebenso wie in reintext oder HTML-Auswahl in Optionen
    (bei ohne-Haken im Textformat sind die Zeichenzeile und das "Einfügen"-Tab weg.)
    Und den Screenshot kann ich auch nicht einfügen in diese Antwort, weil das Fenster bei beiden Möglichkeiten "Bild-Info" und "Link" nur eine URL abfragt und den Desktoppfad des gespeicherten Bildes nicht nimmt als URL.

  • Zitat

    Und den Screenshot kann ich auch nicht einfügen in diese Antwort, weil das Fenster bei beiden Möglichkeiten "Bild-Info" und "Link" nur eine URL abfragt und den Desktoppfad des gespeicherten Bildes nicht nimmt als URL.


    Unter "Lexikon" > "Hilfe zu dieser Webseite" sehe ich leider keine Anleitung zum Einstellen von screen shots in einen Beitrag.
    Versuche es also über "Erweiterte Antwort" -> "Dateianhänge" -> "Hochladen" .....

  • Aaahhh - der tip war ja schon mal gut: also hier die Screenshots - nur ohne das Seitenfenster mit dem hellgrauen Text "(keine...)", weil das weg zum screenshotprogramm verschwindet.


    Nachträgliche Bearbeitung nach der folgenden Antwort von Mapenzi: der Übersicht halber jetzt
    - 1. Bild gelöscht (weil "ohne HTML-Häkchen" die Reintext-ansicht schon geklärt war)
    - 3. Bild gelöscht (Button Bildhochladen hier nur als URL möglich auch geklärt durch Mapenzi/umgangen durch "erweiterte Bearbeitung")
    - bleibt das Fenster wie in Mapenzi's screenshot (dort inkl. dem Nebenfenster) der mein Problem ist und nach seiner Antwort ein Bug in Bearbeitung ist.

  • also hier die beiden Screenshots - nur ohne das Seitenfenster mit dem hellgrauen Text "(keine...)", weil das weg zum screenshotprogramm verschwindet.


    Den ersten screen shot hättest du dir ersparen können, da er ein Reintext-Verfassenfenster zeigt.
    Und in einem Reintext-Fenster kann man, wie schon mehrfach betont, keinen Link-Text erzeugen.
    Lass uns doch nur noch vom HTML-Verfassen-Fenster reden!


    Im zweiten screen shot sehe ich, dass das Feld für die Link-Adresse offensichtlich aktiviert ist.
    Hast du denn wirklich schon einmal versucht, über "Kopieren (Ctrl + C) einer URL" und anschließendes "Einsetzen (Ctrl + V) der URL in dieses durch einen linken Mausklick aktivierte Feld" einen Link-Text zu erzeugen? Oder ist dir vielleicht der Begriff "copy & paste" geläufiger?


    Dass in der Version TB 31 der Klick auf das kleine Dreieck in diesem Feld nicht mehr funktioniert, ist seit Monaten als Bug 1044336 bekannt:



    Was du mit dem dritten screen shot zeigen willst, ist mir in diesem Zusammenhang nicht klar.

    Einmal editiert, zuletzt von Mapenzi ()

  • Also wenn ich das Manno Markiere mit einem linken Mausklick, dann kommt das obige Fenster wie beschrieben - aber mit einem weiteren linken Mausklick tut sich da nix, der Cursor blinkt fröhlich weiter in dem Feld, wo ich nix "paste"/einfügen kann.
    Die kopierte URL kann ich ja nur mit rechtem Mausklick abrufen/paste - was aber halt nicht geht: Ich kann nix reinlegen in das blau umradete Feld. Und zwar weder, wenn ich das über den Button in der Symbolleiste öffne, noch über den Tab "Einfügen" neben Ansicht, geschweigedenn im abgesicherten Modus. Es geht nur noch "abbrechen" (weil die Buttons "ok" und "erweitert" auch hellgrau inaktiv sind, wie auf dem Foto zu erkennen ist).

  • @Mapenzi,


    du schriebst:

    Zitat

    kann man bei schon geöffnetem Verfassen-Fenster über "Optionen" > E-Mail-Format von HTML auf Reintext wechseln oder umgekehrt.


    Auf Reintext ja, aber nicht von Reintext auf HTML, das ist mir jedenfalls noch nie gelungen, wenn ich ein Reintextfenster öffne. Das Menü ist dort auch nicht vorhanden.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Also wenn ich das Manno Markiere mit einem linken Mausklick, dann kommt das obige Fenster wie beschrieben - aber mit einem weiteren linken Mausklick tut sich da nix, der Cursor blinkt fröhlich weiter in dem Feld, wo ich nix "paste"/einfügen kann.


    Also nochmals, und das habe ich schon mindestens drei Mal geschrieben, du sollst das Tastenkürzel Ctrl + V zum Einfügen benutzen, wenn der Kursor im Feld der Link-Adresse blinkt, und nicht den R-Klick -> Einfügen!
    Hast du noch nie mit Tasten-Kürzeln gearbeitet?


    Zitat

    Die kopierte URL kann ich ja nur mit rechtem Mausklick abrufen/paste - was aber halt nicht geht: Ich kann nix reinlegen in das blau umradete Feld.


    Du kopierst (R-klick -> Kopieren) zunächst die URL von wo auch immer (z. B. aus der Adressleiste deines bevorzugten Browsers), danach befindet sie sich in der sogenannten "Zwischenablage" deines PC.
    Dann fügst du sie per Ctrl + V (= Tastenkürzel für "Einfügen) in das Feld der Link-Adresse ein.

  • Auf Reintext ja, aber nicht von Reintext auf HTML, das ist mir jedenfalls noch nie gelungen, wenn ich ein Reintextfenster öffne. Das Menü ist dort auch nicht vorhanden.


    Stimmt, du hast Recht! ;)
    Man kann nur im HTML-Fenster auf Reintext wechseln, und dann auch nicht mehr zurück.
    Ich hatte das in der Eile nicht überprüft.


    Gruß

  • Hallo Mapenzi,


    Tastenkürzel Ctrl + V


    zur Sicherheit hättest Du noch <Strg>+<V> parallel erwähnen sollen.


    Es sind nicht mehr so viele, die noch die guten alten Tastaturen mit <Ctrl>, <Ins>, <Del> usw. benutzen ... ;)


    Für alle Mausschubser ;) : Wo befindet sich die CTRL Taste und welche Funktion hat sie?


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Hallo Feuerdrache,

    zur Sicherheit hättest Du noch <Strg>+<V> parallel erwähnen sollen.


    Vielen Dank für deine Ergänzung!
    Ich bin halt nur Mac-User, und auf Mac-Tastaturen hat es noch nie eine Strg-Taste gegeben ...
    Darf ich das so verstehen, dass auf modernen Windows Tastaturen die Ctrl-Taste durch Strg ersetzt ist und den gleichen Effekt hat?
    Trotzdem, wenn ein Hilfesuchender beim dritten Mal nicht versteht, was "Ctrl = V" bedeutet, kann er doch einfach nachfragen, oder? ;)


    P.S. gilt das Gleiche auch für das Tasten-Kürzel "Kopieren" = Strg + C ?


    gruß

  • [OT]
    Hallo Mapenzi,


    es ist halt so, dass sich in Deutschland bei den PC-Tastaturen die mit deutschen Bezeichnungen überwiegend durchgesetzt haben.


    Es sind lediglich Bezeichnungen, die Tasten-Funktion ist jeweils identisch.


    Zwar gibt es immer noch QUERTZ-Tastaturen mit den US-/Englischen Beschriftungen, die werden aber in der Regel dann gezielt nachgefragt. Das ist selbst bei den Klapprechnern so. Bei letzteren findet sich dann oft ein Hinweis, wenn es das betreffende Modell nur mit den US-/Englischen Tastaturbezeichnungen gibt.


    Ich selbst habe lange Zeit Tastaturen mit <CTRL>, <DEL>, <INS> usw. verwendet.


    Gruß
    Feuerdrache
    [/OT]

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier