Adressbuch / Fehler in Anzeige Geburtstag

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird: 31.4.0 portable
    * Betriebssystem: WinXP-SP3 + alle Patches (bei Win7 alles ok)
    * Sync-Add-on für Online-Adressbuch?: Google Contacts


    Bei der Anzeige des Geburtstages wird in der Übersicht ein falscher Tag angezeigt.
    Bis 27.3. ist richtig, ab 28.3. jeweils 1 Tag falsch.


    [IMG:http://hd0.de/Dateien/Thunderbird_Adressbuch.jpg]

  • Hallo,
    du hast 2 Adressbücher, wie ich sehe.
    Könnte es sein, dass du mehrere gleiche Adressen im Adressbuch hast (dazu zählt auch "Gesammelte Adressen") und dir die falsche angezeigt wird?
    Bei deinem unteren Screenshot fällt mir auf, dass die Anzeige des Geburtstags ganz anders ist, als bei mir:
    Bei dir:
    Geburtstag: 27.3.1960
    und bei mir:
    Geburtstag: Donnerstag, 27. März 1960
    Wie kann das sein?
    Mache bitte einen Test im "persönlichen Adressbuch" mit dem gleichen Datum. Wird das dort auch falsch angezeigt?
    Falls nein, ist dein anderes selbst erstelltes Adressbuch defekt.
    Außerdem:

    Zitat

    Sync-Add-on für Online-Adressbuch?: Google Contacts


    Wenn du das deinstallierst, besteht das Problem weiterhin?
    Überprüfe noch einmal das Verhalten, indem du Thunderbird bei gedrückter Umschalttaste startest und "im abgesicherten Mddus weiterarbeiten" auswählst.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    3 Mal editiert, zuletzt von mrb ()

  • Hallo @all,


    Ich kann das Verhalten bestätigen. Bei mir (Win, TB 31.4) ist auch die Optik identisch zu der von tomas_hh.
    Da es sich bei mir auch unter Thunderbird 36 gleich verhält, habe ich das als Bug (ID 1122571) gemeldet und dieser wurde bereits bestätigt.


    Ich habe die Vermutung, dass du, mrb nicht davon betroffen bist, weil ein AddOn (vielleicht MoreFunctionsForAddressBook?) das korrigiert, könnte das sein? Das wäre dann evtl. ein workaround?


    Ah Thomas (?), ich sehe gerade, dass das dein erster Beitrag hier im Forum ist, Herzlich Willkommen!
    Vielleicht daher noch einmal "auf Deutsch": ich habe der Thunderbird-Community, die hier im Forum in der Regel nicht mitliest, das fehlerhafte Verhalten gemeldet und es hat bereits jemand, der schon so einige Fehler ausgemerzt hat, diesen bestätigt. Ob er (oder jemand anderes) sich auch diesem Problem annimmt, weiß ich nicht. Ich bin aber recht hoffnungsvoll, da die Quelle des Fehlers bereits eingegrenzt zu sein scheint.


    Es bleibt also im Augenblick nur abwarten übrig, oder vielleicht kann man AddOns (???) benutzen - da kenne ich mich nicht aus, mrb?


    Grüße, Ulrich

  • Zitat

    Ich habe die Vermutung, dass du, mrb nicht davon betroffen bist, weil ein AddOn (vielleicht MoreFunctionsForAddressBook?) das korrigiert, könnte das sein? Das wäre dann evtl. ein workaround?


    Das hatte ich ebenfalls gedacht und MoreFunctionsForAddressBook deaktiviert. Möglicherweise reicht das aber nicht, manche Add-ons behalten nach Deaktivierung noch einen Teil der Funktionen.
    Ein erneuter Test in einem recht virginen Profil in ital. Sprache, ergab das gleiche Resultat. Dort sind keine Add-ons installiert.
    Übrigens sieht mein Datum jetzt genau so aus wie bei euch. Allerdings wird in beiden Profilen das richtige Datum angezeigt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    2 Mal editiert, zuletzt von mrb ()

  • Ich kann das Verhalten bestätigen. Bei mir (Win, TB 31.4) ist auch die Optik identisch zu der von tomas_hh.
    Da es sich bei mir auch unter Thunderbird 36 gleich verhält, habe ich das als Bug (ID 1122571) gemeldet und dieser wurde bereits bestätigt.

    Bei mir tritt das Problem nur unter WinXP auf, nicht unter Win7/32.
    Bevor ich mich hier angemeldet habe, hatte einen neuen Kontakt in TB angelegt und natürlich einige Daten ausprobiert.
    Ich arbeite noch nicht so lange mit TB und hatte erst ein PEBCAK Problem vermutet.
    Erst als ich mir sicher war, daß da etwas nicht stimmt, wollte ich eine Bug-Meldung machen, bin aber in diesem Forum gelandet.
    Ist wohl auch besser so - habe mir den Link zu Bug mal angesehen, da wäre ich wohl gescheitert.
    Also vielen Dank für die "Übersetzung".


    MfG
    Tomas (ja richtig, ohne "h") aus HH

  • Hallo,


    ich habe noch einmal in einer virtuellen Maschine getestet. Das Problem tritt bei mir unter Win7 64bit Pro und Win7 32bit Pro auf (Thunderbird 31.4.0). Da es auch bei einem Linux-System aufgetreten ist (wurde in dem Bugreport erwähnt) gehe ich von einem Problem aus, das unabhängig vom Betriebssystem ist.


    Thomas schrieb:

    [... keine Bug-Meldung ... ]Ist wohl auch besser so - habe mir den Link zu Bug mal angesehen, da wäre ich wohl gescheitert.

    Naja, du darfst nicht glauben, ich hätte all die Felder richtig ausgefüllt. Da waren schon andere dran und haben das korrigiert. Ich weiß überhaupt nicht, woher man weiß, dass es z.B. innerhalb der "JavaScript Engine passiert" ...
    Auch die Zusammenfassung wurde komplett editiert, ich hatte was von "Adressbuch", "Editirfenster", ... geschrieben.


    Aber dafür ist ja eine Community da, jeder macht so viel er kann und mag.



    mrb schrieb:

    manche Add-ons behalten nach Deaktivierung noch einen Teil der Funktionen.

    Damit hätte ich nicht gerechnet! Gut zu wissen. Da habe ich ja Glück, dass ich meistens mit frischen Profilen teste.


    Grüße, Ulrich

  • @losgehts,
    ich weiß nicht mehr, welches Add-on das war, es kann auch eins in Firefox gewesen. Vielleicht war's auch das einzige. Auf jeden Fall bleiben ja die Einträge in der prefs.js erhalten, die normalerweise durch einen Schalter unwirksam werden. Sie sind aber nicht weg.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich habe bisher mit Outlook gearbeitet und wollte jetzt auf Thunderbird mit Lightning umsteigen. Beim Anlegen der Kontakte im Adressbuch (teilweise aus OL importiert, aber auch neu eingetragen), bin ich darauf gestoßen, dass gewisse manuell vorgenommene Geburtstagseintragungen falsch gespeichert werden.
    Ich habe dann so halb systematisch getestet, in welchen Intervallen denn fehlerhafte Eintragungen in der von thomas_hh beschriebenen Weise passieren. Hier ein Auszug:


    Frühjahrsintervalle
    Montag, 31. März 1947 bis Sonntag, 6. April 1947
    Montag, 29. März 1948 bis Sonntag, 4. April 1948
    Montag, 28. März 1949 bis Sonntag, 10. April 1949
    Montag, 27. März 1950 bis Montag, 17. April 1950


    Herbstintervalle
    Montag, 6. Oktober 1947 bis Sonntag, 26. Oktober 1947
    Montag, 4. Oktober 1948 bis Sonntag, 31. Oktober 1948
    Montag, 3. Oktober 1949 bis Sonntag, 30. Oktober 1949
    Dienstag, 24. Oktober 1950 bis Sonntag, 29. Oktober 1950


    Die Liste ist unvollständig, aber beispielhaft. Einige der Termine fallen exakt mit den Umstellungsterminen auf Sommerzeit bzw. Normalzeit zusammen. Warum dann allerdings von diesem Tag ausgehend unterschiedlich lange Intervalle fehlerhaft gehandelt und dann wieder ordnungsgemäß gespeichert werden, das verstehe ich überhaupt nicht.


    Gruß
    Josef


    Zu meiner Umgebung:
    * Thunderbird: 31.4.0
    * Betriebssystem: Win7 64Bit
    * Add-Ons: Enigmail 1.7.2, Lightning 3.3.2, Provider for Google Calender 1.0.3, StartupMaster 1.6

  • Hallo Josef und willkommen im Forum!


    Vielen Dank für deine Tests und Mühe.


    Zitat

    Beim Anlegen der Kontakte im Adressbuch [...], bin ich darauf gestoßen, dass gewisse manuell vorgenommene Geburtstagseintragungen falsch gespeichert werden.

    Ich beobachte bei mir, dass sie nicht falsch gespeichert werden, sondern das gespeicherte Datum falsch angezeigt wird: wenn ich einen vom Problem betroffenen Kontakt bearbeite, so erscheint bei mir im "Bearbeiten-Fenster" wieder das richtige Datum.
    Daher gehe ich davon aus, dass lediglich die Anzeige falsch ist, und nicht das Speichern der Geburtstage.



    Dennoch ist es natürlich ärgerlich!


    Das doofe ist, dass wir da im Augenblick (es sei denn, du hast Programmierkenntnisse) wenig tun können, außer diesen Bug zu melden - und das habe ich bereits getan: Link zur Bugmeldung.


    Jetzt heißt es (für mich) leider teetrinken und abwarten :/ .


    Grüße, Ulrich

  • Hallo an Alle,


    ich habe auch noch ein paar Jahre getestet. Vielleicht kann es ja auch noch zur Fehlefindung nützlich sein.
    Folgende Zeiträume sind bei mir fehlerhaft. 2015 ist komplett OK
    1943 Di 05.10. - So 31.10.
    1963 Mo 01.04. - So 27.10.
    1980 Mo 31.03. - So 06.04.
    1980 Mo 29.09. - So 26.10.
    1981 Mo 28.09. - So 25.10.
    1982 Mo 27.09. - So 31.10.
    1983 Mo 26.09. - So 30.10.
    1984 Mo 01.10. - So 8.10.
    1985 Mo 30.09. - So 27.10.
    1986 Mo 29.09. - So 26.10.
    2015 OK


    Gruß
    jeunliro

  • Hallo,


    vielen Dank für deine Mühe!


    Hier gepostete Testergebnisse helfen nicht wirklich, da in diesem Forum keine Thunderbirdentwickler mitlesen, sondern Thunderbirduser anderen Thunderbirdusern helfen.


    Die richtige Platform für Fehlerberichte etc. ist bugzilla.mozilla.org. Den entsprechenden Bugreport findet ihr hier: Link zu Bug 1122571


    Grüße, Ulrich