Bug in Filter bei Suche nach "Inhalt enthält" in Thunderbird

  • Hallo zusammen,


    ich habe ähnliche Probleme, wie viele andere hier, die mit eigenen Thunderbird-Filtern den Inhalt von Mails durchsuchen, um sie zu sortieren, markieren, löchen etc.


    Ich habe nun einen Fehler bei der Filterfunktion von TBird gefunden, der bei reinen html-Mails auftritt. Dazu habe ich an mich selbst solche Mails verfasst, was möglich ist, nachdem man unter Extras/Einstellungen/Verfassen/Sende-Optionen... im Drop-Down-Menü "Nachrichten trotzdem als HTML senden" auswählt. Dadurch werden z.B. Links nicht nochmal als reiner Text in die Mail geschrieben und sind dann für die Filter manchmal nicht mehr durchsuchbar.
    Hier das Beispiel:


    In einem einfachen Texteditor (z.B. Notepad) habe ich folgende kurze html-Datei erstellt, die ich als Email verschicken will:
    ----------------------------------------------------------
    <html>
    <body>
    Lieber Leser,<br>
    <a href="http://www.eine.spamwebseite.die.man.gern.loswerden.will.de">Klick Mich !</a>
    </body>
    </html>
    ----------------------------------------------------------
    Wenn man die als html-Datei speichert (ich habs im UTF-8-Format gespeichert) und in einem Browser öffnet, kann man den Text mit Strg+A und Strg+C herauskopieren und in eine Email an sich selbst mit Strg+V im Nachrichtenfenster einfügen.


    Das gleiche habe ich mit folgender fast identischer Nachricht gemacht, die nur um ein Zeichen kürzer ist, indem ich "eine" durch "ein" ersetzt habe:
    ---------------------------------------
    <html>
    <body>
    Lieber Leser,<br>
    <a href="http://www.ein.spamwebseite.die.man.gern.loswerden.will.de">Klick Mich !</a>
    </body>
    </html>
    ---------------------------------------


    Der Filter soll nach dem Wort "spamwebseite" im Inhalt aller neu eingehenden Nachrichten suchen. Das macht man über Extras/Filter/Neu.../. Als Filter-Name habe ich "spam" gewählt und bei den Häkchen nichts geändert (also ein Häkchen bei "Manuellem Ausführen" und bei "Nachrichtenabruf: Vor Junk-Erkennung ausführen", sonst keine Häkchen).
    In den Suchkriterien habe ich "Inhalt" "enthält" "spamwebseite" eingegeben.
    Unter "Auszuführende Aktionen" habe ich "Verschieben der Nachricht in:" "Papierkorb von GMX" gewählt. "OK" klicken um Filter anzulegen.


    Wenn ich nun die zwei html-Mails sende, kommen sie sofort an. Die um ein Zeichen längere Mail landet wie erwartet im Papierkorb, aber die kürzere Mail bleibt im Posteingang. Was ist der Grund?
    Schaut man sich den Quelltext der beiden Mails an (über Ansicht/Nachrichten-Quelltext oder Strg+U) sieht man, dass Thunderbird sie wegen der unterschiedlichen Zeilenlänge anders umbricht:


    Bei der langen Mail sieht es so aus:
    ------------------------------------------------------------------------------------------



    ------------------------------------------------------------------------------------------


    Bei der kürzeren gibt es einen Zeilenumbruch weniger:
    ----------------------------------------


    ----------------------------------------


    Ich habe festgestellt, dass das kein Einzelfall ist, sondern System hat. Alle Mails, die bei mir nicht richtig gefiltert werden, haben keinen zusätzlichen Zeilenumbruch. Die Mails, die richtig gefiltert werden, haben diesen zusätzlichen Zeilenumbruch. Das sieht für mich definitiv nach einem dicken Bug in Thunderbird aus, denn wenn man manuell über Strg+F in den Quelltexten nach "spamwebseite" sucht, wird das Wort bei beiden problemlos gefunden. Es muss also ein Fehler in der Suchfunktion des Filters von Thunderbird sein.


    Ich würde ungern auf ein anderes Mail-Programm umsteigen. Kann diese Information also bitte jemand an das Entwicklerteam von Thunderbird weiterleiten (Ich weiß, dass das hier nicht die Seite der Thunderbird-Entwickler ist. Ich habe die Hinweise auf der ersten Seite gelesen).


    Vielleicht hängt die Länge der Zeile ab wann der zusätzliche Zeilenumbruch auftritt auch vom Emailanbieter (bei mir GMX) ab oder von weiteren Faktoren wie Schriftgröße, Bildschirmauflösung etc. Daher wäre es gut, wenn jeder, der das liest und versteht, die beiden Beispielmails bei sich ausprobiert und eventuell mit der Länge der Zeile mit dem Link spielt, so dass wir rauskriegen, wann der Fehler auftritt.


    Falls dieser Bug nicht in den nächsten Versionen von Thunderbird behoben werden kann, kennt vielleicht jemand eine Alternative (z.B. ein Add-on, Plug-in etc für Thunderbird) mit dem man fehlerfrei, automatisch in neu eingehenden Emails suchen kann, um sie zu markieren, löschen, verschieben etc?


    Viele Grüße
    ---------------
    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 38.4.0
    * Betriebssystem + Version: Windows Vista Home Premium 32bit (Service Pack 2)
    * Kontenart (POP / IMAP): POP
    * Postfachanbieter (z.B. GMX): GMX freemail
    * Eingesetzte Antivirensoftware: Avira
    * Firewall (Betriebssystem-intern/Externe Software): Windows-Firewall

    2 Mal editiert, zuletzt von Hilbert ()

  • Hallo und willkommen im Forum!


    Ich muss zugeben, dass ich ganz schlau aus deiner Beschreibung nicht werde, weil ich nicht genau weiß, welchen Filter du meinst.
    Meinst du den Suchfilter, den globalen Suchfilter oder den Filter für eingehende Nachrichten?


    In den Suchkriterien habe ich "Inhalt" "enthält" "spamwebseite" eingegeben.

    Und genau das macht mich nachdenklich. Diesen Menüpunkt gibt es nämlich bei mir nicht. Hast du ihn etwa durch "Anpassen" hinzugefügt"? Diese Art Filter funktionieren meistens nicht. Und ich glaube auch nicht, dass der Filter auf den Nachrichteninhalt überhaupt angewendet werden kann, sondern nur auf den Mail-Header.
    Nur beim Suchfilter geht das.
    Und noch etwas: im Lauf vieler Jahre mit Thunderbird und anderen Mailklienten und Webseitenfiltern habe ich bemerkt, dass es keine hundertprozentige Zuverlässigkeit gibt, die Filter defekt werden können und/oder falsch ausgeführt werden.
    Ich gebe bei der Eingabe auch z.B.nie eine abgekürzte Mailadresse ein - etwa nur die Domain- sondern immer die komplette.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    zu deiner Nachfrage nach dem Filtertyp:
    Den Filter habe ich über das normale Menü über Extras/Filter/Neu... angelegt, wie oben beschrieben. Davor war als Ordner mein Posteingang markiert, also denke ich das ist der Filter für eingehende Nachrichten für dieses Konto. Wenn ich einen anderen Ordner in demselben Konto auswähle, sind unter Extras/Filter dieselben Filter vorhanden. Wenn ich in einem anderen Konto bin, dann sind dort keine Filter definiert. Also sind die Filter auf ein E-Mail-Konto beschränkt.


    zu deiner Nachfrage nach den Filterkriterien:
    Ich habe in der englischen Hilfeseite http://kb.mozillazine.org/Filters_(Thunderbird) gelesen, dass "Inhalt" (in der engl. Version "body") in neueren Thunderbirdversionen nur für POP-Konten vordefiniert ist. Ich habe ein POP-Konto, von daher ist das kein Problem. Auf der Hilfeseite steht aber, dass man es auch für IMAP Konten über den "Anpassen..."-Eintrag, den du meinst, hinzufügen kann.


    zum Suchwort: Das Suchen nach "spamwebseite" ist hier nur ein Beispiel, damit es kurz und übersichtlich bleibt. In meine echten Filtern habe ich natürlich auch längere Suchworte und Domains.


    Der Bug sitzt wahrscheinlich in der automatischen Suchfunktion des oben beschriebenen Filters, nicht in der globalen Suchfunktion oder der manuellen Suche, denn wie gesat findet diese das Suchwort problemlos. Ich brauche aber eine zuverlässige Suchfunktion über den automatisch ausgeführten Filter für neu eingegangene Mails. Denn sonst werden diese falsch sortiert oder nicht gelöscht, obwohl sie exakt die Suchworte enthalten. Das ist nervig und man kann so nicht arbeiten. Und das z.B. nur wegen unterschiedlicher Zeilenlängen. Es ist also Glücksache, ob ein Filter in Thunderbird funktioniert bzw. es liegt an den Zeilenlängen der Mail. Dass es besser geht zeigt die manuelle Suche, die funktioniert.


    Bitte probier die zwei Beispielmails aus. Das geht auch AN ALLE, die das lesen:


    :!:
    Bitte ausprobieren, denn ich wäre für eine Bestätigung des Bugs sehr dankbar.
    :!:


    Viele Grüße

  • Ich habe folgenden Test gemacht (habe von 11 Konten nur ein einziges nicht aktives POP-Konto):
    Ich habe den von die gepostetet HTML-code über Einfügen --> HTML... direkt eingefügt , so dass er sofort als ausgeführtes HTML angezeigt wird, sind ja nur 2 Zeilen.
    Diese Mail habe ich an mein POP-Konto geschickt, wobei bei diesem die gleichen Filtereinstellungen verwendet habe:


    HTML
    1. <html>
    2. <body>
    3. Lieber Leser,<br>
    4. <a href="http://www.eine.spamwebseite.die.man.gern.loswerden.will.de">Klick Mich !</a>
    5. </body>
    6. </html>

    also
    Inhalt | enthält| spamwebseite



    in den Ordner "Test" verschieben.


    Dann eine zweite Mail diesmal ohne das "e".




    Und du wirst es nicht glauben, die Mails landen beide im Ordner "Test".
    Und beide Umbrüche sind gleich.
    Ich werde das jetzt mal mit "trotzdem HTML" versuchen.
    Geht das negativ aus, durchsucht Thunderbird keinen HTML-Code in der Nachricht.



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    2 Mal editiert, zuletzt von mrb ()

  • Ja, deine Tests stimmen mit meinem überein.


    Warum jetzt der Filter die Mail mit e anders behandelt als die ohne e, weiß ich nicht.
    Das Ergebnis ist in der Tat auch überraschend für mich.
    Ein Umbruch im HTML-Code ist ganz normal, wenn die Anzahl der Zeichen pro Reihe überschritten wird.


    Ich werde morgen mal einen Test machen und die Zeilenlänge vergrößern, so dass Thunderbird genau an der Stelle keinen Umbruch machen dürfte.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ergebnis:
    trotz Verlängerung wird die Mail ohne e nicht gefiltert.


    Mehr kann ich leider nicht tun.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • [o.T.]
    Susanne, du kennst mich doch, das Fiber lässt mich dann nicht mehr los. Und dann stirbt der Morgen nie.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo zusammen,


    erstmal vielen Dank für die Bestätigung, dass Thunderbirds Filter in html-Nachrichten tatsächlich mal filtern und mal nicht. Ich war mir nämlich nicht sicher, ob dieses Phänomen nicht nur durch ein krankes Bit oder irgendwas Besonderem an meinem Computer verursacht wurde.


    zu deinem Test:

    Ergebnis:
    trotz Verlängerung wird die Mail ohne e nicht gefiltert.

    Das klingt erstmal unlogisch für mich, denn meinen Tests nach greift der Filter eher bei langen Zeilen. Wenn du also die Zeile verlängerst, müsste es einen Zeilenumbruch im Quelltext geben und die Filtersuche greifen. Wäre dran interessiert, wie genau du die Zeile verlängert hast, poste mal den Nachtichtenquelltext, bitte.


    Die Frage ist nun, wie kriegen wir Thunderbird wieder "gesund". Denn diese Filtersuche ist einfach nur unzuverlässig. An wen muss man sich denn da wenden, habt ihr gute Kontakte zu den Entwicklern?


    Gruß

  • Hallo,


    An wen muss man sich denn da wenden, habt ihr gute Kontakte zu den Entwicklern?

    die der Entwickler, so es ihn noch gibt, liest hier nicht im Forum, hier gibt es nur User.
    Du kannst einen Bug erstellen, aber die Chancen, dass sich da jemand drum kümmert, sind derzeit eher gering...

  • An HIlbert,


    suche mal in der erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten")
    nach "72" oder nach "wraplength" und ändere den Wert.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    ich habe mailnews.wraplength mal auf 30 und 100 gesetzt und jeweils Tbird neugestartet und meine 2 Testmails losgeschickt. Alles beim Alten: Die kurze Zeile wird nicht umgebrochen und nicht gefiltert, die lange Zeile wird umgebrochen und wird herausgefilter.


    Ich hab auch andere wrap-Variablen gefunden und mail.wrap_long_lines auf false gesetzt, damit sind alle vier wrap-Variablen auf false. Hat auch nichts geändert.


    Dann hab ich drei wrap-Wariablen, die Einfluss haben könnten auf true gesetzt (mail.wrap_long_lines = true, plain_text.wrap_long_lines = true, view_source.wrap_long_lines = true) und zusätzlich die mailnews.wraplength = 30, damit er auf jeden Fall Umbrüche macht. Denn mit Umbrüchen filtert er ja. Aber auch das hat nichts geändert. Die Formatierung der Mail auch im Quelltext sieht unverändert aus und auch die Filterwirkung ist die selbe. Der Bug bleibt. :(;(


    Gruß

  • Hallo allerseits,


    nach etwa 2 Monaten Wartezeit haben die Bugzillas sich vor einigen Tagen meiner Bugmeldung angenommen und sie als Duplikat einer Fehlermeldung, die etwa 2 Monate vor meiner Meldung dort einging eingeordnet und damit als "erledigt" abgestempelt. Aber diese frühere Meldung war extrem kurz und ohne reproduzierbars Beispiel, so dass es doch was Gutes hatte das oben geschilderte Beispiel dort auf Englisch einzustellen. Es wurde von mehreren Entwicklern bestätigt und sie diskutieren gerade wie sie es lösen sollen unter dieser früheren Fehlermeldung (https://bugzilla.mozilla.org/show_bug.cgi?id=1211128).
    Die Codestelle im TB-Quelltext wurde wohl auch schon identifiziert und verlinkt. Es geht um "HTML stripping".
    Ursprünglich war die Suche mit "Inhalt enthält" wohl nur für den angezeigten Text und nicht für die HTML-Befehle gedacht, wenn ich die richtig verstanden habe. Dass sie bei umgebrochenen Zeilen trotzdem greift ist wohl eher ein unbeabichtigter Effekt gewesen.


    Offenbar gibt es momentan weder eine eingebaute TB-Funktion noch ein Addon, um die Inhaltssuche wiklich auf den gesamten Quelltext einer Email anzuwenden. Sie geben zu, dass unser Anliegen den Quelletext komplett inklusive HTML-Befehlen durchsuchen zu können, gerechtfertigt ist. Momentan überlegen sie, wie sie das Problem lösen können. Es gibt wohl drei Optionen.
    - Ein Addon das das macht. Dafür müsste aber auch Thunderbird angepasst werden.
    - Die Erweiterung der Funktionalität der "Inhalt enthält"-Suche auf den kompletten Quellcode einer Email.
    - Die Einführung einer neuen Option beim Filtern im Dropdownmenü, wo man "Inhalt enthält" auswählt. Als so etwas wie "Volltext enthält" oder "Nachrichten-Quelltext enthält".


    Wann? Ein Thunderbird ESR 45 (=Extended Support Release) ist für März geplant. Bis dahin klappt es definitiv nicht. Aber bis zum darauf folgenden ESR 52 im Dezember könnte es vielleicht gelingen, eine Lösung einzubauen. Ich denke, ein bischen Motivation und Mitarbeit von jedem, der des Englischen halbwegs mächtig ist, könnte die Realisierung wahr werden lassen.
    Ich denke, wir können den Fortschritt unter dem oben genannten Link verfolgen und unterstützen.


    Viele Grüße