ANHÄNGE WERDEN NICHT ANGEZEIGT

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 52.6.0 (32-Bit)
    • Betriebssystem + Version: Windows 8.1 Pro
    • Kontenart (POP / IMAP): POP
    • Postfach-Anbieter (z.B. GMX): t-online, strato, und andere
    • Eingesetzte Antiviren-Software: Avira
    • Firewall (Betriebssystem-intern/Externe Software): intern
    • Router-Modellbezeichnung (bei Sende-Problemen):


    hallo zusammen,


    im ansichtsmodus REINER TEXT werden mir bei einigen nachrichten die anhaenge nicht angezeigt.

    manchmal sehe ich bei diesen nachrichten zwar die büroklammer, die aber beim klicken auf die nachricht auch manchmal verschwindet. wenn ich auf HTML ansicht umschalte, werden die anhänge sichtbar.


    wie kann ich die anhänge auch im REINER TEXT modus sehen?


    ich möchte nämlich grundsätzlich meine eingangsmails im REINER TEXT modus betrachten ohne dass mir die info über anhaenge verloren geht und ich sie somit oft übersehe.


    danke für hilfe.

  • Hallo und willkommen im Forum!


    Im Gegenteil, bei "Reiner Text" müssten dir eigentlich alle Anhänge, die in HTML nicht sichtbar sind, angezeigt werden. Im HTML-Modus verschwinden sie.


    Bist du sicher überhaupt Anhänge zu haben?

    Wie groß ist die Mail (Mails unter 10 KB enthalten selten Anhänge)? Schau außerdem mal im Quelltext (Strg+U) der Mail nach, ob du dort sehr lange Reihen von scheinbar sinnlosen Zeichen siehst. Wenn du keine siehst, enthält die Mail auch keine Anhänge.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • hallo,


    ja, ich bin sicher.

    im HTML modus kann ich die anhänge ja sehen. wenn ich dann auf REINER TEXT umschalte, sind sie nicht mehr zu sehen.

    zwar kann ich (manchmal) die büroklammer sehen, die verschwindet aber, wenn ich auf die nachricht klicke.


    es nicht nicht, wie es sein müsste ;-)


    was kann ich tun?

  • Das mit der Büroklammer halte ich nicht für kritisch, ist bei mir auch schon passiert-

    Daher schaue ich mit den Augenwinkel immer auf die Größe der Mail, dafür habe ich eine Spalte angelegt.

    Könntest du mir mal eine solche Mail zusenden? Du könntest ja auch eine neue schreiben mit eigenen Anhängen aus dem Internet.

    Falls dir das die Mühe wert, schreib mir eine PN per Konversation. Ich schicke dir dann meine Mailadresse, an die du die Mail senden bzw. weiterleiten kannst.

    Ach ja, um was für Anhänge handelt es sich überhaupt, nur Bilder?

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • hallo,

    sind es wirklich Anhänge oder werden im HTML-Modus vielleicht nur aus dem Internet eingebettete Bilder etc. direkt in der Mail angezeigt? In dem fall dürften in der Rein-Text-Mail die Links zu sehen sein, aber eben keine Büroklammer für Anhänge.


    MfG

    Drachen

  • Drachen , genau diesen Verdacht hatte ich ja auch, darum mein Frage nach Überprüfung des Quelltextes.

    Der TE scheint sich ja da recht sicher zu sein.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • also ...


    es ist zum beispiel eine normale email mit einer PDF datei als anhang.


    in meinem normalerweise eingestellten REINER TEXT modus sehe ich die mail in meinem eingang mit bueroklammer. wenn ich draufklicke ist die bueroklammer weg. und unten im anlagenbereich ist KEINE anlage zu sehen.

    wenn ich dann auf HTML umschalte ist die bueroklammer wieder da und der anhang ist im unteren anlagenbereich gelistet.


    scheinbar kaum zu glauben fuer euch ;-)


    gerne schicke ich dir eine solche email zur pruefung zu.

    UPDATE: leider kann ich keine konversation mit dir starten, da dein limit bereits erreicht ist.

  • Bei PDF sieht das schon anders aus, es gibt nämlich verschiedene Formate und auch Deklarierungen.

    Poste mal die Deklarierung des Anhangs aus dem Quelltext.

    Es kann auch eine falsche Deklarierung sein.


    Sieht etwa so aus:

    Code
    1. Content-Type: application/pdf;
    2. name="=?UTF-8?Q?05_-_L=c3=b6tverbindungen.pdf?="
    3. Content-Transfer-Encoding: base64
    4. Content-Disposition: attachment;
    5. filename*0*=utf-8''%30%35%20%2D%20%4C%C3%B6%74%76%65%72%62%69%6E%64%75%6E;
    6. filename*1*=%67%65%6E%2E%70%64%66

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • bez. content finde ich nur folgende zeilen im code:


    Content-type: multipart/alternative; boundary="Apple-Mail=_56102A78-7EDC-4770-BACA-1B45EEB55769"

    Subject: Magnum Tour itinerary


    hilft das?


    und weiter unten finde ich noch das:


    Code
    1. Content-Disposition: inline;
    2. filename="Magnum itinerary 2018.pdf"
    3. Content-Type: application/pdf;
    4. x-unix-mode=0644;
    5. name="Magnum itinerary 2018.pdf"
    6. Content-Transfer-Encoding: base64

    Einmal editiert, zuletzt von manode ()

  • Die Deklarierung entspricht nicht den Windows Gegebenheiten, da die Mail von einem Linux-System kommt.

    Damit kann sie Thunderbird nicht richtig darstellen.

    Knackpunkt ist dabei "Content-Disposition: inline;".


    Man könnte den Quelltext zwar korrigieren, der Aufwand rechtfertigt aber nicht das Ergebnis.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Die Deklarierung entspricht nicht den Windows Gegebenheiten,

    Kannst du das mal erläutern? Was sind denn Windows Gegebenheiten in Zusammenhang mit den Deklarationen in einer E-Mail? Davon habe ich noch nie gehört.

    da die Mail von einem Linux-System kommt.

    Ich glaube eher, sie kommt von einem Mac mit Apple Mail.

    Knackpunkt ist dabei "Content-Disposition: inline;".


    Ja, das ist zumindest komisch. Wieso sollte man ein pdf inline deklarieren? Ich kann mir vorstellen, dass das daran liegt, dass Apple Mail pdf inline darstellen kann. Ist aber eine reine Vermutung.


    manode

    Du kannst das vermutlich korrigieren, indem du die E-Mail als eml speicherst. Dann kannst du sie editieren und diese Änderung vornehmen:


    Content-Disposition: attachment


    Danach müsstest du die eml im Thunderbird öffnen können und das Attachment sehen. Ohne Gewähr.

    Ceterum censeo polypos rerum privatarum esse delendos!

    Frei nach Cato dem Älteren

    (Werter Herr T. , ich hoffe, ich habe da keinen Bock eingebaut.)

  • danke für die hinweise.


    nachdem ich das INLINE im quelltext gesehen habe, dachte ich mir sowas schon.

    das passiert häufiger, wenn ich bestimmte dateitypen von apple-usern bekomme.


    einen nachtraeglichen workaround hab ich ja schon. ich kann die mail ja ganz normal oeffnen. und wenn ich auf HTML umstelle, sehe ich auch alle anhaenge.


    aber eben nicht in meiner standardansicht REINER TEXT. und so uebersehe ich halt manchmal die anhaenge.


    auf meiner seite (thunderbird) kann ich da dann wohl nichts aendern, um die anhaenge auch im REINER TEXT modus gleich von anfang an sichtbar zu machen?

  • Drehmoment ,

    die Deklarationen entnimmt Thunderbird meines Wissens aus der Windows Registry, HKEY_CLASSES_ROOT und dort steht unter .pdf: application/pdf und diesen Eintrag verwendet Thunderbird als Deklaration Content-Type: application/pdf; ist bestimmt kein Zufall, bei anderen Dateitypen ist es ähnlich.


    Sorry, man möge mir vergeben, wenn ich hier Linux und Mac verwechselt habe. Linux kenne ich ein wenig und Mac gar nicht.

    Schneller als mit einer .eml lässt sich die Deklarierung im Quelltext mit dem Add-on HeaderToolsLite  

    bewerkstelligen, wenn man hier die Option "Edit full Source" verwendet.

    Das geht ruckzuck.


    Gruß





     

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich weiß nicht, was Windows genau mit diesen Schlüsseln macht. Ich glaube aber eher, das ist etwas internes und betrifft den Thunderbird bestenfalls indirekt, wenn man einen Anhang öffnet, und der Thunderbird dann mit Windows kommuniziert. Die Deklaration steht schließlich in der Mail selbst und ist völlig unabhängig davon, ob der Empfänger nun Windows, MacOS, Linux oder gar Unix verwendet.


    Hier lag das Problem eindeutig an der Deklaration als "inline" und nicht am Content-Type selbst.

    Ceterum censeo polypos rerum privatarum esse delendos!

    Frei nach Cato dem Älteren

    (Werter Herr T. , ich hoffe, ich habe da keinen Bock eingebaut.)

  • Hallo,

    das passiert häufiger, wenn ich bestimmte dateitypen von apple-usern bekomme.

    Das Problem tritt nur auf bei Anhängen auf, die vom Apple "Mail" Programm verschickt werden, und auch nur dann, wenn der Sender HTML bzw Rich Text verwendet.

    Ich habe es eben auf meinem Mac reproduzieren können, indem ich Testmails mit PDF Anhängen mit Apple Mail an mich selber verschickt und mit Thunderbird empfangen habe.


    Zunächst hatte ich Rein-Text in "Mail" benutzt (Betreff "Attachment PDF") und konnte den PDF Anhang in Thunderbird problemlos empfangen und speichern, unabhängig von der Einstellung "Reiner Text" oder "HTML" im Menü Ansicht .

    Erst als ich in "Mail" einen formatierten Text benutzte (Betreff "HTML Mail mit Anhang"), wurde der PDF-Anhang in Thunderbird nicht mehr angezeigt, wenn die Ansicht auf "Reiner Text" stand. Kein Problem dagegen bei der Ansicht "Original HTML" oder "Vereinfachtes HTML".


    Hier zunächst Ansicht > Nachrichteninhalt > Reiner Text:



    Und nun Ansicht > Nachrichteninhalt > Original HTML:



    Die entsprechende Nachrichtenquelltext sieht so aus:

    Es fällt auf, dass Apple Mail die Content-Disposition: inline; benutzt anstelle von :attachment; wie bei Thunderbird.

    Ich bin mir aber nicht sicher, ob dies ausschlaggebend ist.


    Hier noch ein Screenshot mit der Ansicht eines Verfassen-Fensters von Apple Mail, in dem ein PDF-Anhang eingefügt wurde:



    Es bleibt also offen, ob es sich hierbei um einen Bug von Apple Mail oder Thunderbird handelt.


    Gruß

  • danke fuer deine mühe von mapenzi und schön, dass du du ein solches ereignis reproduzieren konntest.

    (so liegt es wenigstens nicht an mir selbst ;-) )


    ich denke, der bug liegt dann eher bei apple mail, da die den anhang mit INLINE behaften.


    kann ich vielleicht meinen thunderbird irgendwie veranlassen, damit anders umzugehen?

    (nämlich mir diese anhaenge auch im REINER TEXT modus anzuzeigen)

  • kann ich vielleicht meinen thunderbird irgendwie veranlassen, damit anders umzugehen?

    Ich kenne keinen solchen "Würgaround", werde aber noch mal eine Suche nach einem entsprechenden Mozilla-Bugbericht unternehmen.

    Das gleiche Thema wurde übrigens schon im letzten Jahr hier behandelt Dateianhänge von Mac/Apple können nicht geöffnet/gespeichert werden mit der gleichen Schlussfolgerung:


    "Über ANSICHT/NACHRICHTENINHALT/ORIGINAL HTML werden die Anhänge aufgelistet und dann auch korrekt gespeichert."

  • danke.


    klar, ueber den wechsel der ansichtsoption auf ORIGINAL HTML, VEREINFACHTES HTML oder auch dem addon ALLE TEILE DES INHALTS laesst sich alles wunderbar anzeigen, oeffnen und speichern.


    ich aber moechte gerne aus verschiedensten gründen meinen REINER TEXT modus beibehalten.


    hab jetzt auch schon viel gelesen, auch in englisch-sprachigen foren etc, eine lösung aber bisher nicht finden können.

  • Hallo manode,


    hilft Dir eventuell die Erweiterung Allow HTML Temp?


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • werde aber noch mal eine Suche nach einem entsprechenden Mozilla-Bugbericht unternehmen.

    So wie ich es verstehe, wäre die einzige Lösung die, dass Thunderbird pdfs gleich inline anzeigt. So ist es von Apple Mail ja deklariert. Nach meinem Verständnis ist das kein Bug im Thunderbird sondern ein neues Feature, ein Enhancement. Das wäre also eher ein RFE. Wobei Mozilla die RFEs als Bugs tracked. Vielleicht wirst du also doch fündig.

    Ceterum censeo polypos rerum privatarum esse delendos!

    Frei nach Cato dem Älteren

    (Werter Herr T. , ich hoffe, ich habe da keinen Bock eingebaut.)