S/MIME Probleme beim Senden

    • Thunderbird-Version: 52.6.0 (64-Bit)
    • Betriebssystem + Version:Linus CentOS 7
    • Kontenart (POP / IMAP):POP

    Meine E-Mail Adresse hat ein S/MIME Zertifikat zum unterschreiben und verschlüsseln:


    [IMG:http://up.picr.de/32232371py.png]


    [IMG:http://up.picr.de/32232425hc.png]


    Zum Versand (SMPT) wurde die Verschlüsselung ausgestellt und "unterschreiben" eingestellt.

    Der Versand scheitert:


    [IMG:http://up.picr.de/32232994yf.png]


    Das ist schon richtig, weil der Empfänger kein Zertifikat hat.

    Beim erneuten nachschauen war zusätzlich zum unterschreiben auch verschlüsseln angekreuzt, obwohl das vor dem Versand explizit deaktiviert war!


    Erst ohne dem Häkchen beim "Unterschreiben" kann die Nachricht versandt werden, dann allerdings ohne Zertifikat.


    Woran kann das liegen?

  • Du hast offensichtlich Enigmail 2.0 installiert. Jedenfalls kenne ich den Dialog aus den Thunderbird-Einstellungen so nicht. Und auch die Unterstüzung für PEP gibt es in der 1.9.x ja nicht.

    Kontrolliere also zunächst mal die Einstellungen von Enigmail. Vielleicht hast du dort irgendwo angehakt, dass verschlüsselt werden soll.


    Für S/MIME benötigst du Enigmail übrigens nicht. Das kann der Thunderbird allein.

  • Das stimmt schon, weil ich bei einer meiner Mailadressen aus historischen Gründen OpenPGP verwende und deshalb das Plugin installiert habe.

    Ich sehe aber gerade, dass dort bei "Automatische Updates" die Einstellung "Standard" ist und scheinbar zuletzt am 26.03.2018 eine Aktualisierung stattfand. Das passt zumindest zeitlich zum geschilderten Sachverhalt.


    Es scheint tatsächlich so zu sein, dass das Plugin seit dem letzten Update sich nicht mehr mit S/MIME verträgt. Ich habe das Plugin deaktiviert und nun klappt der Versand.


    Vielen Dank für den Tip!

  • weil ich bei einer meiner Mailadressen aus historischen Gründen OpenPGP verwende und deshalb das Plugin installiert habe.

    Dazu eine Frage zu Enigmail 2.0.

    Ich benutze Enigmail in der Version 1.9.x für PGP. Ich werde auch vorerst bei dieser Version bleiben. S/MIME geht über die Funktion des Thunderbird. Ich muss dazu Enigmail nicht deaktivieren.

    Geht das mit der Version 2 nicht mehr so einfach? Ich habe in den Ankündigungen gelesen, dass Enigmail anhand der vorhandenen Schlüssel automatisch wählen kann, ob PGP oder S/MIME verwendet werden soll. Diesen Automatismus kann man doch bestimmt abschalten und manuell auswählen, oder nicht? Dass man Enigmail deaktivieren muss, kann ja nicht gewollt sein.

  • Hallo Drehmoment,


    es hat den Anschein, dass Enigmail 2.0 tatsächlich die "Thunderbird Mail DE"-S/MIME-Funktion außer Kraft setzt!

    S[chimpfwort]!


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • es hat den Anschein, dass Enigmail 2.0 tatsächlich die "Thunderbird Mail DE"-S/MIME-Funktion außer Kraft setzt!

    Der Anschein trügt ein wenig.


    Ich habe jetzt ein Update auf die 2.0. gemacht. Ich habe eingestellt, dass, wenn zu einer Adresse sowohl ein OpenPGP als auch ein S/MIME-Schlüssel vorhanden ist, OpenPGP verwendet werden soll.


    Verfasse ich nun eine E-Mail und setze über das S/MIME-Icon die Häkchen, wird trotzdem OpenPGP verwendet. Die Auswahl über das Icon hat wohl in diesem Fall keine Wirkung mehr.

    Das mag irritieren, erscheint mir aber richtig, denn es entspricht der in Enigmail getroffenen Vorauswahl.


    Im Verfassenfenster kann ich aber über das "Icon" mit den Informationen zu Enigmail nach wie vor auswählen, ob ich PGP/INLINE, PGP/MIME oder eben S/MIME verwenden möchte. Das funktioniert dann auch.