TB 60: Verschwinden von Vorlagen nach Gebrauch?

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 60.0
    • Betriebssystem + Version: Windows 10
    • Kontenart (POP / IMAP): POP (mehrere, Benutzung des globalen Posteingangs)
    • Postfach-Anbieter (z.B. GMX): nicht bekannt
    • Eingesetzte Antiviren-Software:
    • Firewall (Betriebssystem-intern/Externe Software):
    • Router-Modellbezeichnung (bei Sende-Problemen):


    Hallo Mitstreiter,


    ich möchte zunächst ganz allgemein in die Runde fragen, ob einer von euch in der neuen Version Thunderbird 60 Probleme beim Arbeiten mit Vorlagen hat.

    Der Grund für meine Frage ist, dass ich in den letzten Tagen im "linksrheinischen" Mozilla-Forum vergeblich versucht habe, das mysteriöse Verschwinden von Vorlagen bei einem TB-Nutzer aufzuklären.


    Laut der Beschreibung des Themenerstellers im Original-Thread (https://forums.mozfr.org/viewtopic.php?f=4&t=139034) werden bei im die seit dem Update auf TB 60.0 neu erstellten Vorlagen regelmäßig nach der ersten Benutzung gelöscht. Nach dem Senden einer auf einer Vorlage basierenden Nachricht verschwindet die entsprechende Vorlage einfach aus dem Ordner "Vorlagen", unabhängig davon, ob die Vorlage über die R-Klick Befehle "Als neu bearbeiten", "Neue Nachricht aus Vorlage" oder "Vorlage bearbeiten" geöffnet wird. Vereinfacht könnte man sagen, die Vorlagen verhalten sich bei ihm wie Entwürfe.


    Bei Benutzung von Vorlagen, die unter der Vorversion TB 52.9.1 erstellt worden waren, tritt dieses Problem nicht auf. Die betroffene Person hat Windows als Betriebssystem, und ich kann sein Problem unter macOS einfach nicht reproduzieren. Wir haben natürlich den abgesicherten Modus von TB getestet, des weiteren ein neues Profil, die Version TB 60.0b11, ein Einzelkonto statt dem globalen Posteingang,... das Problem ließ sich damit bislang nicht lösen, da wir keine Ursache für das beschriebene Verhalten der Vorlagen erkennen können. Wir haben das Problem vorläufig so umgangen, dass die betroffene Person wieder die Version TB 52.9.1 installiert hat.


    Den Release Notes von RB 60 https://www.thunderbird.net/en…in&buildid=20180731173940 entnehme ich, dass in der neuen Version zwei neue Befehle zu Vorlagen eingeführt worden sind:


    "Edit Template" command. This also solves various problems when saving as template (duplicates created, message ID lost).

    "New Message from Template" command.


    Könnte eine dieser Änderungen einen Bug hervorgerufen haben?

    Bevor ich an die Erstellung eines neuen Bug-Berichtes denke, müsste das beschriebene Problem zumindest von einem anderen Nutzer reproduziert werden können. Im mozfr.org Forum hat sich bisher spontan niemand dazu geäußert.

    Ich würde mich freuen, wenn der eine oder der andere Lust und Zeit findet, das geschilderte Problem unter Windows und/oder Linux zu überprüfen.


    Gruß

    Mapenzi

  • Ich kann das Verschwinden der Vorlagen in TB 60 64bit nicht bestätigen. Die Vorlagen bleiben auch nach mehrmaliger Nutzung erhalten.


    Der Unterschied zwischen dem Themenersteller im Original-Thread und mir ist dass ich IMAP-Konten habe, während der Themenersteller POP-Konten hat.


    Ob das jetzt aber eine Rolle spielt kann ich nicht sagen und ich kann auch nicht mit einem POP-Konto testen, da ich nur IMAP-Konten habe.


    Betriebssystem: Windows 10 64 bit.

  • Hallo Mapenzi,


    ich kann ich mitteilen, dass die Arbeit mit der neuen Funktion sowohl unter POP3 als auch unter IMAP fehlerfrei funktioniert und auch die Vorlage erhalten bleibt.


    Betriebssystem: Linux openSUSE 15 Leap x86_64 und Linux Mageia 6 x86_64


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Road-Runner und Feuerdrache ,


    vielen Dank an euch beide für eure Tests. Damit haben wir schon je einen Test für jedes Betriebssystem, in denen das Problem nicht auftritt.


    Nach vielem Tüfteln habe inzwischen doch ein Szenario gefunden, in dem ich eine Vorlage nach dem Versenden (oder durch das Versenden) zum Verschwinden bringen kann:

    • Vorlage markieren und sie via das Menü "Nachricht" > "Vorlage bearbeiten" in Verfassen-Fenster ôffnen

    • Nachricht bearbeiten, indem z. B. Text geändert oder Grafik eingefügt wird, dann Menü Datei > Speichern, Verfassen-Fenster nicht schließen, sondern...

    • Empfänger einfügen, auf "Senden" klicken und Ordner "Vorlagen" beobachten: die Vorlage verschwindet aus dem Ordner sobald die Nachricht gesendet ist (wenn man die entsprechende Mbox-Datei "Templates" im Text-Editor öffnet, sieht man, dass die verschwundene Vorlage den X-Mozilla Status 0009 = gelöscht hat)


    Vermutlich missbrauche ich aber in diesem Schema die Funktion "Vorlage bearbeiten".

    Offenbar dient diese tatsächlich nur zum Bearbeiten und nicht zum anschließenden Versenden aus dem selben Verfassen-Fenster heraus.

  • • Vorlage markieren und sie via das Menü "Nachricht" > "Vorlage bearbeiten" in Verfassen-Fenster ôffnen

    • Nachricht bearbeiten, indem z. B. Text geändert oder Grafik eingefügt wird, dann Menü Datei > Speichern, Verfassen-Fenster nicht schließen, sondern...

    • Empfänger einfügen, auf "Senden" klicken und Ordner "Vorlagen" beobachten: die Vorlage verschwindet aus dem Ordner sobald die Nachricht gesendet ist

    Das kann ich ebenfalls bestätigen. Könnte es sein dass der Themenersteller im Originalthread seine Vorlagen auf diese Art bearbeitet?

  • Könnte es sein dass der Themenersteller im Originalthread seine Vorlagen auf diese Art bearbeitet?

    Er hat keine Schritt-für-Schritt Beschreibung gemacht wie ich im obigen Beispiel, aber er sagt an einer Stelle, dass es egal ist, ob er die Vorlage öffnet durch Doppelklick oder das Menü "Nachricht" > "Neue Nachricht aus Vorlage" , jedes Mal ist sie weg nach Versenden der Nachricht, während in diesen Fällen die Vorlagen bei mir erhalten bleiben. Und dass seine unter der alten Version erstellten Vorlagen von dem Problem nicht betroffen sind, ist auch sehr merkwürdig.

  • Hallo Mapenzi,


    ich kann Dir dazu aktuell eine "positive" Information geben.


    Ich habe heute eine bestehende Vorlage mit der neuen Funktion "Neue Nachricht aus Vorlage" als neu bearbeitet und mit geändertem Inhalt verschickt. Resultat:


    • a) Die ursprüngliche Vorlage bleibt unverändert im Vorlagenordner erhalten.
    • b) Die veränderte Vorlage, die versendet wurde, ist nicht im Vorlagenordner gespeichert. Statt dessen ist die "neue Vorlage" nach dem Sendevorgang
    • c) im Ordner "Entwürfe" gespeichert.
    • d) Ich habe diese dann anschließend in den Ordner "Vorlagen" verschoben.

    Im strengen Sinne ist c) eigentlich auch logisch, da es ja nicht die ursprüngliche Vorlage ist. Ob das aber sinnvoll ist, das ist eine ganz andere Frage.


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • a) Die ursprüngliche Vorlage bleibt unverändert im Vorlagenordner erhalten.

    ist normal, denn du hast ja nur eine neue Nachricht aus der Vorlage erstellt, aber das Original nicht verändert!

    Die veränderte Vorlage, die versendet wurde, ist nicht im Vorlagenordner gespeichert

    Auch normal, denn du hast ja nicht eine neue Vorlage aus der "originalen" Vorlage erstellt, sondern eine neue Nachricht.

    Statt dessen ist die "neue Vorlage" nach dem Sendevorgang
    c) im Ordner "Entwürfe" gespeichert.

    Das ist nicht normal, es sei denn, du hast zwischendurch auf "Speichern" geklickt oder du hast z. B. fünf Minuten an der neuen Nachricht gewerkelt. Denn dann würde deine "neue Nachricht aus Vorlage" wie eine gewöhnliche neue Nachricht in "Entwürfe" manuell oder automatisch in "Entwürfe" zwischengespeichert. Nach dem Senden würde sie allerdings automatisch aus "Entwürfe" entfernt, so wie ich es inzwischen schon getestet habe.

  • Hallo Mapenzi,


    Das ist nicht normal, es sei denn, du hast zwischendurch auf "Speichern" geklickt oder du hast z. B. fünf Minuten an der neuen Nachricht gewerkelt.


    na ja, ich habe schon einige Minuten an der Nachricht gewerkelt; unter anderem durch ein Telefonat unterbrochen. ;)


    Es wurde also sicherlich mal automatisch zwischengespeichert.


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier