Autom. nach Links Schlagwort vergeben

    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 68.4.2 (war aber auch schon in vorigen 68er Versionen so)
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (bspw. von 60.* auf 68.*): nein
    • Betriebssystem + Version: Win8.1
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): Posteo
    • Eingesetzte Antiviren-Software: Kaspersky free
    • Firewall (Betriebssystem-intern/Externe Software): intern mit externer Oberfläche
    • Router-Modellbezeichnung (bei Sende-Problemen): FRITZ!Box 3272

    Diese Worte hier können Sie mit Ihrem Text bitte überschreiben (scheint mir alles nicht relevant).

    Moinstens Miteinander,


    bislang konnte ich meine Probleme immer durch externes Lesen lösen, aber die halbwegs relevanten Beiträge zum aktuellen Problem sind uralt und da teils gelöst.

    Bei mir löst es sich ohne Hilfe jedoch nicht.


    Ich würde gerne eingehende und auch ausgehende Mails mit einem Schlagwort versehen, damit sie in der Liste als Link-enthaltend erkennbar werden.


    Schlagwort(e) habe ich erstellt, Filter auch und für alle angebotenen Trigger aktiviert.


    Die manuelle Auslösung hat vor Monaten mal funktioniert, die automatische leider nie.

    Nun funktioniert auch die manuelle Auslösung nicht.


    Bitte schaut Euch meine Einstellung an und sagt mir, was ich falsch mache!


    Filter bearbeiten | Filter


    Und optional noch eine Frage: muss ich wirklich für jeden Unterordner einen eigenen Filter erstellen?
    Sie sind im Grunde identisch und zeigen eben jeweils auf einen anderen Unterordner. Wenn ich jedoch den jeweils anderen Filter in der Liste auswähle (markiere), springt die Zielangabe unten nicht mit um. Ist das normal?

  • graba

    Approved the thread.
  • Bei der Definition der Filterbedingungen musst du die "*" entfernen, die du als Joker gedacht hast. Die Bedingung ist doch bereits "enthält".

    So wie du es gemacht hast wird nach dem Text "http://*" usw. gesucht. Der kommt normalerweise nicht vor. Also findet der Filter auch nichts.

    Ja, Du hast Recht, das klingt logisch.

    Nun habe ich das geändert und lasse ihn nur noch nach "http", "www." und "//" suchen.

    Die Wirkung bleibt allerdings aus. Die bereits markierten Mails (bis vor etwa einem halben Jahr) bleiben es, aber es kommen weder manuell noch automatisch welche hinzu.


    Auch das aktivierte Filter-Protokoll bleibt leer.


    Den Wurm haben wir noch nicht ...

  • Wenn das Filterprotokoll leer ist, wurden die Filter anscheinend gar nicht erst ausgeführt. Funktionieren sie wenn sie auf den Posteingang für neu eingehenden Mails anwendet werden?

    Nein ...

    Auch das nicht.

    Normalerweise wird bereits beim Provider alles aus dem Posteingang in Unterordner wegsortiert. Es gibt zum Testen aber eine Ausnahme.

    Nur die manuellen Schnellfilter funktionieren.


    Was kann Filter grundsätzlich verhindern?

    Irgendwas in den Erweiterten Einstellungen?

  • Ich habe so einen Filter mit enthält https:// oder http:// nachgebaut. Bei mir funktioniert er automatisch für den Posteingang. Ich kann dir leider nicht sagen, weshalb das bei dir nicht so ist.

  • Wenn es bei mir funktioniert, bei dir aber nicht, muss es ja eine Ursache dafür geben. Anstatt nun lange danach zu suchen, teste doch einfach mal mit einem neuen Profil. Das kannst du für den Test zusätzlich anlegen. Das ist in 5 Minuten erledigt. Wenn es damit nicht funktioniert, hast du einen Fehler in den Filtern oder in dem Konstrukt mit den Filtern auf dem Server.

  • Setzt du ein Add-on (bspw. Enigmail) zur Verschlüsselung oder Signierung von Mails ein?

    Ich habe nämlich deine Filter nachgebaut und auf meine "Gesendeten Nachrichten" manuell angewendet. Dabei wurden ausnahmslos nur die Nachrichten mit einem Stichwort versehen, welche nicht einmal signiert waren!


    Edit: Nee, das ist es auch nicht

    Edited once, last by Mr. Magpie ().

    [...] Fehler in den Filtern oder in dem Konstrukt mit den Filtern auf dem Server.

    Okay, neues, jungfräuliches Profil, gleiches Konto. Sonst keinerlei Modifikation: oobe.

    Der Ordner TK wurde mit dem Schnellfilter behandelt und der Abruf über das neue Profil bringt diese Markierungen automatisch mit.

    Das wusste ich auch noch nicht: diese Markierungen werden bei Posteo offensichtlich mitgespeichert, obwohl der Webmailer sie gar nicht darstellen kann.


    Spannend wird es beim Ordner UM, weil der immernoch auf dem Stand der letzten gelungenen automatischen Filterung steht.

    Auch im neuen Profil wird er genauso dargestellt: Markierungen nur bis 26.05.2019.


    Also erstellte ich das Schlagwort und den Filter für UM, nur auf den Inhalt: "http".

    Leider gleiches Verhalten, wie im alten Profil: Keine Filterung, weder manuell, noch automatisch und auch im Log zeichnet sich nichts ab.

    Ich weiß, daß es seit dem Mai letzten Jahres zahlreiche Mails mit Weblinks gab und auch hier werden sie per Schnellfilter gefunden: 5.

    Sie wurden vom Filter aber nicht markiert.


    Was mir aufgefallen ist: in der "Erweiterten Konfiguration" (about:config) finden sich unter dem Suchwort "filter" vier geänderte Einträge, im alten Profil sind es gar sechs:

    Wenn ich die Zeitstempel auflöse, sind das

    01/11/1970 21:49:17 01/11/1970 21:49:27

    01/11/1970 21:49:15 01/11/1970 21:49:25.

    Was hat das zu bedeuten? Ist das fürs Thema relevant?

  • Meine Idee war eigentlich die, dass du den Filter nicht auf irgendwelche Unterordner loslässt sondern auf den Posteingang! Ich meine nämlich, dass Filter bei anderen Ordnern außer Posteingang uns Gesendet nicht automatisch bei Maileingang in diesen Ordner ausgeführt werden. Kann sein, dass ich mich irre, hab's nicht getestet.


    Das Speichern der Schlagwörter auf dem IMAP-Server klappt bei mir schon immer.


    Also, nochmal zum Testen bitte: neues Profil, keine Faxen wie Erweiterungen etc. , nur ein Konto einrichten. Auch keine anderen Filter oder sonstige Umsortierungen auf dem Server durchführen. Einfach alles beim Standard belassen.

    Für den Test folgenden Filter für den Posteingang erstellen


    Danach schickst du dir dann eine Mail mit einem Link im Inhalt an dieses Konto. In einer nicht veränderten Standardinstallation muss das funktionieren.

    Im nächsten Schritt kann du dann weiter suchen, welche deiner "Spezialbehandlungen" dazu führt, dass der Filter nicht mehr funktioniert.

    tl;dr


    Filter auf "Inhalt" funktionieren nicht! Die Kopfzeile wurde (vermutlich) selbst erstellt, weil sie fehlte.

    Warum fehlte sie, wie wird sie korrekt implementiert?



    Die Testmail im Posteingang wird genauso wenig markiert, wenn ich den Filter explizit im Posteingang auslöse.

    Auch die Reduzierung der Anwendungsregeln nach Deinem Beispiel macht daran keinen Unterschied.

    Es wird auch da kein Eintrag im aktivierten Filterprotokoll ausgelöst, weder bei automatischer Auslösung, noch bei manueller, ebenfalls egal, ob aus dem Filter-Dialog oder aus dem "Hamburger"-Menü des Ordners "Posteingang" selbst.


    Das Profil wurde gestern extra zu diesem Zweck erstellt und hat wie gesagt ansonsten keinerlei Modifikationen erfahren. Genau so: "Einfach alles beim Standard belassen".

    Die vorgeschaltete Filterung auf dem Server ist bereits in der Vergangenheit geschehen und ich werde da jetzt auch nichts durcheinander bringen.


    Die Testmail jedoch, rauscht direkt durch und bleibt im Posteingang ohne von Sieve-Filtern tangiert zu werden. Daran ändern auch beliebige Wiederholungen nichts: das ist korrekt.

    Wenn ich alle Auslöser ausgewählt habe, müsste es entgegen Deinem Einwand wenigstens bei: "Manuellem Ausführen" und "Alle 10 Minuten erneut ausführen", sowie "Versand" funktionieren. Tut es aber nicht.


    Eine Testmail mit Link wurde auf das Kriterium "Betreff enthält: Tropfen" mit der Aktion "Schlagwort hinzufügen: Wichtig" geprüft. Das hat funktioniert!

    Das Filterprotokoll enthält nun den Eintrag:

    Quote from Filter-Protokoll

    [31.01.2020, 12:52:38] Filter "Betreff enthält: Tropfen" auf die Nachricht <Absender> - Noch ein Tropfen am 31.01.2020, 12:43:58 angewendet
    Schlagwort hinzugefügt

    Eben erst entdeckt:

    Die Bedingung "Inhalt" wird im neuen Profil gar nicht angeboten! Ich weiß nicht, wieso sie im alten Profil vorhanden ist. Vielleicht habe ich sie erstellt?

    Eine neue Kopfzeile "Inhalt" bringt jedenfalls im neuen Profil auch keinen Unterschied: wird nicht ausgeführt (siehe Protokoll).


    Im Übrigen wurde an den Einstellungen auf dem Server im letzten Jahr nichts verändert und vor gut einem halben Jahr hat es ja wenigstens einmal funktioniert (warum auch immer), allerdings weiß ich nicht, wie da die Thunderbird-Filtereinstellungen waren, weil ich nun so viel herumprobiert habe.



    Eine Frage ist noch offen: die Auswahl des Ordners, auf den der Filter angewendet werden soll, steht immer auf dem Ordner, aus dem heraus ich den Dialog öffne.

    Werden die Unterordner des Posteingangs von einem Filter auf den Posteingang normalerweise mit betroffen oder nicht?


    Eine Testmail wurde auf das Kriterium "An enthält: <Name>" mit der Aktion "Schlagwort hinzufügen: Persönlich" geprüft.

    Eine Testmail wurde auf das Kriterium "An enthält: <Adresse>" mit der Aktion "Schlagwort hinzufügen: Persönlich" geprüft.

    Das hat beides nicht funktioniert!


    Eine Testmail wurde auf das Kriterium "Betreff enthält: Re: Hier + So" mit der Aktion "Schlagwort hinzufügen: Später" geprüft.

    Das hat nur direkt auf den Unterordner funktioniert!

  • Da muss ich passen. So, wie du den Sachverhalt beschreibst, kann ich es nicht erklären. Außer mit unbekannten Dingen, die du auf dem Server durchführen lässt oder falls die Mails verschlüsselt sein sollten.

    Bei mir funktioniert der dargestellte Filter nachweislich, IMAP, mit Text wie auch mit HTML Mails. Das können vielleicht auch andere gern einmal testen.

    Die Bedingung "Inhalt" wird im neuen Profil gar nicht angeboten!

    Auch das kann ich nicht erklären. Bei mir gibt es diese Option.

  • Ich meine nämlich, dass Filter bei anderen Ordnern außer Posteingang uns Gesendet nicht automatisch bei Maileingang in diesen Ordner ausgeführt werden. Kann sein, dass ich mich irre, hab's nicht getestet.


    Quote

    Seit Thunderbird Version 45 gibt es eine versteckte Option, um die Filter auf sämtliche Ordner eines Kontos anwenden zu können - also nicht nur den Posteingang.


    Das ist mal ein guter Hinweis. Frage mich nur, weshalb diese Option versteckt ist.

    Außer mit unbekannten Dingen, die du auf dem Server durchführen lässt oder falls die Mails verschlüsselt sein sollten.

    Bei mir funktioniert der dargestellte Filter nachweislich, IMAP, mit Text wie auch mit HTML Mails. Das können vielleicht auch andere gern einmal testen.

    Unbekannte Dinge? Sieve-Filter, die bei mir mindestens ein Jahr unverändert lediglich in die Ordner sortieren und Spam aussortieren.

    Keine Verschlüsselung außer der von Posteo angebotenen Adressbuch- und Kalenderverschlüsselung und TLS natürlich.

    Weil jemand mal fragte bitteschön: im Thunderbird ist kein Enigmail installiert und Autocrypt wurde nur einmal ausgehend getestet.

    Im neuen Profil ist natürlich sowieso nichts davon, es ist ja NEU, gell?

    Ich verwende ein- und ausgehend ausschließlich reine Textmails.


    Daß es bei Dir funktioniert, ist schön, allein diese Info nützt mir nichts. Der entscheidende Punkt ist ja, warum ‒ also: was ist anders?

    vielleicht helfen folgende Informationen: 2 Filter anwenden

    Vielen Dank. mail.imap.filter_on_new steht (offensichtlich standardmäßig) auf true.

    Das dort empfohlene AddOn funktioniert nur bis TB60*, andere AddOns zum Thema muss ich erst untersuchen.

    Filter-Aktionen können bisher leider nur auf den Posteingang automatisch ausgeführt werden. Für alle anderen Ordner muss man die Filter-Aktionen manuell starten.

    Das scheint also veraltet zu sein. Funktioniert bei mir aktuell aber trotzdem nicht.

  • Daß es bei Dir funktioniert, ist schön, allein diese Info nützt mir nichts. Der entscheidende Punkt ist ja, warum ‒ also: was ist anders?

    Das ist das, was ich dir in meinem Essay sagen wollte. Wenn es bei mir und sehr wahrscheinlich auch bei anderen funktioniert, dann ist es kein Problem im Thunderbird. Wenn es bei dir selbst mit einem neuen, blanken Profil nicht geht, dann liegt die Ursache auch nicht im Profil. Du musst also an anderer Stelle außerhalb des Thunderbird suchen.

    Wie wäre denn folgendes? Besorge dir für Testzwecke eine kostenlose E-Adresse. Dann erstellst du erneut ein neues Profil und richtest darin nur dieses Konto als IMAP ein. Und den Filter natürlich. Dann teste.