Beim Verfassen von Nachrichten das verlinken von Grafiken aus dem Internet verbieten

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version: 68.4.1
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (alte und neue Version angeben): Nein
    • Betriebssystem + Version: Xubuntu (Ubuntu 18.04.4 LTS + xfce 4.12)
    • Kontenart (POP / IMAP): IMAP
    • Postfach-Anbieter (z.B. GMX): Postfix/Dovecot
    • Eingesetzte Antiviren-Software: Auf Client-Seite keine
    • Firewall (Betriebssystem-intern/Externe Software): Keine
    • Router-Modellbezeichnung (bei Sende-Problemen): Irrelevant


    Hallo,


    ich möchte Thunderbird so konfigurieren, dass unter keinen Umständen möglich ist, dass beim Verfassen einer Nachricht eine Grafik aus dem Internet verknüpft wird. Das aktuelle Verhalten von Thunderbird begünstigt meiner Ansicht nach Missverständnisse, weil beim Verfassen kein Unterschied zwischen verknüpften und eingebetteten Bildern zu erkennen ist.



    Ich habe vor einiger Zeit schon mal einen Thread zu diesem Thema gestartet, der aber nicht zu einer abschließenden Antwort geführt hat.


    siehe: https://www.thunderbird-mail.de/forum/thread/77527



    Wenn ich im Browser ein Bild kopiere (z.B. im Firefox über das Kontextmenu mit "Copy Image") und dann beim Verfassen einer Nachricht den Inhalt meiner Zwischenablage einfüge (z.B. mit Edit > Paste), ist meine intuitive Erwartung, dass ich ein Bild einfüge. Ich habe ja schließlich auch ein Bild kopiert.


    Leider sieht die Realität anders aus. Das "kopierte" Bild wird nur verknüpft und nicht inline eingefügt, was dann (völlig berechtigter Weise) dazu führt, dass das Bild bei den meisten Empfängern nicht dargestellt wird und es einen Privatsphäre-Sicherheitshinweis gibt.


    Es mag ja sein, dass meine Erwartungshaltung hier unberechtigt ist. Es ist auch gut möglich, dass das Problem beim Firefox zu suchen ist, der mir versprochen hat ein Bild zu kopieren und statt dessen nur einen Link kopiert hat.


    Ich möchte aber wissen ob ich Thunderbird so konfigurieren kann, dass es in keinem Fall möglich ist, beim Verfassen einer Nachricht ein Bild aus dem Internet zu verknüpfen. Während ich eine Nachricht verfasse sehe ich nämlich leider keinen Unterschied, ob ein Bild nun verknüpft oder inline eingebettet wird. Der Fehler ist erst bemerkbar, wenn die Nachricht schon versendet wurde und es bereits zu spät ist. Falls es nicht möglich ist das Verknüpfen von Bildern generell zu verbieten, wäre ich schon zufrieden wenn verlinkte Bilder beim Verfassen eindeutig gekennzeichnet wären.



    Viele Grüße

  • Du hast in deinem alten Thread geschrieben:

    Quote

    ...und in der Eile oder in Gedanken erst im Firefox im Kontextmenu auf "Grafik kopieren" und dann im Verfassenfenster im Kontextmenu auf "Einfügen" klicke, die Grafik trotzdem nicht als Link verschickt wird.

    ... und damit verschickst du einen Link zu diesem Bild, da kann TB nichts dafür. Wenn du das nicht möchtest, musst du das Bild speichern und dann in die Mail als Bild einbetten.

    Alternativ auf HTML Mails verzichten.

    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten zu Testzwecken diverse portable TB in den Versionen 68.* , 78.* und 80.*

  • Hallo Micha,


    vielen Dank für Deinen schnellen Hinweis. Ist aber leider keine Antwort auf meine Frage.


    Ich habe außerdem erhebliche Zweifel, ob man als Benutzer erwarten kann dass "Grafik kopieren" und dann einfügen dazu führt das die Grafik verlinkt wird. Das ist aber natürlich Ansichtssache und es mach keinen Sinn darüber zu diskutieren.


    Viele Grüße

  • Ich habe es eben ausprobiert, mit einer Grafik aus diesem Forum. Wähle ich im Firefox "Grafik kopieren" wird die Grafik base64-codiert mitgesendet und wird auch angezeigt. So sollte es meiner Meinung nach auch sein.

    Für einen Link gibt es extra "Grafikadresse kopieren".

  • Hallo NumLock,


    toll. Das ist genau das Verhalten, das ich erwarten würde. Wenn es bei Dir geht, dann muss es ja irgendwie auch bei mir gehen. Nur tut es das leider nicht.


    Natürlich habe ich auch "copy link address" als Option im Kontextmenu von Firefox aber das ist es nicht was ich verwendet habe. Ich werde noch mal ein paar Versuche machen und womöglich mit noch weiteren Fragen zu Deiner Konfiguration auf Dich zurückkommen.


    Vielen Dank schon mal für die Antwort

  • Bei mir wird auch, ein im Fx per Kontextmenü "Bild kopieren" kopiertes Bild, im Verfassen und beim Empfänger als reine Grafik angezeigt, und nicht als Link oder dergleichen.

    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten zu Testzwecken diverse portable TB in den Versionen 68.* , 78.* und 80.*

  • Hallo nochmal,


    Du hast es aber nicht zufällig mit einer der SVG Grafiken versucht, die als Standard-Profilbilder verwendet werden, oder?


    Mir ist gerade aufgefallen, dass der Dateityp anscheinend eine Rolle spielt. Wenn ich z.B. eine Test-Email verfasse und in diesem Thread mein eigenes Profilbild und das Profilbild von Micha (MSFreak) kopiere und dann einfüge, dann wird mein Profilbild (SVG-Grafik) inline Eingebettet aber das Profilbild von Micha (JPEG) wird verlinkt.


    Viele Grüße

  • Hallo Micha,


    ich hatte Deine Nachricht eben noch nicht gesehen. Der letzte Post war an NumLock gerichtet.


    Danke für den Hinweis. Dass es bei Euch beiden geht gibt ja Hoffnung.


    Hab Ihr eigentlich eine ähnliche Konfiguration wie ich oder benutzt Ihr ein anderes Betriebssystem oder einen andere Fenster-Manager?


    Viele Grüße

  • Hallo wowbagger,


    könnte es nicht sein, dass Du versehentlich die Grafikadresse kopiert hast?:



    Ich persönlich bevorzuge in solchen Fällen "Grafik speichern unter", da ich ohnehin nur Reintextmails versende und in Reintext auf erhaltene E-Mails antworte, wo Bilder dann der zu versendenden E-Mail (oder Antwort-Mail) als Anhang beigefügt werden.


    Hab Ihr eigentlich eine ähnliche Konfiguration wie ich oder benutzt Ihr ein anderes Betriebssystem oder einen andere Fenster-Manager?


    Der Bildschirmausdruck (aus Firefox, Webseite von Zeit-Online) stammt von meinem Arbeitsplatzrechner, wo ich mit Windows 10 und Outlook unterwegs sein muss.


    Privat bin ich mit Linux openSUSE 15.1 Leap bzw. Linux Mageia 7.1 (beides 64-Bit) und Distributionsversionen des Donnervogels unterwegs.


    Gruß

    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Du hast es aber nicht zufällig mit einer der SVG Grafiken versucht, die als Standard-Profilbilder verwendet werden, oder?

    Doch, habe ich. Und genau wie bei dir klappt es mit dem Bild von msfreak nicht. Das hat vielleicht damit zu tun, dass diese Grafik nicht aus dem Forum selbst kommt. Ich kann das im Moment aber nicht weiter testen.

    Zu deiner Ausgangsfrage,

    Ich möchte aber wissen ob ich Thunderbird so konfigurieren kann, dass es in keinem Fall möglich ist, beim Verfassen einer Nachricht ein Bild aus dem Internet zu verknüpfen.

    Ich glaube nicht, dass so etwas geht.

  • Wenn ich z.B. eine Test-Email verfasse und in diesem Thread mein eigenes Profilbild und das Profilbild von Micha (MSFreak) kopiere und dann einfüge, dann wird mein Profilbild (SVG-Grafik) inline Eingebettet aber das Profilbild von Micha (JPEG) wird verlinkt.

    ... kann ich definitiv nicht bestätigen, egal was für ein Profilbild ich ( per "Bild kopieren" ) verschicke, es kommt beim Empfänger als eingebettete Grafik an und nicht als Link.

    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten zu Testzwecken diverse portable TB in den Versionen 68.* , 78.* und 80.*

  • Sehr, sehr vielen Dank schon mal für Eure Mühen und die rege Beteiligung an diesem Thread!


    könnte es nicht sein, dass Du versehentlich die Grafikadresse kopiert hast?:

    Ja Feuerdrache, ich bin mir sicher dass ich nicht "Grafikadresse kopieren" verwendet habe. Deine Vermutung ist natürlich berechtigt aber ich kann es ausschließen. Ich habe es inzwischen mehrfach versucht.


    Doch, habe ich. Und genau wie bei dir klappt es mit dem Bild von msfreak nicht. Das hat vielleicht damit zu tun, dass diese Grafik nicht aus dem Forum selbst kommt. Ich kann das im Moment aber nicht weiter testen.

    Zu deiner Ausgangsfrage,

    NumLock, vielen Dank, dass Du Dir die Mühe gemacht hast, das noch mal zu überprüfen.


    ... kann ich definitiv nicht bestätigen, egal was für ein Profilbild ich ( per "Bild kopieren" ) verschicke, es kommt beim Empfänger als eingebettete Grafik an und nicht als Link.

    Vielen Dank für den Hinweis. Jetzt stellt sich die Frage inwieweit sich Deine Konfiguration von der von NumLock und mir unterscheidet.



    Auch für Eure Hinweise auf die Verwendung von Reintext-Emails bin ich dankbar. Es ist aber so, dass ich viel mit anderen Programmierern kommunizieren muss und es oft sehr hilfreich ist, ein paar HTML-Formatierungen anwenden zu können. Ich benutze HTML-Mails nie um meinen Nachrichten eine "persönliche Note" zu geben, oft brauche ich es aber um die Lesbarkeit von komplexen Beschreibungen oder Quellcode-Beispielen zu vereinfachen. Ich bevorzuge ja generell WYSIWYAF, kann aber verstehen dass beim Verfassen von HTML-Nachrichten WYSIWYG vielleicht mehr Sinn macht. Es ist halt nur schade, dass man beim Verfassen einfach nicht erkennen kann, ob eine Grafik eingebettet oder verlinkt wird.



    Ich bin natürlich sehr daran interessiert, warum das Verhalten von "Bild kopieren" und Einfügen bei uns allen Anschein nach zu verschiedenen Ergebnissen führt. Ich hätte auch sehr gerne das gleich Ergebnis wie Du Micha, nämlich dass das Bild immer eingefügt wird und wüsste sehr gerne, ob das durch Einstellungen möglich ist (ich habe es mittlerweile auch mal parallel auf einem Windows Computer versucht, kam jedoch zu dem gleichen Ergebnis). Trotzdem würde ich gerne noch mal auf die Kernfrage zurückkommen: Kann man das Verlinken von Grafiken generell verhindern oder verlinkte Grafiken beim Verfassen erkenntlich machen? NumLock hat bereits geschrieben, dass er keine Lösung kennt und ich bin für die ehrliche Antwort sehr dankbar. Hat vielleicht sonst noch jemand eine Idee?


    Viele Grüße

  • Hallo nochmal

    ... kann ich definitiv nicht bestätigen, egal was für ein Profilbild ich ( per "Bild kopieren" ) verschicke, es kommt beim Empfänger als eingebettete Grafik an und nicht als Link.

    Nur um ganz, ganz sicher zu gehen, dass wir uns nicht falsch verstehen. Du meinst auch wirklich eingebettet als Content Disposition und nicht nur dass es in der Nachricht angezeigt wird, oder? Mit entsprechenden Privatsphäre-Einstellungen könntest Du das nämlich sehr leicht verwechseln.


    So sieht z.B. mein Profilbild eingebettet im Nachrichten-Quelltext aus:


    und so wird es dann in den HTML-Body eingebunden:

    Das Bild wir als Content Disposition in die Nachricht geschrieben. Das meine ich mit "eingebettet".


    Wenn ich Dein Profilbild kopiere und einfüge, dann sieht der Nachrichten Quelltext so aus:

    In diesem Fall gibt es keinen Content Disposition Teil der Nachricht. Das meine ich damit, wenn ich schreibe dass die Grafik "verlinkt" ist.


    Meinen wir wirklich das Gleiche?


    Viele Grüße

  • Du meinst auch wirklich eingebettet als Content Disposition und nicht nur dass es in der Nachricht angezeigt wird, oder?

    ... sorry, da kenne ich nicht den Unterschied. Beim Empfänger (hier auch TB, ist bei anderen Clients aber auch so) sieht es so aus:


    Gruß Micha


    Mein produktiver Mailclient ist der portable TB mit der derzeit aktuellsten Version.

    Ansonsten zu Testzwecken diverse portable TB in den Versionen 68.* , 78.* und 80.*

  • Man sieht den Unterschied entweder nur im Quelltext der Nachricht oder wenn man in den Privatsphäre-Einstellungen das Nachladen von externen Grafiken verboten hat.


    Vielen Dank und viele Grüße

  • Ich habe es stichprobenmäßig mit jpg von anderen Seiten probiert. Sie wurden allesamt nicht angehängt sondern nur verlinkt. Wie schon oben von dir vermutet. Warum das so ist, weiß ich nicht.

  • Hallo nochmal,


    danke für Deine weiteren Hinweise, NumLock.


    Ich habe leider immer noch keinen Weg gefunden, das Verlinken von Bildern generell zu verbieten oder zumindest beim Verfassen von Nachrichten deutlich erkennbar zu machen, dass ein Bild verlinkt wird.


    Ich habe aber zumindest folgendes herausgefunden: Wenn ich eine beliebige Rastergrafik im Firefox kopiere (z.B. über Kontextmenu mit "Bild kopieren") und in eine Email einfüge, dann wird das Bild standardmäßig nicht kopiert und eingebettet sondern statt dessen nur verlinkt. Mit einem Doppelklick auf das eingefügte Bild öffnet sich das Dialogfenster "Image Properties". Wenn ich in diesem Dialogfenster die Checkbox "Attach this image to the message" aktiviere, wird das Bild eingebettet. Ich wäre schon mit dem Kompromiss zufrieden, dies als Standard einzustellen.


    Kennt jemand einen Weg, den Default-Wert der Eigenschaft "Attach this image to the message" in den "Image Properties" zu ändern?


    Viele Grüße

  • Kennt jemand einen Weg, den Default-Wert der Eigenschaft "Attach this image to the message" in den "Image Properties" zu ändern?

    Habe es gerade gefunden. Im Config-Editor "mail.compose.attach_http_images" auf true setzen führt dazu, dass Bilder im html-Body standardmäßig als Content Disposition eingebettet und nicht verlinkt werden.


    Das ist zwar nicht exakt was ich wollte aber ich bin mit diesem Kompromiss schon absolut zufrieden.


    Danke an alle für die vielen Beiträge!

    Viele Grüße