Profilübernahme so nicht mehr möglich...

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    • Thunderbird-Version (konkrete Versionsnummer:( 78.6.0 32Bit
    • Wurde gerade auf eine neue Versionsreihe aktualisiert (alte und neue Version angeben):
      • Betriebssystem + Version: Windows 10 20H2
    • Kontenart (POP / IMAP): 5 POP Konten, 1x Gmail
    • Postfach-Anbieter (z.B. GMX): GMX, WEB.DE, Telekom, google
    • Eingesetzte Antiviren-Software: AVIRA


      • Firewall (Betriebssystem-intern/Externe Software): Sphinx Firewall Control
    • Router-Modellbezeichnung (bei Sende-Problemen): Fritzbox 7490

    Eins gleich mal vorweg: Die Probleme der Profilübernahme sind Betriebssystem (zumindest Windows 7-10) und Rechner (X86) unabhängig, da ich die gleichen Probleme auch in der VIrtualbox nachstellen kann, ohne Virenscanner und Firewall).


    Ich teste gerade die Profilübernahme von meinem alten Rechner Windows 7 auf den neuen Windows 10. Bisher hatte ich Mozbackup im EInsatz, was eigentlich immer problemlos ging. Es macht ja im großen und ganzen auch nichts anderes, als das Profil unter C:\User\"Username"\Appdata\Roming\Thunderbird\Profiles\"Profilname" in ein Zip Format zu packen. Aber scheinbar eine Ebene zu tief, so daß nicht alles erfasst wird.

    Es braucht jetzt keine Diskussionen, daß dieses Programm eh nicht empfohlen wird, da ich es jetzt in der beschriebenen Weise mache, die auf der Thunderbird Seite vorgeschlagen wird.


    Ich habe es jetzt mal folgendermaßen gemacht. Mein komplettes Profil (Ordner Thunderbird) aus (C:\user\"Username\appdata\Roaming) gesichert und auf dem neuen Rechner genau an diesen Pfad kopiert (der Pfad ist ja auf beiden Rechnern gleich). Dann Thunderbird 78.6.0 installiert und gestartet (Der alte Rechner hat auch die Thunderbird Version 78.6.0). Dann kommt die Meldung, daß diese Version von Thunderbird dies so nicht mehr unterstützt und mit einem eigenen Profil startet. Soweit so gut.


    Dann mal einen anderen Versuch gestartet. Thunderbird - p aufgerufen, ein neues Profil angelegt (ich nenne es mal Reinhard10). In dieses neu angelegte Profil den Inhalt meines alten Profils einkopiert, und alles Daten überschreiben lassen. Dann dieses Profil gestartet, wunderbar, alles da, bis zum 4. Neustart von Thunderbird. Dann peng, alles weg!

    Starte und beende ich den Thunderbird 3-4 hintereinander, dann ist auf einmal alles leer. Keine Konten, keine Mails, die Menüzeile zwar da, aber kein Inhalt in den Menüs. So ein halb und halb Absturz der Thunderbird Oberfläche könnte man sagen. Das ist definitiv reproduzierbar.


    Hat jemand eine Idee? Wenn es jetzt nur um mich ginge, ok, nervig, aber richte ich mir meine 6 Email Adressen wieder von Hand ein, übernimm meine Adressen mit Export/Import, Kopiere nur die Maildaten allein ein. Aber ich habe da an die 20 Leute draussen, ich da betreue, da steht immer wieder mal eine Datenübernahme an, da brauche ich eine Lösung die geht.


    Viele Grüße


    Reinhard


    ich lasse jetzt oben die Grundproblematik mal so stehen, und schreibe jetzt hier drunter mal weiter, welche Erkenntnisse ich dazu gewinne:


    1. Emailadressen (in meinem Fall 5x POP-Postfächer) neu anlegen und dann aber die alten gesammelten Emails aus dem alten Profil (ohne die *.msf) übernehmen, geht.

    2. das Adressbuch konnte ich durch einkopieren der Datei "abook.sqlite" übernehmen.

    3. Google Kalender einrichten und einbinden geht ohne Plugin

    4. komplettes Profil rauskopieren, dann mit thunderbird -p den Profilmanager starten, alle Profile entfernt. Von Hand mit dem Windows-Explorer die Verzeichnisse (Thunderbird) in den beiden Pfaden (c:\user\"username"\appdata\local) und (c:\user\"username"\appdata\Roaming) gelöscht. Wieder thunderbird -p gestartet und ein neues Profil angelegt, Thunderbird 1x gestartet und den Einrichtungsprozess abgebrochen. Dann mein zuvor gesichertes Profil einkopiert. Geht.


    Erkenntnis: In meinem alten, nicht funktionierenden Profil muß irgendetwas drin sein, was die Programmöberfläche so halb und halb zu Absturz bringt. Warum das nicht sofort beim ersten Aufruf, sondern nach 2-4 Starts erst passiert ist mir ein Rätsel. noch dazu läuft ja auf dem alten Rechner auch die 78.6.0 problemlos mit dem alten Profil, das ich ja 1zu1 übernehmen wollte.

    Die Neueinrichtung ändert jetzt auch nichts daran, daß mir der gleiche Mist bei meinen "Kunden" auch passieren kann und ich dann einiges an Arbeit habe. Darum wäre es doch interessant, was da genau den Knall auslöst.

    Noch Vorschläge, was ich noch testen könnte?

    Edited 4 times, last by handbike ().

  • graba

    Approved the thread.
  • Gibt es dem Profil Besonderheiten? Zum Beispiel Erweiterungen, Reste von alten Erweiterungen, absolute Pfadangaben etc. ?

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Warum das nicht sofort beim ersten Aufruf, sondern nach 2-4 Starts erst passiert ist mir ein Rätsel.

    Nur dazu, als inspiration: Es gibt derzeit einen Kalender-Bug, der erst beim zweiten Neustart auftritt. Ich konnte die Ursache in diesem Fall auf einen Teil des Startup-Caches eingrenzen – insofern könnten deine Effekte eventuell ebenfalls mit dem Cache zusammenhängen?


    Eventuell hilft ein zurücksetzen der Caches, das Problem um weitere 2-4 Neustarts zu "verschieben"? In diesem Fall könnte etwas längerfristig helfen, den Startup-Cache zu invalidieren: dazu in der Fehlerkonsole (Strg+Umschalt+J) folgenden Befehl ausführen:

    Code
    Services.obs.notifyObservers(null, "startupcache-invalidate", null);
  • Danke schon mal für das Feedback.


    Susi to visit

    Nun, was soll ich sagen, ich bin jetzt mit der Matierie nicht so vertraut. Ich benutze jetzt den Mozilla seit ungefähr 2000, den so alt sind einige Mails, die ich mir aufgehoben habe. Damals war Browser und Mail noch eine Software. Irgendwann dann die Trennung und von da an auf Thunderbird. Natürlich hat das Programm einige Plugins und gefühlt eine Million Updates gesehen, aber das wurde alles wieder rausgeschmissen, bis auf den "Provider für Google Kalender". Der ist aber auch weg.


    generalsync

    Bevor ich hier viel Zeit mit meinem Profil verbringe, werde ich mich mal über die beiden Rechner meiner Freundin machen und da testen, ob die Übernahme auch so bockig ist oder ob mein Profil einfach einen Schuß weg hat. Die hatte nie irgendwas installiert.

    Ich werde aber Deinen Vorschlag in der virtuellen Maschine mal durchführen. Es hat sich das neu machen bei mir auf dem Hauptrechner insofern schon gelohnt, da der Thunderbird jetzt viel schneller startet als vorher, also vermute ich da schon irgendwelche ALtlasten.

  • Bevor ich hier viel Zeit mit meinem Profil verbringe, werde ich mich mal über die beiden Rechner meiner Freundin machen und da testen, ob die Übernahme auch so bockig ist oder ob mein Profil einfach einen Schuß weg hat.

    Hältst du wirklich für eine gute Idee? Zumal du von dir selbst sagst, du würdest mit der Materie nicht so vertraut sein. Wenn du richtig Pech hast, steht ihr am Ende beide mit defekten Profilen da.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Bevor ich hier viel Zeit mit meinem Profil verbringe, werde ich mich mal über die beiden Rechner meiner Freundin machen und da testen, ob die Übernahme auch so bockig ist oder ob mein Profil einfach einen Schuß weg hat.

    Hältst du wirklich für eine gute Idee? Zumal du von dir selbst sagst, du würdest mit der Materie nicht so vertraut sein. Wenn du richtig Pech hast, steht ihr am Ende beide mit defekten Profilen da.

    Ich übernehme das Profil meiner Freundin in eine virtuelle Maschine und teste das darin. An Ihren Kisten mache ich natürlich nichts.....