Nachricht laden...

  • TB 91.10.0 32 bit, Windows 10


    Hallo,

    ich habe ein Problem festgestellt, dass OpenGGP signierte eMails mit Dateianhängen unwahrscheinlich langsam laden. Im Status steht "Nachricht laden..." für bestimmt bald 10 Sekunden.

    Gut reproduzieren kann ich das indem ich eine von mir verschickte Nachricht im Gesendet-Ordner oder auch in einem Ordner wo ich die Datei hin geschoben habe wieder ansehen möchte.

    Die eMails sind nicht veschlüsselt, es hängt einfach nur mein Schlüssel an der eMail.

    Eine eMail mit 1-2MB Dateianhang reicht. Ich weiß, Dateien lieber über einen FileLink Dienst verschicken, aber das geht halt nicht mit jedem Empfänger.

    Habt ihr auch das Problem? Wie kann ich das abstellen? TB verursacht un der Wartezeit immer eine Auslastung von ca. 30% Rechleistung bis er wieder Reagiert.


    Seit der Umstellung von Enigmail weiß ich gar nicht ob TB das PGP selber mit bringt oder mein lokales verwendet (gnupg 2.3.4)


    TIA

    Dirk

  • Die hohe Auslastung der CPU kann ich nachvollziehen:

    Allerdings tritt die nur für die Dauer der Überprüfung der Signatur auf, die eigentliche Downloadzeit ist wesentlich kürzer (CPU1).

    Nach dem Download ist TB bei mir nicht länger blockiert und reagiert normal.

    Meine Testbedingungen:

    TB 78.14.0, Linux, private PGP-Schlüssel mit 'gpg-agent' verwaltet

    Protokoll: POP3

    Dateianhang: 2,2 MB, Mail nur signiert

    Die lange Auslastzeit bei dieser Mail tritt sowohl im (lokalen) 'Gesendet'-Ordner auf, als auch im (lokalen) 'Posteingang'.


    Deine deutlich längere Blockade könnte mit IMAP zusammenhängen, falls du das verwendest.

  • Ich kann bei einem Anhang von 1MB nur einen kurzen Peak von ca. 1 bis 2 Sekunden beobachten, auf einem wirklich alten Rechner, IMAP. Ich habe es eben extra auch unter Windows 10 getestet. Dass es zu einem kurzen Peak kommt, ist zu erwarten, denn es muss der Hash über Mail + Anhang gebildet werden. Zehn Sekunden würde ich bei einem solchen Anhang keinesfalls erwarten.

    Seit der Umstellung von Enigmail weiß ich gar nicht ob TB das PGP selber mit bringt oder mein lokales verwendet (gnupg 2.3.4)

    Wenn du nichts von Hand verändert hast, sollte der Thunderbird das interne PGP verwenden. Du kannst das leicht im Taskmanager testen, indem du schaust, welcher Prozess die CPU-Auslastung verursacht.


    Wie kann ich das abstellen?

    Wie so oft empfiehlt sich ein Test mit einem neuen Profil.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Hi,

    das mit dem Profil werde ich probieren. Guter Hinweis.

    Aber die Auslastung ist jedes mal wenn ich die E-Mail anklicken. Ja, IMAP und auch lokal gespeichert. Wenn es nur beim erstenmal wäre hätte ich da gar kein Problem mit. Aber immer wieder....

  • Hi zusammen,

    ich habe jetzt noch mal ein wenig rum probiert. Auch auf einem anderen Rechner und einen ganz anderen eMail Account etc. Überall das gleiche Problem.

    Was ich definitiv festgestellt habe:

    Wenn die eMail mit den angehängten 15 Bildern zusätzlich noch meine automatisch angehängte digitale Signatur hat, dann dauert das mit dem "Nachricht Laden..." lange, ca. 10-15 Sekunden und TB geht auf 30% CPU auslastung und zieht sich bis zu 1,6GB Hauptspeicher.

    Wenn ich die selbe eMail ohne die digitale Signatur öffne, geht das fast sofort. Gefühlt unter einer Sekunde.


    Daher muß das doch irgend etwas mit der Signatur zu tun haben. Wenn die eMail verschlüsselt wäre, würde ich das alles verstehen aber er muß doch nur die die Richtigkeit der Signatur prüfen.

    Emails mit kleinen oder keinen Anhängen und der PGP Signatur fühlen sich normal an.

    Als wenn er versucht die Anhänge zu dechiffrieren, was er ja gar nicht tun müßte.

    Im Task Manager sehe ich auch keine weiteren Prozesse ausser dem TB.


    TB verifiziert die Signaturen ja immer standardmäßig und zeigt das dann ja auch immer an.



    Kann man das Verhalten irgendwie beeinflussen / einstellen?


    TIA

    Dirk

    Edited 2 times, last by dirkniemeier: Erweiterung ().

  • Wenn die eMail verschlüsselt wäre, würde ich das alles verstehen aber er muß doch nur die die Richtigkeit der Signatur prüfen.

    Die Signatur dient u.a. dazu, zu bestätigen, dass der Inhalt einer E-Mail nicht verändert wurde. Dazu muss der Hash des Inhalts berechnet werde. Bei PGP/MIME schließt das die Anhänge ein. Deshalb ist je nach Rechner auch ein kurzer Peak normal. Die genannten 10 bis Sekunden für 1 bis 2 MB kann ich aber nicht nachstellen.


    Wenn die eMail mit den angehängten 15 Bildern zusätzlich noch meine automatisch angehängte digitale Signatur hat,

    10 bis 15 Bilder scheinen mir recht viel für 1 bis 2 MB. Bist du sicher, dass es nicht doch deutlich mehr MB sind?

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Wenn die eMail mit den angehängten 15 Bildern zusätzlich noch meine automatisch angehängte digitale Signatur hat, dann dauert das mit dem "Nachricht Laden..."

    Ich nehme an, du meinst wie oben: 'automatisch angehängter Schlüssel' …?


    Ich habe es auch noch mal getestet, ohne zusätzlichen Anhang und ohne 'Signieren', nur mit automatisch angehängtem öffentlichen Schlüssel. Schon beim Anzeigen des Quelltextes der gesendeten Mail (Strg + U) kommt es zur Verzögerung. Es hängt wohl damit zusammen, wie TB den öffentlichen Schlüssel automatisch anhängt (und dann wieder auswertet/interpretiert):

    Autocrypt: addr=***@***.***; keydata=

    MIME-Version: 1.0

    Content-Type: multipart/mixed;

    boundary="------------9127DE9310FB692985BB9664"

    This is a multi-part message in MIME format.

    --------------9127DE9310FB692985BB9664

    Content-Type: text/plain; charset=utf-8

    Content-Transfer-Encoding: 7bit

    --------------9127DE9310FB692985BB9664

    Content-Type: application/pgp-keys;

    name="OpenPGP_0x****************.asc"

    Content-Transfer-Encoding: 7bit

    Content-Description: OpenPGP public key

    Content-Disposition: attachment;

    filename="OpenPGP_0x****************.asc"

    Der gleiche Schlüssel als ganz normaler Anhang sieht im Quelltext so aus:

    MIME-Version: 1.0

    Content-Type: multipart/mixed;

    boundary="------------2E791EE8B1D19B9A2AE6D50B"

    This is a multi-part message in MIME format.

    --------------2E791EE8B1D19B9A2AE6D50B

    Content-Type: text/plain; charset=utf-8

    Content-Transfer-Encoding: 7bit

    --------------2E791EE8B1D19B9A2AE6D50B

    Content-Type: text/plain; charset=UTF-8;

    name="=?UTF-8?Q?Schl=c3=bcssel=2easc?="

    Content-Transfer-Encoding: base64

    Content-Disposition: attachment;

    filename*=UTF-8''%53%63%68%6C%C3%BC%73%73%65%6C%2E%61%73%63

    Damit öffnet sich die Quelltextanzeige sofort.

    Kann man das Verhalten irgendwie beeinflussen / einstellen?

    Als 'workarround' könntest du erst mal den Schlüssel als Datei abspeichern und als normalen Anhang versenden (evtl. in der Signatur – das habe ich aber nicht getestet).

  • Hi,

    Enigmail hat die Signatur damals meine ich auch immer als *.ASC Datei einfach angehängt. Und ich meine, dass das Problem schon länger ist. Der Fall kommt halt nicht so oft vor.


    Dann ist das doch aber ein TB Bug oder liege ich da falsch? Wie geht man denn da vor?


    cu

    Dirk

  • Dann ist das doch aber ein TB Bug oder liege ich da falsch?

    Möglich ist das. Ich vermute aber, dass hier kein Bug vorliegt. Wenn, dann bin ich nicht davon betroffen. Ich habe das jetzt mehrfach getestet, mit einem Anhang von 2 MB, mit 10 Anhängen von insgesamt gut 2 MB, mit und ohne angehängten Schlüssel. Unter Windows 10 wie auch unter Linux. Einige der Anhänge waren Bilder, die direkt in der E-Mail angezeigt werden.

    In keinem der Fälle dauert der Peak in der CPU-Auslastung länger als 2 Sekunden.


    Die Tests von Veteran würde ich zunächst einmal nicht als repräsentativ ansehen, weil seine Konfiguration sehr deutlich vom Standard abweicht.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Dann ist das doch aber ein TB Bug oder liege ich da falsch?

    Ja - der sollte aber in Version 91.4.1 eigentlich gefixt sein:

    "Some messages with autocrypt headers loaded slowly, causing Thunderbird to hang"

    Wie geht man denn da vor?

    Wenn du verifizieren kannst, daß es nur mit dem 'Autocrypt'-Header (= automatisch angehängter öffentlicher Schlüssel) passiert, mit dem öffentlichen Schlüssel als 'normaler' Anhang aber nicht, einen neuen Bugreport erstellen.


    Es soll ja schon vorgekommen sein, daß alte Fehler in neueren Versionen wieder auftauchen …

  • "Some messages with autocrypt headers loaded slowly, causing Thunderbird to hang"

    Hast du die zugehörige Bug-ID? In den Release Notes ist er ja leider nicht angegeben.

    Wenn du verifizieren kannst, daß es nur mit dem 'Autocrypt'-Header (= automatisch angehängter öffentlicher Schlüssel) passiert,

    Das Gleichheitszeichen gilt hier nicht. Thunderbird unterstützt Autocrypt nur teilweise. Auch wenn "Automatisch meinen öffentlichen anhängen ..." in den Optionen des Kontos aktiviert ist, erstellt Thunderbird nicht in allen Fällen einen solchen Header.


    Quote

    Thunderbird does not support the Autocrypt philosophy that encryption should be fully automatic. However, Thunderbird provides limited compatibility with email clients that support Autocrypt.

    • When sending an email and using the option to attach your OpenPGP public key, and your key is sufficiently simply to be compatible with Autocrypt, then Thunderbird will add the appropriate header in the outgoing email, which can allow your correspondent to learn about your public key.

    Quelle: https://support.mozilla.org/en…derbird-support-autocrypt


    Möglicherweise sind meine Schlüssel nicht "sufficiently simply", was durchaus sein kann. Jedenfalls erhalte ich keinen solchen Header, auch wenn die Option aktiviert ist und der Schlüssel angehängt wird.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • Ja, vielleicht, deshalb würde mich der Bug interessieren. Es ist nämlich ebenso möglich, dass der Autocrypt Header auch bei dirkniemeier gar nicht vorhanden ist, sondern nur bei dir. Das wäre etwas, was Dirk vorab klären sollte.

    Wer wenig oder gar nichts kann, schiebt's auf den Antiviruskram.

    (Compuzius, Buch 5)

  • 1. Nachschauen, ob bei dir ein Header 'Autocrypt' vorhanden ist, wenn du deinen öffentlichen Schlüssel automatisch anhängen läßt.

    (s. #7, im Quelltext, Strg + U)

    2. Den öffentlichen Schlüssel als 'normalen' Anhang mitschicken und testen, ob die Verzögerung dann auch noch auftritt.