Update auf 102.3.0 verliert Such-Ordner, lädt alle Emails neu herunter

  • Hallo zusammen,


    ich habe ein zig Jahre altes TB-Profil, nie Probleme gehabt.

    Gestern kam schon ein Update, nichts dabei gedacht. Heute kam noch eins. Nanu, so schnell schon wieder, ok. Neugestartet (Upgrade war auf TB 102.3.0), dann gingen die Probleme los.


    1. Alle Mailkonten bis auf eines sehen OK aus.

    2. Das Mailkonto war zusammengeklappt, aber kein Aufklapp-Pfeil sichtbar. Per Doppelklick klappte es dann doch auf. (Findet man viele Treffer zu bei Google.)

    3. Bei dem Mailkonto fehlten meine lokalen Suchordner.

    4. Er lädt SÄMTLICHE Emails neu herunter.

    5. TB neugestartet, es bot sich folgendes Bild für das Konto:

    6. Auf einen der Ordner geklickt, dann wurde es wieder normal. Aber er lädt halt immer noch alle Emails neu herunter (IMAP) und die Such-Ordner sind immer noch weg.


    Ich hatte echt viele Such-Ordner. Kann man die irgendwie wiederbekommen?

    Ich habe kein Backup, jedenfalls nicht bewusst. Außer TB hat selbst mal eins erstellt...


    Finde es echt krass, dass man Berichte zu diesen Problem schon ab Juli (!!!) findet. Wie kann es sein, dass das in fast 3 Monaten nicht gefixt ist?!

  • Hallo,



    3. Bei dem Mailkonto fehlten meine lokalen Suchordner.

    Mit "Suchordnern" meinst du vielleicht "virtuelle" Ordner (oder saved search Ordner)?

    Aber er lädt halt immer noch alle Emails neu herunter

    Wie macht sich das bemerkbar? Erstellt TB bei jedem Start einen neuen Ordner "INBOX-x+1" - wie im Screenshot sichtbar - und mit dem selben Inhalt?

    Ich habe kein Backup, jedenfalls nicht bewusst. Außer TB hat selbst mal eins erstellt...

    Das ist natürlich ein Handicap. TB nativ erstellt keine automatischen Backups.


    Finde es echt krass, dass man Berichte zu diesen Problem schon ab Juli (!!!) findet

    Kann du das mit einer Quelle oder einem Bug-Report untermauern ?

    Ich habe bei einer Suche zu saved search folders kein ähnliches Problem gefunden.

    Kann man die irgendwie wiederbekommen?

    Ich bezweifle es, wenn kein Backup des Profils existiert, zumal es sich um virtuelle Ordner handelt.


    Ich habe als Beispiel einen virtuellen Ordner (ich vermute, dass du das meinst mit Suchordner) als Unterordner des Posteingangs erstellt mit einer Suche nach komoot als Absender



    Wenn ich den Kontenordner meines Kontos "Mapenzi" im Profilordner von TB öffne, ist der Suchordner "Komoot" durch die Index-Datei "Komoot.msf" im Sammel-Ordner "INBOX.sbd" dargestellt.

    Kannst das bei dir untersuchen, indem du im Profilordner von TB den dem Problemkonto zu dem entsprechenden Ordner "imap.xxx.xx" >> INBOX.sbd navigierst und dessen Inhalt anzeigst:



    Den Profilordner findest du wie hier beschrieben Profilordner - Wo ist er zu finden?

    Dann im geöffneten Profilordner den Ordner "ImapMail" öffnen .....

  • GroennDemon


    Zur Information: Bilderhoster im Forum einzusetzen ist grundsätzlich nicht erwünscht. Vielmehr lassen sich z. B. über "Dateianhänge" Screenshots etc. in Beiträge einsetzen - oder auch durch Ziehen der Bilder direkt in den Beitrag.

    Ich hasse Image-Hoster, hatte nur keine andere Möglichkeit gesehen. Habe es geändert.

  • Ja, ich meinte virtuelle Ordner.


    Nach TB-Neustart ist die Ordner-Anzeige wieder normal (also nicht mehr acht INBOX-Ordner sichtbar).

    Habe noch mal genauer geguckt. Ich habe mehrere Email-Konten:


    Konto 1 (das ist das hier gezeigte): Virtuelle Ordner fehlen, sind auch nicht im "INBOX-8.sbd"-Ordner (andere "INBOX-X.sbd"-Ordner sind da nicht).

    Konto 2: Virtuelle Ordner sind da.

    Konto 3: Virtuelle Ordner fehlen, sind aber im .sbd-Ordner. Kann man die wiederherstellen irgendwie?

    Konto 4: Hatte nie virtuelle Ordner.

    Konto 5: Hatte nie virtuelle Ordner.

  • Mit "Suchordnern" meinst du vielleicht "virtuelle" Ordner (oder saved search Ordner)?

    Da gibt's leider verschiedene Berichte, dass diese nach Upgrade auf 102.x ihre "Komposition" (welche Ordern sollen durchsucht/kombiniert werden) vergessen haben. Kann man die Konfiguration einfach wiederherstellen?

  • Ich habe jetzt mal einen der Suchordner neu angelegt. So sieht es aus:


    Die Emails lassen sich auch nicht öffnen.

    Große Klasse...


    Edit: Nach TB-Neustart war der neu angelegte Suchordner wieder weg.

  • Da gibt's leider verschiedene Berichte, dass diese nach Upgrade auf 102.x ihre "Komposition" (welche Ordern sollen durchsucht/kombiniert werden) vergessen haben.

    Ja, aber vielleicht denkst du jetzt an die "gruppierten Ordner", die zwar auch virtuelle Ordner sind, aber nach meinem Verständnis nicht das selbe wie die saved search folders. Von den dezimierten gruppierten Ordnern hatten wir hier kürzlich ein Beispiel

    Wie man die 'Komposition' dieser Ordner einfach wiederherstellen kann, weiß ich auch nicht.

    Ich kenne nur die manuelle Methode über den Button "Auswählen" im Eigenschaften-Fenster.

  • Hmm, dann habe ich das falsch gelesen, es geht nicht um "gruppierte Ordner" (unified folders/inbox) sondern wirklich um Suchordner, d.h. nach einer Suche speichert man das Ergebnis als virtuellen Ordner. Hier geht es noch, ich habe mal einen Such-Ordner angelegt für "nicht" in Betreff:

    Wenn es bei Dir nicht geht, bitte folgende Fragen beantworten, damit ich das nachvollziehen kann:

    1. Der Suchordner basiert auf einem oder mehreren Ordnern?
    2. Der/diese ist/sind lokale Ordner oder IMAP-Ordner?
    3. Ist/Sind der/die Ordner sonst OK, d.h. Inhalt wird angezeigt, MSF ist nicht verschwunden oder kaputt, d.h. der Ordner muss nicht repariert werden?
    4. Was ist denn die Suche genau? Etwas Einfaches oder Kompliziertes?
    5. Kannst Du mal virtualFolders.dat publizieren oder mir schicken. Für meinen "Nicht"-Ordner sieht der Eintrag so aus, s.u.
    Code
    uri=mailbox://jorgk%40MMMMM.com@mail.XXXXX.de/0%20AA%20Thunderbird%20Mail%20DE/Nicht
    scope=mailbox://jorgk%40MMMMM.com@mail.XXXXX.de/0%20AA%20Thunderbird%20Mail%20DE
    terms=AND (subject,contains,nicht)
    searchOnline=false

    Ich bin ziemlich sicher, dass das Feature im Prinzip noch geht, aber irgendwas ist da kaputt gegangen.

  • Ich bin ziemlich sicher, dass das Feature im Prinzip noch geht, aber irgendwas ist da kaputt gegangen.

    Natürlich funktioniert das Erstellen eines virtuellen Ordners aus einer Suche noch in TB 102.

    Ich habe es eben noch mal getestet mit einer Suche nach "Anne" im Posteingang eines POP-Kontos.

    Auszug aus der Datei Anne.msf:




    Die Daten der virtuellen Ordner (u.a. Suchordner = saved earch folders) werden in der Datei virtualFolders.dat gespeichert:


    Beim TE geht es nicht ums Speichern von Suchergebnissen in einem virtuellen Ordner in TB 102, sondern darum, dass seine zuvor in v91 erstellten virtuellen Ordner beim Update auf v102 verschwunden sind. Wenn die Datei virtualFolders.dat beim Update beschädigt wurde oder sogar verschwunden ist, handelt es sich vielleicht um einen Bug; es wäre nicht mal der schlimmste, denn Mails gehen dabei nicht verloren.

    Ich wüsste allerdings nicht wie man diese Datei reparieren könnte.

    Virtual Folders Disappear / Lost after upgrade to 102.2.2
    Windows 10. Sad but true. You had to recrate all your virtual forders manually :-(
    www.reddit.com


    GroennDemon : kannst du diese Datei in deinem Profilordner suchen und in einem Text-Editor öffnen?

    Edited once, last by Mapenzi: Name unsichtbar gemacht ().

  • Zwei Dinge: In dem zitierten Reddit-Artikel heißt weiter unten (Zitat):

    Same issue here. Couldn't even recreate them. The folder would show a list of blank emails (all fields empty, not possible to open the emails). And after another restart, the virtual folder was gone again.

    Diese Person hat dasselbe Problem wie #8 beschrieben, nach Wieder-Einrichtung ist die Liste leer.


    Dein Post #17 gibt aber noch einen interessanten Einblick. Hinter dem Such-Ordner verbirgt sich nicht nur virtualFolders.dat, sondern auch eine MSF-Datei, offenbar die Datenbank, aus der die Nachrichten angezeigt werden. Wie wir alle wissen, hat TB 102.x haufenweise MSF-Dateien kaputt gemacht. Die leere Nachrichten-Liste spricht dafür. Ich schlage also vor, die zu dem Such-Ordner gehörige MSF-Datei zu löschen und danach neu anzufangen.

  • Es geht um Suchordner. Nachrichten lokal durchsuchen und als Ordner speichern (keine Live-Suche auf dem IMAP-Server, das wäre ja langsam).


    Wie gesagt, wenn ich die Suchordner neu anlege, sind sie nach einem TB-Neustart wieder weg.


    Ist ganz offensichtlich ein Bug. Die alten Suchordner sind weg. Ich erwäge nach 20+ Jahren TB-Nutzung ernsthaft den Wechsel auf Outlook.

  • Wie gesagt, wenn ich die Suchordner neu anlege, sind sie nach einem TB-Neustart wieder weg.


    Ist ganz offensichtlich ein Bug. Die alten Suchordner sind weg. Ich erwäge nach 20+ Jahren TB-Nutzung ernsthaft den Wechsel auf Outlook.

    Also, den Such-Ordner, den ich für Kommentar #16, dessen Fragen Du übrigens nicht beantwortet hast, angelegt habe, ist immer noch da und funktioniert auch noch.


    Da auch anderen Benutzer hier Schwierigkeiten haben, wäre es ober-Affen-geil einen reproduzierbaren Fall zu haben, den man dann analysieren und reparieren kann. Soweit gibt es zwar einige Beschwerden, aber nichts Greifbares.


    P.S.: Outlook hat keine Such-Ordner, da stellt sich das Problem nicht, oder irre ich mich?