link öffnen funktioniert nicht [erledigt]

  • Hallo,


    ich habe das Problem, das ich Links in einer Email anklicken kann, aber es öffnet sich nicht der Webbrowser.
    Meine Version Thunderbird 2.0.0.17, funktioniert auch nicht mit 2.0.0.14.


    Wenn ich aber die Version Thunderbird 3 Alpha 2 starte, dann funktioniert es.


    Ich denke, ein Eintrag in der Konfig ist irgendwie falsch.
    Mein OS:
    OpenSuse 11.0



    Kann jemand helfen ?


    Gruß
    Christian

  • Hallo,
    habe leider das gleiche Problem seit dem 15.10.08!
    Habe in zig versuchen (löschen und wieder inst.) kein Erfolg gehabt. Angefangen mit der Version 1.5.0.0.10 bis zu 2.0.0.17 keine Reaktion. :wall: 
    Ich arbeite mit XP. Keine Probleme bei Vista.
    Gruß Jochen

  • Ich habe den Eintrag network.protocol-handler.app.http mit diversen Einträgen angepasst , z.B. /usr/lib/firefox/firefox, leider keine Änderung. Ich habe bei dem String einfach "gedit" eingetragen, und schon öffnet Thunderbird einen Link mit GEDIT. Was nun, sprach zeus.


    Ich habe festgestellt, das ein Mailto Link funktioniert..


    Meiner Meinung nach ist der Fehler nach der Installation von firefox 3 passiert.


    Gruß
    Christian


  • Danke für die schnelle Antwort!
    Hoffentlich kriege ich das hin, denn ich bin kein so beschlagener PCler.
    Gruß Jochen

  • Hallo, guten Tag und willkommen im Forum Christian,
    guten Tag Jochen!


    Jochen

    Zitat

    Hoffentlich kriege ich das hin, denn ich bin kein so beschlagener PCler.

    ich frage mich gerade, was du hinkriegen willst? Der von dir zitierte Versuch von cwolff

    Zitat

    Ich habe den Eintrag network.protocol-handler.app.http mit diversen Einträgen angepasst... ...Was nun, sprach zeus.

    brachte zum einen bisher kein Ergebnis, zum anderen sagt cwolff

    Zitat

    Mein OS: OpenSuse 11.0

    und du

    Zitat

    Ich arbeite mit XP.


    Du solltest dir lieber mal diesen Artikel ansehen Wieso kann ich aus Thunderbird heraus keine Links öffnen? oder erst mal einfach versuchen, in Start>Programme>Programmzugriff & Standards den Browser einzustellen.
    Übrigens: de-/ und neuinstallieren macht selten Sinn, denn die Fehler liegen im Regelfall im Profil (Daten,Einstellungen...) und das wird dabei nicht geändert.


    Christian
    sorry, ich habe keinen Plan von Suse´s (zumindest nicht von Nichthumanen :cool: )

  • Vielen Dank für den Tip
    "in Start>Programme>Programmzugriff & Standards den Browser einzustellen" nachzuschauen.
    Hat mir geholfen! :lol:
    Gruß Jochen

  • Zitat

    Ich habe den Eintrag network.protocol-handler.app.http mit diversen Einträgen angepasst , z.B. /usr/lib/firefox/firefox, leider keine Änderung. Ich habe bei dem String einfach "gedit" eingetragen, und schon öffnet Thunderbird einen Link mit GEDIT. Was nun, sprach zeus.


    Sicher das "/usr/lib/firefox/firefox" der richtige Pfad ist? Ich habe zwar kein Suse, sondern Gentoo Linux, aber ueblicherweise ist "/usr/bin/firefox" richtiger Wert.
    (Versuche einfach mal den Firefox mit diesen Strings aus einem Terminal aufzurufen)


    Ich habe das bei mir wie folgt gemacht:


    Starte Thunderbird und gehe nach Bearbeiten - Einstellungen - Erweitert
    Klicke auf Konfiguration bearbeiten... (bei "erweiterte Konfiguration")
    Rechtsklick - Neu - String
    und trage


    network.protocol-handler.app.http


    als Namen und


    /usr/bin/firefox


    als Wert ein. (Sollte dieser Eintrag nicht schon vorhanden sein)
    Wiederhole dies mit
    ”network.protocol-handler.app.https”,”/usr/bin/firefox”
    und
    ”network.protocol-handler.app.ftp”,”/usr/bin/firefox”


    Damit geht es bei mir. (Thunderbird neu starten nicht vergessen)


    Uebrigens wird bei google auf manchen Seiten empfohlen, folgendes in die ~/.thunderbird/DEINPROFIL/prefs.js einzutragen:


    user_pref(”network.protocol-handler.app.http”,”/usr/bin/firefox”);
    user_pref(”network.protocol-handler.app.https”,”/usr/bin/firefox”);
    user_pref(”network.protocol-handler.app.ftp”,”/usr/bin/firefox”);


    Dies hat fuer mich das Problem aber nicht geloest!

  • Hallo,


    ich habe genau dieses Problem, hatte es aber bisher auf OpenSUSE 11.0 zurückgeführt, kann natürlich auch Firefox 3 sein. Zeitlich kommt beides etwa hin. Während vorher jedenfalls die "protocoll-handler"-Einträge halfen, sind sie seit dem wirkungslos. Dass die Einstellung für den Standard-Browser stimmt, darf voraus gesetzt werden. Das hilft aber auch nicht.


    Eine Frage an andere Betroffenen: Ich hatte als Verdächtigen auch noch "ThunderBrowse" im Visier - habt ihr den installiert?


    Ob man in OpenSUSE den Firefox mit /usr/lib/firefox/firefox aufruft (da liegt das Programm) oder mit /usr/bin/firefox bleibt sich gleich, denn letzteres ist nur ein LInk auf ersteres.,


    Joke

  • Hallo,


    ich habe alle im diesem Thema angegebenen Hilfen probiert, nichts hat die Lage verbessert.


    Wenn ich die Thunderbird Alpha 3 installiere, dann ist mein Problem weg.
    Leider laufen meine Extentions dann nicht.


    Also steht fest, das Problem ist nicht OpenSuse 11 oder Firefox 3. Ich hatte das Problem auch schon mit OpenSuse 10.2.



    Gruß
    Christian

  • Hallo Christian,


    da gehöre ich dann wohl zu den wahrhaft Gläubigen - an Thunderbird hatte ich nie gezweifelt Du kannst mal versuchen, deine Extensions an Version 3 anzupassen:
    Die "install.rdf" der Extension öffnen, "max Version" auf "3.0.*" setzen, abspeichern (alles bei geschlossenem Thunderbird), eventuell noch "extensions.rdf" + "extensions.cache" im Profil löschen, Thunderbird starten.
    Nach meiner Erfahrung kann da nichts Negatives passieren, entweder es geht, oder es geht nicht. Im schlimmeren Fall hast du unten im Thunderbird-Fenster einen grauen Balken mit einigen roten Einträgen. Manchmal sieht man daraus, welche Erweiterung Schuld ist und kann sie deaktivieren. Wenn's ganz schlimm kommt, muss man testen, welche es war. Auch bei der Firefox-Umstellung konnte man viele Extensions auf diese Weise von Anfang an weiter benutzen.


    Joke

  • Hallo,


    habe Tipp befolgt.
    Thunderbird 3 Alpha 3 installiert. Danach klappt der Linkaufruf sofort.
    Danach einige Install.rdf überarbeitet und jetzt läuft es.
    Die Version hatte ich schon im Einsatz. Ich arbeite mit IMAP Konten und da läuft einfach Thundrbird Super. Die 3er Version noch besser und schneller.


    danke für den Tipp mit der install.rdf


    Gruß
    Christian

  • Hi, guten Tag @all


    Christian : vermutlich ist es dir ja klar, ich weise aber trotdem auch für nachfolgende Leser darauf hin: Thunderbird 3.x ist derzeit noch eine Entwicklerversion, siehe Alpha- und Beta-Versionen und daraus

    Zitat

    Warnung:
    Entwickler-Versionen sind NICHT für den normalen Anwender gedacht und enthalten oft Fehler, die sehr schwerwiegend sein können. Dies können kleinere Fehler in Texten, aber auch eine nicht nutzbare Programmoberfläche bis hin zu Programm-/Systemabstürzen und Datenverlust sein!


    Sie sollten deshalb diese Entwickler-Versionen immer mit einem speziellen Profil verwenden, dass Sie nur für Test-Zwecke angelegt haben.


    Wir empfehlen für den produktiven Einsatz die aktuelle finale Version 2.0.0.18 zu installieren!

  • Hallo hatte das gleiche Problem mit Thunderbird 5.0. unter Ubuntu10.10
    Habe die Schritte von n00ris in den Erweiterten Einstellungen vorgenommen, aber auch nach mehrmaligem Neustart keinen Erfolg gehabt.
    Dann die Erlösung: Habe in den Einstellungen im Reiter Anhänge für die Dateitypen http und https firefox (mit /usr/bin/firefox ) eingetragen, seit dem werden externe Links wieder im firefox geöffnet. Vielleicht nur Zufall aber es geht...
    Grüße

  • "mUHGen" schrieb:

    Hallo hatte das gleiche Problem mit Thunderbird 5.0. ... Habe in den Einstellungen im Reiter Anhänge für die Dateitypen http und https firefox (mit /usr/bin/firefox ) eingetragen, seit dem werden externe Links wieder im firefox geöffnet. Vielleicht nur Zufall aber es geht...
    Grüße


    Hallo, mUHGen,
    also ich finde an der Stelle (unter Anhänge/ keine Dateitypen http und https (in TB 5).
    Kannst du das genauer erklären?
    MfG,
    mehlboggxer