Zeichenkodierung TB3: Wie und wo? [erledigt]

  • Hallo Forum,
    das leidige Thema "Zeichenkodierung" macht mir auch in der Version 3 immer noch Probleme, obwohl ich die einschlägigen Forumsbeiträge gelesen habe: Wenn ich es recht verstanden haben, finden sich entsprechende Einstellungen an mindestens drei Orten (warum eigentlich?):
    1. unter Ansicht/Zeichenkodierung
    2. unter Bearbeiten/Ordner-Eigenschaften
    3. unter Extras/Einstellungen/Ansicht/Formatierung/Erweitert


    Mein Problem ist, dass bei einzelnen Mails in verschiedenen Ordnern die Umlaute etc. nicht korrekt dargestellt werden. Kann mir irgendwer einen Überblick verschaffen, welche Einstellungen ich wo wie einstellen muss, damit ich meine Mails lesen kann?


    Danke im Voraus (und ein frohes Weihnachtsfest) :)
    Bito

  • Moin moin,


    das würde mich auch brennend interessieren!


    Allerdings glaube ich, dass das auch von der Einstellung des Absenders abhängt!
    Aber vielleicht gibt es ja eine universelle Einstellung?


    Gruß :rolleyes:

  • hallo Yankee,


    vielen Dank für deine Antwort. Natürlich wäre eine universelle Einstellung sinnvoll (dann wäre sie aber hoffentlich im TB standardmäßig gesetzt), aber mir würde es ja schon genügen, wenn ich die entsprechenden Parameter für einzelne Nachrichten innerhalb eines Ordners dauerhaft einstellen könnte. Soweit ich es verstanden habe, geht das jedoch nur entweder für den ganzen jeweiligen Ordner (über Bearbeiten/Ordner-Eigenschaften) oder für alle Mails insgesamt (über Extras etc.). Zwar kann ich bei Ansicht/Zeichenkodierung die Darstellung einer Mail so lange ändern, bis sie passt, aber diese Einstellung wird dann wieder auch für alle anderen Mails übernommen (wo die Darstellung dann wieder nicht stimmt).


    Besonders ärgerlich ist, dass die fraglichen Mails im Firefox alle ordentlich lesbar waren, solange sie noch auf dem Webmail-Server (in diesem Falle bei gmx.de) lagen: Erst nachdem ich die Mails mit dem TB abgerufen hatte, stimmen bei einigen von ihnen die Umlaute etc.dort nicht mehr.


    Aber ich gebe die Hoffnung nicht auf: Bisher habe ich diesem Forum noch für jedes Problem irgendwo eine Lösung gefunden.


    beste Grüße
    Bito


    ps: Thunderbird 3.0; Windows XP

  • Hallo,

    Zitat

    Zwar kann ich bei Ansicht/Zeichenkodierung die Darstellung einer Mail so lange ändern, bis sie passt, aber diese Einstellung wird dann wieder auch für alle anderen Mails übernommen (wo die Darstellung dann wieder nicht stimmt).


    Genau das sollte aber nicht sein.
    Ist TB richtig eingestellt, dann zeigt TB unter Ansicht, Zeichenkodierungen automatisch immer den Zeichensatz (=Zeichenkodierung) an, der in der Mail deklariert ist ( im Quelltext [strg+U, charset =....]). Das kann bei u.U. bei jeder Mail anders sein.
    Das klappt aber nur, wenn unter Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten, Erweitert bei den unteren beiden Kästchen kein Haken gesetzt ist.
    Und jetzt kommt das Bedauerliche:
    TB 3 (und auch TB 2) bieten eine für jeden Ordner individuelle Einstellungsmöglichkeit über Rechtsklick, Eigenschaften, Synchronisation, die Möglichkeit unabhängig der globalen Einstellungen, diese unwirksam zu machen, wenn dort ein Haken gesetzt wird. Das Unglückliche dabei ist, dass - so wie es mir scheint - bei allen Ordnern dort by default ein Haken gesetzt ist. Und genau diese Haken verhindern die automatische Darstellung des richtigen Zeichensatzes.
    Man sollte also sofort dort bei allen Ordnern den Haken entfernen, sonst geschehen die geschilderten Probleme.
    Also:
    1. unter Ansicht/Zeichenkodierung - kann man eigentlich nichts einstellen, weil es bei der nächsten Mail wieder umgestellt wird (Deklarierung). Aber nur dann, wenn die besagten Haken nicht gesetzt sind.
    2. unter Bearbeiten/Ordner-Eigenschaften - das ist dasselbe wie der von mir beschriebe Rechtsklick auf einen Ordner.
    3. unter Extras/Einstellungen/Ansicht/Formatierung/Erweitert - das ist die globale Einstellung, die aber außer Kraft gesetzt werden kann.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    2 Mal editiert, zuletzt von mrb ()

  • hallo mrb
    vielen Dank für den Tipp. Ich habe jetzt also folgendes gemacht:


    1. Unter Extras, Einstellungen, Ansicht, Formatierung, Schriftarten, Erweitert fehlen die Haken in beiden Feldern im Bereich "Schriftartenkontrolle" sowie bei "Wenn möglich Standard-Zeichenkodierung für Antworten verwenden"
    2. beim jeweiligen Ordner (Rechtsklick, Eigenschaften), ist kein Haken bei "Standard allen Nachrichten zuweisen"


    Doch leider stimmt die Ansicht noch immer nicht bei allen Mails in dem betreffenden Ordner.
    Das Problem ist m.E., dass bei den Ordner-Eigenschaften (Rechtsklick etc.) immer eine Standard-Zeichenkodierung eingestellt ist, die dann aber natürlich wieder sämtlichen Mails in diesem Ordner zugewiesen wird. Für eine korrekte Ansicht bräuchte aber für einige Mails hier die Einstellung "Unicode UTF-8", für andere dagegen "Westlich (ISO-8859-1)". Die Frage bleibt also wie gehabt: Wie kann ich die Darstellung einzelner Mails in einem Ordner so einstellen, dass nicht zugleich auch alle anderen Mails im gleichen Ordner betroffen sind?
    Nochmal vielen Dank für eure Hilfe.
    Bito

  • Hallo,

    Zitat

    dass bei den Ordner-Eigenschaften (Rechtsklick etc.) immer eine Standard-Zeichenkodierung eingestellt ist, die dann aber natürlich wieder sämtlichen Mails in diesem Ordner zugewiesen wird.


    Ja, aber die ist nur wirksam, wenn dort ein Haken gemacht ist. Das möchten aber die meisten nicht.
    Kurze Erklärung:
    die Standardkodierung wird beim Empfang nur gebraucht, wenn die Mail nicht deklariert ist, also keine Zeichenkodierung angegeben ist ist, dann nimmt TB die Standardkodierung. Dieses kommt aber sehr selten vor, beispielsweise bei bestimmten Newslettern oder bei Mails aus dem entfernten Ausland.
    Beim Senden nimmt TB den eingestellte Zeichenkodierung.
    In Deutschland nimmt man ISO-8859-15 oder UTF-8.
    Der Haken "wenn möglich beim Antworten die Standardkodierungen verwenden" sollte nicht angehakt werden, da man nicht weiß, wie der PC oder das Mailprogramm des Empfängers darauf reagiert. Die Kodierung, die er aber gesendet hat, sollte er auch beim Empfang verstehen.


    Mit ist in meiner vorhergehen Antwort ein Fehler unterlaufen, weil ich vergessen hatte, dass es sich bei euch um TB 3 handelt. In TB 2 gab es nämlich 2 andere Auswahlmöglichkeiten, die in TB 3 (gottseidank) nicht mehr vorhanden sind.
    Mit anderen Worten, es gibt zwar die globale Einstellungen für eingehende und ausgehende Mails, wobei nur die Einstellung für die ausgehenden Mails für TB bindend ist.
    Wie die Einstellung für die empfangenen Mails gehandhabt wird, muss man dann in den Eigenschaften der Ordner entscheiden.
    Bei POP-Konten unter Allgemein, bei IMAP Konten wie oben beschrieben unter Synchronisation..
    Sollte die Automatik greifen, dort also keinen Haken setzen.
    Wie gesagt ist es bedauerlich, dass in den Originaleinstellungen hier offensihtlich ein Haken gesetzt ist, der das automatische Erkennen der Zeichenkodierung unmöglich macht.
    Offenbar haben das viele User noch nicht bemerkt, da sie das alte Profil von TB 2 übernommen haben.


    Zitat

    Für eine korrekte Ansicht bräuchte aber für einige Mails hier die Einstellung "Unicode UTF-8", für andere dagegen "Westlich (ISO-8859-1)". Die Frage bleibt also wie gehabt: Wie kann ich die Darstellung einzelner Mails in einem Ordner so einstellen, dass nicht zugleich auch alle anderen Mails im gleichen Ordner betroffen sind?


    Nein.
    Stehen dort keine Haken, wird TB die richtige Zeichenkodierung automatisch finden und anzeigen, egal, ob UTF-8 oder chinesisch. Kontrolliere das unter Ansicht, Zeichenkodierungen.
    Daher sollten alle Ordner von dem Haken befreit werden. Dort hat die aktuelle Zeichenkodierung einen Punkt, die im Quelltext (strg+U) der Mail steht.



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    nochmal vielen Dank für die Unterstützung. Leider ist mein Problem aber noch immer nicht gelöst.


    Zitat

    dass bei den Ordner-Eigenschaften (Rechtsklick etc.) immer eine Standard-Zeichenkodierung eingestellt ist, die dann aber natürlich wieder sämtlichen Mails in diesem Ordner zugewiesen wird.


    Zitat

    Ja, aber die ist nur wirksam, wenn dort ein Haken gemacht ist.


    Bei mir ist dort in keinem Ordner ein Haken gesetzt. Dennoch werden erstens einzelne Mails in diesem Ordner falsch dargestellt, und zweitens ändert sich diese Darstellung (und zwar natürlich für alle Mails im Ordner), wenn ich bei den Ordnereigenschaften die Standard-Zeichenkodierung nachträglich ändere (wohlgemerkt: ohne einen Haken im Kästchen).
    Evtl. sprechen wir hier aber sowieso von zwei verschiedenen Dingen: Es geht mir nicht darum, ob den Mails beim Empfang vom Web-Mailer (hier: GMX) in den Thunderbird irgendwelche Standard-Zeichensätze zugeordnet werden (das werden sie hoffentlich nicht nicht, weil ich den besagten Haken nicht gesetzt habe). Statt dessen rede ich von Mails, die schon downgeloadet sind, die also schon im Eingangsordner lagen und danach in einen selbstdefinierten Neuen Ordner verschoben wurden.


    Zitat

    Der Haken "wenn möglich beim Antworten die Standardkodierungen verwenden" sollte nicht angehakt werden,


    Dieser Punkt findet sich bei meinem TB3 nicht in dem Menü, von dem ich hier die ganze Zeit spreche (Bearbeiten/Ordner-Eigenschaften oder Rechtsklick/Eigenschaften), sondern bei Extras/Einstellungen/AnsichtFormatierung/Erweitert. Aber auch dort habe ich diese Haken nicht gesetzt.


    Zitat

    Wie die Einstellung für die empfangenen Mails gehandhabt wird, muss man dann in den Eigenschaften der Ordner entscheiden.


    Ja, und genau dann sind von dieser Einstellung wieder alle Mails im jeweiligen Ordner betroffen, und ich bin soweit wie vorher.


    Zitat

    Stehen dort keine Haken, wird TB die richtige Zeichenkodierung automatisch finden und anzeigen, egal, ob UTF-8 oder chinesisch.


    Genau das macht der TB bei mir leider nicht :pale:


    Wahrscheinlich muss ich also weiterhin immer die gesamten Ordner-Eigenschaften ändern, wenn ich einzelne Mails ohne "Verrenkungen" lesen möchte -- und habe dann m it anderen Mails wieder das alte Problem -- schade

  • Hallo graba,


    danke für die Mühe.


    Zitat von "graba"

    Ist unter > Ansicht > Zeichenkodierung > Automatisch bestimmen > "Universell" markiert?


    Ja, und zwar sowohl beim Eingangsordner als auch bei dem Ordner, in dem die Mails jetzt liegen. Ich weiß nicht, an welcher Schraube ich jetzt noch drehen könnte. :nixweiss:


    Gruß aus München.
    Bitlo

  • Re: Zeichenkodierung TB3: Wie und wo?


    Hallo,
    zu:

    Zitat

    Dennoch werden erstens einzelne Mails in diesem Ordner falsch dargestellt, und zweitens ändert sich diese Darstellung (und zwar natürlich für alle Mails im Ordner), wenn ich bei den Ordnereigenschaften die Standard-Zeichenkodierung nachträglich ändere (wohlgemerkt: ohne einen Haken im Kästchen).


    Wenn die Mail falsch oder gar nicht deklariert, nimmt TB die Standardzeichensatz. Der kann trotzdem falsch sein.
    Poste die komplette Deklaration der Mail aus dem Quelltext (strg+U).
    Sie sieht etwa so aus:


    Content-Type: text/html; charset=ISO-8859-15
    Content-Transfer-Encoding: 8bit


    Zitat

    Evtl. sprechen wir hier aber sowieso von zwei verschiedenen Dingen: Es geht mir nicht darum, ob den Mails beim Empfang vom Web-Mailer (hier: GMX) in den Thunderbird irgendwelche Standard-Zeichensätze zugeordnet werden (das werden sie hoffentlich nicht nicht, weil ich den besagten Haken nicht gesetzt habe). Statt dessen rede ich von Mails, die schon downgeloadet sind, die also schon im Eingangsordner lagen und danach in einen selbstdefinierten Neuen Ordner verschoben wurden.


    Ob die Mails einen Standardzeichensatz zugeordnet werden (das sollte man vermeiden) hängt von den Einstellungen (Ordnereigenschaften, allgemein). Da es leider die globale Einstellung dafür in TB 3 nicht mehr gibt, muss man dafür die Konfiguration bearbeiten und den Eintrag:
    mailnews.force_charset_override auf "false" setzen.
    Mache das bitte!


    Zitat

    Ja, und genau dann sind von dieser Einstellung wieder alle Mails im jeweiligen Ordner betroffen, und ich bin soweit wie vorher.


    Wir reden einander vorbei, weil du nicht berücksichtigst, was ich dir in meiner vorigen Antwort gepostet habe.
    Daher nochmal:
    Ist in de Ordnereigenschaften/allgemein kein Haken gesetzt, ist es eigentlich egal, welcher Zeichensatz dort eingestellt ist. TB nimmt dann nämlich automatisch immer den in der Mail deklarierten. Ist sie falsch oder gar nicht deklariert, ist TB nicht der Schuldige, sondern der Absender.


    Zitat

    Genau das macht der TB bei mir leider nicht :pale:


    Dann bleibt dir nichts anderes übrig als dieses:
    Zunächst TB im -safe-mode starten und das Verhalten überprüfen.
    Ändert das nicht, mit dem TB-Profilmanager ein neues Profil mit einen Konto einrichten und dort Verhalten überprüfen.
    11 Profile


    Noch etwas: du hattest nicht dein altes Profil aus TB2 weiterbenutzt, sondern in TB3 ein neues eingerichtet?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hi mrb,


    vielen Dank, du hast das Problem gelöst -- und ich musste nicht einmal ein neues Profil erstellen! :)
    Dein entscheidender Tipp war:


    Zitat von "mrb"

    den Eintrag: mailnews.force_charset_override auf "false" setzen.


    Kaum stand der Eintrag auf "false", genügte ein Neustart, und alle Mails werden jetzt richtig dargestellt, egal, in welchem Ordner sie liegen. :D
    Warum steht dieser Parameter eigentlich nicht standardmäßig auf false? Absichtlich geändert habe ich ihn nämlich nicht: Den Punkt about:config hatte ich bisher noch nie aufgerufen, weil ich mich mit diesen Feinheiten sowieso nicht auskenne und deshalb nichts "verschlimmbessern" wollte.


    Zitat

    Noch etwas: du hattest nicht dein altes Profil aus TB2 weiterbenutzt, sondern in TB3 ein neues eingerichtet?


    nein: Ich habe einfach das automatische Update laufen lassen, zu dem mich mein TB 2.x aufgefordert hatte -- und beim neuen TB zeigte sich dann dieser Effekt. Vielleicht sollte man deshalb an der Update-Routine irgendwas ändern?


    Nochmal vielen Dank: jetzt macht der Thunderbird noch mehr Spaß!


    Beste Grüße.
    Bito

  • Hallo,

    Zitat

    Warum steht dieser Parameter eigentlich nicht standardmäßig auf false?


    Das ist eines der Rätsel von TB3.
    Ich bin auch nur darauf gekommen, weil ich TB2 noch immer am Laufen habe und habe dann die Unterschiede in der Konfiguration bei eingeschaltetem und ausgeschaltetem Zustand verglichen.
    In TB2 ist by default auf "false" gestellt und der in TB2 noch vorhandene Menüeintrag ist dort nicht angehakt.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Von mir ebenfalls vielen Dank für den Hinweis auf den Eintrag "mailnews.force_charset_override" in der config.
    Ich hatte alle Möglichkeiten ausprobiert, wobei ich den Eintrag im grafischen Menü nicht gesehen habe, bzw. dieser nicht sichtbar ist.

  • Hallo hier,


    zunächst mal ein großes Danke an mrb, habe wieder was gelernt hier. :zustimm:


    Bloß ein Problem

    Zitat von "mrb"

    Und jetzt kommt das Bedauerliche:
    TB 3 (und auch TB 2) bieten eine für jeden Ordner individuelle Einstellungsmöglichkeit über Rechtsklick, Eigenschaften, Synchronisation, die Möglichkeit unabhängig der globalen Einstellungen, diese unwirksam zu machen, wenn dort ein Haken gesetzt wird. Das Unglückliche dabei ist, dass - so wie es mir scheint - bei allen Ordnern dort by default ein Haken gesetzt ist.


    Bei mir war bei TB 3 bei bei vorhandenen und neuen Ordnern dort der Haken NICHT* gesetzt (Ordner > Eigenschaften > Allgemein). Der Eintrag mailnews.force_charset_override ist bei mir außerdem standardmäßig bereits auf false.


    Beides habe ich gerade nochmal in einem neuen Profil getestet. Keine Ahnung, warum und wieso ... ;)


    *edit: Entscheidender Tippfehler - das Wort fehlte, wird in weiteren Beiträgen daher falsch zititert. :cry:

    Einmal editiert, zuletzt von allblue ()

  • Hallo allblue.
    Hattest du auch wie -ich - ein neues Profil für TB 3 erstellt?

    Zitat

    Bei mir war bei TB 3 bei bei vorhandenen und neuen Ordnern dort der Haken gesetzt (Ordner > Eigenschaften > Allgemein). Der Eintrag mailnews.force_charset_override ist bei mir außerdem standardmäßig bereits auf false.


    Hundertprozentig weiß ich es nicht mehr, ich weiß nur, dass bei mir alle Ordner den Haken dort hatten.
    Und der Konfigurationeintrag stand auf "true".


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ja, habe ein neues Profil erstellt. Zudem habe ich ja geschrieben, dass es auch in einem neuen Testprofil bei mir auch so ist.

  • Zitat von "mrb"

    Hundertprozentig weiß ich es nicht mehr, ich weiß nur, dass bei mir alle Ordner den Haken dort hatten.
    Und der Konfigurationeintrag stand auf "true".


    Ja, so war es bei mir auch.
    Ich hatte allerdings kein neues Profil erstellt, sondern mein vorhandenes aus TB2 genutzt.

  • Hallo zusammen,


    da ich das gleiche Prob habe, aber ein zusätzliches Verständnisproblem, muss ich mich kurz einschalten.


    [quote]
    Ob die Mails einen Standardzeichensatz zugeordnet werden (das sollte man vermeiden) hängt von den Einstellungen (Ordnereigenschaften, allgemein). Da es leider die globale Einstellung dafür in TB 3 nicht mehr gibt, muss man dafür die Konfiguration bearbeiten und den Eintrag:
    mailnews.force_charset_override auf "false" setzen.

    [quote]


    Wo genau muss ich das beschriebene "mailnews.force..." bearbeiten. Ich finde keine Konfig-Datei. Vielleicht bin ich aber auch weniger schlau, als bisher gedacht.


    Bitte könnt Ihr mir da helfen?


    Gruß
    dawnrainbow

  • Zitat von "allblue"


    Bei mir war bei TB 3 bei bei vorhandenen und neuen Ordnern dort der Haken gesetzt (Ordner > Eigenschaften > Allgemein). Der Eintrag mailnews.force_charset_override ist bei mir außerdem standardmäßig bereits auf false.


    Zur Ergänzung: Bei meinem neuen port.TB 3.0 von Caschy sind keine Häkchen gesetzt und o. g. Eintrag steht auf false.